Questions about the management of packages, in particular the `dpkg` system.

learn more… | top users | synonyms (4)

0
votes
2answers
61 views

Having trouble running update through terminal

After typing sudo apt-get update which I've done quite a bit in the past few months, (I am a new Linux user and kind of went in head first to try to teach myself) the two different error messages I'm ...
1
vote
1answer
118 views

Broken package, but cannot purge or reinstall it!

My mdadm package is not fully installed, when I run sudo apt-get upgrade, I see the following error message: Setting up mdadm (3.3-2ubuntu7.1) ... dpkg: error processing package mdadm (--configure): ...
0
votes
1answer
144 views

Proxy problems after upgrade to Ubuntu 16.04 / Apt 1.2

I used the cntlm proxy for authentication against a ntlm proxy server in the past. While this worked seamlessly in 14.04, now I get some Hash Sum mismatches when trying to sudo apt update. I also ...
0
votes
1answer
59 views

I can't download anything on 16.04 LTS

When I try to download anything at all through the terminal on 16.04, it doesn't finish something as I do this command: sudo apt-get install kdenlive. It then tells me Unmet Dependencies. Try 'apt-get ...
5
votes
1answer
357 views

Upgrading to python 3.x

Any way i can update to python 3.x? The version I am using is 2.7.11+ When I usesudo apt-get install python it says it's already at the latest version.
0
votes
1answer
111 views

apt-get update not Working due to unmet dependencies

Whenever I try installing using apt-get install command I am getting errors like these Reading package lists... Done Building dependency tree Reading state information... Done You might want ...
4
votes
3answers
123 views

How can I get a list of all packages available for a specific version of Ubuntu (not necessarily the one I have installed)?

I can get a list of all available packages and their details using the following command: apt-cache search . Which outputs a list of packages which looks like this: i 0ad - Real-...
2
votes
1answer
174 views

Selective sudo apt-get dist-upgrade [duplicate]

If I run: sudo apt-get dist-upgrade It upgrades all the packages on my system, including LibreOffice, Chrome & Firefox, which for me is undesirable. How can I tell Ubuntu to only install ...
1
vote
0answers
37 views

'System program problem' and generally broken Ubuntu, unable to access files, etc

Today, Ubuntu crashed, and everything's gone wrong. I shut down my computer like usual, the proper way, but it just froze on my desktop background, and nothing else. I finally decided the only way to ...
0
votes
2answers
200 views

Why Warning about Apt's partner in this /etc/apt/sources.list of Ubuntu 16.04?

I use the default GUI to select the packages but it complicates in the package of partner in /etc/apt/sources.list # deb cdrom:[Ubuntu 16.04 LTS _Xenial Xerus_ - Release amd64 (20160420.1)]/ xenial ...
0
votes
0answers
26 views

Why does upgrading the Linux Kernel often cause one to have to run 'apt-get autoremove' twice?

I have noticed that after installing a kernel update through the standard means of sudo apt-get dist-upgrade that sometimes (very rarely) when I run sudo apt-get autoremove afterwards it says that ...
11
votes
1answer
100 views

How to make a deb file which tells the system a reboot is required?

I plan to set up a PPA or perhaps submit my package to Debian, but there is something I really need to know, I understand that packages normally do something with /var/run/reboot-required and are ...
0
votes
0answers
16 views

Openjdk 9 broken package cannot install inubuntu 16.04 [duplicate]

Fellows I tried to install openjdk-9 jdk via this command: sudo apt-geet install openjdk-9* And I got this error: Τα ακόλουθα πακέτα έχουν ανεπίλυτες εξαρτήσεις: Preparing to unpack .../openjdk-9-...
0
votes
0answers
49 views

How to fix the error about incompatible version of libc and libgcc when upgrading Ubuntu server 14.04 LTS?

I encountered the following error when trying to upgrade a server running Ubuntu 14.04.2 LTS. To summary, this error complains that there are incompatible versions (amd64 and i386) of two libraries ...
-1
votes
1answer
34 views

Can wine and play on linux be installed in Ubuntu 16.04? [closed]

I'm upgrading from 14.04 to 16.04 and having trouble installinging some items I used in the old OS.
0
votes
0answers
31 views

zeroc-ice dependencies has broken apt-get, help!

I've busted apt-get while I was trying to get a mumble server viewer running, and have since given up on doing that as I can't find/discover the resources/solutions to make that happen. but now I can'...
0
votes
2answers
73 views

Can't install or update any software

I'm new to Linux and I was trying a few new things. I was having problem install stuffs on software center at first because if this error Failed to fetch http://llvm.org/apt/precise/dists/llvm-...
1
vote
3answers
47 views

How to get the download file name of apt-get download?

I have no sudo privilege, So, I want to install software into my home directory. I have a lot of package to download, so I want to write a script to do this. I use: apt-get download libopencv-dev ...
0
votes
1answer
159 views

Target Packages (main/binary-amd64/Packages) is configured multiple times with Ubuntu 16.04

W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/google-chrome.list:3 and /etc/apt/sources.list.d/google.list:1 W: Target Packages (main/binary-...
0
votes
0answers
21 views

Dependencies issue while installing vlc

The following packages have unmet dependencies: vlc: Depends: vlc-nox (= 2.0.8-0ubuntu0.12.04.1) but 2.1.5-0ppa1~precise1 is to be installed Depends: libavcodec-extra-53 (>= 4:0.8-1~) but 4:0....
0
votes
2answers
73 views

Ubuntu doesn't recognize specific package through apt-get

I'm trying to install libboost-thread1.54.0 (I need this specific version) using this command: sudo apt-get install libboost-thread1.54.0 but it throws me this error: Reading package lists... Done ...
4
votes
1answer
151 views

How do I install photofilmstrip on Ubuntu 16.04?

When I try to install photofilmstrip, I am told that that there is a problem: Error dependency is not satisfiable: pythonwxgtk2.8 When I tried to install it via Command line, sudo apt-get ...
0
votes
0answers
22 views

What is an alternative for Ubuntu tweak that I can use for removing the old kernels? [duplicate]

What is an alternative for Ubuntu tweak that I can use for removing the old kernels? I wanna delete the old kernels and headers
0
votes
0answers
21 views

Ubuntu 14.04 error while installing packages

I can't update my packages or install new ones due to the following error: W: Failed to fetch gzip:/var/lib/apt/lists/partial/repo.mongodb.org_apt_ubuntu_dists_trusty_mongodb-org_3....
1
vote
1answer
88 views

Skipping the InRelease step when apt-get update (and go directly to Release)

I've just installed a fresh Xenial on a server box and almost immediately tried to install Docker on it. The Docker installation page says that you have to create a /etc/apt/sources.list.d/docker....
1
vote
0answers
69 views

problem in installation of packages

When I want to install anything or upgrade in terminal, I see this message: /etc/initramfs/post-update.d//zz-flash-touch-initrd: 9: /etc/initramfs/post-update.d//zz-flash-touch-initrd: /usr/sbin/...
0
votes
0answers
112 views

Can't install libgcrypt11 on ubuntu 16.04

I want to install an EasyCAP DC60+ capturer on my computer running Ubuntu 16.04. I followed the steps on this site: http://randomlinux.com/uncategorized/how-to-properly-install-usb-easycap-device-in-...
0
votes
0answers
99 views

apt uses proxy settings only after initial apt-get update without proxy

I installed a fresh version of Ubuntu Desktop 16.04 in a VMware environment. Then I set up proxy settings via gui, which adds environment variables and configures apt. Here are some infos about my ...
1
vote
0answers
41 views

BADSIG 40976EAF437D05B5

With lots of study in forums answered to the title, I am not able to solve. Please help !!!! I am getting this when I run update via apt-get update every time. I tried sudo -i apt-get clean cd /...
0
votes
0answers
46 views

distribution upgrade 14.04 to 15.04 halted due to multiple errors

During distribution upgrade 14.04 to 15.04, process halts due to many dpkg errors, here are a few of them. dpkg: too many errors, stopping Errors were encountered while processing: udev gnome-...
1
vote
2answers
69 views

Problems installing on terminal, I keep receiving a “E: sub-process /usr/bin/dpkg returned an error code (1)”

I have recently installed Ubuntu and I am a Linux noob. Initially all was fine and installations worked as instructed in various threads. I have now encountered a problem while trying to download an ...
1
vote
1answer
97 views

Installing with Software Centre vs apt-get

I am trying to understand the difference between installing an application with the Ubuntu Software Centre, and installing an application with apt-get. For example, I want to install the Latex ...
1
vote
1answer
28 views

Create a debian package with dependency to older version of python-cherrypy3 package

I have a program with a debian package in my personal repository that depends on python-cherrypy3. However, version 3.5.0 of python-cherrypy3 shipped with Ubuntu 16.04 has a serious unfixed bug that ...
0
votes
0answers
53 views

Error on Skype on Ubuntu 16.04 installation [duplicate]

I am trying to install Skype from the deb package (skype-ubuntu-precise_4.3.0.37-1_i386.deb) on my 16.04 Ubuntu. What is causing the error? How can I fix the problem / install it?
1
vote
1answer
81 views

How to install libeecrypt7:i386 from the Wili package?

I need install a driver for "Canon MF8330", which is discussed here Printer driver depends on libbeecrypt7:i386 but it's not in repositories. I know I need to install libeecrypt7:i386 from the ...
0
votes
0answers
49 views

'libpeas-1.0-0-python3loader' dependency issue after upgrade

I ran the command: sudo apt-get dist-upgrade Today and this was how it went: Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... ...
0
votes
1answer
25 views

installing ubuntu touch -unmet dependancies when installing ubuntu-flash-packagr using Precise or Trusty

in trying to install ubuntu-flash-package (tried on both Precise and Trusty) I get The following packages have unmet dependencies. ubuntu-device-flash : Depends: click-ubuntu-policy but ...
3
votes
2answers
58 views

Is it necessary to uninstall first before updating .deb package?

Once in a while I install a .deb package which is not available via package archive (i.e. dpkg -i some-package-v1.deb). I wonder if I should uninstall these packages before updating in order to ...
0
votes
0answers
14 views

apt-get installing postgresql binaries with root ownership

When I was reading an article about installing postgresql from source, it mentions not only to make sure that the data directory is owned by the postgres user, but also the binaries. In fact, it says ...
2
votes
0answers
106 views

Invalid 'Date' entry in Release file

I have Ubuntu 16.04. When I do sudo apt update I get the following output: W: Invalid 'Date' entry in Release file /var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_xenial-security_InRelease W: ...
0
votes
0answers
12 views

How to install i386 packages on 14.04? [duplicate]

On 12.04, I could sudo apt-get install libcurl3:i386 sudo apt-get install libglib2.0-0:i386 sudo apt-get install libx11-6:i386 and similar, but they don't seem to be available on 14.04. (I need ...
0
votes
0answers
25 views

Unable to install wine 1.4 in Ubuntu 12.04

I am trying to install wine in Ubuntu 12.04. Before given the sudo apt-get install wine, Ubuntu updated successfully. After that I am getting below error. I think proxy error can any one of you ...
3
votes
1answer
132 views

Upgrade to 16.04. Broken dependencies and impossibility to resolve them in usual ways [duplicate]

I upgraded the system some days ago and after that I had a problem of broken packages which affects to MySQL and several libraries. After that I can do updates but not install, upgrade, remove or ...
0
votes
0answers
13 views

How to disable upgrade/update of selective packages permanently?

I read this Q&A about How to prevent updating of a specific package? But, I would like to disable/prevent update of a lot of packages, how can I do this efficiently? The above given method ...
0
votes
0answers
9 views

In Ubuntu 14.04 there is no character palette

The Character Map is not what I want. I want the character palette I could put on the panel in 12.04, mostly European linguistic marks. The Character Map in Accessories is impossible to figure out.
0
votes
1answer
23 views

Rare Full Partition Behaviour

Yesterday, I had my main Linux partition more than 60% free. Today, I tried to upgrade the system (as usual, each day) and it tells me: There is not enough room to perform the upgrading. Please, free ...
0
votes
1answer
41 views

Error in software installation

I have installed Ubuntu 16.04 LTS and when I want to install any software I encounter this error: sudo apt-get install openjdk-7-jre openjdk-6-jre [sudo] password for ali: Reading package lists... ...
0
votes
0answers
66 views

dpkg: unrecoverable fatal error, aborting: files list for package 'adwaita-icon-theme' is not a regular file

When I try to run " sudo apt-get update && sudo apt-get upgrade" command on my Ubuntu 16.04 PC, it throws this error below: pxxxx@pxxxx:~$ sudo apt-get update && sudo apt-get upgrade ...
0
votes
1answer
67 views

Warnings and errors when updating Aptitude with multiple architectures enabled

I have an Odroid XU3 with Ubuntu installed on it. I recently installed qemu-user-static for the purpose of running i386 binaries. Part of this process was adding the URLs of a repository I can ...
1
vote
0answers
18 views

Reading Package List Error Xenial [duplicate]

After upgrading to ubuntu 16.04, whenever I run sudo apt update, I receive Reading Package List Error and for most of the archives, Failed to fetch http://. . . Empty files can't be valid archives. ...