Questions about the management of packages, in particular the `dpkg` system.

learn more… | top users | synonyms (4)

0
votes
0answers
123 views

Unable to uninstall xbox driver

I've used the following article to install xbox 360 drivers on my Elementary OS Luna installation http://www.omgubuntu.co.uk/2013/07/dealing-with-xbox-controllers-in-ubuntu Now, I'm facing some ...
1
vote
1answer
127 views

got a problem with the package youtube-to-mp3

When ever I try to install or remove a package in Ubuntu 14.04, I get an error that 'youtube-to-mp3' could not be configured. I tried to remove it, but that is also not possible. Most recently I tried ...
0
votes
1answer
52 views

Error while Running ztemyapp MTS Mblaze modem in Ubuntu 14.04

My Ubuntu version is E7440:~$ lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 14.04.1 LTS Release: 14.04 Codename: trusty ~$uname -a Linux ...
0
votes
0answers
17 views

Ubuntu 14.04 LTS Crashes while package conversion

I'm new to Ubuntu.Ubuntu 14.04 LTS is crashing when I tried to convert RPM package to DEB package. Here is the command I'm trying the following command. sudo alien --scripts -d ...
1
vote
0answers
39 views

“apt-get install” using local packages acting weird

I have downloaded packages using: apt-get install -d gcc Then, what I did was to save the "deb" package and upload it to another machine so that I can install it manually without download. apt-get ...
1
vote
1answer
21 views

How to add a package from a later version of an ubuntu? [duplicate]

I am on ubuntu 12.04 and I want to install tesseract-ocr 3.03 via apt-get. I found this package, which seems like it is for ubuntu 14. Is there a way to install it without installing the full ...
0
votes
0answers
98 views

How can I resolve package conflicts when installing old version of PHP with apache2?

I have a legacy app which requires a specific version of php. I've downloaded debs for php, pear, etc. from old-releases.ubuntu.com, and I am writing a script to install them when provisioning a ...
0
votes
1answer
84 views

How to fix problems with following packages

I tried to install AmberTool. But when I followed the installation manual system told me to install the following dependencies: sudo apt-get install csh flex gfortran g++ xorg-dev \ zlib1g-dev ...
1
vote
1answer
40 views

I purged TZData and now Lubuntu won't boot! Help!

Ok, so in hind sight purging a package that was marked as a critical package was probably a terrible idea, but I was only following the instructions of people from this thread. I couldn't get ...
1
vote
0answers
14 views

I cannot install openssh-server [duplicate]

When I go to install, I get this error: $ sudo apt-get install openssh-server The following packages have unmet dependencies: openssh-server : Recommends: ssh-import-id but it is not going to be ...
0
votes
1answer
33 views

autogen.sh can't find “ fontconfig” package

ran autogen.sh and get the error "package 'fontconfig' not found". I also get the suggestion to adjust the 'PKG_CONFIG_PATH' enviroment variable and/or variables "FONTCONFIG_CFLAGS" and ...
0
votes
0answers
44 views

How do I (or Can I) enable the “install” button in Software Center for offline repository?

I am talking about to install software by Apt Offline Repository. I've read Community Help and used to apply this method to install software offline. I can successfully install software through ...
0
votes
0answers
10 views

Trying to install AVRO, but failed [duplicate]

When I try to install AVRO I get the following : The following packages have unmet dependencies: ibus-avro : Depends: libibus-1.0-0 (>= 1.4.1-3ubuntu1) but it is not installable ...
0
votes
1answer
53 views

is there a GUI front end for Nix package manager?

I've heared about Nix package manager and how powerful it is so i installed in my Ubuntu ? I was wondering if there is GUI front end for it ( Like pacman simple GUI in manjaro linux ) or It just runs ...
0
votes
0answers
20 views

So confused, broken pipe

I have a broken pipe on Tor with Linux i686, I can't get into it to figure out what my user name is, so how can I figure out what my user name is while on the could not write page
1
vote
1answer
210 views

Ubuntu Touch using apt-get

I'm sorry if this has already been asked, I did do some searching and didn't find it. However a number of questions, I have just installed the latest Ubuntu touch, on a nexus 5, and was going to have ...
0
votes
1answer
45 views

What is the difference between `extra`, `suggested`, `recommended` and `NEW` packages?

I'm wondering what are the extra, suggested, recommended and NEW packages are? What is the difference? Why do I need this information when I want to install a new package? Here's the terminal output ...
0
votes
0answers
28 views

Why is whoopsie (after removed in base-settings) - reinstalling itself - after installation with update?

This is no complaint, want to know, if whoopsie is absolutely necessary for Ubuntu to work ?! - Are the update-packages dependent on whoopsie ?! - I tried to leave away some packages - cause I at ...
1
vote
1answer
52 views

How to create deb packages for fonts [duplicate]

How do I create a package of fonts? I am not going to be uploading them to the Archive as they are for my own use. Can anyone point me to a tutorial or a document on creating font packages? I have ...
0
votes
0answers
343 views

Package update fails due to “GConf-WARNING **: Client failed to connect to the D-BUS daemon” and “No D-BUS daemon running”

When I run my updates in my Update Manager I get this error: (gconftool-2:4452): GConf-WARNING **: Client failed to connect to the D-BUS daemon: Failed to connect to socket /tmp/dbus-n18dYWJJ0U: ...
1
vote
1answer
368 views

hplip 3.14.10, no python-devel

Tech specs: Intel® Xeon(R) CPU E5420 @ 2.50GHz × 8 , 32GB Memory, ubuntu 14.04 (64bit). HP 5660 envy aio richard@Doc:~$ cd Desktop richard@Doc:~/Desktop$ sh hplip-3.14.10.run Creating directory ...
0
votes
1answer
108 views

How to correct source-list entry for fetching debs from desired location? (Apt Offline Repository)

I am currently trying to install software offline (studying this question) and want to use Offline Repository according to this answer. I followed steps like: put all debs in /var/my-local-repo ...
0
votes
0answers
87 views

How do I create a Debian source package for a JavaFx application for the Ubuntu Software Center?

I submitted a native .deb file to the Ubuntu Software Center, but I got the response below from reviewers: Your application is not in the correct archive format. Please provide us with the Debian ...
0
votes
1answer
49 views

Remove manually installed java application

I had installed an Java application named Visual_Paradigm. Now I want to uninstall it from my Ubuntu 14.04 System. I couldn’t find the package in synaptic Package Manager. I know this could be ...
0
votes
0answers
36 views

how to downgrade related packages together?

Related Question : downgrade a package The situation is a bit different, I have a group of packages say aaa-*.deb which was involved in the down grade. obviously I don't want to deal with them one ...
0
votes
0answers
13 views

Internal package repository

I have a Raspberry Pi with the Raspbian OS installed. I developed multiple applications that I manually installed on it. I would like to use the standard package manager to install those applications ...
0
votes
1answer
31 views

create local ubuntu pacakage repository

I am using Ubuntu 12.10 (Quantal) version and it is at EOL. The repositories for older releases that are not supported get moved to an archive server. These repositories are available at ...
0
votes
0answers
132 views

Problem compiling pygame for Python 3.4

I was trying to compile pygame from source on Ubuntu 14.04 (64 bit) and issued the following command as given in the Wiki: apt-get install mercurial python3-dev python3-numpy ffmpeg ...
1
vote
1answer
668 views

Package 'lib32ncurses5-dev', 'lib32z1-dev' has no installation candidate [NOT a duplicate, I tried all soution posted here]

I'm trying to build blink(content_shell) on Ubuntu 12.04 32bit and I am stuck on build/install-build-deps.sh. I think I have tried every single solution that I found on stackoverflow Error Log: It ...
0
votes
0answers
84 views

apt-get -f install error code (prozilla) [duplicate]

I'm sure there's a super simple solution, but I'm not entirely certain what's wrong and my best guesses are below. All I know is I can't install anything else at all due to this error. I don't need ...
0
votes
1answer
60 views

Where is the location of packages cached by apt-cacher?

When you install something by sudo apt-get install <packageName>, the packages are saved in /var/cache/apt/archives by default. I have installed and configured apt-cacher. I want to know where ...
3
votes
1answer
160 views

Why does apt-get install a newer dependency than supported by the specified package

I have encountered a problem where a package, at a specific version, requires another package, also at a specific version, but Apt-Get selects a newer version of the dependency and then fails. I have ...
2
votes
1answer
75 views

Can I use a Debian package build environment to build Ubuntu packages?

I have a Debian wheezy server that I use to build packages using pbuilder and git-buildpackage. I can currently build packages for Debian sid, wheezy, and squeeze. I would like to use this same ...
0
votes
1answer
111 views

when i want to install build essential package the result is as below.I am new to ubuntu 12.10 can some one help me out please [duplicate]

Reading state information... Done The following extra packages will be installed: dpkg-dev fakeroot g++ g++-4.7 libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl ...
5
votes
2answers
264 views

How to download all repository using apt-get?

Is there any way to just download all Ubuntu repositories using apt-get? I am looking for something like : sudo apt-get install --download-only * So that I can access the downloaded repository in ...
0
votes
1answer
51 views

How to install packages in ubuntu? [duplicate]

I have tried to install ubuntu-restricted-extras and vlc, but I'm getting this: $ sudo apt-get install ubuntu-restricted-extras [sudo] password for aashay: Reading package lists... Done Building ...
1
vote
1answer
379 views

Cannot find a package in Ubuntu 14.04 with apt-get install

I tried everything but for some reasons I cannot find any packages in this new distro. I wanted to install wicd, git, ... all of the packages cannot be found for some reasons. I followed this guide ...
1
vote
1answer
73 views

Creating debian package to install to a path with spaces

I have a Qt application that I want to deploy as a deb package. I have been reading so many sources, all slightly different - most of what I did follows this How To: preparing an application for ...
1
vote
0answers
132 views

Synaptic Package Manager -E-“cache open”, E - Default-Release not available

In an attempt to re-install Bash I tried to open Synaptic Package Manager but got this message E: The value 'precise-updates' is invalid for APT::Default-Release as such a release is not available in ...
0
votes
0answers
104 views

“Could not write byte: broken pipe” [duplicate]

I have read several articles on this issue, but they did not help. What I did: I go into the mode "Recovery Mode" run the "Enable networking" then "Drop to root shell prompt". Often found this ...
0
votes
0answers
316 views

dpkg: error processing package libapache2-mod-php5

I have a problem at moment of use my apt-get/aptitude package manager When I want install some packages I get the following output: sudo aptitude install libxslt1.1 libxml2 The following partially ...
0
votes
0answers
34 views

How to add Manually installed package(through bin file or script) in “--get-selections” list

I have installed tomcat5.5(from tar file) and jre6(from bin file) on my Ubuntu server 12.04(64 bit). When I try to install php-java bridge, it shows "tomacat5.5 not installed". Tomcat and java are ...
0
votes
1answer
111 views

How do I ppa-purge Bodhi Linux?

I'm using Ubuntu 14.04 x64, and I wanted to try the enlightenment wm. I installed it and it was alright, but really not my cup of tea. I uninstalled it, but it also updated some of the packages that ...
1
vote
4answers
2k views

How to get Bamboo Pad working on Ubuntu 14.04

I'm trying to get Bamboo Pad working on Ubuntu 14.04 I am sure that device is not broken = I can see it via lsusb All "howtogetyourwacomtabletworking" guides are designed for older versions of ...
0
votes
0answers
23 views

Is there some way to check before upgrade which of installed packages can be preserved?

I would like to upgrade from 12.10 to 14.04, but I would like to know which of installed packages/software could be preserved during the upgrade. Is there some way to check this?
0
votes
1answer
67 views

Do I have to compile SDL2_mixer myself?

I want to get the package SDL_mixer to use in a game I am making, but from what I've seen there are only versions compatible with SDL 1.2. Did I overlook something or will I have to compile the SDL ...
1
vote
2answers
303 views

Can't install anything on ubuntu 14.04 nor updates

installArchives() failed: (Reading database ... (Reading database ... 5% (Reading database ... 10% (Reading database ... 15% (Reading database ... 20% (Reading database ... 25% (Reading database ...
1
vote
1answer
98 views

How do I resolve unmet dependencies caused by a conflict between Open Office and LibreOffice? Software Update is broken and will not update [duplicate]

I recently uninstalled LibreOffice to install OpenOffice and experienced no problems in using Open Office. Later, I installed a file preview software known as Sushi. When trying to view .odp files, ...
0
votes
1answer
3k views

How install elementary os desktop on ubuntu 14.04 [duplicate]

I found that this command install elementary os $ sudo apt-get install elementary-desktop but the package cannot be located so please help.
0
votes
0answers
308 views

Problems in update ubuntu 14.04

I am using Ubuntu 14.04 alongside Windows 7 in my Sony laptop. I tried to update using sudo apt-get update but the following errors occurred while updating Err http://ppa.launchpad.net trusty/main ...