Questions about the management of packages, in particular the `dpkg` system.

learn more… | top users | synonyms (4)

1
vote
1answer
2k views

No package 'ncurses' found [duplicate]

I'm trying to install XWiimote and they tell me to run ./autogen.sh in the installation notes . This is the output: zorin@Samsung-NP300E4Z-S03TH:~/Downloads/xwiimote-master$ ./autogen.shlibtoolize: ...
3
votes
1answer
2k views

How to solve package issues/dependencies

Background info I am trying to install Veins simulation environment by following the tutorial provided by the author. In step 1 it is required to install some packages in Linux, the tutorial ...
0
votes
1answer
90 views

unresolvable broken packages [duplicate]

I have been desperate to resolve this problem as I am not being able to install certain programs. my computer says that I have broken packages: The following packages have unmet dependencies: ...
-1
votes
1answer
36 views

Does upgrading to new version deletes my current package?

I want to upgrade to ubuntu 14.04 from 12.*. But i dont want to loose my currently installed packages. Does upgrading to new version deletes my current package?
0
votes
1answer
149 views

Problem in Installing Gnome 3.12

I tried to install Gnome 3.12 on my Ubuntu Gnome 14.04 (Gnome shell: 3.10) I did the following steps (from this tutorial): $ sudo add-apt-repository ppa:gnome3-team/gnome3 $ sudo add-apt-repository ...
0
votes
2answers
3k views

Running lmgrd on ubuntu 14.04 LTS

I have installed Xilinx 14.7 in ubuntu 14.04 LTS machine(i386 - 64bit). But I am unable to run lmgrd (for starting the license server). When I googled this problem, I found that lsb-core package ...
0
votes
1answer
519 views

I fixed my PPA errors but when I try to install Steam all additional packages say No Installation Candidate

While I was downloading Steam I get this code: user@computer:~/Downloads$ sudo dpkg -i steam_latest.debSelecting previously unselected package steam-launcher. (Reading database ... 195561 files and ...
0
votes
1answer
99 views

Upgrade from 12.04 LTS to 14.04 LTS fails

Output of the Bash Terminal: http://pastebin.com/wXKtLzin I used apt-get upgrade -f as well, with the same result. I only want the 14.04 LTS that works fine and I don't lose my data. In the past the ...
1
vote
1answer
3k views

How To Uninstall Haguichi/Hamachi completly? [closed]

I want to uninstall Haguichi and Hamachi from my computer, I try to find anything on Google but I don't find nothing.I just want to remove 100% of Haguichi and Hamachi.
1
vote
0answers
11 views

Wine error, packages being held, help please :S [duplicate]

I am getting this error: The following packages have unmet dependencies: udev : Depends: libudev1 (= 204-5ubuntu20.2) but 204-5ubuntu20.4 is to be installed E: Error, pkgProblemResolver::Resolve ...
4
votes
3answers
11k views

How can I know that I have g++ installed in my ubuntu? [duplicate]

I have recently installed ubuntu 14.04 . I tried to run a c++ code by a command like this: g++ first.cpp -o first Then it said: The program 'g++' is currently not installed. You can install it by ...
0
votes
1answer
142 views

Package download problem [closed]

Whenever I try to install the vim package the following error appears. What should I do? Failed to fetch http://dk.archive.ubuntu.com/ubuntu/pool/main/v/vim/vim-runtime_7.3.547-4ubuntu1.1_all.deb ...
1
vote
0answers
103 views

Package:astrolog isn't available on Ubuntu repository?

https://help.ubuntu.com/community/Astrology says: astrolog is available on Ubuntu repository: But it is not located/available: $ sudo apt-get install astrolog Reading package lists... Done Building ...
0
votes
2answers
251 views

Can't Install Wine, held Packages [duplicate]

I am getting this error: The following packages have unmet dependencies: udev : Depends: libudev1 (= 204-5ubuntu20.2) but 204-5ubuntu20.4 is to be installed E: Error, pkgProblemResolver::Resolve ...
3
votes
0answers
300 views

libssl-dev and libssl1.0.0 on confilcting versions

My problem on 12.04lts is that somehow my libssl1.0.0 got upgraded to 1.0.1-4Ubuntu5.17 and my libssl-dev requires 1.0.1-4Ubuntu5.14 apt won't update libssl-dev because libssl1.0.0 was upgraded first. ...
2
votes
1answer
846 views

Removing idle-python2.7 in Ubuntu 12.04

I'm having some issues when updating packages on Ubuntu 12.04: Processing triggers for menu ... Errors were encountered while processing: idle-python2.7 Setting up idle-python2.7 (2.7.3-0ubuntu3.5) ....
2
votes
1answer
3k views

Tex-common troubleshooting on Ubuntu 14.04 LTS

I recently upgraded my computer from 12.02 LTS to 14.04 LTS, but experienced problems with launching Google Chrome and being able to use Rhythmbox. Rhythmbox asked if I wanted to install additional ...
0
votes
1answer
336 views

package xxxx and python-xxxx

I am trying to install the latest version of package xxxx. I downloaded, unarchived and follow the readme: python setup-py install But python does not see my latest version. It seems that there is a ...
0
votes
0answers
25 views

How can I put a package on Ubuntu repositories? [duplicate]

I create a simple charset converter by Qt which can use to subtitle correction or any missing encoding. I published it in Github by GNU license (See here). Now, I want to put this program on Ubuntu ...
1
vote
1answer
940 views

MrSID support for QGIS 2.4 in Ubuntu 14.04

I am trying to get MrSID support in QGIS 2.4 in Ubuntu 14.04. According to the this tutorial you have to rebuild libgdal against MrSID SDK from LizardTech. But I cannot find the package libgdal-mrsid-...
2
votes
3answers
2k views

Ubuntu 12.04 Libreoffice update breaks software updating

After applying the latest updates today (August 16, 2014), Libreoffice-base will not complete the upgrade due "no diversion" error which then seems to break the postrm script and now I can neither ...
1
vote
1answer
306 views

failed installing libamd2.2.0, libumfpack5.4.0 and libatlas-sse2-dev [duplicate]

I have a script I run on erach new machine I own, that installs somethings I need. For some reason, on a dell Inspiron 3542 with Ubuntu 14.04, the following fails: $ sudo apt-get install libamd2.2.0 ...
1
vote
1answer
69 views

“Failed to load the package list” - fixes posted not working

I have a pretty new installation, and this week tried to add a vlc server application. That seems to have broken something, as I now have the warning bar that indicates a "serious problem." Digging ...
0
votes
0answers
22 views

Spotify installed packages have unmet dependencies [duplicate]

I used wine to emulate the Windows version of Spotify and I recently just uninstalled it and ever since then, when I start up my Ubuntu, after a while I will get this restricted logo beside the wifi ...
6
votes
3answers
15k views

Cannot install python module urlparse

some program written in Python 2.7 complains that ImportError: No module named 'urlparse'. So I need to install the module, but I am not able to do it. The module does exist, it is described e.g. at ...
0
votes
1answer
2k views

Half installed package nightmare

At some point, one of my servers stopped writing to its network attached storage device (I presume), and it resulted in a week or more's worth of packages ending up in the "half-installed" state. ...
1
vote
0answers
38 views

Complete Deletion/Reinstallation of Downloaded Package

I want to know how to delete every file installed by a package using either aptitude or apt-get and then re-download and re-install that package completely again. I've tried doing aptitude reinstall ...
3
votes
2answers
178 views

How does dpkg install a package?

The dpkg manual states: This manual is intended for users wishing to understand dpkg's command line options and package states in more detail than that provided by dpkg --help. ...
0
votes
1answer
559 views

Trying to install ncview on Ubuntu 12.04 [duplicate]

The package ncview requires X development headers and headers. On Ubuntu 12.04 I tried the following command sudo apt-get install xorg-dev and I got the below error message. This looks like a very ...
1
vote
1answer
983 views

How to download and install a single package with all it's dependencies? [duplicate]

How to download a package with all its dependencies So that it can be installed later on another computer without the internet. I tried at Official packages for Ubuntu. But it also needs to be ...
1
vote
0answers
11 views

ppa repositories removed for raring. How do you install packages using old-releases.ubuntu.com [duplicate]

Using a Ubuntu/Debian variant (Navigatrix) release based on Raring, which is no longer supported in the Ubuntu Repositories. Current etc/apt/source.list is: deb (http removed) pa.archive.ubuntu.com/...
2
votes
0answers
17 views

Add Package to Official Repository [duplicate]

I wrote a driver for a remote filesystem (mounts a Google Drive, similar to the way SSHFS mounts a remote server). It's super useful as an alternative to dropbox or ubuntuone. It is now getting ...
0
votes
0answers
20 views

How can I determine the minimal installation set for a list of packages? [duplicate]

I have some installation notes for installing the GLEW libraries for development purposes. They read: Install everything with "glew" in its name. This means I currently run: sudo apt install ...
0
votes
1answer
145 views

I can not install or remove apps After trying to install bumblebee and nvidia prime

Here are the details which terminal output when trying to remove or upgrade I tried autoremove - install configure dpkg and nothings work for me Removing nvidia-331 (331.89-0ubuntu1~xedgers14.04.2) ....
3
votes
0answers
69 views

Ubuntu 14.04 64bit - Provides in a package not working

I have recently switched over to 14.04 64bit from 12.04 32bit. I use packages that are built by my company and I have added architecture dependency in the sources.list file like: deb [arch=i386] ...
1
vote
0answers
75 views

Downgrade all external packages to the official ones

Let's say I installed bunch of packages from external PPA repositories and they modified or replaced the existing default packages in the system. Assume that then I remove those PPAs from the apt-...
0
votes
1answer
1k views

Unmet dependencies problem on 12.04 - libcurl4-openssl-dev depends librtmp-dev

I'm having troubles with unmet dependencies on Ubuntu 12.04: libcurl4-openssl-dev depends librtmp-dev Here is what I've got after running sudo apt-get -f install which suggested running apt-get ...
2
votes
1answer
1k views

How to transfer the apt keyring to another computer

I'm currently moving my installation of Ubuntu from one laptop to another. Both laptops run Ubuntu 14.04. I moved my /etc/apt/sources.list, the contents of my home directory, and installed all ...
0
votes
1answer
103 views

deb package has no usr/lib after installation

I'm building a simple single binary deb package, everything works fine with the executable that is placed in the usr/bin folder and executes when I click the desktop icon. Now I want to start ...
0
votes
1answer
2k views

Trying to remove apache2/httpd and installing mod_perl

It started with me trying to install Apache and mod_perl by following this guide. However, foolishly I installed Apache by using sudo apt-get install apache2, which installed 2.4 on my system. ...
0
votes
1answer
27 views

is it safe to delete package files

After downloaded, extracted package files from .tar.gz and installed (e.g. using setup.py install or make all), is it safe to delete the extracted files? Similarly, if I use pip, there is a build ...
26
votes
3answers
31k views

What's the development package for Qt5 in 14.04

I want to build a Qt5 example on my desktop machine. I installed qt5-default and qtdeclarative5-dev, but I'm still getting this error: Project ERROR: Unknown module(s) in QT: quick qml Which ...
0
votes
1answer
470 views

Which package should I install to solve this problem?

I am using Ubuntu 14.04 (32bits) When I installed TORCS-1.3.1 (which is a sort of Racing game), Error is occurred. Error is " No rule to make target /usr/include/i386-linux-gnu/bits/predefs.h', ...
1
vote
1answer
405 views

how to create a debian package using “equivs-build” which can be “upgraded” if already installed?

I have created a .deb package using equivs-build command and providing necessary control, preinst, postinst, etc. I noticed that version can also be mentioned in control file. Now I want to create a ....
4
votes
1answer
372 views

apt-get install stuck at “Unpacking wine…”

I'm running Ubuntu 14.04 LTS and using an ordinary apt-get install playonlinux command to have it installed. However, it is always getting stuck at (i.e. doesn't do anything further): Preparing to ...
-1
votes
1answer
1k views

Could not exec dpkg! E: Sub-process /usr/bin/dpkg returned an error code (100)

i m using 12.04 .. i m unble to perform any installation or remove b'coz i lost my dpkg in /usr/bin/dpkg i tried with following procedure mkdir /tmp/dpkg cd /tmp/dpkg wget http://archive.ubuntu.com/...
3
votes
3answers
449 views

Removing a plethora of default installed packages

i just bourght a VPS, imaged with ubuntu 12.04, and i notice right out of the box it's using 10% ram. I then proceeded to run this: dpkg-query -Wf '${Package;-40}${Priority}\n' | sort -b -k2,2 -k1,1 ...
1
vote
1answer
879 views

Installing a package with apt-get for a single user [duplicate]

Is it possible to install a package for just the current user (placing files in locations that the user can write to, such as their home directory)?
3
votes
1answer
602 views

How can I accept the Lience agreement for steam prior to apt-get install?

I'm currently fiddling around with using ansible to setup my machine with my chosen configuration/apps etc... I've hit a stumbling block with steam and it's licence agreement. I've been trying to use ...
1
vote
1answer
4k views

Cannot update software, cannot install anything, cannot upgrade

I cannot update anything in my system. I use the terminal and this is what I get. Reading package lists... Done Building dependency tree Reading state information... Done E: The package ...