Questions about the management of packages, in particular the `dpkg` system.

learn more… | top users | synonyms (4)

0
votes
0answers
24 views

Winusb not working/ not opening

I am trying to download win-USB, when i finish downloading package and go to open the application i click on it and it will not open. i downloaded the ppa and still nothing. I am currently using the ...
0
votes
1answer
22 views

Which directory should I be in when installing ATP packages?

I'm planning to install a package through APT. sudo apt-get install gimp From which directory should I run the command? I'm asking because I need to know if this will install everything to my ...
0
votes
2answers
220 views

Errors when installing wine in ubuntu 14.04 LTS

I have followed the below procedures to install wine in Ubuntu 14.04 LTS: add-apt-repository ppa:ubuntu-wine/ppa apt-get update apt-get install -y wine However, I see the below error messages: ...
0
votes
1answer
31 views

Reinstalling Broken PostgreSQL 9.1 on Ubuntu 14.04

After upgrading Ubuntu from Precise to Trusty, I was attempting to upgrade PostgreSQL from 9.1 to 9.3 and have hit a bit of a snag. When I ran pg_upgrade in "check" mode, it complained about being ...
0
votes
0answers
16 views

libsemanage-common problems, No idea what to do

Ok, having a bad time i hope someone can help. I was messing around attempting to get kali tools working on ubuntu mostly to see if I could. Ran into a bunch of problems and attemted to return my ...
1
vote
1answer
24 views

Can't install scsh on Ubuntu 15.10

In trying to install scsh (not ssh and not csh) - the Scheme Shell - on Ubuntu 15.10, I keep running into dependency errors and it won't let me do it: emd@luna:~$ sudo apt-get install scsh Reading ...
-2
votes
0answers
25 views

BitDefender Uninstall - Corrupted Package!

I tried to istall BitDefender to Ubuntu 14, following their website but was never successful. Now I try to remove the corrupted package but nothing seems to work no matter what I try (tried almost ...
1
vote
0answers
22 views

JRE reinstallation error - Cannot install or upgrade any package

This error occurs everytime I try to install or check for updates. I simply cannot do anything. E:The package jre1.8.0-66 needs to be reinstalled, but I can't find an archive for it.
4
votes
1answer
70 views

How to get backup and restore the software from a unbootable hard drive

I have an Ubuntu partition that is unbootable although still mountable, and I'd like to create a newly installed system with the exact same packages as this system. The way to restore the list of ...
-1
votes
0answers
14 views

creating .deb files for compiled packages and programs

i want to find out how i can create .deb files for packages and programs that i want to install. I want to install a program like GNS3. but all the information i get leads me to compile the program ...
0
votes
0answers
25 views

Install chruby and ruby-install so that they update

I want to install chruby and ruby-install to manage my ruby installs. However, it seems that they cannot be obtained via apt-get nor from a .deb file. Is there a way to install these so that they ...
0
votes
0answers
30 views

I run sudo apt-get update and then sudo apt-get dist-update. For months I've been told there is nothing to update or upgrade. This is hard to believe

phillip@phillip-Satellite-P50t-B:~$ sudo apt-get update (repository links appear) Reading package lists... Done phillip@phillip-Satellite-P50t-B:~$ sudo apt-get dist-upgrade Reading package ...
0
votes
0answers
19 views

How to handle do-release-upgrade wanting to remove many packages?

If I run sudo do-release-upgrade in my console it performs as expected up to the point when it tells me about packages to be removed. So many packages are obsolete and will be removed, fair enough. ...
1
vote
1answer
61 views

installing r-base error: Unable to correct problems, you have held broken packages

Problem: I am trying to install new version of R, but what ever I found as solution still gives me these errors: The following packages have unmet dependencies: r-base : Depends: r-base-core (>= ...
0
votes
0answers
66 views

Unable to use apt-get to install kubuntu-desktop in Ubuntu 15.10?

I was trying to install kde in my ubuntu 15.10. I used the following command sudo apt-get install kubuntu-desktop Before this commands completion i encountered these two errors-- The ...
0
votes
1answer
21 views

dpkg and systemd: unit file silently disappears

I try to package my self-made daemon into debian package. I wrote systemd's .service file for it. This file is present in the package. Package installs ok. But after install there is no .service file ...
10
votes
3answers
610 views

Delete PPA after install the software?

Is it safe to delete the PPA after successful installation of the package? For example: Yesterday, I put a PPA in the list cause of the Trackpad function. Now, it works, but will it work when I delete ...
1
vote
0answers
10 views

How to create a minimal repository of needed tested packages? [duplicate]

What is the best way to create a local repository of packages that are needed to operate an own application? Currently all packages were synced and the versions are frozen. What is the best way to get ...
0
votes
0answers
35 views

Can't Compile/Install Libusb 1.0.9

I can't compile downloaded version of libusb 1.0.9 which is needed for my other program. I am using root through terminal, and I used ./configure as it says in the instructions, and it seems to ...
0
votes
1answer
31 views

GIMP failed to uninstall

This is what I get when I try to uninstall GIMP: yoyo@yoyo-Inspiron-3521:~$ sudo apt-get remove gimp [sudo] password for yoyo: Reading package lists... Done Building dependency tree Reading ...
1
vote
1answer
17 views

Dpkg fatal error

I am using UbuntuMATE 15.10, on a Lenovo X201 tablet. I try to update my system, with: sudo apt-get dist-upgrade The system read the packages that need to be updated, it download them, but it ...
1
vote
0answers
26 views

Unmet Dependencies: libapache2-mod-passenger

I need to insatll libapache2-mod-passenger on apache2.4 root@server:~# apt-get install libapache2-mod-passenger Some packages could not be installed. This may mean that you have ...... The following ...
0
votes
0answers
39 views

Restoring my old python and python dist-packages after pyenv

After following the instructions on http://askubuntu.com/a/533581/63298 to update my python to python 2.7.11 and python 3.5.1, I have lost all my dist-packages. They still exist: gillin@mt:~$ sudo ...
3
votes
2answers
366 views

Out of date Skype in software center

I've enabled the Canonical Partners sources, but my software centre (or apt-cache show skype) both only show skype 4.2.x, rather than the current 4.3.x Sources such as this Ubuntu Handbook Article ...
0
votes
0answers
24 views

FlareGet - Bad quality package

I'm aware that bad quality doesn't mean the .deb is not good, but I don't know the publisher and don't know if I should trust them. I'm asking here those who installed FlareGet and can give their ...
1
vote
0answers
19 views

Ubuntu update errors [duplicate]

My Ubuntu 14.04 "Trusty Tahr" LTS is not updating. I get a red circle which reports the following error: E:Encountered a section with no Package: header E:Problem with MergeList ...
0
votes
0answers
17 views

apt-get/kernel update/broken pipe issue

need some help, bit of a noob at the end of my tether lol, I've got a machine running Ubuntu server 14.02LTS (kernel 3.16.0-56 generic) which is running from an 8GB usb stick that I use as a NAS Drive ...
0
votes
1answer
86 views

dpkg error processing packages, cannot complete install desktop/GUI from terminal

I've rented a VPS with ubuntu 14.04 LTS and have googled my way to tutorials and basic terminal knowledge. I want to set up a ubunutu desktop so I can also navigate using TightVNC. This whole process ...
1
vote
3answers
87 views

VLC Help on ubuntu 14.04 LTS

I am trying to install VLC on my ubuntu server. This is what i get when trying. larry@ubuntuserver3:~$ sudo apt-get install vlc New Info larry@ubuntuserver3:~$ sudo apt-get update Ign ...
0
votes
0answers
83 views

apt-get dependency failed! Please help!

I got this very strange error trying to do sudo apt-get upgrade Reading package lists... Building dependency tree... Reading state information... You might want to run 'apt-get -f install' to ...
4
votes
1answer
26 views

apt-cache unmet shows non-existent packages

Running apt-cache unmet outputs a 1.2 MB file of missing dependencies of packages, none of which exist (the packages themselves). This is possibly due to restoring old configurations to a fresh ...
1
vote
1answer
50 views

I'm a noob at ubuntu and linux need help

every time I try to update anything or install any program onto my computer like skype and simple things, I cannot find them like in the tutorials. I can see they have downloaded but I can not find ...
1
vote
0answers
28 views

lots of symbol lookup errors in dynamically linked libraries

I'm using Ubuntu 15.10 Problem: For some days now I have been getting Errors like this when opening some applications: /usr/lib/x86_64-linux-gnu/libpoppler-qt5.so.1: undefined symbol: ...
0
votes
2answers
24 views

archived .deb file error-specified file is not found using dpkg

i think my problem may be simpler than i am making it, but i am still learning linux servers the hard way. i cannot install or update packages, and i managed to track it to an archived version of the ...
0
votes
0answers
9 views

mysql-client : Depends: mysql-community-client (= 5.7.10-1ubuntu12.04) but it is not installable [duplicate]

I have tried to upgrade my mysql in 12.04 from 5.5 to 5.7 but after removing 5.5 I had to add 5.7 to apt. However when I did apt-get install mysql-server it asked me to install 5.5 again. So I did the ...
0
votes
1answer
104 views

How to install dependencies not found in the repositories for JHBuild?

I have been following this guide in order to set up JHBuild. And I have got up to the bit which says to execute: jhbuild sysdeps --install However there is a slight problem because upon running ...
0
votes
0answers
166 views

vboxdrv module compilation failed

I have a serius problem after I' ve compiled kernel. I downloaded and compiled a vanilla 4.3.3 and I see that my pc thanks... it is really faster. But there are some problems... The most important is ...
0
votes
1answer
44 views

Apt-Get Dependencies Won't Install

OK I'm kind of confused here. After I installed Code::Blocks from the website, a little error popped up the top bar. It said that "Error: BrokenCount > 0", and that one of my packages had unmet ...
1
vote
1answer
27 views

how to proxy specific repo in apt

I recently switched to Ubuntu 15.10. I need to use a proxy to connect to external internet.And on my local internet there's a repo that doesn't require proxy to connect. So I wrote something like ...
0
votes
0answers
11 views

14.04, fresh install/encrypted, dependencies not meet, including mount libraries

having a dependency problem can be infuriating. Having my machine down a couple of days, I finally had it all and stuck in a network install, I believe for 14.04. I do this: jack@Kilo:~$ echo ...
1
vote
0answers
26 views

Package gvfs-common is not configured yet?

I am having trouble getting into Synaptic Package Manager. When I run sudo dpkg --configure -a as it suggests I get: dpkg: error processing package gvfs-common (--configure): package is in a very ...
0
votes
1answer
28 views

How to create package including source codes, which compile during installation

Is it possible to create a deb package for Ubuntu, which contains source codes and automatically compiles them into executable during its installation? I haven't found any tutorials for this, only ...
1
vote
1answer
41 views

Getting correct version of the package python-django

I have python-django package installed on Ubuntu 14.04. However the version numbers I get with dpkg -s and django-admin --version does not match. $ dpkg -s python-django | grep Version Version: ...
0
votes
1answer
53 views

Can't upgrade old Ubuntu, error processing package fontconfig

I'm running old Ubuntu Server 13.04 (raring), and trying to upgrade or even install any packages I'm getting the following error: root@oem-mobilidade:~# sudo apt-get upgrade -y Lendo listas de ...
1
vote
1answer
45 views

broken packages with PgAdmin3 version 1.20 in Ubuntu 14 LTS

My pgadmin3 was perfect, working with PostgreSQL 9.3 (pg9.3)... Them I upgraded to pg9.4... And start the problems... Old pgAdmin3 not runs with new pg9.4, so pgAdmin3 needs also upgrade. With ...
1
vote
1answer
35 views

Messed up with ppa: restore package manager

I was trying to read a Matrioska video, so I've added the followiong ppa: ppa:strukturag/libde265 but it supports until ubuntu vivid, so I've modified the list.d file changing wily to vivid, then ...
0
votes
1answer
20 views

Trying to use autoremove [duplicate]

When removing unused kernals (to make space on /boot) I get this message: The following packages were automatically installed and are no longer required: gnome-mplayer hardinfo libgda-5.0-4 ...
3
votes
1answer
51 views

update-alternatives: error: /var/lib/dpkg/alternatives/vim corrupt: invalid status

Whenever I try to install, update, or do anything with apt-get, I always get a error message similar to this, griping about vim: 0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded. 1 not ...
0
votes
0answers
44 views

Missing Steam Packages

In Ubuntu 14.04, when I try to install steam via .deb file, it shows: Steam needs to install these additional packages: libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, libc6:i386 Then it asks for my ...
0
votes
1answer
50 views

upgrade requires 525M free disk space on /boot while boot is only 230M in total there are also dependencies with previous kernels

I was having problems installing the latest kernel due to lack of free space in the /boot partition. Finally I managed to force delete the old kernel files, but when I tried sudo apt-get -f install it ...