Questions about the management of packages, in particular the `dpkg` system.

learn more… | top users | synonyms (4)

19
votes
5answers
57k views

How to completely remove a oracle jdk that didn't install properly?

I recently installed a oracle jdk from a webupd8ppa on Ubuntu 12.04 beta, but apparently it didn't work out, and now it is giving me errors at every update or install I make, even after deactivating ...
16
votes
3answers
12k views

How do I add a software source?

Sometimes I see sites offering Ubuntu packages via something like Add this line to your software sources: deb http:// something something How can I add these to my package manager so I can ...
12
votes
2answers
18k views

Find package name using terminal

Hello I want to remove software (for example transmission) using Terminal. How can i find the package name for the software ?
19
votes
5answers
2k views

zsh man page documentation missing in packages?

I have a newly installed xubuntu 13.10 x64. I decided to install zsh via synaptic and make it my default shell. The installed zsh's version is: zsh 5.0.2 (x86_64-pc-linux-gnu). The installed zsh ...
16
votes
4answers
20k views

How do I add the kernel PPA?

I can get Ubuntu mainline kernels from this kernel PPA - is there a way to add it to my repository list the same as regular Launchpad PPAs?
12
votes
3answers
14k views

Fix half-installed package

I am getting error while using sudo apt-get upgrade stating: dpkg: error processing libgfortran3:amd64 (--configure): package libgfortran3:amd64 is not ready for configuration cannot configure ...
10
votes
3answers
19k views

Can't install/remove/upgrade any package

So I've been trying to upgrade Ubuntu 11.10 64-bit few days back and received an error: dpkg: ../../src/archives.c:978: tarobject: Assertion `r == stab.st_size' failed. So I followed this Ubuntu ...
7
votes
3answers
8k views

Install a different version of a package

I'm running lucid server and have installed tomcat. The version it installed is 6.0.24-2ubuntu1.6. Is this the version I'm tied to? Is it possible to install a more recent version? The one available ...
8
votes
2answers
6k views

FGLRX won't install: Unable to correct problems, you have held broken packages

When I run sudo apt-get install fglrx, I get the following output: Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be ...
7
votes
6answers
8k views

download.01.org certificate verification failed - CRLfile missing?

So I had intel-Linux-graphics-installer on my computer but lately when I sudo apt-get update I get the following error Err https://download.01.org trusty/main amd64 Packages ...
6
votes
2answers
6k views

How to install one GUI program on Ubuntu Server?

I am using Ubuntu Server 10.10 in a VirtualBox. I need to install a single GUI program (RubyMine) on it. I checked out installing ubuntu-desktop with apt-get, and it wants me to install 430 new ...
3
votes
3answers
58k views

The following packages have unmet dependencies!

I am writing this because I am very confused about installing postgresql 9.3 on mine Ubuntu 14.04. First I need it for mine Python/Django development, and I ran in to the problem, when i tried to ...
3
votes
2answers
6k views

Getting the error Error:BrokenCount>0 after installing the packages

I am getting the following error in the top menu bar: "An error occurred.Please run the Package Manger form the right-click menu or apt-get in a terminal to see what is wrong.The error message ...
3
votes
1answer
6k views

Unable to repair packages in Ubuntu Software Center

When I open up the Software Center it gives me, "Items cannot be installed or removed until package catalog is repaired". Can someone help me?
2
votes
3answers
700 views

Why does 'quickly package' fail with “An error has occurred when creating debian packaging”?

I've got a big problem with packing my quickly application for the Ubuntu App Showdown. When I try to package or submit my application, I get some warnings: quickly package --verbose ........ ...
2
votes
3answers
24k views

How do I install the build dependencies for Android?

I'm trying build the Android source using these packages. ButI am getting this error: $ sudo apt-get install git-core gnupg flex bison gperf build-essential zip curl zlib1g-dev gcc-multilib ...
13
votes
2answers
5k views

What exactly is in ubuntu-desktop?

I'm also interested in its variants, like kubuntu-desktop. It appears to include GNOME (or KDE) and a bunch of other things. But it's quite large - is there a breakdown of what is included in ...
6
votes
2answers
2k views

How to download all repository using apt-get?

Is there any way to just download all Ubuntu repositories using apt-get? I am looking for something like : sudo apt-get install --download-only * So that I can access the downloaded repository in ...
4
votes
3answers
2k views

Blacklisting packages from installing

I'm currently running 10.10 with a package removed. I'm concerned that when it comes time to upgrade, synaptic may well install that package again. Is there way to blacklist a package that works ...
2
votes
3answers
11k views

Not able to install g++ in ubuntu 13.10 because of broken packages

When I try to install g++ in my machine I am getting the following message. support:/$ sudo apt-get install g++ Reading package lists... Done Building dependency tree Reading state ...
2
votes
1answer
1k views

Keyboard and touch-pad stopped working after shutting down the computer while it was installing updates

When I boot my notebook, the touch-pad and the keyboard don't respond. The last thing I did before shutting down was killing the terminal that was running a sudo apt-get install because I had to go. ...
13
votes
0answers
125k views

“Unable to locate package” errors for all software [duplicate]

My apt-get doesn't install any programs. I try to install programs with apt-get install but always it shows same error: unable to locate package. For example I try to install the xbmc media center; ...
3
votes
2answers
13k views

Fixing broken myslq-server package after upgrade to 12.04

After upgrade to 12.04 mysql server was unable to start. I tried many different things but without any luck. Now when I try to install it, I get: $ sudo apt-get install mysql-server-5.5 Reading ...
2
votes
2answers
6k views

apt-get remove --purge wine* removed everything!

sudo apt-get remove --purge wine* opened the gates of hell and removed many things. I wasn't allowed to paste the output here, too big. I stopped the process, I wanted to save what's left of my ...
1
vote
2answers
5k views

I Cannot install or remove packages

I tried to install the openoffice.org package but it gave an error. Now i cannot repair, remove or install nothing. The Software center of xubuntu gives this error log. Nothing seems to solve this. I ...
0
votes
1answer
4k views

Cannot install automake and libboost-all-dev [duplicate]

Possible Duplicate: How do I fix a download issue when updating? I downloaded Ubuntu 12.04 and installed it in a VMware workstation. and I've been using all the installation commands: sudo ...
95
votes
5answers
82k views

How can I check the available version of a package in the repositories?

How can I check the version of the available package in the Ubuntu repositories without installing it?
29
votes
2answers
803 views

What precautions should I take with .debs I find on the internet?

So I was browsing the web the other day, and I came across a few places that wanted me to download .deb files - and since those are installed by root (and as such have the "powers" and capabilities of ...
27
votes
3answers
203k views

Install gcc on Ubuntu 12.04 LTS

When I try to install gcc on Ubuntu 12.04 LTS Server with apt-get install gcc, I get the following error: The following packages have unmet dependencies: gcc : Depends: cpp (>= 4:4.6.1-2ubuntu5) ...
32
votes
3answers
32k views

How do you see what packages are available for update

FreeBSD user joining your ranks. I've been asked to look after an Ubuntu Server running 10.04 LTS. I see from /usr/lib/update-notifier/update-motd-updates-available that there are a number of ...
24
votes
2answers
35k views

Install python 3.5 on vivid using apt-get

How can I install Python 3.5 on 15.04 Vivid using apt-get? Obviously I realise I can install Python 3.5 using the source tar ball, however I would prefer not to install from source and instead use ...
22
votes
6answers
35k views

How do I remove cached .deb files?

I think once we get the packages with apt-get it stores in /var/cache/apt/archives . Is it safe to remove the archives files to save space? Can we remove other files as well to save some space?
19
votes
1answer
13k views

How to create a deb package that installs a series of files

I would like to create a brand new deb package to install series of files. If at all possible, I would like to untar the folder containing these files as part of the installation into a known folder ...
46
votes
1answer
2k views

What is Ubuntu's policy on keeping old kernels

I've just run out of disk space on /. Looking into the situation I realised that since first installing 12.04, Ubuntu has upgraded the kernel ~23 times and has kept every old kernel, binaries and ...
15
votes
1answer
6k views

Is there a Ubuntu sanity check

Is there a standard procedure to 'unit test' an Ubuntu system against the deb packages? Assume, a system has ubuntu-desktop installed according to the package manager. Can I find out, whether the ...
14
votes
1answer
12k views

How do I check only security updates from the command-line?

Is there a way to quickly check for the availability of security updates from the command line? On my 12.04 system running apt-get update fetches 20MB of data about available packages every time I ...
11
votes
1answer
6k views

Keep only essential packages

In an attempt to learn more about Ubuntu and its packages, I want to remove all non-essential packages, so I can install what I need, when I need them and know what they do. I'm using the commands ...
17
votes
3answers
721 views

How can I start my own Repository

I'm an avid developer but I never actually gotten around to setting up my own PPA - how would someone go about this? Common issues encountered? How do I get my source code to be compiled into packages ...
13
votes
6answers
3k views

Finding out what package a command came from [duplicate]

Is there a generalised way to find out what package caused the installation of a command?
5
votes
5answers
2k views

Why not all Linux packages/software come in .deb format? [closed]

A .deb package is very easy to install, just like .exe in Windows, simply double click and install via USC. I wonder why some developers choose formats like .tar.gz (it scares the hell out of me) ...
11
votes
5answers
3k views

Syncing apt-get installations between multiple computers

Is there a way to synchronize my installations (and removals) between multiple PCs? Preferably with dropbox - since I'm already using that to keep my files in sync. I thought of an alias for the ...
10
votes
3answers
1k views

How can I make a live CD/DVD from my harddisk installation?

How can I make a live CD/DVD from my harddisk installation? In other words, I would like to create a boot CD from Ubuntu that is installed on my PC, because I want to include the updated packages in ...
8
votes
3answers
873 views

Search Launchpad for PPAs matching software or package name?

Is there a way to search though LaunchPad's PPAs for a certain package name? For instance if I was looking for PPAs with Firefox packages I could search for "firefox" and retrieve a list of all the ...
5
votes
2answers
5k views

Removing broken packages on distro update (13.04 to 13.10)

i'm kinda new to linux. last night i tried upgrading from 13.04 to 13.10 but i got the "could not calculate" error. i read this question and found this error in the main log: Dist-upgrade failed: ...
4
votes
1answer
13k views

How do I restore default settings and configuration, but keep local data, installed apps, and PPAs?

I'm fairly new to Ubuntu and while messing around with different things and trying out some shells, I've managed to mess my system up. Specifically I really messed up my GNOME session and can't get it ...
3
votes
4answers
12k views

How to delete all desktop environments except Unity?

I am using Ubuntu 12.04 with many desktop environments like Unity,Gnome,Lubuntu,Xubuntu , Cinnamon and many . Now i'd like to remove all except Ubuntu because they all are messing with my main unity ...
2
votes
5answers
10k views

Wine installation not completing due to held broken packages

I'm running Ubuntu 12.04 64bit and I want to install wine. This is the output of sudo apt-get install wine: Reading package lists... Done Building dependency tree Reading state ...
8
votes
2answers
381 views

How do I get security updates for restricted/partner packages?

I want to perform just security updates on Ubuntu 12.04 LTS, keeping the rest of the system unchanged. I need to do this from the command line, no the GUI update manager. I have implemented the ...
7
votes
3answers
6k views

Is it better to compile from source or to install from a .deb package?

Sometimes, when downloading software from the Internet, I find that there is a .deb package ready for either my Debian/Ubuntu and also a tarball to be compiled. In the beginning I would simply use the ...
7
votes
2answers
3k views

How to trick apt dependencies? [duplicate]

Possible Duplicate: How to create a meta-package that automatically installs other packages? I want to use Frescobaldi (an editor for Lilypond), but the packaged release of lilypond ...