Questions about the management of packages, in particular the `dpkg` system.

learn more… | top users | synonyms (4)

0
votes
0answers
27 views

libobasis5.1-core is missing with apt-get

When I install language pack, libobasis5.1-core is missing: sudo apt-get install libobasis5.1-core ... tells that libobasis5.1-core exists in list, but not in ubuntu bases. Where I can find ...
2
votes
1answer
50 views

Can't purge old kernels (dependency problems), but /boot is out of space

I'm running Ubuntu 14.04.4 LTS, and I'm trying to install a new package using apt-get. Unfortunately, whenever I try I get messages like: The following packages have unmet dependencies: ...
0
votes
1answer
64 views

How to downgrade smbclient

I'm trying to downgrade smbclient as is no longer working with backuppc. I have followed the instructions in this post How to downgrade packages on Ubuntu? but it doesn't seem to work. I ran sudo ...
0
votes
2answers
78 views

Gnome-shell can't install - broken packages [duplicate]

I am trying to install gnome-shell but it shows me an error: $ sudo apt-get install gnome-shell ... Some packages could not be installed. This may mean that you have requested an impossible ...
3
votes
0answers
42 views

List all packages available (and/or installed) from a specific source

How can I list all package names and their versions available from a specific package source (official repositories, PPAs or other repositories) ? Also, how can I filter only the installed packages ...
0
votes
0answers
13 views

VMware VSphere Client on Ubuntu

Is it possible to have VMware VSphere client on Ubuntu?I have tried this link https://www.higebu.com/vsphere-client-on-ubuntu-en.html#install-vsphere-client for installation guideline but the problem ...
-1
votes
1answer
63 views

Unable to install graylog-web [duplicate]

Package graylog-web is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source. E: Package ...
0
votes
1answer
31 views

apt-get upgrade always hangs at same percentage

I am currently trying to ugprade my server system using apt-get update && apt-get upgrade -y. However, the upgrade process always starts to hang at exactly 31%. First, I suspected a problem ...
0
votes
0answers
16 views

Broken Packages Issue

I have Ubuntu 12.04 LTS in VM on Windows. I am trying to install OpenGL. I am getting the following error: vinayak@Vinayak:~/VinGL$ sudo apt-get install freeglut3 freeglut3-dev [sudo] password for ...
0
votes
0answers
37 views

Installing libpoppler.so.28

I'm so new to this and I know I'm going to ask this all wrong. I'm also scared that I've missed the correct answer somewhere already posted, and I'm very sorry if that's the case! I've been trying to ...
0
votes
2answers
67 views

IcedTea and OpenJDK-8 packages errors after upgrading to 16.04

I just upgraded from 15.10 to 16.04 on my laptop and now I have errors with IcedTea and OpenJDK-8 related packages. There seems to be a problem with dependencies. Can someone tell me how to get rid of ...
-1
votes
2answers
88 views

can't upgrade from google chrome 45 to 50. Says, Unable to find expected entry

i have looked at some of the solutions here, but nothing worked: Unable to find expected entry 'main/binary-i386/Packages - Chrome and No more updates for Google Chrome | apt-get update error. ...
0
votes
3answers
71 views

How to downgrade Ruby on Ubuntu?

I'm running Ubuntu 16.04. My ruby version is: ruby 2.3.0p0 (2015-12-25) [x86_64-linux-gnu] How can I downgrade ruby to version 2.1 to be in line with the rest of my development team (some of our ...
-1
votes
1answer
38 views

perfBroken dependencies in insralling opencv

I am receiving this error again and again. At the end, getting it has already installed. Please suggest how I can fix this. I tried all solutions mentioned on this question but got no solution. ...
7
votes
2answers
1k views

Can not install 'openjdk-9-jdk' because it tries to overwrite file aready included in 'openjdk-9-jdk-headless'

I'm running Ubuntu 16.04 Xenial desktop, 64 bit, and wanted to install openjdk-9-jdk (Java 9 development kit). The version available from the universe repository is 9~b114-0ubuntu1. Running the ...
0
votes
0answers
33 views

How can I keep gstreamer up to date?

So there's GStreamer-0.10 and there's GStreamer-1.0 and they turn out to be different. And there are many packages (like -plugins-bad, -plugins-good and so...). It's very confusing. And Ubuntu 14.04 ...
0
votes
0answers
18 views

how to uninstall remove haguichi? Erro!

When I try to uninstall the haguichi , this happens: Removing haguichi (1.3.3~ubuntu16.04.1) ... /var/lib/dpkg/info/haguichi.postrm: 3: /var/lib/dpkg/info/haguichi.postrm: ...
2
votes
1answer
32 views

apt-get seems to be broken

I don't really know what happened, but it seems like my apt-get command in ubuntu is broken. No matter what I do, I cannot use it to either install or uninstall anything. Right now, I am for example ...
0
votes
2answers
23 views

Can you help to install “Not Installed” packages

Hi there... I am really new on Linux system. Can you help me to install "Not Installed" packages ???
0
votes
0answers
12 views

Upgrade dependencies while upgrading a package not included in a distribution

I am using a machine with Ubuntu 12.04 LTS and don't want to upgrade the OS. However I wish to upgrade a specific package to the latest version. The package in point is spyder: The version ...
0
votes
1answer
28 views

Is there a way to set up some sort of flag or tag to a command instead of referring to its full name in terminal?

I'm trying to figure out if theres a way to rename or use some sort of tag that points to a package instead of having to write the whole name of the package in the command line? because some packages ...
1
vote
1answer
24 views

apt-get autoremove does not see dependencies of a removed package?

I had ubuntu-sdk installed, /var/log/apt/history.log has to say this about it: Commandline: apt --no-install-recommends install ubuntu-sdk Install: python3-simplejson:i386 (3.3.1-1ubuntu6, ...
0
votes
2answers
31 views

What package brings an application to the system [duplicate]

Some application may installed with a bunch of packages. For example, vim can go along with packages: vim-gnome, vim-gtk, vim-nox etc. To uninstall application I need to define what is the exaxt ...
1
vote
0answers
51 views

Build an Ionic application for ubuntu phone as click package

Hello fellows I have the following application: https://github.com/kawai-developers/faster And I try to build it as a scope for ubuntu phone I managed to add the platfrom for ubuntu with the ...
5
votes
1answer
32 views

How to reverse '-proposed' channel package upgrade?

I have an Ubuntu GNOME 16.04 with GNOME 3.18 64-bit VM, and in that VM I needed to test something in the xenial-proposed channel so I activated it in the software-properties-gtk, ran sudo apt-get ...
1
vote
0answers
86 views

How to install Boost 1.60 on 12.04 LTS?

I am trying to work out how to install Boost 1.60 under Travis CI, which runs Ubuntu 12.04 LTS Server Edition 64-bit. I tried adding the debian-sid repo as an apt source so I could install ...
0
votes
2answers
149 views

How to remove php 5.6

I just went ahead and added PHP7 to my server following a guide by using ondej's PPA. Now I want to remove the old php so obviously I did sudo apt-get remove --purge php5 and ti seemed like everything ...
-1
votes
0answers
40 views

Ubuntu Dedicated Server can't install anithing (apt-get) because various errors

Hello guys yesterday I unistalled mysql server because I bought a dedicated server and it was already installed but host from I bought it didn't gave password for root access. so I decided to delete ...
1
vote
0answers
13 views

Why does Ubuntu package node.js packages?

I've been looking through this list of node.js packages provided by Ubuntu, and it's confused me a little. Why do any of these exist beyond node.js and npm itself? The majority of these packages ...
1
vote
1answer
25 views

How to report that a package is obsolete in ubuntu repositories

There are plenty of software that has had newer releases, but has not yet been updated in ubuntu repositories. Is it possible to fill a "bug" report somewhere to tell the maintainer, he should update ...
1
vote
0answers
13 views

xenial - s390x missing grub/grub2 packages?

Folks, I am trying to "apt-get install grub (or grub2)" on s390x architecture but it is unable to find this package. Please let me know how I can access it or any workaround that may exist. Thanks. ...
1
vote
2answers
557 views

(K)Ubuntu 16.04 can't install mysql server unmet dependencies

When I try to sudo apt-get install mysql-server I keep getting following error: The following packages have unmet dependencies: mysql-server : Depends: mysql-community-server (= ...
0
votes
0answers
14 views

Installing cuda 6.5: likely some package issues

So I had successfully install Cuda 7.5. Turns out I needed something pre 6.5, and I was having difficulty installing it. Seemed like no matter what i did it stayed there, so I did a good search for ...
0
votes
1answer
83 views

Samba won't install becuase of broken packages

I am running Ubuntu Server 14.04.4 and I didn't install Samba with the original OS setup. I would like to install it now but I keep getting a error about broken packages. It appears that the main ...
0
votes
0answers
11 views

Could not initialize the package information. An unresolvable problem occurred while initializing the package information [duplicate]

Recently I had an update prompt while working on my Dell Vostro Machine with Linux(Ubuntu) 12.04 LTS, after complying with the same when the package was getting downloaded, suddenly an error message ...
0
votes
0answers
13 views

Is ita safe to delete uninstalled packages with orphaned configuration files with gtkorphan?

I'm running xenial right now, and since my computer is actually slow on startup, I wanted to free a little bit more of space, though I do not have many files in my hdd. So I ended up using GtkOrphan ...
2
votes
1answer
60 views

python and package manager are broken

After upgrading Ubuntu from 15.04 to 16.04, python and package manager are broken. When running apt-get update I receive the message use apt-get -f install, but when running this command I get ...
0
votes
1answer
23 views

apt-get install fails because of libmagic1

my apt-get install is failing because of following error with respect to libmagic1. My Ubuntu version is 12.04 LTS. Can you please help if anyone aware of it? I need to fix this to update some ...
0
votes
1answer
147 views

Unable to locate pipelight-multi package [duplicate]

sudo apt-get install --install-recommends pipelight-multi Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package pipelight-multi I got ...
0
votes
0answers
7 views

How can I make sure O/S doesn't use a particular Signing Key (gpg)

Actually this is two (2) different questions. I am on Xubuntu 14.04 but I believe the answers would be the same for all *buntu variants. The first one is in the title of this message. The second is ...
0
votes
0answers
20 views

How to make pre-depends install packages in debian packaging

I am building a package that depends on package X, Y, Z. So i put them into the control file und der Pre-Depends: X, Y, Z However, this doesn't install the packages it just says my package can't ...
1
vote
1answer
36 views

“loop involving service”: apt-get install breaks dpkg

One apt-get install went bad, now every apt command results in it trying to get apache2 into a consistent state, which of course crashes. I'm not sure that the package that did it matters, but it was ...
0
votes
1answer
29 views

PyBFD cannot find Binutils in 16.04

I've upgraded my distro from 15.10 to 16.04 LTS. In 15.10 everything was okay. I am using pybfd 0.1.1 with binutils 2.26 (In 16.04). The python package pybfd used to be okay with binutils of 15.10. ...
1
vote
0answers
18 views

Cant install libgl1-mesa-glx:i386

I was trying to get wine to work and end up screwing up the system. Steam used to work but now it keeps saying I need libgl1-mesa-glx:i386 which I cant get it to install. I tried many ways and spent ...
0
votes
1answer
52 views

Upgrading kubuntu: error trying to overwrite package

I am trying to pgrade my kubuntu to the latest version. When running sudo apt-get dist-upgrade, I get: (Reading database ... 558588 files and directories currently installed.) Preparing to unpack ...
3
votes
1answer
27 views

Cannot read repositories after update

This morning my system gave me a security update that I installed. Now I cannot read or update Repositories, either from Update Manager or Terminal with sudo apt-get update. I am getting the ...
0
votes
1answer
26 views

Version range in debian/control

When declaring dependencies in debian/control to create a package, I can specify a lower or upper bound on the version. For example, if I depend on libvtk6-dev being at least version 6.0.0 I can write ...
1
vote
1answer
16 views

Is there a way to build a snappy pakage from a unstable repo like the arch repo or DebianUnstable repo

I am wondering if you can truly get new package versions with snappy? Maybe something like running a chroot of DebianUnstable and using deb2snap to build snappys? Is this possible?
0
votes
1answer
85 views

How do I fix a lot of broken packages?

I'm currently running on Ubuntu 15.10, but I want to update to 16.04. But the updater says I have broken packages. But, in my opninion, I have way too much broken packages and I have no idea why they ...
0
votes
0answers
12 views

debian package that installs other debian packages

I am trying to get familiar with debian packages and trying a couple of tutorials, so far this is the only one that makes sense and also works. So my goal is to build a package that downloads and ...