Questions about the management of packages, in particular the `dpkg` system.

learn more… | top users | synonyms (4)

2
votes
2answers
153 views

Compiling custom kernel with debug symbols

I have Ubuntu 14.04 with Linux-3.14.3-rt51 kernel. I need to use Systemtap so I compiled my kernel with the following options chosen during make menuconfig: General setup [*] Kprobes [*] Kernel->...
2
votes
1answer
361 views

ubuntu resolve unmet dependencies

I have tried to upgrade from ubuntu 14.10 to 15.04, it stopped upgrading and offered a partial upgrade which I didn't do. Right now I'm having an issue with deja-dup-monitor which is consuming about ...
2
votes
1answer
707 views

apt-get update size mismatch error

I am using Ubuntu 15.04 vivid. When I try to update I get a Size mismatch error like the one below: $apt-get update ... Get:92 http://ports.ubuntu.com/ubuntu-ports/ vivid/...
2
votes
1answer
215 views

Dependency error: Unable to install Anjuta IDE

I'm unable to install anjuta studio in Ubuntu 15.04 using the Gnome 3.16 DE. This is the output of terminal: shivam@shivam-Inspiron-3521:~$ sudo apt-get install libjavascriptcoregtk-2.4.9-0 Reading ...
2
votes
1answer
3k views

Can't install some packages. Depends: x but x is to be installed

I am on a 64bit system, that is what I suspect is creating this problem. I'm trying to install various packages, one of them is libssl-dev. $ sudo apt-get install libssl-dev Reading package lists... ...
2
votes
1answer
240 views

Cannot install using Software Center - fix does not work

The Ubuntu Software Center no longer lets me install software (tried to install pdfsam, and Synaptic, both give the same error): There seems to be a programming error in aptdaemon, the software ...
2
votes
1answer
255 views

ubuntu-restricted-extras

I am trying to install ubuntu-restricted-extras on Ubuntu 14.04 LTS (so that I can play mp3 files). However, I get an error message (see below). Any suggestions? Thanks! ...$ sudo apt-get install ...
2
votes
1answer
184 views

Zenity does not show messages in deb preinst when it is ran through Ubuntu Software Center

I am creating a deb package which requires java oracle >= 7. So I wrote a simple preinst file with bash script that will pop up a message (using zenity) that will warn the user that he needs to ...
2
votes
1answer
634 views

Error in dpkg-configure: Can not find file “symbols/u” in any known directory

After upgrading to vivid, I keep getting this error for each apt-get operation or when running sudo dpkg --configure -a directly: Setting up keyboard-configuration (1.108ubuntu5) ... Error loading ...
2
votes
1answer
62 views

Stripping image metadata

A while back, on an old installation, I had installed a package that allowed me to view and delete metadata from images. I'm fairly certain the syntax was as follows To display the metadata in an ...
2
votes
1answer
112 views

The “supported packages” in R

From http://stat.ethz.ch/CRAN/bin/linux/ubuntu/ SUPPORTED PACKAGES A number of R packages are available from the Ubuntu repositories with names starting with r-cran-. The following ones are ...
2
votes
1answer
659 views

Update Manger offline error

I'm running Ubuntu 14.04, using the i3 window manager. I'm having troubles with the Software and Updates for my system. When I start the update-manager I get this screen : The internet is working ...
2
votes
1answer
42 views

Where to put binary file?

I am packaging my own application into .deb. According to this, my compiled application should be installed in /opt/my-package. However, the tool Lintian reports such error: E: dir-or-file-in-opt ...
2
votes
1answer
2k views

Packages are broken with unmet dependencies - cannot install fglrx

I'm new to Ubuntu and trying to survive, but, I can't figure this one out - hopefully it's easy! Ubuntu Software Center says: New software can't be installed, because there is a problem with the ...
2
votes
1answer
370 views

broken package install, purge, configure, reinstall, apt-get -f wont work

so i was installing some packages by the command: openstack@controller:~$ sudo apt-get install ceilometer-api ceilometer-collector ceilometer-agent-central ceilometer-agent-notification ceilometer-...
2
votes
2answers
1k views

How to install suggested package after installation main package?

I just install chromium-browser and installation list some suggested packages to install and I continued installation and done it. $ sudo apt-get install chromium-browser Reading package lists... ...
2
votes
3answers
12k views

How to install needed Qt packages to build kernel on 14.04?

I'm going to compile kernel on Ubuntu 14.04 64-bit, so I start with installing packages that I need: sudo apt-get install build-essential bin86 kernel-package libqt3-headers libqt3-mt-dev wget ...
2
votes
1answer
284 views

Is there a way to open synaptic package manager with specific Custom Filter selected?

I have created a custom filter for specific set of tools. I want to start SPM (synaptic package manager) with the above mentioned filter so that synaptic open with list of tools I wants to show. I ...
2
votes
1answer
32 views

How do I get a list of needed packages

I want to know how to get a list of needed packages for a program. I want to get one program/application from one computer to another, by taking every package that is needed and compile it on the ...
2
votes
3answers
2k views

sudo sh -c ‘echo “deb http://archive.canonical.com/ubuntu trusty partner” >> /etc/apt/sources.list.d/canonical_partner.list’ not woking

I'm trying to skype on ubuntu 14.04, but when I type: sudo sh -c ‘echo “deb http://archive.canonical.com/ubuntu trusty partner” >> /etc/apt/sources.list.d/canonical_partner.list’ It says "...
2
votes
1answer
704 views

Cannot install any package via apt-get

So my problem is quite easy to describe: I can't install anything in my Ubuntu installation. apt-get stopped working after I tried to fix some other package errors I was getting. Now I'm nowhere. Let ...
2
votes
1answer
532 views

dpkg: warning: files list file for package 'linux-generic' missing; assuming package has no files currently installed

Every time I want to install something with terminal it shows this warning message but it continue to install, what's the problem? dpkg: warning: files list file for package 'linux-generic' ...
2
votes
1answer
3k views

How to find packages when updating Ubuntu and creating standard source.list file

I just upgrade to Ubuntu 14.04 LTS, amd64. I'm trying to install some software and it says for Ubuntu 13.10 and above, the following libraries need to be installed for 32-bit compatibility components:...
2
votes
2answers
5k views

How to solve missing libmng.so.1 in Trusty (14.04) Package is no more available

I would like to run SoulseekQT. However unfortunately one of the dependencies is libmng1, which is no more included in Trusty. sudo apt-get install libmng.so.1 or libmng1 or libmng1:i386 in Trusty (14....
2
votes
2answers
2k views

libc6-amd64 dependency problem

I'm trying to install fglrx manually from the AMD website however it keeps complaining that it's missing the dependency "libc6-amd64". When I run the fglrx package through gdebi I get this message: ...
2
votes
2answers
6k views

apt-get remove --purge wine* removed everything!

sudo apt-get remove --purge wine* opened the gates of hell and removed many things. I wasn't allowed to paste the output here, too big. I stopped the process, I wanted to save what's left of my ...
2
votes
1answer
2k views

Can't launch JD-GUI on Ubuntu 12.10 64bits

When I try to open JD-GUI via the terminal it gives me the following error error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory So ...
2
votes
2answers
1k views

How to rename deb package?

I get package source by typing: sudo apt-get source nginx and added --add-module=/usr/src/nginx-rtmp-module \ string to debian/rules How I can rename packages from nginx-* to nginx-rtmp-*?
2
votes
1answer
67 views

Ubuntu distribution upgrades: move all user interaction to the end?

Is there a way to move all user interaction that occurs during a release upgrade to the end of the upgrade process? As it currently stands, the Ubuntu upgrade process will be interrupted whenever ...
2
votes
1answer
266 views

How can run a gsettings command inside a postinst script from a custom .deb package?

I want to change the wallpaper when a custom .deb package is installed. In the postinst script I've written this: PID=$(pgrep gnome-session) export DBUS_SESSION_BUS_ADDRESS=$(grep -z ...
2
votes
1answer
449 views

unable to locate package cgroups-lite [duplicate]

$ sudo apt-get install cgroups-lite [sudo] password for neethu: Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package cgroups-lite
2
votes
1answer
486 views

Cannot install libgtkmm-2.4-dev in Kubuntu 13.10 - unmet dependencies

I'm trying to install grub-customizer in Kubuntu 13.10. After a lot of fiddling, following various online advice, I got to the point where I needed to install libgtkmm-2.4-dev (which I know nothing ...
2
votes
1answer
314 views

Need to downgrade a package with many dependents

In order to get a working low-power video card setup I decided to use a custom xserver from Andrikos:ppa. It worked well, but when the official release caught up to the bug fixes I dried to drop the ...
2
votes
3answers
118 views

How to conveniently find local HTML documentation?

There are many doc packages in the repositories which provide documentation in HTML. Is there an easy way to find locally installed HTML documentation, like info or man? I guess I should clarify ...
2
votes
1answer
1k views

apport-retrace fails with error: report file does not contain one of the required fields

I installed an application from the developer's website and it was crashing. I tried using this form of apport-retrace to get a report I could email to the dev myself: apport-retrace --confirm --gdb ...
2
votes
1answer
165 views

how to copy updates from 1 linux box to another using cli remote serial and usb drive

I have 2 old pc's that I'm going to remote into using serial port/tcp. The first one is a 32-bit machine that I remoted into serially and couldn't get it to connect to the internet for various reasons....
2
votes
2answers
938 views

How can I remove the Lubuntu packages after installing ubuntu-desktop on top of Lubuntu? [duplicate]

On this machine, I installed Lubuntu 12.04 and then installed the ubuntu-desktop package. Now there is some Lubuntu software, such as the Lubuntu Software Center, Xscreensaver, and Abiword, that needs ...
2
votes
1answer
746 views

Downgrading a package with older version “physically” in the repository

I want to downgrade from OpenJDK Update 25 to OpenJDK Update 21. If I look, for example, at security.ubuntu.com or at mirror.pnl.gov, I can see that .deb files for Update 21 are still there, however, ...
2
votes
1answer
399 views

how to find out what versions of a package from a launchpad repository are available with apt-get

If I go to the following web page https://launchpad.net/ubuntu/+source/gedit/+publishinghistory there are a number of versions of gedit listed for the distribution "raring" (3.6.0-0ubuntu1, 3.6.1-...
2
votes
1answer
726 views

Unmet Dependencies for handbrake-gtk

I have reviewed the suggestions at [How do I resolve unmet dependencies?]. As yet, my issue remains. Here's hoping the good folk here can help me. sudo apt-get install handbrake-gtk ...
2
votes
2answers
1k views

Installed then removed Kubuntu Desktop - now Ubuntu/Unity doesn't look quite right

I am running QQ - default Ubuntu/Unity desktop Installed kubuntu-desktop with 'apt-get install kubuntu-desktop' to try it out. Decided I didn't like it, so I removed it with 'apt-get remove kubuntu-...
2
votes
1answer
1k views

How can Ubuntu detect some mobile devices that debian doesn't?

For example, when I plug a Samsung i770 in ubuntu and I run eclipse, the mobile device is detected and I can run my apps. But debian doesn't recognise this device. What package is included in Ubuntu ...
2
votes
1answer
3k views

Ubuntu Chromium browser - how to define zoom percentage via command line launch?

I have Chromium browser running as Ubuntu Desktop, when i launch my system i need to set the Chromium browser zoom percentage to 79%, so that it always remain default. Using command line, how do i ...
2
votes
1answer
96 views

Why is the library's linker name only in the -dev package?

Take a package like sqlite3: http://packages.ubuntu.com/lucid/i386/libsqlite3-0/filelist http://packages.ubuntu.com/lucid/i386/libsqlite3-dev/filelist Note that the linker name (/usr/lib/libsqlite3....
2
votes
2answers
9k views

Cannot get OpenGL to install [duplicate]

When I try to run an example application it says I am missing a file that is found in OpenGL. I found information online and tried to install OpenGL with the following command: sudo apt-get install ...
2
votes
1answer
328 views

How to create package download script with correct dependencies?

In Synaptic it's possible to select a bunch of packages for installation (or reinstallation), then just click File → Generate package download script to get a set of commands to download the ...
2
votes
1answer
885 views

Old ubuntu 10.10 [closed]

Explanation: I have a VPS that comes with ubuntu 10.10. I'm using it for a webserver that runs a bunch of sites. My problem is that I cannot upgrade the distribution (which I really want) . I ...
2
votes
1answer
3k views

Failed to fetch http://np.archive.ubuntu.com/ubuntu/pool/main/k/krb5/libkrb5-3_1.10+dfsg~beta1-2ubuntu0.3_i386.deb 403 Forbidden

I am using Ubuntu 12.04 32-bit with kernel 3.2.0-26-generic and GNOME 3.4.1. when I run the upgrade manager, I get the option for partial upgrade and details show: install (11) remove (1) upgrade (...
2
votes
1answer
636 views

Installing zsnes on Lubuntu

How do I install zsnes on Lubuntu? I've already updated Synaptic and ran sudo apt-get install zsnes, it came up with this error: >Reading package lists... Done Building dependency tree ...
2
votes
1answer
5k views

How do I install signal so I can install Octave?

anyone can help me with this error? octave:4> pkg install signal-1.2.0.tar.gz error: the following dependencies where unsatisfied: signal needs optim >= 1.0.0 signal needs specfun >= 0.0....