Questions about the management of packages, in particular the `dpkg` system.

learn more… | top users | synonyms (4)

0
votes
1answer
25 views

Unmet dependencies after skype

I tried install Skype from deb-file, downloaded from Skype.com on my fresh Ubuntu 14.04. This attepmt caused an error: ... skype depends on libasound2-plugins. dpkg: error processing package skype ...
0
votes
1answer
1k views

Can't install systemctl - E: Package 'systemd' has no installation candidate

I want to install 'systemd' in ubuntu/trusty64 but getting E: Package 'systemd' has no installation candidate error, have done sudo apt-get update and upgrade before and after installation commands. ...
0
votes
0answers
77 views

Can't reinstall Banshee?

So, I had Banshee because of dependencies issues and now I can't reinstall the player from Guake or Synaptic Package Manager. error from Synaptic: banshee: Depends: libglib2.0-0 (>=2.44.1) but ...
1
vote
1answer
17 views

how to get the sudo apt-get install r-base failure

after entering the command sudo apt-get install r-base r-base-dev it prompts me to insert a disc labeled ubuntu 14.04.2 trusty tahr. What does that mean? Do i have to insert a disc as the prompt ...
1
vote
1answer
794 views

dpkg: error processing archive

I am new to Ubuntu, when I try to install new package, It is asking for run sudo apt-get -f install command, and when I execute that command, I am getting following logs: temp@temp-desktop:~$ sudo ...
0
votes
0answers
157 views

Reg installing packages on Ubuntu 15.04 Vivid vervet

I have installed Ubuntu 15.04 on my PC. I am using this PC behind corporate firewall. I am not able to install any package from terminal.when I run sudo apt-get install git I am getting the error ...
0
votes
1answer
58 views

/usr/local/lib contains libraries which Aptitude reports aren't installed

I am trying to build a project that uses a specific library (SDL) on Ubuntu. The project uses old version of the library (libSDL-1.2). I've made mistake of installing the newest library but have since ...
1
vote
2answers
6k views

Unable to locate package lib32bz2-1.0

I am trying to install Simplicity studio on Ubuntu 15.04 (64-bit) and I get this error E: Unable to locate package lib32bz2-1.0 E: Couldn't find any package by regex 'lib32bz2-1.0' I tried to ...
0
votes
2answers
554 views

gcc fails to compile

I'm a newbee but adventuresome. I'm tri-booting Windows, Fedora, and Ubuntu 14.04 LTS (all 64). Learning but not using dpkg, apt, and apt-get. Starting to study C++ using Ubuntu (the only one with gcc ...
1
vote
0answers
17 views

Is there a way to create a deb package that installs only on certain distros? [duplicate]

We have a certain set of supported OSs. And within that - for debian/ubuntu, we support only wheezy and trusty. Is there anything within the packaging that can control this? That is, the .deb file ...
24
votes
3answers
3k views

Why can terminal uninstall itself?

How does apt-get remove xterm go through? And after it's been uninstalled, xterm doesn't close and continues to function normally. Is the xterm process cached in RAM whilst it is running?
0
votes
0answers
414 views

pkg-config not updating installed libs

I am trying to install GTK+-3.16 and I have installed all the dependencies but when I finally try to configure GTK, it gives the following errors: configure: error: Package requirements (glib-2.0 ...
0
votes
1answer
346 views

Unable to correct dependencies while installing vlc

In an attempt to install vlc offline(internet was down), I manually installed the packages needed to run vlc. I copied the packages from my friends Ubuntu(apt-cache depends vlc). So now my apt-get ...
0
votes
0answers
179 views

system trouble after apt-get upgrade

I ran sudo apt-get upgrade a few times and kept returning an error message. After a restart my system doesn't work properly. I've looked at other questions and found that my boot partition is full. So ...
1
vote
2answers
40 views

Package explanation

I was having issues with my graphics card working on Ubuntu and I had to enter the commands below as part of the process to get it working. I don't know what they are or what they do, so I'd like ...
1
vote
0answers
757 views

Upgrading from 14.04 LTS (Trusty Tahr) to 15.04 (Vivid Vervet)

How long does it take to upgrade from 14.10 LTS to 15.04 ? The procedure of Saving installed packages is going on for last 18 hrs on my system. I have chosen the option of keeping all my personal ...
0
votes
1answer
783 views

How can I slove postgresql-9.3-postgis-2.1 unmet dependencies Ubuntu 14.04

I've installed PostgreSQL v9.3 (database) on Ubuntu 14.04 and I'm currently attempting to install the following: sudo apt-get install postgresql-9.3-postgis-2.1 However I'm getting the following ...
1
vote
1answer
52 views

Which packages is installed by default in Ubuntu?

How to determine whether a given package is shipped by default in Ubuntu installation or it's installed later by the user?! The answer in this U&L says: To figure out if a package (Tor here) ...
0
votes
2answers
45 views

Several unmet dependencies

I have recently tried downloading steam from the Ubuntu Software Centre but when I try to launch the program I got the bellow error message. Also my results when trying to install are this when it ...
1
vote
1answer
264 views

Not All Updates Can Be Installed Lubuntu

When I try "Software Updater" -> "Not All Updates Can Be Installed" Please tell me is everything ok with the updates? sudo apt-get update Ign http://dk.archive.ubuntu.com trusty InRelease Ign ...
0
votes
0answers
80 views

vlc player is not installing from ubunto software center giving a massage

The following packages have unmet dependencies: vlc: Depends: vlc-nox (= 2.1.6-0ubuntu14.04.1) but 2.1.6-0ubuntu14.04.1 is to be installed Depends: libc6 (>= 2.15) but 2.19-0ubuntu6.6 is to be ...
0
votes
0answers
40 views

How do I compare my openssl version with non-ubuntu openssl versions?

I have an ongoing problem where every time an openssl vulnerability is found, the announcement documentation tells me what versions of openssl are safe -- but ubuntu doesn't actually use the same ...
0
votes
1answer
60 views

Bash script to log all recent apt-get installs and locations

Sorry if something like this already exists, but in my research I found no evidence that it did. what I want: a "monitor" type script that I can write, that I would "activate" prior to apt-get ...
1
vote
2answers
485 views

I want to remove .deb package in ubuntu

I installed youtube-dl_2015.06.04.1-1~webupd8~trusty0_all.deb in my system. It is not properly installed and I want to remove this package from my system. I am using the command below to remove this ...
0
votes
0answers
31 views

wd mybook world edition. mdadm package

After cleaning the disk I want to put new firmware on the disk. This has to be done according to different tutorials with Ubuntu. So this is completely new for me as a normal windows user. In the ...
0
votes
1answer
293 views

Error You might want to run 'apt-get -f install'

I have the next error when I try to install Google Chrome or LibreOffice or any software I want. Error console: Reading package lists... Done Building dependency tree Reading state ...
2
votes
1answer
162 views

Not work “sudo apt-get upgrade”

I am use ubuntu 12.04 installed Dell vostro 15 3000 series laptop. when I hit sudo apt-get update it works fine and then i hit sudo apt-get upgrade its shows me and then when i press Y it ...
0
votes
1answer
403 views

Ubuntu 14.10 can't install libplrpc-perl, and php-bcmath

My system is: Distributor ID: Ubuntu Description: Ubuntu 14.10 Release: 14.10 Codename: utopic when I try to apt-get install libplrpc-perl , and php-bcmath it tells me ...
1
vote
1answer
192 views

Installing libapache2-mod-fcgid, but can't get through configure

I have setup two servers today from a vmware template. One one this worked, the other it didn't. The only difference is that on the failing one I ran apt-get distupgrades from the last few days before ...
1
vote
0answers
127 views

enabling proposed repos in 15.04 server fails to update packages

i am trying to use the proposed repo of vivid on ubuntu 15.04 server system. user@controller:~$ cat /etc/lsb-release DISTRIB_ID=Ubuntu DISTRIB_RELEASE=15.04 DISTRIB_CODENAME=vivid ...
0
votes
0answers
26 views

Package bash-builtins: unable to run make sucessfully in examples/loadables

When I was wander through the Ubuntu 14.04 apt repository using apt-cache search ^bash, I found the bash-builtins package, and installed it. After installation, with dpkg -L bash-builtins, I found ...
0
votes
0answers
175 views

apt-get problem after having removed Python2

I'm quite a newbee. I installed Python2 and Python3. I got bored of Python2 and decided to uninstall it, if i remember well by sudo apt-get remove python2 but now, everytime i use apt-get , i get ...
0
votes
0answers
62 views

Can I map Archlinux's official-packages into a PPA automatically?

I've been using chroagh on my Chromebook to get an Archlinux environment. Unfortunately, maintenance of chroagh is not keeping up with Freon. I'm switching to Ubuntu on my Chromebook, since crouton ...
3
votes
2answers
63 views

Auto remove limitations?

Is it possible to do sudo apt-get autoremove without removing packages in use? I did an autoremove command and it asked my if i wanted to remove those packages. Since it was a lot of packages i ...
0
votes
0answers
27 views

problem with unmet dependencies while installing libgdal1-1.5.0 and odbcinst1debian1

I am trying to install flightgear 1.9.1 in Ubuntu 15.04. My computer is not very fast and a version that could work is flightgear 1.9.1 I installed odbcinst1debian1 but when I try to install ...
0
votes
0answers
62 views

No static libraries in some packages

I am using Ubuntu 14.04 and installing tons of prerequisites in order to build some large libraries. I compiled lots of dependencies myself already, but would like to avoid compiling any more due to ...
0
votes
2answers
606 views

apt-get install/remove/reinstall doesn't work. Python errors

Recently I tried to install the ubuntu desktop on my ubuntu server 14. The installation failed hard. I tried several things fixing it and did a lot of research. But I couldn't find anything helpful. ...
0
votes
0answers
38 views

Problem installing lisbdl2 amd64 and i386 together

I'm using 64-bit Ubuntu 15.04. If I compile simple apps to 32-bit, with -m32, it works, I've installed the multiarch stuff. I've installed libsdl2-dev and libsdl2-image-dev. Now I want to compile it ...
3
votes
2answers
2k views

How do I add i386 architecture in Ubuntu MATE 15.04?

So I want to install wine:i386 so I can use PlayOnLinux. http://wiki.playonlinux.com/index.php/Installing_PlayOnLinux For users' Debian wheezy and Ubuntu Precise (and higher), they'll need to ...
4
votes
1answer
2k views

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages

I've been trying to install the CoreBird Twitter application and have had horrible luck with getting it to compile and then I came across a deb (from here) and tried to install it that way. However, ...
0
votes
1answer
20 views

Synaptic 'Complete Removal' messed my system

I'm having a bad time trying to flash a android ROM in my phone. It almost take me to the need of using windows again for runing 'Odin'. After searching I found 'Heimdall', but has some problems ...
1
vote
1answer
131 views

An error occured…unmet dependecies…run package manager

There's a red circle with minus sign at the top left corner on my ubuntu 14.04 desktop, when clicked it says: An error occurred, please run Package Manager from the right-click menu or apt-get in ...
0
votes
0answers
106 views

How to purge everything?

I have for months a corrupted thing in my packages system since I tried to install Skype. Now, I need to install lib32stdc++6, but whey I try to do it with apt-get, I get the following error: ...
0
votes
0answers
53 views

I tried to install mysql and got this error message about broken package , can anyone suggest a fix?

I tried to install mysql and got this error message about broken package , can anyone suggest a fix? The following packages have unmet dependencies: mysql-server-5.6: PreDepends: mysql-common ...
0
votes
3answers
1k views

unable to find mysql-server package in ubuntu

I tried installing mysql using the command sudo apt-get install mysql-server then after entering the password, I'm getting the message Reading package lists... Done Building dependency tree ...
2
votes
1answer
54 views

Is an Ubuntu packages update via GUI superior to one via CLI?

Why do GUI-based packages update and CLI-based packages update differ? Many times after updating Ubuntu packages via GUI, it ask me to restart my computer. However, when I do it via the command-line ...
0
votes
1answer
98 views

New to UBUNTU, problems installing steam

Distributor ID: Ubuntu Description: Ubuntu 14.04.2 LTS Release: 14.04 Codename: trusty firefox Steam needs to install these additional packages: libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, ...
1
vote
0answers
21 views

how to install packages which is not in the cache with python

i install packages in my application using python apt. Some example: import apt cache = apt.cache.Cache() pkg = cache["brukkon"] pkg.mark_install() cache.commit() In this example, brukkon is not in ...
1
vote
2answers
1k views

Problem removing avg

I've tried to remove avg2013 however when I try I get a funky error message. The command I'm running: sudo apt-get remove --purge avg2013flx The error I get: Removing avg2013flx (2013.3118) ... ...
0
votes
1answer
58 views

I got a problem upgrading packages on Ubuntu 12.04.5 LTS

root@ubuntu:~# su root@ubuntu:~# apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done The following packages have ...