Questions about the management of packages, in particular the `dpkg` system.

learn more… | top users | synonyms (4)

0
votes
0answers
86 views

Failure on apt update in Trusty (14.04)

When I try apt update it fails with Hash Sum mismatch I already tried to change mirrors (like in How can I get apt to use a mirror close to me, or choose a faster mirror?) I also tried to ...
0
votes
0answers
7 views

dependendy is not satisfiable: libcupsimage2

I'm trying to install libcupsimage2-dev package, but when I run it I get the message: dependendy is not satisfiable: libcupsimage2 (=1.4.3-1) But then I try to install libcupsimage2 1.4.4-7 and I ...
-1
votes
0answers
18 views

dpkg error,Maxreports error, python errror [Ubuntu 14.04]

i think i have a big problem :) sudo apt-get purge python-gi i wrote this. and sudo apt-get purge python-gi i wrote. ~$ sudo apt-get upgrade Paket listeleri okunuyor... Bitti Bağımlılık ağacı ...
2
votes
1answer
93 views

unmet dependencies for synaptics touchpad driver

I have Ubuntu 14.04.2 installed on a Lenovo S21e-20. To get things like two-finger-scrolling or suspending the touchpad during typing, I wanted to install xserver-xorg-input-synaptics but installation ...
1
vote
1answer
60 views

System messed up due to partly remove of Python2 - How to restore it? [duplicate]

I installed python 2.7.9 then after a while I want to install python 3.4.3. So I tried to remove python with this command: sudo apt-get remove python but I installed a lot of tools and IDEs for ...
0
votes
0answers
40 views

minimal install of Ubuntu 14LTS has SSHd enable , but no Openssh package installed

I'm installing U14 LTS from the "Minimal" CD image on a VM. Installation goes as planned, only item I checked to install additionally was 'OpenSSH server'. After install, I'm doing an inventory of ...
1
vote
0answers
21 views

apt-get configured to use proxy with some sources but not others

Can apt-get be configured to use a proxy with some sources but not with other sources? I have a Ubuntu 14.04 trusty server on an AWS EC2 instance. It needs to use a proxy to get to ...
2
votes
1answer
45 views

I broke my package manager

So basically, I run ubuntu 14.04 and I can't install packages. I ran sudo apt-get -f install and the terminal gave me this the-administrator@Tower-Of-Power:~$ sudo apt-get -f install Reading ...
0
votes
2answers
31 views

How to manage package from previous Ubuntu versions

I have Ubuntu 14.04 (Trusty Tahr). This output should clarify what I'm referring to $>dpkg -l | grep raring ii ezame 0.5~raring-1 ...
1
vote
1answer
30 views

How to get a list of the package home pages in a repository section from command line?

A while ago, I asked here about how to get the list of packages in a repository section from the command line. According to the Synaptic Package Manager, many of these packages feature a home page. ...
0
votes
0answers
16 views

How to make voice call from EON 3G data card?

As a windows user I was able to make calls through my system . In ubuntu there is no option for calls , my question is " Is there any software which can help me to make voice calls ? " The built in ...
1
vote
0answers
49 views

Messed up “update-notifier-common”-package / debian.deb882 not found

Unfortunately, when attempting to reinstall ttf-mscorefonts-installer and flasplayer-installer, I got the error that update-notifier-common is not working. According to root@AlkaliMetal:~# dpkg -s ...
0
votes
1answer
58 views

Cannot install anything! Unmet dependencies. Libre Office

Please help, I've searched around loads and can't seem to find a solution that works. I recently removed libre office and installed open office. After trying to reinstall libreoffice. I now can't ...
-1
votes
1answer
38 views

14.04 trusty: 'apt-get install' silently refuses upgrade package with unsatisfied dependencies

This is more or less replication of this question. I hope AskUbuntu is more suitable place for it. Short description: apt can't upgrade a package if some dependencies are missing (it's OK), but ...
0
votes
0answers
20 views

dependencies error when install software-center

when I want to install software-center on Ubuntu 14.04.2, I got these messages: software-center: Depends: software-center-aptdaemon-plugins but it is not installable Depends: gir1.2-gmenu-3.0 ...
0
votes
1answer
19 views

remove package with broken pipe problem

I installed qupzilla today to replace chrome (it was hogging WAY to much ram). I liked it and I wanted to update it to the latest version using there repository but as I tried to update it an error ...
0
votes
1answer
55 views

Red Triangle with an exclamation point [duplicate]

I am new to Ubuntu 14.04, having just installed it 2 weeks ago. I am running Ubuntu 14.04 as my only OS. I am a new user and I have to say I love the OS but I am having a difficult time learning it. I ...
1
vote
1answer
63 views

Terminal commands are not working Ubuntu 14.10 [duplicate]

How do I fix this major issue: E: Type 'sudo' is not known on line 3 in source list /etc/apt/sources.list.d/libdvdcss.list What do I do to fix this? This is what I get when I open Synaptic Package ...
0
votes
0answers
48 views

Installing libgl1-mesa-dev gives unmet dependencies

I am using Ubuntu 14.04 sudo apt-get install libgl1-mesa-dev When I try to run this command I get: The following packages have unmet dependencies: unity-control-center : Depends: libcheese-gtk23 ...
1
vote
1answer
32 views

Why Landscape is not showing package information?

I just install Landscape 15.01 (it came on the testing package of openstack-install), and everything is working fine: the nodes are being reported to LDS, but there is no package information. If I go ...
-1
votes
2answers
23 views

one click software installation [duplicate]

friends, i am very new to ubuntu,and is been using this incredible thing from past few days, it's a really very new experience for me,i would like to know about one click install methods as like in ...
0
votes
0answers
24 views

Have multiple versions of ImageMagick installed. How do I choose the latest version?

Using 14.04 I have multiple versions of ImageMagick installed. Version 6.7.7 was installed by a chef script with that set up our sever, I believe w/ 'package "imagemagick"' Version 6.9.1 was ...
3
votes
3answers
90 views

How to read package description before installing?

How can I get information about a package before installing it, from the terminal? I mean something like man pages, but accessible even before the package is installed.
0
votes
0answers
27 views

Working code examples of python-apt

i downloaded the source code of python-apt from here : https://github.com/excid3/python-apt In this source code, in directory doc/examples , some python codes are exist. I thought that i could run ...
-2
votes
1answer
29 views

how install stack package nxt_python in ROS FUERTE? ubuntu 12.04

i have the following problem, i have installed ROS FUERTE in my pc with ubuntu 12.04 l decided choose ROSE FUERTE because was the only that works with ubuntu 12,04 i tried to installed ROS ELECTRIC, ...
1
vote
1answer
30 views

how to uninstall emacs from command line?

I have ubuntu 12.04 I installed emacs using below commands. $ apt-get update $ apt-get install emacs Then, as expected, I could find emacs while searching in dash. Next I wanted to uninstall ...
0
votes
1answer
23 views

With Ubuntu 14.04 I get errors related to QGIS when I type sudo apt-get dist upgrade

Mods - This is not a cross post and please do not flag it as a cross post. I did not receive any answer on GIS - ...
0
votes
1answer
34 views

Unable to install or remove package

This specific message is displayed in the terminal $ sudo apt-get remove bio-linux-cdbfasta Reading package lists... Done Building dependency tree Reading state information... Done The ...
-1
votes
0answers
30 views

Apt-get install -f wants to remove pantheon-shell

I had some sound issues on my old laptop and couldn't install pulse audio for unmet dependencies that seemed that no one else on the internet ever had. After all I did a stupid thing $ sudo dpkg ...
-1
votes
2answers
26 views

Unable to locate package perl(Net: & IO::Socket:)

When i am trying to use following command it shows following error root@RR-DE-NMS-1:~# apt-get install 'perl(Net::SSLeay)' 'perl(IO::Socket::SSL)' Reading package lists... Done Building dependency ...
0
votes
1answer
35 views

Please, help me install libboost1.40-all-dev

I am trying to install NXT-ROS and in order for me to do that, I need libboost1.40-all-dev When I input the command sudo apt-get install libboost1.40-dev-all I get the following: root@joel:~# sudo ...
-1
votes
2answers
125 views

Can't find libgnutls28 for ubuntu 15.04

Where to find libgnutls28 for Ubuntu 15.04? I installed Ubuntu 15.04 today, and i tried to install Kodi, but it requires libgnutls28, and i was not able to find it anywhere, i tried searching for it ...
0
votes
0answers
46 views

apt-get install problem with MySQL Ubuntu 12.04 [duplicate]

I have a working system with Ubuntu 12.04 and LAMP For some reason i am unable to install any new software on system. Every time I try to use apt-get install i get the following error: Example: ...
-1
votes
0answers
19 views

DPKG Error code - Gnome, Gnome-core, Gnome-online-accounts,

When i try to install pretty much anything or typing -f install this outputs: jure@jure-desktop:~$ sudo apt-get install aptitude Reading package lists... Done Building dependency tree Reading ...
-1
votes
0answers
14 views

Failed to load session “ubuntu” - recommends plymouth-theme-ubuntu-logo [duplicate]

Whenever I try to log into Ubuntu 12.014LTS, I get this message in my log in screen: Failed to load session "ubuntu" When trying to log in via the command-line interface and installing the ...
0
votes
0answers
6 views

Uninstall Eclipse Indigo

I have a preinstalled Eclipse Indigo on my ubuntu 12.04 that I want to uninstall. When I try sudo apt-get remove eclipse what I get is: Reading package lists... Done Building dependency tree ...
1
vote
0answers
36 views

Regarding Too many errors in /usr/bin/dpkg returned an error code (1),

Output of command on terminal at Ubuntu 14.04 LTS sudo apt-get install python No apport report written because MaxReports is reached already No apport report written because MaxReports is ...
1
vote
1answer
41 views

Error when sudo apt-get upgrade

I run Ubuntu 14.04 LTS. When I type sudo apt-get upgrade into the terminal I get this error message. The following packages have unmet dependencies. cups : Depends: libc-bin (>= 2.13) E: Unmet ...
1
vote
2answers
34 views

How can I check how much space specific packages occupy?

I maintain a list of packages I installed on my system (using apt-get). I would like to know how much space these packages occupy, together with their dependencies if possible. Can I use some tool ...
0
votes
0answers
16 views

Error removing Xplico

Do you want to continue? [Y/n] y Preconfiguring packages ... (Reading database ... 205993 files and directories currently installed.) Removing xplico (1.1.0) ... /var/lib/dpkg/info/xplico.postrm: 23: ...
0
votes
1answer
23 views

Is it safe to install libstdc++6:i386 on machine which already has libstdc++6:amd64?

Is it safe to install libstdc++6:i386 on machine which already has libstdc++6:amd64? I mean will i386 libs overwrite the existing amd64-libs?
0
votes
1answer
35 views

Conflict between freefem++ and fglrx

I am trying to install the package freefem++ via command-line and I stumble upon a strange conflict. Indeed freefem++ is a finite element solver for PDE and I can't see why it wants to remove my ...
0
votes
1answer
37 views

Uninstall libav packages after re-installing from source

I'm running kubuntu 14.04 and don't plan on upgrading until at least these summer holidays. The libav packages provided are somewhat outdated (two major versions behind) and produce unsatisfying ...
0
votes
0answers
20 views

Is there a way to install all packages (and their dependencies) in a repository

Is there a way to install all packages (and their dependencies) in a repository ? I am using synaptic package manager and I cannot mark all the packages within a repo because its dependencies are not ...
0
votes
1answer
53 views

How to keep all linux kernel packages on Kubuntu 14.04?

I'm running Kubuntu 14.04 on my private laptop. When the package system updates my Linux kernel it removes the old packages, only keeping the 2 newest versions of the kernel images (and associated ...
0
votes
0answers
93 views

Why can't I install mono-complete?

When I try to install it, the following result comes up: Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may ...
2
votes
2answers
46 views

apt-get update doesn't work gives an error

Errors were encountered while processing: /var/cache/apt/archives/libsdl2_2.0.3+z4~20140315-8621-1ppa1trusty1_i386.deb ...
0
votes
1answer
102 views

Removing cuda-repo Network Installer and installing the local version

I have followed the instructions in a tutorial to install cuda on Ubuntu 14.04. Problem is that I didn't notice that I installed the Network Version of the cuda-repo*.deb . How can I change this and ...
1
vote
0answers
15 views

What are the implications of compiling packages from source?

What are the implications of compiling packages from source? For example, what if doing sudo apt-get upgrade upgrades a dependency of the manually-installed package? How would using a package from the ...
0
votes
1answer
165 views

Broken packages while installing cuda-drivers in Ubuntu 14.04

I am trying to install cuda on Ubuntu 14.04, I posted a question , and tried to install cuda via aptitude. I eventually got an error message of broken packages (and now I have a red sign on the upper ...