Questions about the management of packages, in particular the `dpkg` system.

learn more… | top users | synonyms (4)

0
votes
0answers
13 views

apt-get detects no package [duplicate]

I have a problem which is probably linked to the internet problems. I have an ubuntu 14.04 LTS as a partition on MBP, and I have very recently got the Wi-Fi driver working. However, it is very slow. ...
1
vote
1answer
44 views

How can I install the latest version of Tor?

I can't run tor from Iran with obfs3 but when I download the latest version of Tor Browser from https://www.torproject.org/dist/torbrowser/4.5.1/tor-browser-linux64-4.5.1_en-US.tar.xz, it worked ...
0
votes
0answers
11 views

How to get libloginhelper in Trusty?

I'm trying to compile gok (Gnome On screen Keyboard) version 2.30.1 on Xubuntu 14.04. The only pkg-config packages that I'm missing are: checking for gtkdoc-mkpdf... no checking whether to build ...
0
votes
0answers
18 views

QGIS errors when I update/upgrade Ubuntu 14.04

I ran the instructions as given in this answer - With Ubuntu 14.04 I get errors related to QGIS when I type sudo apt-get dist upgrade but I still get the errors below. Can someone guide me in ...
6
votes
1answer
389 views

How to recover accidentally removed /bin/ls binary

I have mistakenly deleted the ls executable from the /bin folder. Can I recover it or install it through the terminal?
-1
votes
1answer
56 views

apt-get install -f — Error: no space left on disk

I had cache limit problems with GPG keys. A post here solved that, and now sudo apt-get update runs without any errors. Now sudo apt-get upgrade does not work. It tells me to try sudo apt-get -f ...
2
votes
1answer
68 views

How do I update to Version 4.7 of KMyMoney from Ubuntu 12.04?

I have tried the following steps and I am still in version 4.6.6. I am a newbie to linux. Any help would be much appreciated. sudo add-apt-repository ppa:claydoh/kmymoney2-kde4 sudo apt-get update ...
0
votes
0answers
15 views

Install package fail: require dependency that already exists

I am developing something that requires a specific version of "libselinux1". I need version 2.1.9-5 so I do: sudo apt-get install libselinux1=2.1.9-5 I get: Reading package lists... Done Building ...
3
votes
1answer
56 views

Error in dpkg-configure: Can not find file “symbols/u” in any known directory

After upgrading to vivid, I keep getting this error for each apt-get operation or when running sudo dpkg --configure -a directly: Setting up keyboard-configuration (1.108ubuntu5) ... Error loading ...
-1
votes
0answers
21 views

Im having problems downloading from the SoftwareCenter, and also downloading new updates

Everytime i try and download an item from the USC i get this message: installArchives() failed: Extracting templates from packages: 93% Extracting templates from packages: 100% Preconfiguring ...
7
votes
3answers
146 views

How do I exclude specific packages from installation with apt-get?

I would like to exclude specific packages from installation with apt-get, that is, install a metapackage without the list of specific packages, preferably with one invocation of apt-get. For example, ...
5
votes
3answers
243 views

Uninstalling Dependencies. Is This a Good Practice?

As far as I know I can uninstall a program from Ubuntu using this command... $ sudo dpkg -r packagename But this does not remove the dependencies while the packagename installed. To remove all ...
0
votes
0answers
20 views

Having Trouble Installing DeSmuME from the Software center [duplicate]

I tried installing DeSmuME on 14.04.2 LTS. But I keep getting this error: "Package dependencies cannot be resolved..." How can I fix this and install DeSmuME?
-2
votes
0answers
23 views

Why on Ubuntu 14.04.2(updated) the Python 2's version is 2.7.6 [duplicate]

i have just installed a Vagrant box of Ubuntu 14.04.2 (Trusty). Now, as i ran Python interpreter, it loads up Python 2 automatically. That's ok. However, i wonder why the Python 2's version is 2.7.6 ...
0
votes
1answer
24 views

why do you have /home partition even you can't use it? [duplicate]

I've set the / volume for 30gb and it's getting full now. I want packages and programs to be installed in /home partition and I don't know how. I want to install things into my /home partition!!
1
vote
2answers
286 views

“Unmet dependencies” When trying to install KDE Plasma 5.3 on Ubuntu 15.04

I'm trying to install the latest KDE Plasma here but I'm getting You might want to run 'apt-get -f install' to correct these. The following packages have unmet dependencies: kde-telepathy-minimal: ...
0
votes
1answer
25 views

Why can't apt find Packages file when compressed versions exist?

When I execute apt-get update on a Precise Ubuntu server I am getting an errors like this: W: Failed to fetch http://se.archive.ubuntu.com/ubuntu/dists/precise/main/binary-amd64/Packages 404 Not ...
0
votes
0answers
6 views

Ruby broken completely

I want to install jekyll 1.0 but it seems my system is broken somehow. If I type ruby: ruby The program 'ruby' can be found in the following packages: * ruby1.8 * ruby1.9.1 Try: sudo apt-get ...
0
votes
3answers
34 views

Software Center does not open

When I try to open the Software Center, I get a message saying "Could not determine the package name." I am a new Linux user, detailed help is most appreciated!
1
vote
0answers
23 views

Ubuntu freezes and crashes on startup and nothing works [closed]

I've been trying for days to fix this. I thought it might have been my graphics card, but nothing happens when I try to install it from the command console. All Ubuntu has done for me so far is freeze ...
2
votes
0answers
51 views

Perl package not found with apt

When I try to do an upgrade or install something, apt(-get or aptitude) throw an error, saying that perl can't find XML/SAX/Debian.pm while trying to configure libxml-libxml-perl. Here is the full ...
0
votes
0answers
29 views

DBus Error while Packagekit Install

I have been trying to install Packagekit-1.0.6, the latest build from their website: http://www.freedesktop.org/software/PackageKit/releases/ I installed all the dependencies by sudo apt-get ...
0
votes
0answers
18 views

Trouble installing gnome-boxes on ubuntu 14.04 (depends libclutter, broken packages)

When I try to install gnome-boxes on Ubuntu 14.04 64 bit from the terminal I get the following error: Reading package lists... Done Building dependency tree Reading state information... Done Some ...
0
votes
1answer
97 views

update-manager & update-manager-core

# apt-get dist-upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not ...
0
votes
1answer
174 views

Why is Ubuntu moving to Snappy packages?

Why Ubuntu dumping .deb packages and moving to .snappy packages? (At least for now they are keeping .deb package for normal distributions). .deb is already the most popular packaging out there. ...
2
votes
1answer
20 views

Stripping image metadata

A while back, on an old installation, I had installed a package that allowed me to view and delete metadata from images. I'm fairly certain the syntax was as follows To display the metadata in an ...
1
vote
1answer
42 views

Unable to upgrade or remove broken virtualbox package

I'll start with some details of what led up to this: I'm using Ubuntu 14.0 (KDE on top although presumably that's irrelevant) a few days ago I let the system do an auto-upgrade. It crashed partway ...
1
vote
1answer
61 views

how to fix failed avidemux installation

Using 14.04 64 bit, I tried to install avidemux 2.6.8 from ppa:rebuntu16/avidemux+unofficial Unfortunately, the installation sudo apt-get install avidemux2.6-qt4 failed: dpkg: error processing ...
1
vote
0answers
168 views

unmet dependencies when trying install wine1.7

I'm trying to install wine1.7 from official ppa,my OS is Ubuntu 14.04 64bit, however when I use the apt-getcommand to install wine, the output is: The following packages have unmet dependencies: ...
0
votes
0answers
33 views

How to install package from old Ubuntu release?

I want to install package from older Ubuntu release. MariaDB server 5.5 was replaced with MariaDB server 10.0, but I need 5.5 for compatibility reasons. I want rest of Ubuntu (and packages) remain ...
1
vote
1answer
136 views

apt-get is “Unable to locate package [package-name]” after upgrade to 15.04 [duplicate]

I installed Ubuntu 15.04, then I updated it and restarted. After that I can't install anything from terminal using apt-get install [package-name] any more. For every package it says Unable to ...
0
votes
1answer
574 views

Plex is not working properly in ubuntu 15.04, now i cant even remove it?

sudo rm -f /etc/init.d/plexmediaserver && sudo dpkg --purge --force-all plexmediaserver and the result is: Failed to get D-Bus connection: Operation not permitted dpkg: error while cleaning ...
2
votes
1answer
117 views

Installing cuda toolkit Ubuntu 14.04 causes dpkg error

When I was installing cuda toolkit Ubuntu 14.04 causes dpkg error. This is what I did: sudo apt-get install build-essential sudo dpkg -i cuda-repo-ubuntu1404-7-0-local_7.0-28_amd64.deb However I ...
2
votes
1answer
46 views

Cannot install Gimp 64 bit

I am trying to install Gimp on a 64 bit PC with Ubuntu 14.10. I have added the dedicated PPA ppa:otto-kesselgulasch/gimp but I am not able to install Gimp due to its reliance on a lot of 32 bit ...
0
votes
1answer
15 views

Copying packages in PPA fail due to same version

I copied my package from trusty's repository also to utopic's repository of my PPA without re-building the binaries by using Launchpad's copy packages feature. Now I noticed that the utopic package ...
0
votes
0answers
46 views

Installing TinyOS on Ubuntu 15.04

I followed this tutorial carefully, but I still can't compile this hello world program. What did I miss? Should I install: nesc: 1.3.5 tinyos-tools: 1.4.2 tinyos-tools-14: 1.4.2 tinyos-tools-devel: ...
1
vote
1answer
23 views

Ubuntu 14.04 LTS: Trying to install Ruby 2.0, but gnome-session-bin seems to be half installed

I cannot install any packages, the problem started when I tried to install the ruby2.0. Before, apt-get was installing everything. But now, every package returns this error: Processing triggers for ...
0
votes
1answer
31 views

my ubuntu 12.04 software center wont work and i cant install software using apt-get

i try opening my software center then it closes after a few seconds, i read posts saying i should try some apt-get codes but it gave this error: Reading package lists... Error! E: Encountered a ...
0
votes
0answers
17 views

Question about apt-mirror

I would like to make you a question about apt-mirror. It works fine but we would like to know whether it is posible to clean all unneeded packages available to the clients that connect to our mirror. ...
1
vote
1answer
127 views

How to install postgresql-9.4-postgis-2.1 on Ubuntu 14.04(Trusty Tahr)?

I get the following error when trying to install postgres-9.4-postgis-2.1 on Ubuntu 14.04(Trusty Tahr): Depends: libgdal1 (>= 1.9.0) but it is not installable I also tried to install the package ...
0
votes
0answers
12 views

How create a deb package with older libs

I was trying to create a deb package but it has some dependencies who I did not find on software center, one of them is libqtmultimedia4. How could I create this package? May I include the lib in the ...
0
votes
2answers
253 views

Notify OSD config on vivid vervet

I upgraded to Ubuntu 15.04 Vivid Vervet today and was annoyed, but unsurprised, to see that notify OSD was updated and restored to its default, limited, functionality. The thing is, the patched ...
0
votes
1answer
89 views

zfs broken after upgrading package spl

Just now I did an apt-get upgrade, which upgraded package spl to 0.6.4.1. After rebooting, my zfs-formatted disk failed to mount. How should I regain zfs functionality? All zfs commands are now ...
3
votes
1answer
56 views

How to remove failed dpkg .deb installation

I tried install .deb file using the dpkg -i command. However the installation failed, when I tried sudo apt-get install -f I just get this error: -- Installing init scripts. Sweet! Please run `prey ...
0
votes
1answer
22 views

Error downloading steam

After downloading steam, it requires me to download the packages libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, and libc6:i386. However, when I attempt do do so I get this error message: E: unable to ...
0
votes
0answers
22 views

How to install indicator-messages package?

I uninstalled Thunderbird's indicator-messages by entering this command... sudo apt-get remove indicator-messages Now I realize I could disable the message box icon (a little cute envelop shown on ...
0
votes
1answer
47 views

Installing nodejs ubuntu on 14.04

Many misleading sources, nothing works cleanly on my side. Installing from source ? Any tips on this one ?
0
votes
0answers
42 views

Problem getting curl working in php and broken packages on install.

Im trying to get curl running in php on ubuntu 12.04. (A setup script complains that curl is not enabled, which appears to be true). phpinfo does not list curl at all ie it doesnt appear to even say ...
4
votes
1answer
1k views

VLC will not install in Ubuntu 15.04 [duplicate]

VLC was working fine until I upgraded to 15.04. When I try to install via Software Centre, I get this error message: The following packages have unmet dependencies: vlc: Depends: vlc-nox (= ...
0
votes
1answer
30 views

Need help with installing a package (dpkg problem)

When trying to install insight from some ppa repositories i get these errors. sudo apt-get install insight Reading package lists... Done Building dependency tree Reading state information... ...