Questions about the management of packages, in particular the `dpkg` system.

learn more… | top users | synonyms (4)

0
votes
1answer
30 views

dependency in ppa

i have a package(fcl) in my ppa in my launchpad ppa and it depends on another package (libccd) which is in another ppa ppa:imnmfotmal/libccd. FCL has both build and run dependency in libccd. SO i ...
0
votes
0answers
14 views

error when loading packages

dpkg: error processing package matlab-gdf (--configure): dependency problems - leaving unconfigured No apport report written because MaxReports is reached already ...
1
vote
0answers
27 views

unable to resolve package dependencies

I installed Ubuntu 12.04LTS operating system but when I added a new repository with the packages I find this error: Unable to resolve the package dependencies Information requested by @electron: ...
3
votes
1answer
65 views

Probable server issue - unable to apt-get update

When I run: sudo apt-get update I get this error at the end: W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/trusty/Release Unable to find expected entry 'restricted/source/Sources' in ...
1
vote
0answers
47 views

System updates are broken

I'm not exactly sure what the problem is, but I can't update Ubuntu 14.04 LTS. I also have this error showing up: (it's transparent because I screenshotted just before the drop-down closed) When I ...
0
votes
1answer
47 views

How can I repair my Ubuntu?

I unfortunately had a bad typo mistake when I was removing a package. My intention was to remove glib-2.0-dev, but seemed something else I typed and got all the necessary packages removed (for example ...
0
votes
0answers
26 views

Trying to reinstall apache2 due to an issue i had with websvn libsvn1 error

When trying to reinstall apache2 with all the dependencies that i need i get this. I run this: sudo apt-get install libapache2-mod-svn and this is the error that i get Reading package ...
0
votes
0answers
29 views

Apache2 Latest stable

I'm running Ubuntu Server 14.04.2 LTS and I want to update my Apache version from 2.4.7 to the latest 2.4.16. do I need to add a different repository? $ sudo apt-get install apache2 Reading package ...
3
votes
2answers
68 views

How do I make space to resize the root (/) partition? No free space on root, cant uninstall software nor update [duplicate]

The main question is how to make space in root (/). After this I want to resize the root partition, this topic can be found on: How to resize partitions? or elsewhere. I'm a little bit confused. No ...
0
votes
1answer
19 views

(kubuntu) Can't Remove KaliTools from system

I have problem with Kali tool it can not remove and when a type in terminal sudo apt-get upgrade it does not work It say that when I type sudo apt-get upgrade or when I type anything ...
6
votes
2answers
3k views

Where are the Rust (aka rust-lang) packages for Ubuntu?

I'd like to play with the Rust language on Ubuntu, but there don't seem to be any packages. Did I miss it or is there some problem?
4
votes
2answers
14k views

Can't install lib32ncurses5-dev or ia32-libs

I'm trying to install Android source and I keep getting this error. I kept with the installation but seems these packages are sort of required to have a complete and successful installation. this is ...
2
votes
1answer
44 views

Zenity does not show messages in deb preinst when it is ran through Ubuntu Software Center

I am creating a deb package which requires java oracle >= 7. So I wrote a simple preinst file with bash script that will pop up a message (using zenity) that will warn the user that he needs to ...
0
votes
1answer
18 views

Synaptic is giving me an error

After I start up synaptic this error message shows up. How can I fix this? E: Encountered a section with no Package: header E: Problem with MergeList ...
0
votes
0answers
11 views

Package operation failed downloading from software center

As the title says, when ever I download software from the software center it says "Package operation failed" even though it still downloads the software and the software I've downloaded does seem to ...
0
votes
1answer
67 views

Best way to install PyQt5 for Python 2.7 on Ubuntu 14.04

I am attempting to install PyQt5 on my Ubuntu box. I have been able to install the packages for Python 3, however,I have code that depends on pygraphviz which has a hard dependency on Python 2.7. I ...
286
votes
15answers
351k views

How do I resolve unmet dependencies after adding a PPA?

Occasionally, when I'm installing stuff, I get an error like the following: Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the ...
0
votes
1answer
33 views

Cannot install libgfortran3 (unmet dependencies)

I cannot install ligbfortran3. What is the best way to solve this ? I want to keep my install as standard as possible. Thank you. root@arau:~# apt-get --simulate install libgfortran3 Reading package ...
0
votes
0answers
13 views

More about synaptic package manager

A day after yesterday I'm trying to install GNS3 in my Ubuntu 14.04. At first step of instruction it said that I have to install dependencies using synaptic package manager, and said that synaptic ...
0
votes
0answers
10 views

What is the command for focus of debconf popup window?

I have created a script to show a debconf popup for my custom deb package to warn the user that he has not installed java-oracle. When I run the install through the Ubuntu Software Center the ...
2
votes
3answers
369 views

Cannot apt upgrade due to kernel package problems

an Ubuntu 14.04 LTS user here. Basically I had a problem when running sudo apt-get update sudo apt-get upgrade An error code was returned by dpkg because the Linux kernel package 3.13.0.57 was ...
0
votes
1answer
37 views

Learning more things about dependecies and repositories

A month ago I moved from Windows to Ubuntu. While using Ubuntu I notice some things about installing software. I've read some installation guides about installing software, and been curious about two ...
0
votes
0answers
10 views

Screenshots for self hosted debian repos?

According to this link, you can add screenshots to a debian hosted package, but what about packages in repos that you host yourself and manually add to your list of sources? I've never actually run a ...
1
vote
1answer
53 views

Dependency is not satisfiable: libglibmm-2.4-1c2a (>= 2.42.0)

Updated my mysql to 5.6 and as a consequence broke my preexisting mysql workbench. Trying to reinstall the newest mysql workbench, from both the Software Manager and the latest .deb from their ...
0
votes
2answers
83 views

APT totally broken

i am on Ubuntu 14.04 and my apt is totally broken. The problem started with grub-pc package and now continues , along with that package, with libuuid1:amd64 package. intsallation of libuuid1:amd64 ...
0
votes
1answer
20 views

Cannot install NIS package

I cannot install NIS package on Ubuntu 14.04 (upgrade from 13.10). When I try to run apt-get install nis I get the following output: Reading package lists... Done Building dependency tree ...
0
votes
0answers
19 views

Boot and Broken Count

I have 2 error messages, one is that the volume boot has 0 bytes disk space remaining. The other is error: broken count >0. When I try to fix these error it says I have to fix the other first. ...
0
votes
1answer
18 views

Remote package installation over LAN

I am trying to work on a project where i am supposed to install softwares and packages on one system and it should replicate on other systems connected on LAN. How can i proceed with this? I was ...
0
votes
1answer
34 views

Why does the Software Updater allow me to update the package list without authentication unlike in Terminal? [duplicate]

I have found recently that when running the Software Updater GUI it automatically, without asking for authentication, updates the local package list, but when running the equivalent in Terminal ...
1
vote
1answer
4k views

Unable to correct problems, you have held broken packages while installing nfs server?

I am trying to install nfs server on my Ubuntu 12.04 machine but everytime it is giving me an error like this - david@machineA:~$ sudo apt-get install nfs-common nfs-kernel-server Reading package ...
5
votes
5answers
446 views

Unable to insall libgtk2.0-dev on ubuntu 12.04

I am using opencv 3 on ubunut 12.04 and while displaying an image the error message asks me to build the library with libgtk2.0-dev. I tried sudo apt-get install libgtk2.0-dev but I get the following ...
3
votes
1answer
897 views

unmet dependencies for synaptics touchpad driver

I have Ubuntu 14.04.2 installed on a Lenovo S21e-20. To get things like two-finger-scrolling or suspending the touchpad during typing, I wanted to install xserver-xorg-input-synaptics but installation ...
1
vote
1answer
33 views

Uninstall terminal [closed]

I ask here, because googling about is quite chaotic (you fall to 'how to uninstall via terminal). I wonder how to uninstall terminal ? Cause I want to add some hardness in playing with a delivered ...
0
votes
1answer
13 views

dpkg-buildpackage ignores Vcs-Git in debian/control

I'm building a Debian package and have the following debian/control file: Source: custom-package Section: custom Priority: optional Maintainer: Dusan Rychnovsky <dusan.rychnovsky@gmail.com> ...
0
votes
2answers
53 views

can not open software center 14.04 LTS

OS - Ubuntu 14.04 lts Background - wanted to install chrome, but software centre was not opening. What I did - tried to uninstall and re-install software centre through terminal. failed. result ...
2
votes
1answer
6k views

apt-get package is not available but is referred to by another package - but cannot find that package

When I try to install a package with apt-get install, I'll occasionally see a message of the form Package somePackage is not available, but is referred to by another package. This may mean that the ...
6
votes
2answers
8k views

How to create deb installer from tarballs? [duplicate]

Possible Duplicate: Simplest Debian Packaging Guide? there are several tarballs (e.g. Firefox, Eclipse, Zend Studio and ...) that have executable file within, that easily we can extract ...
0
votes
1answer
124 views

in Ubuntu 14.04.3 UCK tool,I can't install wine 1.6 or wine1.7 [duplicate]

I can install wine1.7 successfully by following commond,but can't install in uck tool Why is this happening and how can I fix it? $ sudo add-apt-repository ppa:ubuntu-wine/ppa $ sudo apt-get update ...
1
vote
1answer
38 views

Apt-get upgraded package from 32bit to unsupported 64bit - why and how to revert?

Recently the repository of qtox had to change its domain and the new one only contains only 64bit builds at the moment. However, I'm on 15.04 32bit and can't run any 64bit software. Now when I last ...
5
votes
2answers
146 views

'apt-get update' gets stuck for hours at “100% [Working]” for specific PPA

When I run sudo apt-get update on Ubuntu 15.04, I get the following (shortened) output: $ LANG=C sudo apt-get update [sudo] password for ipc-admin: Ign http://ftp.uni-stuttgart.de vivid InRelease ...
6
votes
1answer
721 views

Why py and not pyc or pyo?

When I install a python deb package, say python-numpy the files are plain python files. How do I tell to the package manager -- that I actually would rather use pyc or even better -- pyo files?
1
vote
1answer
77 views

ipython qtconsole

I get this error when launching qtconsole. I already installed: sudo apt-get install libzmq-dev sudo pip install pyzmq sudo pip install pygments sudo apt-get install libqt4-core libqt4-gui ...
0
votes
0answers
11 views

Resolving Wine Dependency Errors

Here's the broken package problem I get from wine: The following packages have unmet dependencies: wine1.7 : Depends: wine1.7-i386 (= 1:1.7.12-0ubuntu1) E: Unable to correct problems, you have held ...
1
vote
2answers
44 views

Can you *simulate* an upgrade from one Ubuntu version to the next?

How do I upgrade to a newer version of Ubuntu? does a great job of explaining how to do a version upgrade. It also says "Upgrading Ubuntu works 99 times out of 100" which has not been my experience - ...
8
votes
2answers
13k views

Is it safe to use the command apt-get autoremove in this particular scenario?

The last time I used sudo apt-get autoremove, nearly every important display driver or parts got deleted. This made me very squeamish about using the command again. However, each time I install ...
0
votes
0answers
17 views

How to install nvidia-cuda-toolkit package?

If I enter sudo apt-get install nvidia-cuda-toolkit it will remve almost all my packages (xorg server, abiword etc.). Downloading local repository from nvidia official site breaks a lot of ...
0
votes
1answer
21 views

How can I install libsdl-ttf2.0:i386 without nuking my system?

I'm trying to play Toribash, and after regularly installing all of the required libraries, I decided to try the i386 ones and they solved the problems. Until I got to libsdl-ttf2.0. Trying to install ...
10
votes
1answer
361 views

Why is package 'xul-ext-ubufox' is required to install the Firefox package?

When trying to install the Firefox package on Ubuntu 14.04 it prompts me to also install xul-ext-ubufox: $ sudo apt-get install firefox Reading package lists... Done Building dependency tree Reading ...
552
votes
17answers
807k views

How to list all installed packages?

I'd like to output a list of all installed packages into a text file, so that I can review it and bulk-install on another system. How to do this?
1
vote
2answers
41 views

Fix “half-installed” package

I have the latest google chrome but accidentally tried to install the .deb package i downloaded two years ago, then cancelled with ctrl-c when it was unpacking, now it keeps telling me its half ...