0
votes
0answers
131 views

How to change gcc-4.9-base version without removing dependecies?

I have a freshly installed Ubuntu 14.04.1 but cannot install nvidia-331 driver because of dependencies conflict: lib32gcc1 should be installed but it conflicts with already installed gcc-4.9-base ...
0
votes
1answer
56 views

No package 'ncurses' found [duplicate]

I'm trying to install XWiimote and they tell me to run ./autogen.sh in the installation notes . This is the output: zorin@Samsung-NP300E4Z-S03TH:~/Downloads/xwiimote-master$ ./autogen.shlibtoolize: ...
0
votes
0answers
219 views

I already have the newest version of g++ but I still get a 127 error what do I do?

I have done the following. I just don't know what to try next. I supposedly have the newest version of gcc by following these directions sudo add-apt-repository ppa:ubuntu-toolchain-r/test sudo ...
0
votes
2answers
552 views

How do you fix a gcc compile 127 error? sudo apt-get install g++ doesn't work

*emphasized text*when I try to run a program I get the following error. ubuntu@ubuntu-VirtualBox:~/Desktop$ make g++ -Wall -Wno-switch -I. -g -c -o pass.o pass.cpp make: g++: Command not found ...
16
votes
4answers
19k views

Getting + installing gcc/g++ 4.9 on Ubuntu?

How do I install the latest version of gcc and g++? I am using a variety of C++11 and C++1y features; which is why I need this.
3
votes
2answers
1k views

Why does apt-get want to remove gcc-4.8 and g++-4.8 when I try to upgrade?

I am trying to upgrade gcc-4.8.1 and g++-4.8.1 to 4.8.2. I added the PPA containing g++-4.8.2, ran apt-get update and then when I try: martin@martin-Studio-1537:~$ sudo apt-get upgrade [sudo] ...
1
vote
0answers
74 views

Why I have to remove so many packages when I try to install zlib1g-dev:i386

When I try to install zlib1g-dev:i386, I got below message: sudo apt-get install zlib1g-dev:i386 Reading package lists... Done Building dependency tree Reading state information... Done The ...
3
votes
2answers
524 views

Using 12.04, can I compile packages with gcc for 10.04?

My development machine is running Precise, but some of my target servers are still running Lucid. I'm trying to set up my dev machine so that it can compile c/c++ for both Lucid and Precise. I already ...
3
votes
2answers
3k views

Can not compile any C code under Xubuntu

I am not a seasoned C programmer, but I compile some C code sometimes. The last time I successfully compiled and run some C code I did it on the same system that I have now (the very same OS on the ...
0
votes
1answer
1k views

I want to save apt-get package

I am using Ubuntu 10.10. Suppose I run this command to install GCC: sudo apt-get install gcc* I want save gcc on my pc forever, so that next time I do not have to run that apt-get command to ...
4
votes
1answer
232 views

Reverting problems caused by checkinstall with gcc build

I recently downloaded the GCC 4.6.2 source in order to play around a bit with C++11. Having been told about checkinstall and its usefulness in installing programs from source, I created a Debian ...
3
votes
2answers
490 views

How can I install gcc 4.6 side-by-side with the current version from the repositories?

I have 4.5.2 installed from the Ubuntu official repositories. I would like to install 4.6 as well to try out the C++0x features it brings. How can I do this without breaking my system? I'm fine with ...