0
votes
1answer
35 views

problem installing package

I've faced following problems while installing packages- installArchives() failed: E: Cannot get debconf version. Is debconf installed? debconf: apt-extracttemplates failed: No such file or directory ...
0
votes
0answers
8 views

Patch a package by adding new files to it?

I'm trying to patch an existing package, and my patch is supposed to change some files and add some files and directories to the package. All seems to work, the .patch file in debian/patches looks ...
1
vote
1answer
16 views

Where can I find statistics on package downloads and dependencies?

Is there a site that lists (or ranks) Ubuntu/Debian packages by downloads or dependency count? The Node.js package manager npm has leaderboards, as does PyPI (unofficially). It'd be interesting to see ...
0
votes
1answer
27 views

Error installing ubuntu-desktop on 14.04

I am trying to install ubuntu-desktop on 14.04 but when I run apt-get install ubuntu-desktop it gives error: Some packages could not be installed. This may mean that you have requested an ...
2
votes
2answers
25 views

Maximum space required for ubuntu repository

I am using Ubuntu 12.10 (Quantal) version and it is at EOL. The repositories for older releases that are not supported get moved to an archive server. These repositories are available at ...
1
vote
0answers
18 views

Upgrade from 13.10 to 14.04 “rolled back”

I've tried to upgrade my Kubuntu from 13.10 to 14.04, through the notification popup appeared in my taskbar. The upgrade process started, it begun to download about 1800 packages, it downloaded ...
0
votes
0answers
17 views

Unable to install bsddb185, Python library for opening Berkeley DB version 1.85 files on Ubuntu

I am writing a python program that makes use of some legacy Berkeley DB 1.85 files. Unfortunately I am unable to install the bsddb185 Python package, either for Python version 2.x and for Python 3. ...
0
votes
3answers
56 views

dpkg error when using apt-get install

I upgraded to Ubuntu 14.04 from 12.04 and every time I use apt-get install for any package it ends with a bunch of errors about processing some of my latex packages. Including a snippet below: ...
2
votes
1answer
22 views

apt-get and aptitude seem to disagree — do I really have broken packages?

If I do aptitude search ~b I get a list of 78 broken packages. But 76 of them aren't even installed (they have a status of pB). How can an installed package be considered broken?? But if I do ...
0
votes
1answer
10 views

No package 'ncurses' found [duplicate]

I'm trying to install XWiimote and they tell me to run ./autogen.sh in the installation notes . This is the output: zorin@Samsung-NP300E4Z-S03TH:~/Downloads/xwiimote-master$ ./autogen.shlibtoolize: ...
0
votes
1answer
66 views

Upgrade from 12.04 LTS to 14.04 LTS fails

Output of the Bash Terminal: http://pastebin.com/wXKtLzin I used apt-get upgrade -f as well, with the same result. I only want the 14.04 LTS that works fine and I don't lose my data. In the past the ...
0
votes
0answers
21 views

libssl-dev and libssl1.0.0 on confilcting versions

My problem on 12.04lts is that somehow my libssl1.0.0 got upgraded to 1.0.1-4Ubuntu5.17 and my libssl-dev requires 1.0.1-4Ubuntu5.14 apt won't update libssl-dev because libssl1.0.0 was upgraded first. ...
0
votes
0answers
18 views

How to clone an Ubuntu system using the package manager?

I would like some way to exactly duplicate what is installed on one Ubuntu system, onto another, regardless of the target system's state, using the package manager. This includes: installing the same ...
2
votes
3answers
876 views

Ubuntu 12.04 Libreoffice update breaks software updating

After applying the latest updates today (August 16, 2014), Libreoffice-base will not complete the upgrade due "no diversion" error which then seems to break the postrm script and now I can neither ...
0
votes
0answers
19 views

Spotify installed packages have unmet dependencies [duplicate]

I used wine to emulate the Windows version of Spotify and I recently just uninstalled it and ever since then, when I start up my Ubuntu, after a while I will get this restricted logo beside the wifi ...
0
votes
1answer
38 views

Half installed package nightmare

At some point, one of my servers stopped writing to its network attached storage device (I presume), and it resulted in a week or more's worth of packages ending up in the "half-installed" state. ...
1
vote
0answers
19 views

Complete Deletion/Reinstallation of Downloaded Package

I want to know how to delete every file installed by a package using either aptitude or apt-get and then re-download and re-install that package completely again. I've tried doing aptitude reinstall ...
-1
votes
0answers
43 views

Ubuntu 13.1 apt-get installs fails with every install/remove command inux-image-3.11.0-26-generic

including sudo apt-get --purge autoremove etc and after trying sudo apt-get clean, autoclean, dpkg reconfigure etc I've been around this problem for days, read everything I could find there, or other ...
0
votes
0answers
39 views

The package system is broken… unmet dependencies [duplicate]

Some will say this is duplicate but it is not :) Basically, I am running Ubunto 14.04 LTS and I removed LibreOffice to install OpenOffice. Then I was trying to re-install Libre again (so that I have ...
0
votes
0answers
28 views

How do I uninstall ttf-mscorefonts while it is currently 'half installed'?

I tried using this as a step to watching Netflix. The package itself is half installed or something and removing or purging or reinstalling it doesn't seem to do anything. It won't let me remove it ...
0
votes
0answers
62 views

Unable to reinstall apache on Ubuntu 12.04.5 LTS

Unfortunately, What I did: Updated apt repository to install apache244 and installed it. Uninstalled apache2.4 using following commands: apt-get remove apache* apt-get purge apache* apt-get clean ...
1
vote
0answers
10 views

ppa repositories removed for raring. How do you install packages using old-releases.ubuntu.com [duplicate]

Using a Ubuntu/Debian variant (Navigatrix) release based on Raring, which is no longer supported in the Ubuntu Repositories. Current etc/apt/source.list is: deb (http removed) ...
2
votes
0answers
16 views

Add Package to Official Repository [duplicate]

I wrote a driver for a remote filesystem (mounts a Google Drive, similar to the way SSHFS mounts a remote server). It's super useful as an alternative to dropbox or ubuntuone. It is now getting ...
0
votes
0answers
19 views

How can I determine the minimal installation set for a list of packages? [duplicate]

I have some installation notes for installing the GLEW libraries for development purposes. They read: Install everything with "glew" in its name. This means I currently run: sudo apt install ...
0
votes
1answer
27 views

I can not install or remove apps After trying to install bumblebee and nvidia prime

Here are the details which terminal output when trying to remove or upgrade I tried autoremove - install configure dpkg and nothings work for me Removing nvidia-331 (331.89-0ubuntu1~xedgers14.04.2) ...
-1
votes
0answers
13 views

Cannot install Java [duplicate]

here is the deal i keep getting this whenever i put in sudo apt-get install openjdk-7-jre openjdk-7-jdk but it never works it always comes up as sudo apt-get install openjdk-7-jre openjdk-7-jdk ...
1
vote
0answers
24 views

Downgrade all external packages to the official ones

Let's say I installed bunch of packages from external PPA repositories and they modified or replaced the existing default packages in the system. Assume that then I remove those PPAs from the ...
0
votes
1answer
34 views

Unmet dependencies problem on 12.04 - libcurl4-openssl-dev depends librtmp-dev

I'm having troubles with unmet dependencies on Ubuntu 12.04: libcurl4-openssl-dev depends librtmp-dev Here is what I've got after running sudo apt-get -f install which suggested running apt-get ...
0
votes
1answer
14 views

How to transfer the apt keyring to another computer

I'm currently moving my installation of Ubuntu from one laptop to another. Both laptops run Ubuntu 14.04. I moved my /etc/apt/sources.list, the contents of my home directory, and installed all ...
0
votes
1answer
38 views

Trying to remove apache2/httpd and installing mod_perl

It started with me trying to install Apache and mod_perl by following this guide. However, foolishly I installed Apache by using sudo apt-get install apache2, which installed 2.4 on my system. ...
1
vote
0answers
41 views

apt-get install stuck at “Unpacking wine…”

I'm running Ubuntu 14.04 LTS and using an ordinary apt-get install playonlinux command to have it installed. However, it is always getting stuck at (i.e. doesn't do anything further): Preparing to ...
-1
votes
1answer
58 views

Could not exec dpkg! E: Sub-process /usr/bin/dpkg returned an error code (100)

i m using 12.04 .. i m unble to perform any installation or remove b'coz i lost my dpkg in /usr/bin/dpkg i tried with following procedure mkdir /tmp/dpkg cd /tmp/dpkg wget ...
0
votes
0answers
18 views

Package not present in ubuntu package list. Different approach (ubuntu precise 12.04)

I currently have an application that I am doing packaging now. I require ruby2.0 and the package is for Ubuntu precise. (12.04LTS) but the issue is that, ubuntu precise package list does not have ...
0
votes
1answer
45 views

Deleted elements that I don't know

In order to install a new version of Skype, I did sudo apt-get -force remove skype sudo apt-get autoremove This deleted lots of elements on my laptop and I don't know if they are important. Can ...
0
votes
2answers
22 views

apt-get broken…help [duplicate]

I tried to install ubuntu-restricted-extras using the terminal, but a "Microsoft Eula" screen poped up and I closed the terminal (now I know I should not have done it). After failing to "click" on the ...
1
vote
0answers
18 views

trying to install App but getting errors

I'm trying to install OpenPilot 14.01 on my "Precise" i386 system but I keep getting errors like Error: Dependency is not satisfiable: libc6 (>= 2.17), and after trying several Cl answers to try and ...
0
votes
0answers
33 views

apt-get won't install dependency

File A, version 12, has a dependency on file B, version 12. However, in the repo, there exists a B_12_all.deb and B_13_all.deb. The dependency in A_12_all.deb's control file is the following: ...
1
vote
1answer
18 views

Difference between key (recv-keys), signing key, and fingerprint in APT/PPA system

Let's take https://launchpad.net/~ansible/+archive/ubuntu/ansible as an example. If you click on 'Technical details about this PPA' you see: Signing key: 4096R/7BB9C367 Fingerprint: ...
-1
votes
1answer
46 views

I'm trying to do a sudo apt-get upgrade, but there are some packages that are no longer required. Should I remove them? [duplicate]

I'm trying to upgrade my packages and there were some packages that were automatically installed and are no longer required. What should I do? I'm asked to use 'apt-get autoremove' to remove them, but ...
1
vote
1answer
45 views

Why am I getting the terminal error “try apt-get -f install”?

Okay, I just install Ubuntu (the LXDE version, which is Lubuntu) and everytime I try to install a package through the terminal with the "Apt-get install" command, this error pops up: E: Unmet ...
1
vote
0answers
52 views

Can't remove 2XClient using dpkg

I have a problem removing 2XClient from Ubuntu 12.04. This is the output Removing 2xclient ... Unregistering tuxclient url-protocol handler in gconf tree (gconftool-2:3905): GConf-WARNING **: ...
1
vote
1answer
49 views

Package 'ruby1.8-dev' has no installation candidate [duplicate]

How can I solve this error? sudo apt-get update sudo apt-get install ruby1.8-dev sudo apt-get install mysql-server sudo apt-get install libgemplugin-ruby Currently I am getting this error: sudo ...
1
vote
1answer
45 views

Getting error while installing python-kivy packages in Ubuntu

I'm not able to install python-kivy, I got this error: dpkg: error while cleaning up: subprocess installed post-installation script returned error exit status 127 Processing triggers for ...
-1
votes
1answer
56 views

software center and ppa not working [duplicate]

I am new to Ubuntu, just today I was trying to download a program with a ppa, crebs, and it did not work; not only that, the software center doesn't work either, and I can't get it from the internet ...
0
votes
1answer
35 views

Cannot update Ubuntu due to broken package [duplicate]

When I run software updater I get The Package system is broken Check if you are using third party repositories. If so disable them, since they are a common source of problems. Furthermore run ...
1
vote
0answers
15 views

For an automated install of .deb I need to set DPkg::Options before installing package with new conffile

I have a custom Debian package that creates a touch-screen calibration file and will be deployed for automatic updating. I want to preserve the calibration file if the user has changed it, so my new ...
0
votes
0answers
39 views

Backup software sources and reinstall: get latest versions of installed programs from the repository for new distribution

I'm migrating from 12.04 to 14.04. I have already backed up my installed software sources in 12.04 using sudo cp -R /etc/apt/sources.list* ~/ command from this question - Best way to backup all ...
1
vote
0answers
56 views

How to fix a Failed Package Operation Error?

Launched the software center and I am getting this error: installArchives() failed: E: Invalid archive signature E: Internal error, could not locate member control.tar.{gzbz2xzlzma} E: Prior ...
2
votes
2answers
115 views

“you have held broken package” While trying to install R

I know this question has already been asked, but all the answer posted weren't able to help solve my problem. I tried the following command on Ubuntu 14.04: sudo apt-get install r-base-core and I ...
2
votes
1answer
72 views

Can a ppa repository be added to /etc/apt/source.list?

By sudo add-apt-repository '<deb url codename component>', a repository is added to the /etc/apt/source.list file. By sudo add-apt-repository ppa:<user>/<ppa-name>, I saw that all ...