Is a free and open source implementation of the Java programming language. It may be installed from the software centre.

learn more… | top users | synonyms

3
votes
1answer
4k views

Minecraft doesn't connect to Mojang servers/the internet (15.04) [duplicate]

I've been trying to run Minecraft on Ubuntu 15.04 for a while. Whenever I try running, it won't download the launcher pack and it gives me this message: Bootstrap (v5) Current time is Jun 19, 2015 2:...
10
votes
4answers
14k views

Minecraft with OpenJDK 7, I get “the trustAnchors parameter must be non-empty”

Im using Ubuntu 15.04 and OpenJDK 7, trying to run Minecraft. This is what I get. EDIT: Minecraft is working now when I use sudo java -jar Minecraft.jar but doesn't work without super user, how would ...
0
votes
1answer
793 views

lost right-click open with java 7 Ubuntu 14.04

Does the following method seem proper enough (or alternatively, fundamentally flawed) as the way to get back the right-click ability for opening with Java? After some sort of hang and crash of ...
2
votes
2answers
198 views

what is the minumim required packages for installing open java 8

What are the minimum packages required to install open java 8? Available packages: openjdk-8-dbg openjdk-8-jdk openjdk-8-jre-jamvm openjdk-8-demo openjdk-8-jre ...
1
vote
0answers
178 views

JRE failed even after open jdk as well as oracle

$ sudo update-alternatives --config java There are 2 choices for the alternative java (providing /usr/bin/java). Selection Path Priority Status ----...
0
votes
3answers
2k views

Minecraft doesn't run; I do all the things to fix it, but it doesn't works!

No OpenJDK 7 Java Runtime on the dialog box. Done fixing this. Here's my Java version. I'd just reformatted my PC because there's problems in the last Ubuntu installation but Minecraft works ...
3
votes
2answers
6k views

Problem running jar from gui in 15.04

I updated ubunut to 15.04 today. Now when I try starting a jar file from the gui it only opens the archive manager. Checking the open with tab in Properties I can't find Openjdk. I got both Openjdk ...
0
votes
1answer
454 views

removing jva openjdk 7, ubuntu 15.04

Can I safety remove OpenJDK 7 from my system? I've got OpenJDK 8 but I've found this: I suppose you are using 12.10 or 13.04. Here default-jre depends on openjdk-7-jre. So you can't remove ...
1
vote
1answer
934 views

Can't install anything via apt-get - openjdk errors

I have become unable to install anything on my Ubuntu 14.04 box. When I try to, I get the following error: No apport report written because the error message indicates its a followup error from a ...
0
votes
2answers
933 views

unable to install OpenJDK Java 6 runtime

Please mind im fairly new to linux so please try to keep the technobabble to a minimum. So in the ubuntu software centre i tried to install the java 6 runtime and it gave me this error message The ...
0
votes
1answer
410 views

Problem while installing oracle-java8-installer

I am trying to install Oracle's Java8, but I get the following errors. How can I fix those? Translated from Spanish. For original text, please see the revisions. r06xd@uers1-H61MLV2:~$ sudo apt-get ...
1
vote
0answers
774 views

Setting JAVA environment variable [duplicate]

I am setting up new Ubunut machine. Stuck on setting up Java environment variable. I have tried all possible way and whatever solution I found here. None of them worked. It is still giving me blank ...
1
vote
0answers
131 views

Support / lifetime of OpenJDK 6+7 in Ubuntu 12+14 LTS

We have a few systems running OpenJDK 6 on Ubuntu Server 12LTS..we are planning on updating to Ubuntu Server 14LTS with OpenJDK 7. Unfortunately I cannot find any information about OpenJDK 6 + 7 ...
2
votes
0answers
1k views

How to make openjdk-8 default java version and remove openjdk-7

I have intalled openjdk-8 (from official repo) with apt-get install openjdk-8-jre-headless openjdk-8-jre openjdk-8-jdk and updated alternatives with update-alternatives --config java now $ update-...
2
votes
2answers
551 views

Apparmor problem: Icedtea plugin freezes firefox (35.0.1)

EDIT5: finally it's probably is an Apparmor problem. /usr/lib/firefox/firefox{,*[^s][^h]} is indeed in complain mode, but /usr/lib/firefox/firefox{,*[^s][^h]}//browser_java /usr/lib/firefox/...
2
votes
4answers
6k views

Missing tools.jar (Android Studio)

The command $ ~/android-studio/bin/studio.sh says 'tools.jar' seems to be not in Android Studio classpath. Please ensure JAVA_HOME points to JDK rather than JRE. I have searched for the solution ...
1
vote
1answer
59 views

Can I tell, from the browser, which Java version is installed, including whether OpenJDK, Oracle, etc

I know of java.com/verity, but it only tells me the the version number of Java, e.g. Your Java version: Version 8 Update 25 It does not tell me whether I have OpenJDK or Oracle installed. Is there ...
1
vote
0answers
115 views

Cannot remove openjdk without having an older version installed, how can I do so?

I am running Ubuntu 14.04.1 64-bit with Oracle Java installed, hence I would like to uninstall openjdk, but when I try to uninstall it via the command line I get the following output: ~$ sudo apt-get ...
0
votes
1answer
576 views

Installing JDK 8 after removing OpenJDK 7

I just removed OpenJDK at Ubuntu Software Center, and downloaded JDK 8 at official Oracle site, and installed with alien. But when I type java -version at terminal, it keeps returning root@pcowner:/...
1
vote
4answers
7k views

Installation of SAP GUI 740 on Ubuntu 14.04

I need your help! I have the following version of JRE installed on my system: java version "1.7.0_75" OpenJDK Runtime Environment (IcedTea 2.5.4) (7u75-2.5.4-1~trusty1) OpenJDK 64-Bit Server VM (...
2
votes
0answers
418 views

Apache ActiveMQ's main instance does not start in Ubuntu 14.10

I have installed the `activemq package in Ubuntu {12.04|14.04|14.10} In the LTS releases the service works fine, but in the 14.10 dist release the activemq does not work: # ln -s /etc/activemq/...
0
votes
1answer
142 views

fatal error while using Java3d on newer ubuntu version than 11.10

I'm running a java based website where i use java3d to render some 3d images without any problem on oneiric. I also need to say since the application runs on a server without a graphiccard, i use ...
3
votes
1answer
274 views

libjai-imageio-core-java in Ubuntu 14.04

It seems that libjai-imageio-core-java is missing on 14.04 (it is available on Ubuntu 12.04): Is there a replacement for this file? Or, how do I build from the source code?
2
votes
2answers
8k views

OpenJDK-7-JRE throws “broken packages” error (14.04 LTS)

I have an application that requires the Java JRE. I decided to go ahead and install the JRE from the repositories. Normally, the only issue I would have with this is it taking forever and a day to ...
1
vote
2answers
2k views

Minecraft Crashing, linux download

Hi so I've been going at this for hours and I have installed everything correctly, I'm using a HP 14 chromebook, and I hear you can get minecraft on it, with downloading a Linux desktop. I'm using ...
0
votes
1answer
82 views

Why is the installed version of openjdk 32-bit instead of 64-bit?

I have a fairly new installation of Ubuntu 14.10. I am pretty sure that I installed the 64-bit version and confirmed via $ uname -a Linux Family 3.16.0-28-generic #38-Ubuntu SMP Fri Dec 12 17:38:37 ...
2
votes
1answer
8k views

Where is my Java compiler 1.8, in Eclipse?

I installed openjdk8 In Eclipse (v3.8.1) -> window -> preferences -> Java -> installed JREs, I added the related standard VM. In Eclipse -> Project -> Properties -> Java build path, I changed the JRE ...
1
vote
1answer
4k views

Android Studio Desktop Entry shows “OpenJDK shows intermittent performance and UI issues.”

On Ubuntu 14.04 I recently installed Android Studio v1.0.1 and noticed that it warns against using the OpenJDK due to "intermittent performance and UI issues." As recommended, I installed the Oracle ...
7
votes
5answers
7k views

OpenJDK-8/Oracle JDK 8 Font Patches for Ubuntu

Is there a patched version of OpenJDK-8 or Oracle JDK 8 for Ubuntu 14.10 which fixes ugly fonts in Java Applications (Jetbrains products, Netbeans etc.)? I had previously installed a patched version ...
1
vote
2answers
349 views

jar files not working

In terminal when try to run jar file it doesn't launch. I have recently uninstalled open jdk 6 to save some space if that matters. abe@abe-Dimension-8400:~/Desktop$ java -jar Minecraft.jar I use ...
4
votes
2answers
931 views

Cannot sudo apt-get -f install because of jdk problem

I am completely stumped. The problem is as follows. user@mycomputer:~$ sudo apt-get -f install Reading package lists... Done Building dependency tree Reading state information... Done ...
0
votes
1answer
115 views

openjdk-7 gdb list main.c sources error

I'm currently struggling with debugging openjdk in Trusty Tahr. I already installed opejdk-7-jdk openjdk-7-dbg. When I issue gdb java I see it reads the symbols properly, but when I ask to list the ...
0
votes
1answer
662 views

I can't install openJDK 7 in ubuntu 12.10 (32-bit)

Using Ubuntu Software Center I tried to install OpenJDK 7 but got the following notification. **Package dependencies cannot be resolved** This error could be caused by required additional software ...
2
votes
0answers
242 views

The installed java is version 7u65, yet the ubuntu package is 7u71, why the discrepancy?

I'm running Ubuntu 14.04 and need to use Java 7 update 71. It seems like openjdk has been updated in the Trusty repos to update 71, yet even if I install the update java seems to still be at version ...
0
votes
1answer
449 views

IcedTea Doesn't Run Properly in Firefox

I have Java 7 installed for Ubuntu 12.04 and I have IcedTea installed in Firefox (33.0). Some Java plugins are not working correctly. For example: starting from the IcedTea-Web-Tests (see the IcedTea ...
0
votes
0answers
30 views

I have an Issue With Java! Scottrade! [duplicate]

My problem is that I downloaded a file with the the extension .jnlp . I have the necessary installed requirements Java Runtime Environment (JRE) 7 openjdk. When I try to open the necessary/required ...
0
votes
1answer
276 views

too many JDK's after installing openjdk-8

I upgraded to Ubuntu gnome 14.10 this weekend. I've been curious to try out JavaFX, and noticed that there is now an openjfx package available. So I apt-get installed openjdk-8-jdk and openjfx and ...
7
votes
4answers
13k views

Unable to install icedtea plugin on Utopic Unicorn 14.10

Trying to install icedtea-7-plugin on 14.10 x64 gives an error. apt-get install icedtea-7-plugin . . . Selecting previously unselected package icedtea-netx:amd64. . . . Processing triggers for man-...
1
vote
1answer
651 views

errors with sudo apt-get update after sudo apt-get autoremove openjdk-7-jre

Everything was fine before executing this command sudo apt-get autoremove openjdk-7-jre. After this openjdk-7-jre got removed.Then when i try sudo apt-get update i get the following errors: 0% [...
5
votes
2answers
14k views

Android Studo showing :“OpenJDK shows intermittent performance and UI issues.”

I have recently installed Android Studio on my Ubuntu 12.10 64bit machine, but every time that I opened it kept giving the following error "OpenJDK shows intermittent performance and UI issues. We ...
2
votes
1answer
240 views

Do I need to Install jdk?

I realized that my java compiler wasn't up-to-date on my ubuntu 12.04 $ sudo update-alternatives --config javac There are 2 choices for the alternative javac (providing /usr/bin/javac). Selection ...
0
votes
1answer
676 views

Eclipse does not open

I've installed Eclipse 3.8 through Ubuntu Software Center and when I open it the loading window pops up and freezes. Eclipse never opens... When I try to launch eclipse from Terminal it doesn't show ...
1
vote
1answer
551 views

Unable to update openjdk7 and 6 with apt-get

System: Ubuntu 12.04.4 LTS, Server I can't update openjdk7 and 6 with apt-get. It always ends with this failers: Err http://security.ubuntu.com/ubuntu/ precise-security/main openjdk-6-jre-headl ...
-2
votes
1answer
506 views

OpenJDK patched with font fixes mess up google chrome fonts

I've installed the patched OpenJDK in order to get proper font rendering in WebStorm 8. It works fine but i realized chrome has some font rendering problems since then. I only see this in chrome so ...
3
votes
0answers
454 views

How to use Firefox AppArmor profile with IcedTea Java plugin on Ubuntu 14.04?

Whenever I set up Ubuntu on a new system, I active the default AppArmor profile for Firefox via sudo aa-enforce /etc/apparmor.d/usr.bin.firefox Doing this on Ubuntu 14.04, however, makes Java ...
0
votes
1answer
53 views

Binary archives of OpenJDK for ubuntu

My goal is to have multiple version of java 6 and multiple version of java 7 installed on my ubuntu in order to do some tests with different versions of java. I found instructions to install oracle ...
1
vote
1answer
389 views

Installing oracle java versions

I went to the website to download (Java Platform (JDK) 8u20 ), http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html to download ORACLE java for my machine. I was ...
2
votes
2answers
488 views

What exactly should I set as JAVA_HOME?

I am trying to make Tomcat 7 working with Eclipse, and I am not sure if my JAVA_HOME is correct. ~$ echo $JAVA_HOME /usr/lib/jvm/default-java And there is no such catalog! I only have: ~$ ls /...
2
votes
0answers
462 views

Unable to start topcoder arena in Ubuntu 14.04

When I want to clear cache using javaws - viewer these error comes. I am trying to launch my topcoder arena. Picked up JAVA_TOOL_OPTIONS: -javaagent:/usr/share/java/jayatanaag.jar Exception in ...
0
votes
2answers
4k views

Changing the Java Runtime in NetBeans 8 on Ubuntu 14.04

(Not sure if this is the right site for this question - if not please migrate.) I am using Netbeans 8 for C++ on Ubuntu 14.04. Ubuntu comes with the Open JDK Runtime, which is what Netbeans is ...