Questions about OpenGL, a library for rendering 2D and 3D graphics

learn more… | top users | synonyms

22
votes
6answers
69k views

After logging in, there's a black screen and my cursor, nothing else! in Ubuntu 12.10

I've been using Ubuntu(12.10) for a long time, and recently, my Ubuntu went through yet another update. The whole update prompt showed up, following by a password prompt, and finally the good ol' ...
3
votes
3answers
20k views

Could not find required OpenGL entry point 'glGetError'

I am not able to play "Half-Life-2" on Steam + Ubuntu 14.04 . Error shown in message box on screen: Could not find required OpenGL entry pint 'glGetError'! Either your video card is unsupported, ...
19
votes
3answers
92k views

How to fix 3D Acceleration for Vmware Workstation 9?

I have recently installed Vmware workstation 9 on Ubuntu 12.04 & i have migrated my VM's from windows to Ubuntu 12.04 . Now i am getting openGL error & it says no 3D acceleration as shown in ...
8
votes
3answers
107k views

How to update OpenGL Driver on Ubuntu 14.04 LTS

I recently upgraded to 14.04, then I installed steam, and TF2. I get this error message: Could not find required OpenGL entry point 'glGetError'! Either your video card is unsupported, or your ...
15
votes
2answers
15k views

Screen tearing in 11.10 with intel graphics [closed]

I have a slight screen tearing when watching videos in Ubuntu 11.10 x64, really annoying. Both in Unity and GNOME-Shell. Please focus the answer to GS since it's my primary DE and it's where I want it ...
18
votes
1answer
31k views

Compile OpenGL Program (Missing GL/gl.h)

I am a complete Linux/Ubuntu noob, so I apologize for any dumb portions of this question or follow up ones. I am trying to get a program that my software engineering class's group wrote onto my home ...
12
votes
1answer
2k views

Why do I have low FPS unless root?

Problem: Normal users aren't using the best graphics driver. I first noticed this playing Osmos from the HumbleBundle2, but I can observe it while running glxgears too. Maximised on a 1280x1024, ...
3
votes
1answer
19k views

Ubuntu 14.04 “could not find required OpenGL entry point 'glGetError'!" [duplicate]

I am trying to play Dota2 and FT2 on my pc when I got this error: "Could not find OpenGL entry point 'GLGetError'! Either your video card is unsupported or it needs to be updated." I have ...
2
votes
0answers
3k views

Ubuntu 13.04 “could not find required OpenGL entry point 'glGetError'!” [duplicate]

Just recently upgraded to 13.04 and am having trouble running TF2 via Steam. Whenever I start Steam I get a dialog saying: OpenGL GLX context is not using direct rendering, which may cause ...
17
votes
1answer
30k views

Switch from NVidia to internal Intel HD graphics - OpenGL does not work

I switched today to the internal Intel HD graphics of my G630T CPU. The desktop works but XBMC would not start. It complains that it needs OpenGL accelerated hardware. When I check the System Info - ...
3
votes
1answer
4k views

How to install LLVMpipe?

I hear about the LLVMpipe gallium 3d state tracker that is said to be faster than software renderer. But I cannot find a good instruction from a to z that tell me how to install it. So here I am, ...
2
votes
2answers
7k views

Trying to install Proprietory Nvidia Graphics Drivers

After reading and trying many different suggestions for some hours, I returned to this how-to: https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia The first problem I encounter is how to ...
51
votes
5answers
96k views

What is terminal command that can show OpenGL version?

So I want to find out which is my OpenGL version. I have access to Ubuntu via SSH. Which command shall I execute?
35
votes
5answers
87k views

How to perform a detailed and quick 3D performance test

I am wondering how to quickly test performance of my 3D graphics. Since glxgears is not benchmark what should I use. Also glxgears sometimes stuck at 60FPS, you cannot even compare before/after driver ...
2
votes
1answer
43k views

X Error of failed request: BadRequest (invalid request code or no such operation) [duplicate]

Possible Duplicate: How to fix error with ATI driver “Error of failed request”? Though this question is asked before for 11.10, it's still unanswered. I am using ubuntu 12.04 (on Dell Inspiron ...
3
votes
3answers
2k views

HIB Games (Aquaria & Penumbra) cannot find libGL.so.1 even though it exists

I'm trying to play some Humble Indie Bundle (HIB) games, but I'm getting errors with Aquaria and Penumbra: Overture that are related to the libGL.so.1 file. Aquaria gives this error on launch: ...
1
vote
2answers
6k views

OpenGL with Intel 82865G integrated graphics

There's a similar question on the site, but it's outdated and doesn't specify exactly what I'm faced with. Namely, I have an old computer that I'm fixing for someone, and it's got this Intel 82865G ...
3
votes
1answer
772 views

Opengl Mesa : use opengl 4.0

I'm an opengl programmer, and I would like to use opengl 4.0; problem is that I cannot install any proprietary drivers, and when I type : glxinfo | grep "OpenGL version" in the terminal, it outputs me ...
3
votes
1answer
11k views

ubuntu 14.04 unity desktop without panel and launcher [closed]

Now after having succeeded to make running the new Ubuntu 14.04 I see, that Unity seems not to work (the desktop appears without launcher and panel). Gnome is working. CCSM is possible to open under ...
2
votes
1answer
69 views

Does Ubuntu Touch have WebGL support?

I would like to create a WebGL game for Ubuntu Touch, building on the HTML5 app template. Is this a possible option?
0
votes
0answers
82 views

Problems launching Steam game (OpenGL error)

So, fresh install of Ubu MATE 16.04, and the lastest Steam from Software Boutique. Dell Latitude E4310, 8 gigs ram, decent processor, integrated graphics (I'm not sure how to get a detailed report of ...
23
votes
7answers
8k views

Alt+tab out of fullscreen game

Right now I'm running Trine, which is a game using OpenGL running in fullscreen, in Ubuntu 10.10. What I would like to be able to do is Alt+Tab out of the game to be able to browse the web, check ...
15
votes
3answers
9k views

How can I record an OpenGL game in Ubuntu?

I would like to create a short clip of me playing Minecraft, an OpenGL game. The usual screencast recorders do not properly record OpenGL. What kind of software is available for this purpose? My ...
10
votes
2answers
5k views

intel_do_flush_locked failed Input/Output error

Sometimes while running apps using OpenGL, the following message comes in the command line where I run the app. I have a Sandy Bridge integrated graphics card (the same as in the bug reports) ...
5
votes
1answer
1k views

Where is the documentation for programming OpenGL ES for Ubuntu Touch?

How can I program an OpenGL ES program for Ubuntu Touch? I have installed QtCreator and the Ubuntu SDK, but I can't seem to find any documentation about this topic.
11
votes
2answers
28k views

How to enable OpenGL 2.0 and WebGL on GMA 3150?

I have a Dell Mini 1012 which has an Intel N450 processor and GMA 3150 integrated graphics card running Ubuntu 10.10. According to Intel's website the graphics card supports OpenGL 2.0. http://...
6
votes
2answers
11k views

OpenGL Warning not in mesa table

I am running Ubuntu 13.04 on a virtual machine. My host is: windows 7 64 bit machine i7-2630QM NVIDIA geforce gtx 460M graphics I have installed openGL, glut and mesa onto my Linux OS in the ...
5
votes
1answer
3k views

My NVidia GTX 960 card creates openGL problems with Unity on Ubuntu

I posted a bug about this on launchpad already, but was hoping maybe someone on here would have some suggestions about other things I could try. Background: I had a working Ubuntu 14.10 system with ...
1
vote
5answers
5k views

ubuntu 13.04, kde 4.11, ati fglrx 13.8 beta - opengl doesn't work

I have just upgraded to ubuntu 13.04 with kernel 3.10.6. After that I have updated my fglrx to 13.8 beta and after that I have added ppa:kubuntu-ppa/backports and I have upgraded my system. After ...
5
votes
1answer
17k views

Update to latest version of OpenGL

I recently installed TF2 and CS:S on my Ubuntu and it was showing nothing but a black screen (I could still hear the sounds) and after searching a bit I found out it may be my OpenGL version. After ...
4
votes
3answers
1k views

Frozen Synapse started crashing with a “Unable to initialize OpenGL” error after upgrade

I just played Frozen Synapse 2 days ago using Ubuntu 11.04. Now with a clean upgrade of 11.10, I cannot play the game anymore. When I run the game in terminal I get this error: Alert: Error Unable ...
3
votes
5answers
645 views

Problem with Ubuntu Phone SDK demo app

I have installed the Ubuntu phone SDK on a VirtualBox VM running Ubuntu Precise (12.04.2 LTS) as the guest OS. The "guest extensions" have been installed. The guest OS kernel is 32 bit 3.2.0-37 ...
2
votes
1answer
3k views

Ubuntu openGL issues

my OpenGL doesn't work at all i get Xlib: extension "GLX" missing on display ":0". lspci output 00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family ...
2
votes
2answers
5k views

How to use 3D graphics on Asus Eee PC 1215n

I need OpenGL for some programs, but OpenGL is not being used although installed, as is the Nvidia driver. As I understand it, the Asus Eee PC 1215N has an Nvidia ION2 GPU and an Intel graphics unit. ...
5
votes
0answers
815 views

Why is this application throwing OpenGL errors when run in Unity? [closed]

I have an application that ran flawlessly in Wine 1.3 in Maverick. However, when run in Natty under Unity, I get the following error: X Error of failed request: BadAlloc (insufficient resources for ...
2
votes
1answer
1k views

After Nvidia 331 and Bumblebee install, OpenGL reverts to old version

I recently installed Bumblebee and the Nvidia 331 driver, because apparently this was the only way to get my Geforce 860m to work. Now, when I try to compile OpenGL programs, it behaves as if I have ...
2
votes
3answers
2k views

Braid downloaded from humble bundle 3 is not running on 11.04

Hello fellow brothers in Linux I run Ubuntu 11.04 32bit and I need your help. Had downloaded Braid from humble bundle 3. They have provided a debian package and Installed the game but the game won't ...
2
votes
1answer
6k views

Can I upgrade my graphics driver to support the latest OpenGL versions?

My laptop is a Core 2 Duo Dell from 2008. I am trying to run some OpenGL programs. The program with following code doesn't work: glutInitContextVersion(4, 0); glutInitContextFlags(...
1
vote
2answers
1k views

How do I upgrade OpenGL? Intel

Solved: The Intel Core i3 380M Processor does not support a higher level of OpenGL. Anything past 2.1 is not currently available. intel-linux-graphics-installer did not work out of the box. Any ...
1
vote
1answer
1k views

VLC video playback is choppy on Vivid with nvidia-346

I'm running Kubuntu Vivid, and have an Nvidia 940GM card on my Inspiron laptop. When using the nvidia-346 driver, VLC plays choppy videos (video seems "pixelized" with green dots appearing). The ...
1
vote
1answer
347 views

Trying to get opengl 2 shaders to work glxinfo says I have 4.20 installed

I am trying to get opengl 2 shaders to work. I just installed kubuntu on my lenovo z575 laptop which sports a AMD A6-3420M APU, integrated 6520 gpu. In kubuntu under desktop effects I have opengl 2 ...
1
vote
1answer
6k views

How do you update an old Integrated Intel GPU's drivers to work with Steam?

I am trying to play Steam games on my computer running Ubuntu 14.04. On launching Team Fortress 2 I receive the error Cannot find required OpenGL entry point 'glGetError'! Either your video card is ...
1
vote
1answer
2k views

Installed libgdx and OpenGl in ubuntu

first let me say thanks for all the help in my other questions; the answers have really help a lot. Now I'm in the process in developing game for tablet, pc and android platform. I have decided to ...
0
votes
1answer
2k views

OpenGL problems with steam

Any time i launch a source game on steam i get the message Could not find required OpenGL entry pint 'glGetError'! Either your video card is unsupported, or your OpenGL driver needs to be ...
0
votes
1answer
755 views

How to fix: Unity not working at all (updates, upgrade, drivers, OpenGL)?

Recently I got stuck with Unity since it does not work at all - I see no system bar nor Unity launcher (3D/2D). Possible causes are: system update/upgrade or playing with drivers (additional fglrx or ...
0
votes
0answers
49 views

I can not login to gnome-cairodock session after manually installed udev (systemd-218)

I am on Ubuntu 14.04.3 32 bit platform. Last night I wanted compile and install an application called qtcam according to this guide https://github.com/econsysqtcam/qtcam/blob/master/INSTALL I thought ...