Questions about OpenGL, a library for rendering 2D and 3D graphics

learn more… | top users | synonyms

0
votes
1answer
713 views

How to fix: Unity not working at all (updates, upgrade, drivers, OpenGL)?

Recently I got stuck with Unity since it does not work at all - I see no system bar nor Unity launcher (3D/2D). Possible causes are: system update/upgrade or playing with drivers (additional fglrx or ...
0
votes
1answer
262 views

Blank screen in Ubuntu 13.10 after login; missing opengl

I had aworking Ubuntu 13.10 on my laptop till yesterday when I installed OpenCV 2.4. It did not cause any immediate problem yesterday but when I turned on the power this morning, I did not get a ...
0
votes
1answer
2k views

Diablo III Play On Linux

I'm using the PlayOnLinux program to install Diablo III on my Ubuntu 12.04 OS. I get to a point where it says Please wait while vcrun2008 sp1 x86 is installed... It then stays at this point ...
2
votes
0answers
210 views

Blank Screen upon login after installing openGL

I have an Inspiron N5010 running Ubuntu13.10 64b. It uses Intal HD Graphics (i.e. no ATI/Nvidia graphics card) I need a software that uses OpenGL, and I installed multiple packages using synaptic ...
4
votes
2answers
10k views

How do I get OpenGL working on an Nvidia GeForce GT 750M?

So, what do I have: Acer Aspire V30772G laptop with an Intel video-chipset and an Nvidia Geforce GT 750M video-card Ubuntu 12.04 installed and updated, with the proprietary driver selected ...
1
vote
0answers
95 views

Why won't `import` correctly capture the inside of a window rendered in OpenGL, while `scrot` will?

I have been experimenting with OpenGL recently, and I decided to take a screenshot of one of my fancy triangles with import, which is part of imagemagick. However, on two different computers, one ...
0
votes
1answer
13k views

How to install OpenGL version 2.0

How can I install OpenGL 2.0 on Ubuntu? Long Version: This Ububtu is running in a VM (VMWare). I wanted to use kivy for developing a GUI. I encountered many errors. I have searched around and those ...
0
votes
1answer
2k views

“fatal error: GL/glfw.h: No such file or directory #include <GL/glfw.h>” - How to solve it?

I'm trying to install GLFW to develop a OpenGL 3.0+ program and I've followed a few tutorials on how to install GLFW and I keep getting this error. I know I have installed it correctly with cmake, ...
2
votes
1answer
1k views

Problem when trying to run a compiled C++ file (uses OpenGL). Error: “Inconsistency detected by ld.so: dl-version.c: 224” [closed]

I created a simple opengl file in cpp. It works on the University computer. I'm able to compile the file, but i can not run the compiled file. The error I get is: Inconsistency detected by ld.so: ...
4
votes
1answer
2k views

Building Opengl 3+ in ubuntu under virtualbox/vmware

For a computer graphics class we will be developing opengl 3+ applications. I have installed ubuntu under both vmware and virtualbox, and installed there respective guest additions. If I run ...
1
vote
1answer
2k views

gnome shell with very high CPU usage

i'm running ubuntu gnome 13.10 on my dell latiude e6510 with a i5 m560. The I5 comes with a embedded Intel HD 3400 Graphics. The average cpu usage of the gnome-shell is by 160% it's to high, I think. ...
0
votes
1answer
566 views

Intel HD4000 and yet only OpenGL 3.0 (ubuntu 12.04)

I have a laptop with a Core i5-3317U CPU, which features a HD4000 chipset (http://ark.intel.com/fr/products/65707/intel-core-i5-3317u-processor-3m-cache-up-to-2_60-ghz), which normally supports OpenGL ...
2
votes
0answers
133 views

Why are there two sink input index generated by pulseaudio?

I'm planning to spawn a thread as I detect a new sink input index in pulseaudio. But when I run some application, I find out that a second sink index for same client is created. The system spawns a ...
1
vote
1answer
2k views

OpenGL 4.0 on ubuntu 13.04 using an intel graphics card

I have a new laptop with an Iris Pro 5200 integrated graphics card, everywhere I look it says that this card supports OpenGL 4.0. The reason why I want 4.0 (or 3.3+ to be more specific) is that I'm ...
0
votes
1answer
794 views

How do I download, install, and run Minecraft? As well as OpenJDK7?

First off, I have tried downloading Minecraft. I logged in, and the launcher did work. But, when I tried to "play Demo", this is what showed up: Developer Console before clicking "Play Demo" ...
1
vote
0answers
822 views

Driver related OpenGL graphics problem(Minecraft and steam wont start)

This has been bothering me for about a week now, I have been looking up answers on forums and everything and nothing seems to work. What happens is when i start minecraft i get this stacktrace: ...
0
votes
1answer
2k views

Ubuntu 13.04 ATI graphics card and OpenGL issues

Problem I am trying to run an OpenGL application which has worked on previous releases of Ubuntu on other machines but which happily opens windows crashes when I try and draw anything in them. ...
1
vote
1answer
3k views

Gameplay/openGL performance issues with AMD APU

I recently built a new desktop with an AMD A10-6800K (Radeon HD 8670D) APU. Basic graphics performance was fine with the open source drivers, but I installed fglrx* because I wanted to enable sound ...
1
vote
5answers
5k views

ubuntu 13.04, kde 4.11, ati fglrx 13.8 beta - opengl doesn't work

I have just upgraded to ubuntu 13.04 with kernel 3.10.6. After that I have updated my fglrx to 13.8 beta and after that I have added ppa:kubuntu-ppa/backports and I have upgraded my system. After ...
2
votes
2answers
7k views

Trying to install Proprietory Nvidia Graphics Drivers

After reading and trying many different suggestions for some hours, I returned to this how-to: https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia The first problem I encounter is how to ...
0
votes
3answers
92 views

Somehow, I've stoped OpenGL working

Somehow, I can no longer run anything that uses OpenGL. Any attempts to do so get the error Xlib: extension "GLX" missing on display ":0".. In /usr/lib I have LibGL.la, LibGL.so, LibGL.so.1 and ...
3
votes
1answer
3k views

OpenGL runs on very low framerate with a intel graphic card

I got two systems which are almost identical but with slightly different graphic cards: System A product: N10 Family Integrated Graphics Controller vendor: Intel Corporation driver: i915 System B ...
-1
votes
1answer
480 views

Support for OpenGL 4.3 for nVidia on 12.04.2 (or any version)?

Are the OpenGL 4.3 features of the latest nVidia cards supported yet in the drivers?
6
votes
2answers
10k views

OpenGL Warning not in mesa table

I am running Ubuntu 13.04 on a virtual machine. My host is: windows 7 64 bit machine i7-2630QM NVIDIA geforce gtx 460M graphics I have installed openGL, glut and mesa onto my Linux OS in the ...
2
votes
0answers
496 views

How to set up opengl on a dual graphics card laptop

I'm having trouble in getting newer version opengl. First, I get my graphics cards information using: lspci -nnk | grep VGA and it returns: 00:02.0 VGA compatible controller [0300]: Intel ...
0
votes
1answer
350 views

Why does “AMD testing use only” pop up upon login? [duplicate]

I have just used this website to follow some of the steps to manually create the .deb file from the .zip file that is on the AMD site. Then I installed them one by one using the Debpackage installer. ...
0
votes
1answer
959 views

ProSavage8 KM266/KL266 refuses to work in Ubuntu 12.04

I am trying to configure an old laptop, and this is driving me up the wall. I have spent at least ten hours trying solutions to no avail. I initally installed mesa 7.11, which did not work. I ...
1
vote
1answer
3k views

extension “GLX” missing on display “:0”, raden, 12.04 KDE

At some point my OpenGL stopped working in Kubuntu 12.04. "glxinfo" reports Xlib: extension "GLX" missing on display ":0". I know it worked previously since I was using before, even developing for it, ...
3
votes
0answers
569 views

Error message when running OpenGL programs with bumblebee

X Error of failed request: BadDrawable (invalid Pixmap or Window parameter) Major opcode of failed request: 152 (DRI2) Minor opcode of failed request: 8 (DRI2SwapBuffers ) Resource id in failed ...
3
votes
1answer
2k views

How do I get my compiler to locate the X11 header files?

I'm trying to use GLEW and XServer / X11 in a C++ app as instructed in Chapter 15 of the OpenGL Superbible, 5th ed. I'm using this Makefile: LIBDIRS = -L/usr/X11R6/lib -L/usr/X11R6/lib64 ...
8
votes
2answers
3k views

OpenGL warnings with Ubuntu 12.04 LTS running as a VirtualBox Guest under Windows7

I have been using 12.04 as a guest on my laptop for quiet some time now and it works flawlessly. Today a colleague asked me about the 3D performance of the guest. It never came in my mind to use ...
0
votes
1answer
260 views

Mesa brokes down in Ubuntu 13.04 after installing gcc 4.8

I wanted to install gcc 4.8 from 4.7.3 with this following commands: sudo add-apt-repository ppa:ubuntu-toolchain-r/test -y sudo apt-get update sudo apt-get install gcc-4.8-base after that gcc was ...
12
votes
1answer
25k views

Compile OpenGL Program (Missing GL/gl.h)

I am a complete Linux/Ubuntu noob, so I apologize for any dumb portions of this question or follow up ones. I am trying to get a program that my software engineering class's group wrote onto my home ...
6
votes
1answer
4k views

Why do I need to use lite mode in the new Google Maps? (Chrome) [duplicate]

I was wondering if I could use the new Google Maps. I have latest stable Chrome and Ubuntu 13.04. I am currently told that I must use lite mode. Under Chrome in Windows 8 on the same machine it works ...
0
votes
1answer
456 views

Completely separate full screen OpenGL context on second monitor

For a 3D scanner implementation I need to precisely control the output of a projector connected as a second monitor to my graphics card. I would need to issue OpenGL commands in a full screen context ...
1
vote
1answer
651 views

WARNING: The OpenGL rendering context obtained on X display

I've installed bumblebee with this tutorial http://eternalvoid.net/tutorials/linux-optimus-gt650m/ and when I try optirun i've got black screen & this: $ optirun glxspheres Polygons in scene: ...
-1
votes
2answers
6k views

PlayonLinux says i need 32bits OpenGL libs, can someone give me Nvidia 32bit libraries

So I am totally new to Ubuntu and saw that someone said that I need to install the 32bit libraries. Can someone tell where do I find them? I know I can get them with sudo apt-get install but I don't ...
0
votes
2answers
703 views

How do I shut down X in order to install nvidia drivers/looking to install gl.h, glut.h (opengl files) [duplicate]

It's astonishingly hard to find out how to install opengl headers on ubuntu. I've seen pointers to the opengl registry: http://www.opengl.org/registry/ but the files do not appear to be there. I've ...
2
votes
0answers
3k views

Ubuntu 13.04 “could not find required OpenGL entry point 'glGetError'!” [duplicate]

Just recently upgraded to 13.04 and am having trouble running TF2 via Steam. Whenever I start Steam I get a dialog saying: OpenGL GLX context is not using direct rendering, which may cause ...
0
votes
0answers
106 views

Qt Creator Blank Debug Screen [duplicate]

When debugging my First Phone app in Ubuntu I get a blank black screen Environment : Virtual Box OS :Ubuntu I have attached the terminal out put here http://pastebin.com/mfSdH1KV My unity test ...
2
votes
1answer
1k views

Laptop overheating, Unity / OpenGL / nvidia drivers conflict

My problem is that my laptop, Dell Inspiron N5110, running ubuntu 12.04, is overheating, and occasionally shuts down voluntarily. The fan is working non-stop. I know much has been ...
0
votes
1answer
1k views

3D Graphics Acceleration

Grphics acceleration is disabled in Ubuntu. I went to Software & Updates and opened the Additional Drivers tab and was presented with a list of drivers, which one am I supposed to install? Why is ...
2
votes
2answers
8k views

Cannot get OpenGL to install [duplicate]

When I try to run an example application it says I am missing a file that is found in OpenGL. I found information online and tried to install OpenGL with the following command: sudo apt-get install ...
5
votes
1answer
16k views

Update to latest version of OpenGL

I recently installed TF2 and CS:S on my Ubuntu and it was showing nothing but a black screen (I could still hear the sounds) and after searching a bit I found out it may be my OpenGL version. After ...
1
vote
1answer
397 views

Ati - Problems with open drivers after fglrx remove

I have ubuntu 12.04 and kde 4.10.1. I have removed fglrx drivers 13.1 doing this: sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* I have also removed xorg.conf (it was in a ...
1
vote
1answer
940 views

Unity gone after upgrading kernel

I recently got an automatic software update where I was alerted that there was insufficient space on /boot. Attempting to purge old kernel versions following this answer, I accidentally removed also ...
1
vote
1answer
1k views

Can Compiz work in an Ubuntu guest in VMware workstation 9?

OpenGL it's supported in VMware Workstation 9 http://www.vmware.com/support/ws90/doc/workstation-90-release-notes.html#OpenGL So Compiz theoretically can run inside a Ubuntu guest in VMware ...
1
vote
1answer
334 views

Trying to get opengl 2 shaders to work glxinfo says I have 4.20 installed

I am trying to get opengl 2 shaders to work. I just installed kubuntu on my lenovo z575 laptop which sports a AMD A6-3420M APU, integrated 6520 gpu. In kubuntu under desktop effects I have opengl 2 ...
2
votes
3answers
1k views

World of Warcraft under primus/crossover getting Direct3D9 is not available without opengl

I'm running Ubuntu 12.10 64bit and having issues using primus (due to nvidia optimus) to run World of Warcraft in Crossover.. I'm getting the following: steorra@perpetual:~$ primusrun ...
0
votes
1answer
766 views

Get at least OpenGL 3.0 for Radeon card

I have an ATI mobility Radeon HD series 5000. I searched for it and I found that it supports OpenGL up to version 4.1 When I updated Ubuntu 11.10 to 12.04 I got OpenGL version string: 2.1 Mesa 8.0.4 ...