Event-driven I/O server-side JavaScript environment based on V8. Includes API documentation, change-log, examples and announcements.

learn more… | top users | synonyms

1
vote
3answers
2k views

Problem: “npm ERR! cb() never called! npm ERR! not ok code 0” when installing etherpad

on an Ubuntu 12.04.3: adduser --system --home=/var/www/etherpad --group etherpad apt-get install gzip git-core curl python libssl-dev build-essential abiword python-software-properties ...
1
vote
2answers
358 views

Having trouble to find the node in ubuntu 14.04 after installing

I installed the NodeJS in Ubuntu 14.04 by nvm by following this site Installing NodeJS Though I had the following problem as nvm ls sbin mkdir: cannot create directory ‘/usr/sbin/alias’: ...
2
votes
1answer
74 views

UTF-8 Issue, don't know where?

I am running a node.js server and the following line just isn't working. console.log("☺☻♥ مرحبا 你好"); I opened up the file in nano and cat on my ubuntu server 14.04 (no gui, no window manager, no ...
2
votes
1answer
250 views

Strange recursive folder created on npm installation

something very strange is happening to my system. I'm running Ubuntu 12.04 and I use it for node.js deveopment. Every time I perform an installation either (sudo npm install -g myPackage) a srtange ...
1
vote
1answer
582 views

Trying to install yeoman on ubuntu to use with nodejs and npm

Using Ubuntu 13.10 I am trying to install yeoman using sudo npm install -g yo but it doesn't seem to work globally both npm and nodejs are installed, however, I am not sure that they are installed ...
1
vote
1answer
2k views

How to set-up Nginx correctly? “Welcome to nginx” is not displayed

I installed Nginx on my Ubuntu Server 12.10 using this instructions https://www.digitalocean.com/community/articles/how-to-install-nginx-on-ubuntu-12-04-lts-precise-pangolin , the Nginx was installed ...
0
votes
1answer
733 views

alias of nodejs as node on 14.04

i installed nodejs with apt-get on 14.04 When i do nodejs -v v0.10.25 and when i do node -v node : command not found. So i want to make alias of nodejs as node So i inserted a line in ...
0
votes
1answer
828 views

node.js app runs from command line but gives errors when run from cron job on reboot on ubuntu 14.04 LTS

When starting my app manually using forever, it works fine. It runs on localhost:8080 and nginx does the routing. When using a cronjob my starter.sh script runs but in the forever log I get an error. ...
0
votes
1answer
313 views

Install custom version of node with apt-get

I've installed nodejs this way: sudo apt-get install python-software-properties python g++ make sudo add-apt-repository ppa:chris-lea/node.js sudo apt-get update sudo apt-get install nodejs The ...
0
votes
1answer
985 views

npm installed packages are not accessible

I installed nodejs with the instructions from this post on ubuntu 13.1 All went smooth. After that I installed express by issuing the command npm install express which result in express@3.4.4 ...
0
votes
1answer
406 views

Upstart and Node js: Cannot find module

I'm trying to setup upstart to run with my Node js and Socket.io server. /etc/init/quizens.conf env NODE_BIN=/usr/bin/node env APP_DIR=/root/quizens env SCRIPT_FILE="quizens.js" env ...
0
votes
1answer
22 views

Nodes.org install sur local src node

I am installing nodes the command sudo ./configure is ok but when I type next command menudo make I got an error g++ and 127 . How could I resolve them to finish the nodes installation
0
votes
1answer
123 views

which application is needed to read genesis rom files

I had downloaded node.js in my ubuntu 11.10. When i had unzipped and pretend to open README.md, it prompts me that ' there is no application installed for genesis rom files. Please help me by sharing ...
3
votes
0answers
422 views

Problem with Node.js installation

I am very new to Linux so my question may seem stupid however I cannot install Node.js and npm software successfully. More precisely, the installation is completed but when I am trying to run some ...
3
votes
0answers
51 views

Access API for Unity topbar?

Is there any way to access Ubuntu Unity topbar using node.js ? I just want to make a web app and need some way to make a indicator for the web app .
1
vote
0answers
484 views

Getting “mkdir: cannot create directory…” while installing & using NVM/Node.js commands

Please bare with me, not a Linux wiz (unfortunately). Anyways, I have a freshly installed 14.04 LTS version of Linux, onto which I recently installed NVM & Node.js. I did so by entering the next ...
1
vote
0answers
224 views

NodeJS Hangs on Ubuntu 14.04 Boot [Big CPU & Memory usage]

Node somehow hangs on Ubuntu 14.04 boot. It uses lots of CPU and RAM (Checked with Terminal -> top). I need to have root permissions to kill it and it doesn't work after the first time. Had to spam ...
1
vote
0answers
144 views

Forever cannot be installed

While trying to install Forever using this command: sudo npm -g install forever I'm getting this error: npm WARN engine hawk@0.10.2: wanted: {"node":"0.8.x"} (current: ...
1
vote
0answers
34 views

How can I stop a process from moving to the background?

I have a machine running Ubuntu server version 12.04.3 LTS. On it, I'm attempting to run a node.js server that needs to stay up and running at all times. I'm running into an issue, however, where ...
0
votes
0answers
10 views

How to connect Node js Application with the dedicated ubuntu server?

I have a working Appication With nodejs and total js. it work fine on localhost Project I want to know what steps i want to follow to App run with brandnew dedicated ubuntu server. only know ...
0
votes
0answers
48 views

How to install nodejs specific version

I have installed nodejs using sudo apt-get install nodejs. This installed version 0.10.32 but I want to install version 0.10.15. I already tried this command sudo apt-get install ...
0
votes
0answers
84 views

Install Node on Ubuntu 14.04 1and1 Virtual Server

I have a Virtual Server from 1and1 running Ubuntu 14.04. After correcting the /etc/apt/sources.list to the official ones I tried to install nodejs and npm (to install bower later). I followed the ...
0
votes
0answers
190 views

How to install IBM DB2 drivers on Ubuntu

I need assistance installing IBM DB2 drivers onto Ubuntu. Using Ubuntu 14.04, I'm attempting to create a simple web page that gets served by the node.js server-side framework. A ...
0
votes
0answers
75 views

Where does node.js install to?

I'm trying to install a script, which is a clone of a game, and uses node.js for it. Now, the documentation says I should copy the node.exe (windows) and put it where the clone is. Now, I can't find ...
0
votes
0answers
495 views

module: graceful-fs : npm ERR! install Couldn't read dependencies

1) Just built a freshly installed Ubunto 14.04 VM. 2) Followed instructions at http://askubuntu.com/a/83290 3) Followed instructions at https://www.npmjs.org/package/generator-sili 4) Getting error - ...
0
votes
0answers
32 views

Most secure way to install node?

Should I install node as root and then add user permissions to run it, or add a sudo user to the sudoers file and install and run it that way? It seems to me that adding the user to sudo would be a ...
0
votes
0answers
422 views

Nginx Load-Balacing node.js, SSL Not Working

I'm running 12.04 and using Nginx to load-balance node.js and I'm having an issue getting SSL to work. The Problem Using the configuration below, when I send any requests via https I get no response ...
0
votes
0answers
137 views

Node.js application is not working ARM Ubuntu

I use a Samsung ARM Chromebook as a dev machine, and as a result Node.js is absolutely essential. In the past I've had no issues with it whatsoever. However, due to unfortunate circumstances I was ...
0
votes
0answers
90 views

Node-hid doesn't see a Xbox controller - Ubuntu 12.04.03

I am trying to get node-hid to display information information on an Xbox controller. It can display info on other hid devices such as a mouse just fine but when I run the below code with an Xbox ...
0
votes
0answers
118 views

How can I install older version of node-less

I need version 1.3.3 of node-less. I've tried to force an older version using Synaptic Package manager, but no earlier versions are available. If I attempt to install less via npm, it results in ...