Mesa is a software library for 3D computer graphics that provides a generic Khronos-compliant OpenGL implementation for rendering three-dimensional graphics on multiple platforms.

learn more… | top users | synonyms

0
votes
0answers
9 views

How to rebuild swrast_dri.so?

I tried to run glxgears in aarm64 plaform in specific device, but it failed due to problems with swrastr_dri.so X Error of failed request : BadValue Major opcode of failed request: 154 (GLX) ...
0
votes
0answers
43 views

Is there any chance to install newest mesa on ubuntu 14.04?

I am using ubuntu 14.04 and tried to install the newest mesa version 11.2.2 on it. However the ./configure requires libdrm_nouveau >= 2.4.66 but the version of libdrm_nouveau on my ubuntu 14.04 is ...
0
votes
0answers
61 views

AMD GPU Open Source driver issues

I have an AMD FirePro v4800 (Redwood XT based) that I was running on a Kubuntu 14.04 setup just recently. Just a little bit ago, I got a notification to update to 16.04. I'd read about fglrx not being ...
0
votes
0answers
22 views

Can't start system after installing steam

after installation of steam my system won't start. I had to fix some dependencies listed in messages (believe somthing with mesa and i386 in it, I don't know how to find it now) i think something with ...
1
vote
0answers
113 views

How to switch graphics from Intel to AMD with open source driver in Ubuntu 15.04 Gnome

I have Inspiron 14z-5423 with Intel Core i7-3517U APU and a dedicated AMD Radeon HD7550M GPU. I was using it with proprietary fglrx driver and was getting even lower performance then Intel integrated ...
0
votes
1answer
84 views

Ubuntu 14.04.4 LTS Enablement Stack has unmet mesa-dev dependencies

I have just updated to the latest LTS Enablement Stack for Ubuntu 14.04.4 using the wiki. I am trying to install some dependencies for building plexhometheater and getting an error. Any ideas what ...
0
votes
1answer
119 views

Upgrade to Mesa 10.5.9 from 10.1.3

I have some issues with my graphic card that I'm trying to solve. I have done some research and one solution could it be to use the latest mesa 10.5.9 but apparently I don't have it installed. How do ...
0
votes
0answers
44 views

Unable to build Mesa 3d Library

I'm trying to install mesaLib 7.9 (Pre-req for Paraview)on ubuntu 12.04. When I run the configure file I get this. checking build system type... x86_64-unknown-linux-gnu checking host system type......
0
votes
1answer
63 views

Upgrading OpenGL

My graphics are Intel® Q45/Q43 and my processor is Intel® Core™2 Duo CPU E7500 @ 2.93GHz × 2. I have the latest mesa: 11.3.0 but my OpenGL version string is still 2.1. Any help would be helpful.
-1
votes
1answer
56 views

How to block Ubuntu from upgrading to a newer version?

So, I have Ubuntu 14.04.2 and when I type the command "sudo apt-get upgrade", it upgrades my Ubuntu to 14.04.3. I don't want 14.04.3 because it has problems for me such as the infamous login loop ...
0
votes
0answers
112 views

AMD APU + GPU (MSI GX70) Switchable Graphics Card

I want to move away from windows, since microsoft is doing a great mess right now with their OS. Though I've been an Ubuntu user since 2010, I was using this computer mainly for gaming. I have a MSI ...
0
votes
2answers
61 views

Ubuntu is sluggish and fells slow

I have installed ubuntu 14.04 on my Lenovo s20-30. This is fresh install. System is quite slow, i thought it may be driver problem. How to check if im not missing some drivers or i need to configure. ...
0
votes
1answer
304 views

Ubuntu Qt 5.5.1: error Cannot find -lGL

I have developed an GUI application on Qt 5.3.1. I am using Qt Creator 3.1.2 (based on Qt 5.3.1) to build my GUI application and am able to build and deploy my application successfully. I wanted to ...
2
votes
0answers
4k views

libgl - failed to load driver: vboxvideo

I'm attempting to run this code to create a transparent xlib window with openGL features, but when I run the program I get these errors in the terminal: libGL error: pci id for fd 4: 80ee:beef, ...
1
vote
0answers
194 views

libglu1-mesa-dev, how to keep both i386 and amd64 packages

I'm using ubuntu 14.04 LTS 64-bit I want to build both 32-bit and 64-bit app under 64-bit Ubuntu. I have a problem with package libglu1-mesa-dev, when I install i386 package, it removes amd64, and ...
2
votes
2answers
9k views

Upgrading to latest version of OpenGL on Ubuntu 15.10

I currently have an intel integrated GPU Intel 5100 iris graphics and I would like to upgrade to the latest version of OpenGL available. I currently have OpenGL 3.0 and mesa 11.0.2 installed.
0
votes
0answers
27 views

Light blue screen when enabled opengl in compiz

I have a little problem with my opengl driver. When I use opengl in compiz or in chrome it breaks my color gamma. image1 image2 This is after I purge my fglrx driver and reinstall xserver-xorg, ...
1
vote
0answers
399 views

How do I uninstall the mesa drivers now I've switched my graphics to nvidia?

As per Why-are-my-32bit-opengl-libraries-pointing-to-mesa-instead-of-nvidia, I've managed to get ldconfig to no longer reference mesa drivers by editing the conf files, but when the mesa GL drivers ...
0
votes
0answers
189 views

How to fix Mesa 3d acceleration flickering in Vmware Player with Broadwell graphics?

On a fresh 15.04 Ubuntu install, with Intel 5500 integrated Graphics, drived by Mesa 10.5.9, I experience weird artifacts trying to accelerate graphics on a guest, fresh installed, Windows 10 Pro ...
-1
votes
1answer
203 views

“You are missing the following 32-bit libraries, and Steam may not run: libc.so.6” Standard fixes not working

Recently set myself up with 14.04 LTS and when I install steam and try to run it, I get this message in terminal. Steam needs to install these additional packages: libgl1-mesa-dri:i386, libgl1-mesa-...
2
votes
2answers
3k views

Install Mesa? How?

I want to try to install the mesa driver to see if it helps my FPS with radeon gpu for Dota 2. However, I can't find a proper way to install it. How would I go about it? I tried adding the ppa and ...
1
vote
0answers
114 views

OpenGL sources: Libglu1-mesa-dev depends on libglu1-mesa (= 8.0.2-0ubuntu3) but 8.0.4-0ubuntu0.7 is to be installed

When trying to install an R package (rgl, which makes 3-D plots), R gives the following error: configure: error: missing required header GL/glu.h ERROR: configuration failed for package ‘rgl’ ...
0
votes
1answer
135 views

Unable to locate package mesa?

Following this guideline. sudo add-apt-repository ppa:xorg-edgers/ppa then, sudo apt-get update Followed by sudo apt-get install mesa The last results in: Reading package lists... Done ...
1
vote
0answers
191 views

Need help with Mesa3D and updating OpenGl, Noob here

The issue here is that Ive been trying to update my OpenGl trough Mesa3d, I recently installed Mesa 10.6.7 successfully trough a package from Mesa3d official page (It was a pain to build the whole ...
1
vote
0answers
70 views

How to install gtkglextmm in Ubuntu LTS 14.04?

Can you let me know the steps to install "gtkglextmm" in Ubuntu LTS 14.04? For learning experience, I am trying to compile basic examples from "gtkglextmm"? According to the "README" file from "...
3
votes
1answer
773 views

Opengl Mesa : use opengl 4.0

I'm an opengl programmer, and I would like to use opengl 4.0; problem is that I cannot install any proprietary drivers, and when I type : glxinfo | grep "OpenGL version" in the terminal, it outputs me ...
0
votes
1answer
1k views

How to get OpenGL Shader Language 1.4 working with Intel HD Graphics 4000? (Trusty/14.04)

I am running Ubuntu 14.04 (trusty) on an Ultrabook with the i7-3537U CPU. This processor has the Intel HD 4000 GPU (ref), which supports OpenGL 3.3 under Linux (ref). OpenGL 3.3 includes support for ...
1
vote
1answer
94 views

Is Floating Point Texture Support Enabled in Mesa?

I am attempting to play a game through CrossOver for Linux. However, I get a warning that floating-point textures isn't supported in OpenGL. I recently found that this was due to a legal issue that ...
1
vote
0answers
588 views

Unity desktop on Raspberry Pi 2

The first thing needed to make it work is a driver. There was a Mesa and DRM driver for Broadcom VC4 developed recently by Eric Anholt. It's an OpenGL driver. http://dri.freedesktop.org/wiki/VC4/ ...
0
votes
0answers
37 views

14.04: Unable to locate package mesa [duplicate]

sudo apt-get install mesa results in: Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package mesa lspci -k | grep VGA -A2 01:...
1
vote
0answers
157 views

Can't start X server on main partition — Mesa/NVidia conflict?

I am unable to start my X server any time I try booting my computer -- which is running Ubuntu 14.04 -- from the default partition (i.e., by choosing the first "Ubuntu" option in the GRUB menu). ...
1
vote
2answers
167 views

What are these commands for (fglrx-updates installation)? And how to undo one of them?

My ubuntu 14.04 was not able to install fglrx-updates. I have two graphic cards (intel and amd). I searched on the net and found some answers related to it. Firstly i tried this one: sudo apt-get ...
0
votes
1answer
51 views

Couldn't bind mesa with vis5d+

Problem: I am trying to link mesa with vis5d+ mesa is installed under this directory: /usr/lib/i386-linux-gnu/mesa when I run ipc@ipc-ThinkPad-X240:~/Downloads/vis5d+-1.3.0-beta$ ./configure it ...
0
votes
1answer
13 views

How to use a never library on Ubuntu 12.04

I run Ubuntu 12.04 on my laptop and I have originally installed libxcb version 1.8.1 from package, but I need a newer version, because I need it to use the new mesa. I have compiled it from git with ...
1
vote
1answer
2k views

Can't install mesa-common-dev

I can't install this package, it gives me an error, this is the output from terminal: ➜ ~ sudo apt-get install mesa-common-dev Reading package lists... Done Building dependency tree ...
0
votes
1answer
142 views

Problem with Mesa 3d Inteldriver

I am using Ubuntu 14.04 with the following graphic card 00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06) ...
0
votes
1answer
296 views

Have problem while installing openGL ( using mesa-common-dev)

It says : The following packages have unmet dependencies: mesa-common-dev : Depends: libx11-dev but it is not going to be installed Depends: libdrm-dev (>= 2.4.52) but it is not ...
1
vote
1answer
1k views

Broken OpenGL: Wrong GLX renderer in glxinfo and inxi (Nvidia instead of Intel)

I have spent all day trying to resolve this issue, I hope someone in this friendly forum can help: I am running the following setup: Distribution: Ubuntu 14.04.01 Kernel: 3.13.0-43-generic Hardware:...
1
vote
0answers
841 views

How to install Mesa 9.2 on Ubuntu 12.04

I want to install at least mesa 9.2. I am running 12.04 Precise Pangolin. Lots of places suggested xorg-edgers and oibaf, but every time I type sudo apt-get install mesa, it says package missing. I ...
4
votes
1answer
2k views

higan says that OpenGL 3.2 is not available, but I should have 3.3

I am running Trusty with gnome in crouton on a Toshiba Chromebook 2. I installed higan, and it reports: "Error: OpenGL 3.2 is not available." I googled this, and apparently the problem may be related ...
1
vote
0answers
241 views

Where to get latest stable Mesa?

Atm the only choice we got is between Mesa which ships with Ubuntu (it's outdated before release) or one from Oibag PPA which is latest git development branch (very unstable). What about latest ...
3
votes
0answers
1k views

How do I install the latest Mesa release?

Which is the preferred way to install the latest stable version of Mesa on Ubuntu? I believe that would be a PPA, but not the bleeding-edge one like xorg-edgers. I would like to see a PPA that ...
0
votes
1answer
605 views

install issue opengl Mesa-10.2.6 cannot find llvm shared libraries

So I was working on this one most of yesterday. I am trying to install the mesa3d opengl libraries on ubuntu 14.04 x64. So I downloaded and installed the dependency for this install: llvm-3.4.2. So ...
0
votes
1answer
324 views

How to bring back older version of mesa packages from ppa:xorg-edgers/ppa

I'm trying to install older version of mesa packages from xorg-edgers PPA using following command: sudo apt-get install libgl1-mesa-dev=10.3.0~git20140812.fa5b76e3-0ubuntu0ricotz~trusty mesa-common-...
7
votes
1answer
4k views

Is there a GUI for configuring the Radeon Open Source Drivers and Mesa 3D similar to Catalyst Control Center?

Is it possible to change the settings of the radeon open source drivers and Mesa 3D graphics library? I am thinking of something similar to Catalyst Control Center that would allow me to control ...
0
votes
1answer
862 views

Opengl version problem on MESA

I'm running Ubuntu 14.04 LTS on Vmware Fusion 6 on my Macbook Pro Retina (which supports OpenGL upto version 4.1) I have installed MESA by using following command sudo apt-get install mesa-utils ...
0
votes
1answer
650 views

Unable to install mesa-common-dev:i386 on my ubuntu system

I am using Ubuntu(12.04 LTS) x86_64 GNU/Linux. I have to setup my build environment on my Ubuntu system. While trying to instal the mesa-common-dev:i386 package, I am facing the following error. sudo ...
-1
votes
1answer
267 views

Fglrx doesn't load, system using mesa

I installed fglrx from Ubuntu repo, yet it doesn't work, system loads with Mesa anyway. Ubuntu 14.04 64bit with latest updates.
0
votes
1answer
2k views

Unmet dependencies for libgl1-mesa-dev while initializing build environment for android [duplicate]

I am trying to setup build environment on Ubuntu 12.04 (precise)(64bit). I am following the guide at official android site. I encountered the following message. $ sudo apt-get install libgl1-mesa-...
2
votes
0answers
353 views

VMWare: Check if 3D Hardware is used for rendering or not

How do I check whether my VMWare installation is using the GPU on the computer or using software rendering? The output from glxinfo is OpenGL vendor string: VMware, Inc. OpenGL renderer string: ...