matplotlib is a plotting library for the Python programming language

learn more… | top users | synonyms

1
vote
0answers
14 views

Plotting with Octave and Matplotlib Broken on Ubuntu 16.04

I'm having a problem using plot commands using python-matplotlib and Octave ever since I installed Octave. Prior to installing Octave v4.0.2, I was able to plot with Matplotlib v. 1.5.1 just fine. ...
1
vote
1answer
100 views

Unable to install matplotlib using pip in Ubuntu 16.04

In Ubuntu 16.04 I am able to install almost every python package and library using pip except for matplotlib. I use this command to install matplotlib pip install matplotlib This gives the error: ...
1
vote
1answer
105 views

When trying to import Matplotlib.pyplot, get “UnicodeDecodeError”

When trying to run a Python script starting with import numpy as np import matplotlib.pyplot as plt I'm getting the following error message: /usr/lib/python2.7/dist-packages/matplotlib/...
2
votes
1answer
143 views

How to ensure matplotlib in a Python 3 virtualenv uses the TkAgg backend?

I am using Ubuntu 16.04 with Python 3. Using apt to install matplotlib and then printing the matplotlib backend gives TKAgg, which is expected because Ubuntu has 16.04 has python3-tk installed. This ...
1
vote
1answer
44 views

How do I install matplotlib dependencies?

How can I easily install all the non-Python dependencies I require before I can pip install matplotlib?
0
votes
0answers
22 views

In Spyder, the window turns gray the moment I type “plt” (for matplotlib.pyplot)

I'm following a course on Machine Learning on Udacity, https://github.com/tensorflow/tensorflow/blob/master/tensorflow/examples/udacity/1_notmnist.ipynb, and after importing the data I'd like to try ...
1
vote
1answer
172 views

Segmentation fault (core dumped) using matplotlib on Ubuntu Mate 16.04

I recently installed on my machine (an old imac) Ubuntu Mate 16.04. When I try to run a python script from terminal I get the error: Segmentation fault (core dumped) The same script works perfectly ...
0
votes
0answers
35 views

Getting this error :Sub-process /usr/bin/dpkg returned an error code (1) when I try to run sudo apt-get install python-matplotlib

I tried installing matplotlib, to make graphs on python on Ubuntu 14.04 and am getting the following error. I am unable to resolve this error: (env)ubuntu@ubuntu-Inspiron-5423:~/tweepy$ sudo apt-get ...
0
votes
3answers
1k views

No module named 'numpy'

Actually I am shifting from Windows to Linux. Using pycharm on Windows I have a python script that requires numpy and matplotlib to run, so I installed them on my Linux system using sudo apt-get ...
2
votes
1answer
748 views

How to install Python Matplotlib 1.5.1 on Ubuntu

I want to install matplotlib 1.5.1 for python 3.4 on ubuntu 14.04, but when I type in the terminal sudo apt-get install python3-matplotlib I just get matplotlib 1.3.1. I tried to use pip to install ...
1
vote
1answer
189 views

Error Getting Dependencies for Matplotlib

I am trying to install the python package matplotlib from source. I cannot install the package from the repository using sudo apt-get install python-matplotlib because I need to be able to install the ...
1
vote
2answers
884 views

matplotlib not working in Pycharm 4.5.3

I'm trying to run a simple code in Pycharm Community Edition 4.5.3 to display a graph with some points using matplotlib import matplotlib.pyplot as plt plt.plot([5,4,4,4,6,6,7,7,8,8,9,10,10,10,10,11,...
1
vote
0answers
2k views

Really installing PyQt4/5 for python 3.4 on trusty

I am using Python 3 on my ubuntu 14.04.2 (trusty), along with Python 2. I am trying to run ipython --pylab, but with Python 3, this fails (works well with Python 2). It fails since it needs QT4/5 or ...
1
vote
2answers
5k views

Python 2.7 matplotlib provides error?

import numpy as np import matplotlib.pyplot as plt provides the error Traceback (most recent call last): File "/home/xx/PycharmProjects/Udemy/Array_Processing.py", line 2, in <module> ...
2
votes
0answers
257 views

Installing python libs under Lubuntu 14.10 getting Errors

Hey there I need to install some python packages on my Laptop for work(university). The command they gave us is sudo apt-get install python3 python3-pip python3-pyqt4 python3-tk and pip3 install --...
1
vote
1answer
1k views

How to install numpy, scipy, and other packages from source for Python3 in Ubuntu 14.04.2 LTS

I just recently installed Ubuntu 14.04.2 LTS alongside Windows-7 (64-bit). I wanted to install the latest versions of numpy, scipy, matplotlib, and other packages for Python3. I saw the we can use ...
3
votes
1answer
2k views

Plotting with Matplotlib in Python 3 pylab: Tkinter and Qt FontManager errors

I'm trying to use pylab (i.e., $ ipython3 --pylab) in Python 3 on Ubuntu 14.04. I'm running into the same error regardless of whether I use the Tkinter or Qt4 backends. AttributeError: 'FontManager' ...
1
vote
0answers
217 views

matplotlib xkcd with utf-8 label

In python3 / matplotlib, I'd like a plot with a label: plt.plot(np.sin(np.linspace(1,10)), label='fête') plt.legend(loc='upper left') plt.show() Works great. Now let's try with xkcd mode: plt.xkcd(...
3
votes
1answer
622 views

Ubuntu 14.04 upgrade causes matplotlib error

Since upgrading to 14.04 any python code I run that uses matplotlib returns an error. Here is what my ipython console returns In [1]: import matplotlib.pyplot as plt ----------------------------------...
3
votes
0answers
643 views

Backend for python3 module matplotlib

I'm trying to use python3 to plot graphs. The only backend for matplotlib that seems to work is tkAgg (Tkinter), however this looks like it has been designed in the Stone Age. So I was trying to find ...
1
vote
1answer
828 views

How to install an earlier version of matplotlib?

I have matplotlib 1.3.1 installed on my computer. However I have to run some code that runs with matplotlib 1.1.1 but not with 1.3.1. Therefore I should remove this version and installed 1.1.1. How ...
2
votes
1answer
399 views

Problem embedding a pylab Figure in a Gtk application using quickly

I am currently trying to build a simple app that includes some pylab figures. I just started to use quickly and I am concerned about some import issues. That is, none of the matplotlib backends will ...
0
votes
2answers
5k views

matplotlib Error: No module named matplotlib even though it is installed

I have been through the process of installing matplotlib on my Ubuntu 12.04 computer. However, when I try to run a test program, I get the following error: Traceback (most recent call last): File "...
7
votes
2answers
3k views

Most up to date Ipython and Matplotlib in Ubuntu 13.10

I've recently updated my Ubuntu to the 13.10 version. To my surprise, Ipython and Matplotlib are available only in versions prior to those I had in my previous 12.04 LTS install. When with the 12.04, ...