Make is a utility that automatically builds executable programs and libraries from source code by reading files called makefiles which specify how to derive the target program.

learn more… | top users | synonyms

0
votes
3answers
5k views

How can I fix errors installing D-Link DWA-121 wireless driver tarball?

I tried the following instructions as given on D-Link's website to install the necessary drivers: Supported OS and kernel version : LINUX (kernel 2.6.18 ~ 2.6.37) tar zxvf ...
17
votes
2answers
45k views

“autoreconf: not found” error during making qemu-1.4.0

I was ./configure'd the qemu-1.4.0 and during make it cause: (cd /home/amin/Simulate/qemu-1.4.0/pixman; autoreconf -v --install) /bin/sh: 1: autoreconf: not found make: *** ...
6
votes
1answer
2k views

How do I install make?

/usr/bin/perl install-module.pl --all ERROR: Using install-module.pl requires that you install "make". I need to install make on my ubuntu on AWS EC2. How can I do that ? I could finally install ...
1
vote
1answer
6k views

ALFA AWUS036NH driver

hello everyone i have a question about ALFA AWUS036NH network adapter, i tried this link: How do I install drivers for the Alfa AWUS036H USB wireless adapter? but when i do: make i get these ...
0
votes
1answer
3k views

Missing modversions.h

I`m trying to compile a program, which was actually designed for Linux OS based on kernel 2.4. When I run the make command, I get the following error ...
13
votes
1answer
9k views

What does “./configure; make; make install” do?

What does ./configure do? Why make then make install? How does it know where libs are? ( they are all there and loaded but it cant find them.) Why need libs if compiler is supposed to compile?
8
votes
1answer
4k views

How to speed up compilation of Ubuntu apps (make, cmake, gcc)

I am compiling some programs here and I have 4 cores. Is there a way to tell make, cmake or gcc to compile using all cores or something to that affect.
8
votes
1answer
14k views

Compile OpenGL Program (Missing GL/gl.h)

I am a complete Linux/Ubuntu noob, so I apologize for any dumb portions of this question or follow up ones. I am trying to get a program that my software engineering class's group wrote onto my home ...
3
votes
2answers
98 views

Is there a plugin for the terminal which allow to detect and open files?

I'm looking for a terminal plugin/extension that would allow me to detect files path in terminal output and open them in a text editor by clicking on them. The perfect solution would open the file at ...
1
vote
0answers
2k views

error adding symbols: DSO missing from command line

I am newbie to Ubuntu.i want to compile a project that uses opencv but it gives following error: cmake . && make /usr/bin/ld: ...
5
votes
1answer
16k views

“error adding symbols: DSO missing from command line” while compiling g13-driver

I'm trying to compile the download received here: https://code.google.com/p/linux-g13-driver/ by running make but I'm receiving errors that to me, after searching on the web, look like they're the ...
4
votes
3answers
29k views

Getting an error when using 'make' command (installing aircrack-ng on Ubuntu 12.04)

I followed these instructions. I edited the common.mak file successfully and when I ran make I get this error: mohd-arafat-hossain@TUD:~/aircrack-ng-1.1$ make make -C src all make[1]: Entering ...
4
votes
2answers
3k views

Building ATLAS (and later Octave w/ ATLAS)

I'm trying to set up ATLAS (so I can later compile octave with ATLAS support). If I'm correct, I still need to build this manually due to the environment specific optimizations. I do see a package ...
3
votes
2answers
10k views

Getting missing dependency for compilation glib-compile-schemas

I Downloaded empathy-3.0.1.tar.bz2 to install in Ubuntu 10.04 LTS. I ran the makefile and I got the error : configure: error: glib-compile-schemas not found. How can I fix this problem ? Please ...
2
votes
2answers
578 views

Trying to install Erlang on Ubuntu 12.04, error with make install

I am trying to install Erlang R16B on my laptop with Ubuntu 12.04. I get an error which says: /usr/bin/install -c -d "/usr/local/lib/erlang" /usr/bin/install: cannot change permissions of ...
2
votes
0answers
402 views

Is it possible to get PdfEdit running on Ubuntu 12.10 using qt3to4? [duplicate]

PdfEdit is pretty much the only FOSS low-level PDF-editing tool out there. It's pretty useful, and pretty recent since it's updated in 2012. However, it's a shame that packages are nowhere to be ...
2
votes
1answer
156 views

How do I make my application startable from the terminal?

I've created several Python applications wherefore I know how to create a DEB and how to push an application into my PPA in Launchpad. What I never found out is how to make the application startable ...
1
vote
1answer
1k views

Issues with importing existing source C++ code in Eclipse CDT

I have cloned an emulator's source code from git, and would like to work on it on Eclipse CDT on my Ubuntu 12.04. I have tried different ways, such as creating a hello world project, and simply ...
1
vote
0answers
374 views

WARNING: 'automake-1.11' is probably too old [closed]

I am trying to install a package. When doing make command, I got an error as: make[5]: Entering directory ...
1
vote
1answer
3k views

Makefile:448: *** missing separator. Stop. error

The tutorial I am following is the automake hello world. I am compiling a code using GTK+2 and C language hp@ubuntu:~/amhello$ autoreconf --install configure.ac:2: installing `./install-sh' ...
1
vote
1answer
197 views

`make install` fails apparently due to typo, but not in makefile: How to find and fix?

I'm trying to install the fujitsu-usb-touchscreen drivers from here, on Kubuntu 12.04 on my new Fujitsu LifeBook P1630. (See fujitsu-usb-touchscreen on kubuntu 13.04 (64-bit) on P1630: `make` errors.) ...
1
vote
1answer
778 views

fujitsu-usb-touchscreen on kubuntu 13.04 (64-bit) on P1630: `make` errors

I installed Kubuntu 13.04 (64-bit) on my new Fujitsu LifeBook P1630, and added just a few packages: First aptitude, then I did aptitude update && safe-upgrade, then xinput-calibrator (which ...
1
vote
3answers
1k views

Error while installing tiff-4.0.3

I get the following errors while installing tiff-4.0.3: pranav@pranav-Inspiron-1545:~$ cd dependency/ pranav@pranav-Inspiron-1545:~/dependency$ tar -xvf libtiff4-3.6.0-5.tar.bz2 usr/bin/cygtiff4.dll ...
1
vote
1answer
2k views

How to install Hercules Webcam Deluxe

I am trying to install a Hercules Webcam Deluxe on my Ubuntu 11.10 (64 bits). I followed this guide: https://help.ubuntu.com/community/Ov51x Step by step, only changing wget ...
0
votes
1answer
122 views

Make external display resolution auto set

everytime i connect to external display i have to type these commands to set optimum resolution: $ xrandr --newmode "1368x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync $ ...
0
votes
0answers
236 views

Problems getting 5.1 Audio support over Optical Out (make not completing as expected)

after some time figuring out what's wrong with my HDMI audio I've switched to optical out which seems to have fixed the stuttering I was getting in games. Now I am having problems getting 5.1 audio ...
0
votes
1answer
287 views

Problem building an rtl8723 driver

We all know the problems with RTL8723 wireless card and some people achieved to install but i can't. I have Ubuntu 12.10. When I do the make in terminal, it gives me this error make -C ...
0
votes
1answer
597 views

Header files missing

I'm trying to compile a source code and I'm getting many errors indicating that header files are missing from my system checking sys/ioccom.h usability... no checking sys/ioccom.h presence... no ...
0
votes
2answers
5k views

how to build dogecoin CLI wallet

I'm trying to install dogecoin wallet, which depends on: Library Purpose Description ------- ------- ----------- libssl SSL Support Secure communications libdb4.8 Berkeley DB Blockchain & ...
0
votes
1answer
1k views

Compiling rtl8188ee driver fails

I am trying to compile and install the proprietary driver for my RTL8188ee Wireless card. Using make in the download directory ...
0
votes
1answer
1k views

where or how to compile or download libzdb-devel

I'm trying to compile the development library for libzdb, because dbmail requires this dev package to compile. While I've downloaded and compiled the package from libzdb, this is just the regular ...
-1
votes
1answer
991 views

How do I compile lbflow 1.1?

After using "sh ./configure" command, I encountered another error during lbflow package installation (a scientific one). The sequence of operations is here with error: ./configure --disable-gts ...