Metal as a Service – MAAS – lets you treat physical servers like virtual machines in the cloud. Rather than having to manage each server individually, MAAS turns your bare metal into an elastic cloud-like resource.

learn more… | top users | synonyms

3
votes
0answers
41 views

How do I make juju request machines and provision them in parallel?

I provision about 40 machines using MAAS and juju. The script I use is below (it has the same problem is I turn --debug off): juju bootstrap -e maas --debug --upload-tools=true --metadata- source="~/...
3
votes
0answers
49 views

crm status failing to work after adding remote node

My setup: 1. Ubuntu 14.04.4 LTS 2. Kilo Release (2015.1.3) 3. pacemaker: 1.1.10+git20130802-1ubuntu2.3 4. pacemaker-cli-utils: 1.1.10+git20130802-1ubuntu2.3 5. corosync: 2.3.3-1ubuntu2 6. libcorosync-...
3
votes
0answers
67 views

Cannot Deploy Charms from Charm Store

Ran into a strange problem, on juju 1.24.2-utopic-amd64 and 1.7.0+bzr3299-0ubuntu1~utopic, when trying to deploy a charm to a node, e.g. juju deploy --config ./kilo.yaml nova-compute nova-compute-01 -...
3
votes
0answers
188 views

Wordpress deployed with JUJU using LXC fail

When I deploy the wordpress and mysql charms with juju on my maas controller like so: juju deploy --to lxc:0 wordpress juju deploy --to lxc:0 mysql juju add-relation wordpress:db mysql:db --debug ...
3
votes
0answers
476 views

JUJU Error “ERROR failed to bootstrap environment: waited for 10m0s without being able to connect: ”

Having a bit of a struggle with bootstrapping Juju using juju-quickstart -i With two separate ubuntu clusters, we are having the same exact error (displayed below). I've confirmed I can SSH to ...
3
votes
0answers
620 views

openstack-install Can't import Boot Images

Trying openstack-install, http://www.ubuntu.com/download/cloud/install-ubuntu-openstack, on a Trusty server - hoping to get Openstack Juno going - but having problems with importing images. Install ...
3
votes
0answers
613 views

Juju bootstrap node can't access Ubuntu archives via MAAS

I am trying to install MAAS and Juju on VirtualBox. The network configuration of VirtualBox is set to NAT Network. Everything is just fine. I am able to PXE boot. But when I start juju bootstrap, ...
3
votes
0answers
188 views

Maas out of sync with lshw

I created a maas tag with $ maas-cli maas tags new name='5-disks' comment='A machine that has at least 5 hard disks' definition='count(//node[starts-with(@id,"disk") and @class="disk"]) >= 5' ...
2
votes
0answers
47 views

MaaS fails commisioning node

After having setup MaaS (DHCP configured), I am able to PXE boot a node but get a lot of warnings like "Temporary failure to resolve proxy" with Xenial after it reaches its login screen. Then it shuts ...
2
votes
0answers
87 views

Juju bootstrap wrong Maas API

Ubuntu 16.04 Maas 2.0.0 (beta3+bzr4941) Juju 2.0beta7 While attempting to bootstrap to an arbitrary MaaS node, Juju tries to access Maas api version 1.0 which does not exist. 2016-05-30 19:16:49 ...
2
votes
0answers
51 views

Apple Mac Pro as part of a MaaS Cluster?

Has anyone tried putting a Apple Mac Pro in a MaaS cluster. Basically we have a internal cluster for development builds, continuous integration, automated testing etc. We need to support Linux, ...
2
votes
0answers
68 views

Does services like Trove, Ceilometer et cetera come with Ubuntu Openstack Autopilot?

1. Since there is limited information(yes) about the current and updated status of ubuntu openstack autopilot on your website, i will like to find out if all services of openstack will come with ...
2
votes
0answers
123 views

How to deploy ramdisk image on to disk less nodes using MAAS?

I am using MAAS version 1.7.6 with ubuntu 14.04. Currently MAAS can deploy ubuntu/centos images on to the nodes by installing into local disk. I want to deploy my disk less nodes with ramdisk image. ...
2
votes
0answers
20 views

Ceph cannot reformat because disk is mounted

I am using MaaS 1.8, trying to use the juju-deployer with juju-deployer -c config.yaml -d vivid-kilo -e envName Here is my config. http://pastebin.com/TsvdnSKA Here is the error output: http://...
2
votes
0answers
254 views

Canonical openstack deployment, an issue with JuJU

I'm deploying canonical openstack in my lab environment on following topology: -------------- MAAS + DHCP VM -------------- |-Switch-| |_ Server 1 |_ Server 2 |_ Server ...
2
votes
0answers
51 views

Bringing up interfaces on ceph nodes

I have machines under MAAS with 4 interfaces. I want to configure my ceph nodes to use two networks that are not the pxe boot network. MAAS doesn't "up" all of the interfaces when a machine is ...
2
votes
0answers
213 views

Juju incomplete Neutron installation

We have installed Openstack on distributed nodes using Juju + MAAS. Everything looks good, but Neutron cli is unresponsive. user@controller:~$ nova list +----+------+--------+------------+------------...
2
votes
0answers
191 views

How to configure /etc/maas/maas-proxy.conf?

is there someone who could help me to set properly MAAS to use a proxy ? there is a proxy in between MAAS and the internet, How to point MAAS to a different proxy and tell maas-proxy to use an ...
2
votes
0answers
169 views

Adding network to machine deployed by Juju

I have a small OpenStack cluster deployed with Juju/MAAS. How can I add an extra network to one of the already deployed machines? Because the cluster is operational I would like to avoid redeploying ...
2
votes
0answers
95 views

Strange behaviour observed on Ubuntu MAAS Juju server

Sorry for the wall of text. I have observed some pretty strange behaviour in Juju and our Ubuntu MAAS OpenStack over the last couple of weeks, seemingly totally out of the blue (I was out of the ...
2
votes
0answers
447 views

Nova get-password returns empty string

I have a multi-host MaaS, Juju Openstack deployment. Each charm on different host, multiple nova-compute units (nodes). And Im using Quantum charm for networking. When I attempt to retrieve the admin ...
2
votes
0answers
76 views

Deploy ubuntu with MAAS fails

I have a problem with the Ubuntu deploying with MAAS. I'm trying to install Ubuntu on a KVM virtual machine. The boot with pxe works, I see the login prompt during the deploying, the server connect ...
2
votes
0answers
2k views

With MAAS set to manage DNS on a subnet on a private IP range, why do only some nodes have DNS entries?

I'm trying to set up OpenStack on MAAS, using trusty. I have a network between these machines all bridged/switched together. I have set up MAAS at 192.168.7.200, I have a Juju client machine at 192....
2
votes
0answers
338 views

MaaS dhcp cannot be detected at node installation

I am installing a MaaS Ubuntu 12.04 by ISO with virtualbox as the host machine. I have a problem on the cluster management during the process of adding the node. The node cannot detect the dhcp ...
2
votes
0answers
110 views

Infiniband + Maas?

I'm looking at setting up an HPC based on Mellanox Infiniband rather than Ethernet. Because I have many nodes to manage, I was looking at trying something new, like MAAS. I know Infiniband cards ...
2
votes
0answers
1k views

MAAS with external DHCP TFTP time out

I'm trying to get MAAS up and running, and I've installed the control node without maas-dhcp or maas-dns since I already have another DHCP server. I've set up the next-server attribute in my DHCP ...
1
vote
0answers
10 views

Commissioning VMware machines not visible in MAAS using Autopilot VMware Appliance Setup

I'm trying Openstack Autopilot VMware Appliance Setup on vSphere and Workstation. After running autopilot-config it looks like everything is OK and I get an INFO message that VMware machines are ...
1
vote
0answers
12 views

MAAS 2.0.0 - Extra Data when adding subnet

I've seen this error on another post here, but can't comment on it. The error I'm getting when trying to add a subnet is "Extra data: line 1 column 6 (char 5)". I've attempted multiple ways to put ...
1
vote
0answers
16 views

Cannot add SSH key to MaaS

I have install Ubuntu 16.04, kernel 4.4.0-24-generic. As MaaS I have generate SSH keys using ssh-keygen -t rsa I hit enter for no passphrase I have typed more ~/.ssh/id_rsa.pub to get the key I have ...
1
vote
0answers
9 views

Force JUJU to not remove Machine after removing all charms

Why juju remove machine after removing all charms? How can I force juju to not remove machine when I remove all charms from that machine?
1
vote
0answers
25 views

Cannot get disk parameters after deployment the node

I deploy the maaS node manually. When the status turned to be deployed, I start the machine again. However it says: "cannot get disk parameters" Could anyone told me what is the possible problems ...
1
vote
0answers
22 views

Deploying node in maas error

I deploy the node after they are commissioned, it is failed. The screen prints out a lot of messages, repeatedly says cannot create symlink to/usr/share/ca-certifcates/mozilla/...
1
vote
0answers
18 views

juju-gui Access through local network not private network

How can I provide access to juju-gui through public local network not private MAAS network?
1
vote
0answers
67 views

openstack autopilot deployed new machine with juju not showing in horizon dashboard

I added new machine in MAAS and deployed it in juju by using the following command: mrau1@mrau1$ juju ssh landscape-server/0 sudo 'JUJU_HOME=/var/lib/landscape/juju-homes/`sudo ls -rt /var/lib/...
1
vote
0answers
25 views

MAAS: new host's IP changes after commissioning, but config files keep original IP

So, I've got a region controller, and two cluster controllers. (All separate machines.) Cluster #1 -- the local cluster, on a 172.23.x.0/23 subnet -- works great. The remote cluster, on 10.2.0.x/16,...
1
vote
0answers
40 views

Openstack installer Autopilot failing at juju bootstrap

I have a MAAS node already deployed using juju bootstrap --upgrade tools option and when I run sudo openstack-install and select option Autopilot. It appears it is timing out for entropy.ubuntu.com. ...
1
vote
0answers
14 views

Juju node is eating up a lot of memory

my Juju node is consuming more than 90% of its RAM. $ free -m total used free shared buffers cached Mem: 3953 3843 109 0 131 ...
1
vote
0answers
25 views

Hardware upgrades/reconfiguration on Openstack nodes deployed with autopilot

I have a openstack deployed with autopilot. Now I need to do some hardware upgrades on one of my nodes(add RAM and HD). How can/should I do that, since recomissining the node would wipe it clean?
1
vote
0answers
31 views

bootstrap error in juju 1.25

Using juju 1.25 when I tried to bootstrap it hangs and gives error after waiting a long time: juju version 1.25.3-trusty-amd64 "Attempt 5 to download tools from https://streams.canonical.com/juju/...
1
vote
0answers
29 views

How do I know if OpenStack is installed on my device or not?

Following this link to install OpenStack, now that I've added the repository ans I got the first interface of selecting Multi, Single or Open Stack Autopilot mode. I selected Single and then enter the ...
1
vote
0answers
37 views

autopilot deploy fails at 99% - Configure availability zones

I'm having a difficult time with the autopilot deployment of openstack. I have set up a lab where I have a MAAS server with two network interfaces: one that is on my office private network of 10.x.x.x ...
1
vote
0answers
9 views

MAAS WebSocket Interface

MAAS seems to use a websocket connection to watch node state changes for the API. Is this interface documented? I have looked around a bit and found documentation on the REST API, but not the web ...
1
vote
0answers
123 views

Cannot load into OS after install Ubuntu 15.10 with MAAS

After install Ubuntu Server 15.10 with "Multiple server install with MAAS" selection from the ISO, I cannot load into the Ubuntu linux OS after my server detected to boot from the harddisk. The screen ...
1
vote
0answers
124 views

Issue with MAAS commissioning in lab. Internet not working?

The setup. Stock Ubuntu 14.03 LTS install with MAAS from the CD installed in a kvm virtual machine. I selected the MAAS install on the boot prompt. Then ran update and upgrade. The MAAS server as 4G ...
1
vote
0answers
153 views

MAAS node deployment failed with curtin installer

I have installed Ubuntu Server 15.10 with MAAS & have configured two nodes with the MAAS Server. The nodes reached to Ready State after commissioning. Then I run "juju bootstrap" on shell. One ...
1
vote
0answers
54 views

Landscape Deployment slow download causes timeout

I've been troubleshooting deployment timeouts all day and I finally narrowed it down I'm getting about average 100kb/s download speed from the cloud images repository. I've verified that it is not my ...
1
vote
0answers
147 views

MAAS KVM nodes commission timesout

So, I have set up MAAS and several KVM and Qemu VMs. When I add them as nodes, they start up during commissioning but then the attempt times out. Here's the line from the MAAS log: [ERROR] test: ...
1
vote
0answers
98 views

MAAS issue with IPMI

I am trying to enroll 4 Dell R720 Servers that utilize IPMI in the IDRAC. I am able to enroll two of them without issue and they commission without error. The other two which are set up the same ...
1
vote
0answers
39 views

MAAS mirrored regions

I've started setting up a MAAS environment. The basic configuration is pretty straightforward so far except it doesn't seem like mirroring is an option. Rather it looks like the region controller ...
1
vote
0answers
56 views

Landscape installer stalls after bootstrapping first node. SSh works from MAAS but seems to be doing nothing

Maas: 1.9.0 Juju: 1.24.7-trusty-amd64 I imported 3 machines into maas with 2 Nics and 3 Disks each and commissioned them. I then chose the services of openstack to deply and started the region ...