Metal as a Service – MAAS – lets you treat physical servers like virtual machines in the cloud. Rather than having to manage each server individually, MAAS turns your bare metal into an elastic cloud-like resource.

learn more… | top users | synonyms

0
votes
1answer
8 views

Failed commissioning because of false power on error

OS: UBUNTU 16.4 MAAS: 2.0.0 Beta 3 I Added new node to MAAS After commissioning it gets Failed commissioning and says under node Latest machine events: Failed to power on node - Node could not be ...
0
votes
0answers
7 views

MAAS new Node Network and Storage error

OS: UBUNTU 16.04 MAAS: 2.0.0. Beta 3 I added one node it shows up as new , both network adopter connectet to network(One internal and one exteral), When I am looking at node pages on MAAS GUI, it ...
0
votes
0answers
10 views

Is Autopilot Openstack 16.04 available?

I tried to build an openstack deployment from scratch starting with 7 physical servers and Ubuntu 16.04. I've had no issues using 14.04 on the same setup. After the initial setup in MAAS 2.0 beta3 ...
1
vote
1answer
50 views

Connection timeout to streams.canonical.com when installing juju

The .cloud-install/commands.log file shows this error: Attempt 5 to download tools from https://streams.canonical.com/juju/tools/agent/1.25.3/juju-1.25.3-trusty-amd64.tgz... curl: (7) Failed to ...
0
votes
0answers
24 views

MAAS 2.0 and Ubuntu 16.04 Node Enlist get connection error to Internet behind a NAT

OS: UBUNTU 16.04 MAAS : 2.0.0 beta 3 1 Node as region/rack controller 2 Nodes Nodes are behind proxy I defined NAT on my region/rack controller i defined proxy on MAAS GUI When nodes try to boot ...
0
votes
1answer
18 views

How change Gateway of subnet ( private network, Internal) on MAAS

Ubuntu : 16.04 MAAS: 2.0.0 beta 3 I need to change the gateway address of my subnet( private lAN,Internal which is 192.168.120.1) to ip address of my region/rack controller( internal ip ...
0
votes
1answer
13 views

How I can set MAAS to download boot-image for nodes from local storage not internet

OS: ubuntu 16.05 MAAS : 2.0.0 beta 3 There is boot-image setting for nodes in MAAS settion GUI, how can I use local storage for downloading the boot-image for Nodes through PXE booting and ...
0
votes
1answer
13 views

which file contains network configuration for MAAS?

Ubuntu : 16.04 MAAS: 2.0.0 beta 3 Which file contains network configuration for MAAS?
0
votes
1answer
18 views

MAAS virbr0 interface created

MAAS server had two interfaces eth0 external net and eth1 internal (for pxe boot). Somehow I am seeing a virbr0 under interfaces and an IP assigned to it. Not sure where that interface and its IP came ...
0
votes
2answers
24 views

Booting under MAAS direction error: File not found

I am PXE boot a node .... PXE IPV4 starts and then i get the error Booting under MAAS direction error: File not found I have downloaded a 14.04 image and Cluster Master is connected, Status Enabled ...
0
votes
2answers
64 views

MAAS 1.9.1 PXE boot looking for Xenial image but i have trusty

MAAS 1.9.1 .....I deployed couple of nodes in MAAS and deployment went fine with 14.04 trusty image.....On my third node commissioning at PXE boot it start to look for Xenial image and failing with ...
0
votes
0answers
15 views

juju bootstrap failing

I have MAAS 1.9.1 and commissioned a node...the node is in ready state..i am behind proxy and can apt get or update ...There two interface on MAAS eth0 is on 170.x.x.x and eth 1 is on 10.x.x.x ... I ...
0
votes
1answer
19 views

Problems with Maas and LVM's across mutiple drives

I'm trying to use ubuntu 14.04 MAAS to provision a system and am having some issues. The end goal I am after is: 1 x 64Gb SSD with a boot partition, a root partition, an lxc partition and a swap ...
0
votes
1answer
17 views

MAAS 1.9.1 GUI Link interface

I have two interfaces on MAAS 1.9.1 eth0 - External Network eth1 - Private/Internal Network ie 10.x.x.x with DHCP/DNS configured I have MAAS GUI configured to access over eth0 ie ...
0
votes
0answers
17 views

MAAS wrong Image location when PXE boot

As per regiond.log It looks like that when i PXE boot ....MAAS trying to go to wrong image location and thus failing......which file can i update for MAAS to get the image from correct ...
0
votes
2answers
391 views

Failed to bootstrap during Openstack autopilot installation

I'm installing Openstack autopilot on Ubuntu 15.04 server. I've installed Maas and join nodes successfully. I tested Maas connection by installing juju and deploying service. but when I want to ...
0
votes
2answers
53 views

MAAS unable to to keep Node details under MAAS nodes

Ubuntu 14.04.4 --- MAAS 1.9.1+bzr4543-0ubuntu1 (trusty1) I have a Machine that PXE Boot and getting the console messages below Start PXE over IPV4 Booting under MAAS direction .......... ....Bunch ...
0
votes
2answers
86 views

Deploy MAAS, Juju, Openstack

I have look in to dozens on online document but none give me the exact steps and recommendation for deploying MAAS, Juju and OpenStack on Ubuntu. There's plenty of documentation available but none ...
0
votes
1answer
24 views

MAAS 1.9.1 GUI Taskbar missing Network TAB on Ubuntu 14.04.4

I deployed MAAS 1.9.1 on Ubuntu 14.04.4 but all the install guides showing MASS GUI having Network Tab ie Nodes-Cluster-Images-Zones-Network-Settings but i am seeing the GUI Taskbar option below ...
0
votes
1answer
50 views

MAAS 2.0. Importing custom images does not work?

How should I import custom images to MAAS 2.0.0~beta2+bzr4920 in Ubuntu 16.04 LTS Beta2? The command I successfully used in 1.9 is uploading an image without errors: $ maas local boot-resources ...
0
votes
1answer
59 views

MAAS “Failed deployment” on node with 16.04 LTS

We have a node with commodity hardware (Dell r620). I can successfully deploy Ubuntu 14.04 LTS and 15.04. When I attempt to deploy 16.04 LTS MAAS eventually returned "Failed deployment". INFO ...
1
vote
1answer
1k views

Can't get MAAS nodes to enlist

I'm having an issue very similar to this: MAAS add node failing I've been banging my head against the wall for days. I'm running VMWare ESXi 5.5 and Ubuntu 14.04.1. I have a maas controller setup ...
0
votes
2answers
29 views

Understand the differences between two network configurations for MAAS

I am trying to understand the differences between two network configurations for MAAS. My understanding is that the both achieve the same tasks where the first network connects to the internet and the ...
0
votes
2answers
160 views

Downloading packages from Ubuntu local package mirror during Ubuntu 14.04LTS server installation

During Ubuntu 14.04LTS server installation using MAAS, some packages are downloaded from Ubuntu mirrors. Is there a way of installing Ubuntu using MAAS in an environment without internet connection ...
0
votes
1answer
26 views

Juju bootstrap fails with dns resolution issues

I am building a proof of concept install using old hardware and the AutoPilot install which is using Liberty. I finally managed to get the physical servers to commission in MAAS and commenced the ...
0
votes
2answers
33 views

juju no route to host

I have set up a system as described below. A server connected to the internet(192.168.16.250) and also to a switch(10.1.1.100). I have nat configured on the switch facing interface and can access the ...
0
votes
1answer
169 views

MAAS interface eth0 (External) and eth1 (internal)

I have two interfaces configured in MAAS under Cluster eth0 - external IP VLAN 10 eth1 - internal (10.x.x.x) VLAN 20 - DHCP-DNS Managed I am going to add a node in MAAS.....I have setup the node ...
0
votes
1answer
33 views

MAAS 1.9 can't deploy OS

I recently upgraded my MAAS server and found myself with MAAS 1.9.1+bzr4543-0ubuntu1. I saw that the old version of MAAS that I had been running was no longer supported, so no great loss there. ...
-1
votes
1answer
8 views

Ubuntu Autopilot Openstack Dashboard inaccessible

After a successful Autopilot install, I had to recommission nodes in order to reenable ssh. Since then, the Openstack Dashboard is offline. The once reachable IP Address for the dashboard is now not ...
0
votes
0answers
48 views

OpenStack Autopilot fails to deploy Landscape with “public/private no address” warnings

After installing MaaS 1.9.1 and Juju 1.25.5 on Ubuntu 14.04.4 and successfully commissioning and deploying nodes and charms I then moved onto Openstack Installer 0.99.28 and chose the "Landscape ...
0
votes
2answers
40 views

Ubuntu - Auto Pilot Open stack Deployment Guide

I have Ubuntu 14.04.4 Installed and wondering if there is a guide step by step with details and screenshots to deploy the components below MAAS-Landscape-OpenStack The guide available online is not ...
0
votes
1answer
32 views

OpenStack AutoPilot failing at 98%

I'm trying to deploy OpenStack using Landscape's Autopilot. I get no errors till the final steps but after reaching 98% of the install two tasks fail to completed. The two tasks that never reach ...
0
votes
1answer
22 views

Does MAAS Cluster Controller API URL need to setup to Internal Network and not LAN Network

MAAS 1.9 - Ubuntu 14.04.4 Wondering if the MAAS Cluster Controller API URL need to setup to Internal Network and not LAN Network..... My Internal network is 10.x.x.x on eth1 and not accessible from ...
0
votes
1answer
21 views

MaaS Node cant ping external servers

I have setup a MaaS server with eth0 going to the internet and eth1 an internal switch connecting the the MaaS nodes. I and can commission and deploy nodes on Trusty Ubuntu but those nodes can only ...
0
votes
1answer
16 views

'juju status -e maas --debug' showing connection refused

while trying to query status of an environment i am getting the following errors. juju status --debug 2016-03-31 09:44:05 DEBUG juju.api apiclient.go:337 error dialing ...
1
vote
1answer
33 views

MaaS Hyper-v Power Type

I have a Hyper-V 2012 R2 Host that has Ubuntu 14.04 running MaaS 1.9.1 as a Guest VM. This has works well until I need to commission a virtual node as it requires a Power Type to be used to turn on ...
3
votes
0answers
27 views

crm status failing to work after adding remote node

My setup: 1. Ubuntu 14.04.4 LTS 2. Kilo Release (2015.1.3) 3. pacemaker: 1.1.10+git20130802-1ubuntu2.3 4. pacemaker-cli-utils: 1.1.10+git20130802-1ubuntu2.3 5. corosync: 2.3.3-1ubuntu2 6. ...
3
votes
1answer
47 views

Can you prevent Juju from destroying machines?

I've been experimenting with Juju and after I deploy a service to a node if I destroy it the node is released from Juju back into the MaaS pool. From the documentation it doesn't seem like this ...
1
vote
2answers
246 views

MAAS - PXE won't boot images

I'm currently trying to set up a maas/openstack environment for testing purpuses, but I've got problems with deploying the nodes. When I start the node that is connected to the private network of my ...
0
votes
0answers
9 views

Update-status hook duration

is there a way to set the interval for update-status hook? As per my observations, it runs after every 5 minutes.
0
votes
2answers
2k views

MAAS can't download boot images

On my MAAS Gui and "Images" I've got these errors Boot image import process not started. Nodes will not be able to provision without boot images. Visit the boot images page to start the import. ...
0
votes
1answer
34 views

Juju on Maas, Lxc container not deploying

I have the latest juju deployed on maas. I also deployed the gui with: juju deploy juju-gui --to 0 This seem to work fine. But when I deploy an lxc container on that machine the conatiner stays in ...
0
votes
1answer
53 views

Will the first server be added as one of 5 nodes in OpenStack Autopilot?

1. After reading the documentation for setting up OpenStack Autopilot, I am instructed to install Ubuntu server on the first server. But after going to MAAS GUI to add the other nodes, I don't know ...
8
votes
2answers
127 views

Can I manage ZFS with Landscape and MAAS?

I have 5 different servers. I am very interested in installing ZFS across all of them. I also am interested in using JuJu, MAAS, and Landscape to automate the installation of ZFS, and the management ...
1
vote
0answers
12 views

Juju node is eating up a lot of memory

my Juju node is consuming more than 90% of its RAM. $ free -m total used free shared buffers cached Mem: 3953 3843 109 0 131 ...
1
vote
0answers
13 views

Hardware upgrades/reconfiguration on Openstack nodes deployed with autopilot

I have a openstack deployed with autopilot. Now I need to do some hardware upgrades on one of my nodes(add RAM and HD). How can/should I do that, since recomissining the node would wipe it clean?
0
votes
0answers
33 views

Only 3 Hypervisors available with HA deployment - Openstack - Autopilot

I have "successfully" deployed Openstack with Autopilot, I have 6 nodes and have HA configured. My understanding was that it should be deployed with compute and storage everywhere. But when I do a ...
2
votes
2answers
470 views

Why install OpenStack [closed]

I am trying to understand why someone would need OpenStack when MAAS and Juju are available. I know that MAAS abstracts the machines in order to use them as resources and Juju allows to install ...
0
votes
0answers
44 views

Open Stack nodes shutdown automatically

I want to install OpenStack AutoPilot on VMware (for test). so, I download test driver version .OVA and deploy open satck autopilot and 3 nodes (node-1,node-2,node-3). these VMs connected to the same ...
-1
votes
0answers
8 views

How to change the maas region controller

Is there any way to replace an maas "all-in-one" cluster/region controller with a new server, without need to reinstall the system in the deployed nodes? I mean, my all-in-one server failed, and now ...