Metal as a Service – MAAS – lets you treat physical servers like virtual machines in the cloud. Rather than having to manage each server individually, MAAS turns your bare metal into an elastic cloud-like resource.

learn more… | top users | synonyms

0
votes
0answers
62 views

MAAS Node commissioning I get a lots of“Ignored relative path” and “Error retrieving chunk extents: Operation not supported”

UBUNTU 16.04 MAAS 2.0.0 Beta 3 Nodes get faild comissioning when I looked at node logs: /var/log/maas/rsyslog//.../messages 1) it has a lots of "Ignored relative path" petroleous-arthur ...
0
votes
0answers
69 views

MAAS 1.9.1 No storage information. Commissioning this node will gather the storage information

MAAS 1.9.1 No storage information. Commissioning this node will gather the storage information. Also MAAS picking eth0 for PXE network but i have eth1 configured for PXE.....
0
votes
2answers
85 views

Failed commissioning because of false power on error

OS: UBUNTU 16.4 MAAS: 2.0.0 Beta 3 I Added new node to MAAS After commissioning it gets Failed commissioning and says under node Latest machine events: Failed to power on node - Node could not be ...
0
votes
1answer
140 views

MAAS new Node Network and Storage error

OS: UBUNTU 16.04 MAAS: 2.0.0. Beta 3 I added one node it shows up as new , both network adopter connectet to network(One internal and one exteral), When I am looking at node pages on MAAS GUI, it ...
0
votes
1answer
49 views

MAAS virbr0 interface created

MAAS server had two interfaces eth0 external net and eth1 internal (for pxe boot). Somehow I am seeing a virbr0 under interfaces and an IP assigned to it. Not sure where that interface and its IP came ...
0
votes
1answer
27 views

which file contains network configuration for MAAS?

Ubuntu : 16.04 MAAS: 2.0.0 beta 3 Which file contains network configuration for MAAS?
0
votes
1answer
129 views

How change Gateway of subnet ( private network, Internal) on MAAS

Ubuntu : 16.04 MAAS: 2.0.0 beta 3 I need to change the gateway address of my subnet( private lAN,Internal which is 192.168.120.1) to ip address of my region/rack controller( internal ip 192.168.120....
0
votes
1answer
37 views

How I can set MAAS to download boot-image for nodes from local storage not internet

OS: ubuntu 16.05 MAAS : 2.0.0 beta 3 There is boot-image setting for nodes in MAAS settion GUI, how can I use local storage for downloading the boot-image for Nodes through PXE booting and ...
0
votes
0answers
220 views

MAAS 2.0 and Ubuntu 16.04 Node Enlist get connection error to Internet behind a NAT

OS: UBUNTU 16.04 MAAS : 2.0.0 beta 3 1 Node as region/rack controller 2 Nodes Nodes are behind proxy I defined NAT on my region/rack controller i defined proxy on MAAS GUI When nodes try to boot ...
0
votes
3answers
216 views

juju bootstrap failing

I have MAAS 1.9.1 and commissioned a node. The node is in ready state. I am behind proxy and can apt get or update. There are two interface on MAAS eth0 is on 170.x.x.x and eth 1 is on 10.x.x.x. I ...
0
votes
0answers
26 views

Problems with Maas and LVM's across mutiple drives

I'm trying to use ubuntu 14.04 MAAS to provision a system and am having some issues. The end goal I am after is: 1 x 64Gb SSD with a boot partition, a root partition, an lxc partition and a swap ...
1
vote
2answers
231 views

MAAS 1.9.1 PXE boot looking for Xenial image but i have trusty

MAAS 1.9.1 .....I deployed couple of nodes in MAAS and deployment went fine with 14.04 trusty image.....On my third node commissioning at PXE boot it start to look for Xenial image and failing with ...
0
votes
0answers
22 views

MAAS wrong Image location when PXE boot

As per regiond.log It looks like that when i PXE boot ....MAAS trying to go to wrong image location and thus failing......which file can i update for MAAS to get the image from correct location.........
2
votes
1answer
41 views

MAAS 1.9.1 GUI Link interface

I have two interfaces on MAAS 1.9.1 eth0 - External Network eth1 - Private/Internal Network ie 10.x.x.x with DHCP/DNS configured I have MAAS GUI configured to access over eth0 ie http://192.168.1.45/...
1
vote
2answers
68 views

Booting under MAAS direction error: File not found

I am PXE boot a node .... PXE IPV4 starts and then i get the error Booting under MAAS direction error: File not found I have downloaded a 14.04 image and Cluster Master is connected, Status Enabled ...
0
votes
2answers
83 views

MAAS unable to to keep Node details under MAAS nodes

Ubuntu 14.04.4 --- MAAS 1.9.1+bzr4543-0ubuntu1 (trusty1) I have a Machine that PXE Boot and getting the console messages below Start PXE over IPV4 Booting under MAAS direction .......... ....Bunch ...
0
votes
1answer
181 views

MAAS “Failed deployment” on node with 16.04 LTS

We have a node with commodity hardware (Dell r620). I can successfully deploy Ubuntu 14.04 LTS and 15.04. When I attempt to deploy 16.04 LTS MAAS eventually returned "Failed deployment". INFO ...
0
votes
1answer
165 views

MAAS 2.0. Importing custom images does not work?

How should I import custom images to MAAS 2.0.0~beta2+bzr4920 in Ubuntu 16.04 LTS Beta2? The command I successfully used in 1.9 is uploading an image without errors: $ maas local boot-resources ...
0
votes
2answers
1k views

Downloading packages from Ubuntu local package mirror during Ubuntu 14.04LTS server installation

During Ubuntu 14.04LTS server installation using MAAS, some packages are downloaded from Ubuntu mirrors. Is there a way of installing Ubuntu using MAAS in an environment without internet connection i....
0
votes
2answers
191 views

Deploy MAAS, Juju, Openstack

I have look in to dozens on online document but none give me the exact steps and recommendation for deploying MAAS, Juju and OpenStack on Ubuntu. There's plenty of documentation available but none ...
0
votes
2answers
49 views

Understand the differences between two network configurations for MAAS

I am trying to understand the differences between two network configurations for MAAS. My understanding is that the both achieve the same tasks where the first network connects to the internet and the ...
-1
votes
1answer
12 views

Ubuntu Autopilot Openstack Dashboard inaccessible

After a successful Autopilot install, I had to recommission nodes in order to reenable ssh. Since then, the Openstack Dashboard is offline. The once reachable IP Address for the dashboard is now not ...
0
votes
2answers
67 views

MAAS 1.9 can't deploy OS

I recently upgraded my MAAS server and found myself with MAAS 1.9.1+bzr4543-0ubuntu1. I saw that the old version of MAAS that I had been running was no longer supported, so no great loss there. ...
0
votes
0answers
156 views

OpenStack Autopilot fails to deploy Landscape with “public/private no address” warnings

After installing MaaS 1.9.1 and Juju 1.25.5 on Ubuntu 14.04.4 and successfully commissioning and deploying nodes and charms I then moved onto Openstack Installer 0.99.28 and chose the "Landscape ...
0
votes
1answer
29 views

Does MAAS Cluster Controller API URL need to setup to Internal Network and not LAN Network

MAAS 1.9 - Ubuntu 14.04.4 Wondering if the MAAS Cluster Controller API URL need to setup to Internal Network and not LAN Network..... My Internal network is 10.x.x.x on eth1 and not accessible from ...
0
votes
1answer
2k views

MAAS interface eth0 (External) and eth1 (internal)

I have two interfaces configured in MAAS under Cluster eth0 - external IP VLAN 10 eth1 - internal (10.x.x.x) VLAN 20 - DHCP-DNS Managed I am going to add a node in MAAS.....I have setup the node (...
0
votes
2answers
80 views

Ubuntu - Auto Pilot Open stack Deployment Guide

I have Ubuntu 14.04.4 Installed and wondering if there is a guide step by step with details and screenshots to deploy the components below MAAS-Landscape-OpenStack The guide available online is not ...
0
votes
1answer
89 views

MAAS 1.9.1 GUI Taskbar missing Network TAB on Ubuntu 14.04.4

I deployed MAAS 1.9.1 on Ubuntu 14.04.4 but all the install guides showing MASS GUI having Network Tab ie Nodes-Cluster-Images-Zones-Network-Settings but i am seeing the GUI Taskbar option below ...
0
votes
1answer
52 views

MaaS Node cant ping external servers

I have setup a MaaS server with eth0 going to the internet and eth1 an internal switch connecting the the MaaS nodes. I and can commission and deploy nodes on Trusty Ubuntu but those nodes can only ...
0
votes
1answer
34 views

Juju bootstrap fails with dns resolution issues

I am building a proof of concept install using old hardware and the AutoPilot install which is using Liberty. I finally managed to get the physical servers to commission in MAAS and commenced the ...
3
votes
0answers
51 views

crm status failing to work after adding remote node

My setup: 1. Ubuntu 14.04.4 LTS 2. Kilo Release (2015.1.3) 3. pacemaker: 1.1.10+git20130802-1ubuntu2.3 4. pacemaker-cli-utils: 1.1.10+git20130802-1ubuntu2.3 5. corosync: 2.3.3-1ubuntu2 6. libcorosync-...
1
vote
1answer
85 views

MaaS Hyper-v Power Type

I have a Hyper-V 2012 R2 Host that has Ubuntu 14.04 running MaaS 1.9.1 as a Guest VM. This has works well until I need to commission a virtual node as it requires a Power Type to be used to turn on ...
0
votes
1answer
51 views

OpenStack AutoPilot failing at 98%

I'm trying to deploy OpenStack using Landscape's Autopilot. I get no errors till the final steps but after reaching 98% of the install two tasks fail to completed. The two tasks that never reach ...
0
votes
1answer
141 views

Will the first server be added as one of 5 nodes in OpenStack Autopilot?

1. After reading the documentation for setting up OpenStack Autopilot, I am instructed to install Ubuntu server on the first server. But after going to MAAS GUI to add the other nodes, I don't know ...
1
vote
2answers
57 views

juju no route to host

I have set up a system as described below. A server connected to the internet(192.168.16.250) and also to a switch(10.1.1.100). I have nat configured on the switch facing interface and can access the ...
1
vote
0answers
14 views

Juju node is eating up a lot of memory

my Juju node is consuming more than 90% of its RAM. $ free -m total used free shared buffers cached Mem: 3953 3843 109 0 131 ...
1
vote
0answers
26 views

Hardware upgrades/reconfiguration on Openstack nodes deployed with autopilot

I have a openstack deployed with autopilot. Now I need to do some hardware upgrades on one of my nodes(add RAM and HD). How can/should I do that, since recomissining the node would wipe it clean?
0
votes
0answers
46 views

Only 3 Hypervisors available with HA deployment - Openstack - Autopilot

I have "successfully" deployed Openstack with Autopilot, I have 6 nodes and have HA configured. My understanding was that it should be deployed with compute and storage everywhere. But when I do a ...
2
votes
0answers
56 views

Apple Mac Pro as part of a MaaS Cluster?

Has anyone tried putting a Apple Mac Pro in a MaaS cluster. Basically we have a internal cluster for development builds, continuous integration, automated testing etc. We need to support Linux, ...
0
votes
1answer
29 views

'juju status -e maas --debug' showing connection refused

while trying to query status of an environment i am getting the following errors. juju status --debug 2016-03-31 09:44:05 DEBUG juju.api apiclient.go:337 error dialing "wss://10.1.0.11:17070/...
1
vote
0answers
35 views

bootstrap error in juju 1.25

Using juju 1.25 when I tried to bootstrap it hangs and gives error after waiting a long time: juju version 1.25.3-trusty-amd64 "Attempt 5 to download tools from https://streams.canonical.com/juju/...
0
votes
1answer
98 views

“One cluster is not yet connected to the region” after install ubuntu server?

Today was my first install of an MAAS server. So as you can guess I am new to whole concept ;) After using the MAAS option during install of ubuntu server install it worked really well. I installed ...
0
votes
0answers
48 views

Openstack scale without landscape?

So I am a VMware user for some time now and not very satisfied anymore (mainly, because of the number of functions that cost A LOT of money, that I simply can not pay). So I was looking around at the ...
0
votes
0answers
54 views

MAAS does not detect any nodes in cluster after PXE boot

I was wondering if anyone has seen this problem. I installed a brand new MAAS node (Ubuntu 14.04) and set it up with a ubuntu 14.04 image for PXE boot. Then I power cycles all the nodes and I can see ...
0
votes
1answer
117 views

In MAAS 1.9.1, what do I do to fix the error “Node must be connected to a network”?

Just upgraded to MAAS 1.9.1 from 1.8.something, and struggling with the networking setup. My MAAS nodes are on a subnet that already has a non-MAAS DHCP server. I don't want MAAS to manage or assign ...
1
vote
1answer
64 views

Connection timeout to streams.canonical.com when installing juju

The .cloud-install/commands.log file shows this error: Attempt 5 to download tools from https://streams.canonical.com/juju/tools/agent/1.25.3/juju-1.25.3-trusty-amd64.tgz... curl: (7) Failed to ...
0
votes
1answer
198 views

Using MAAS to deploy ubuntu 14.04 on HP DL380 gen9

I'm new to MAAS and I'm having trouble installing ubuntu 14.04 on HP DL380 gen9 server, I'm using latest MAAS version(1.9) and so far I was able to enlist the node after the curtin installation on ...
0
votes
0answers
42 views

Openstack Deployment

These might be basic questions but they will help all the beginners to clear their concepts. So detailed answers would be really appreciated. If we have 4 nodes how we can distribute the components ...
0
votes
0answers
28 views

MaaS not finding vm disks during commissoning

I have seen in previos versions where bugs were filed about using kvm guests leaves the disk section empty but I am unable to figure out what to change to allow it to find the disks. I am needing to ...
1
vote
1answer
358 views

How do you install the MAAS Image Builder on 14.04 LTS

I have followed the instructions here: https://maas.ubuntu.com/docs/os-support.html#generated-images-vs-custom-images After running these commands: sudo apt-add-repository ppa:maas-maintainers/...