Metal as a Service – MAAS – lets you treat physical servers like virtual machines in the cloud. Rather than having to manage each server individually, MAAS turns your bare metal into an elastic cloud-like resource.

learn more… | top users | synonyms

0
votes
0answers
12 views

Running openstack-install with MAAS and Juju - Keystone errors while “waiting for deployed services to be in a ready state”

I'm trying to deploy OpenStack (Liberty) to my machines using the openstack-installer's multi option on an Ubuntu 14.04 machine, but I'm not having a lot of success. As far as I can tell, MAAS 1.9.3 ...
1
vote
0answers
13 views

Cannot add SSH key to MaaS

I have install Ubuntu 16.04, kernel 4.4.0-24-generic. As MaaS I have generate SSH keys using ssh-keygen -t rsa I hit enter for no passphrase I have typed more ~/.ssh/id_rsa.pub to get the key I have ...
1
vote
0answers
8 views

Commissioning VMware machines not visible in MAAS using Autopilot VMware Appliance Setup

I'm trying Openstack Autopilot VMware Appliance Setup on vSphere and Workstation. After running autopilot-config it looks like everything is OK and I get an INFO message that VMware machines are ...
1
vote
0answers
10 views

MAAS 2.0.0 - Extra Data when adding subnet

I've seen this error on another post here, but can't comment on it. The error I'm getting when trying to add a subnet is "Extra data: line 1 column 6 (char 5)". I've attempted multiple ways to put ...
0
votes
0answers
7 views

cannot add nodes to MaaS 2.0

Using Cisco C240M3 servers Installed 16.04 on one server Installed MaaS Add new node using IPMI MaaS reboots the node, but node does not get added, it goes through a boot procedure and then stops at ...
1
vote
1answer
21 views

How to remotely power on nodes on maas 2.0

I wonder if anyone minds instructing me how to remotely power on a node on maas since on maas 2.0 wake-on-lan is no longer available on power type options you were able to choose from at the maas gui'...
0
votes
0answers
9 views

MAAS/Autopilot install enable console

In Autopilot install of Openstack I see that I don't have console enabled. Googled it and only found below as a solution. Thing is I don't have nova-cloud-controller installed at all using autopilot. ...
0
votes
0answers
19 views

MAAS Failed commissioning

Everyone , I'm receiving this error on my maas controller node: provisioningserver.drivers.hardware.virsh.VirshError: Unknown state: apagado all my machines have this status " Failed ...
3
votes
1answer
74 views

A step by step Openstack installation on Ubuntu tutorial

I am an IT Student doing a cloud related project and self learning about cloud technology. I am planning to build a private Cloud for my project, I have been searching for the openstack installation ...
1
vote
1answer
48 views

How to install openstack autopilot without JUJU & MAAS

I want to install the Openstack in a single node (one server) using the Ubuntu Autopilot , but I don't want install the JUJU and MAAS. Yes, I try the command in the link above: $ sudo apt-add-...
1
vote
1answer
33 views

Unable to nslookup deployed nodes on maas server

In the path toward establishment of an Openstack cloud I've already reach to the point that I must install juju and opensatck but the problem is a deployed node does not have access to the internet (...
0
votes
0answers
18 views

juju bootstrap failure while installing LDS package

Trying to juju bootstrap the Landscape Dedicated Serverand getting the error below. Proxy is set in bashrc with http,https,HTTP,HTTPS,no-proxy; I did try IP forwarding and masquerade, and MAAS Key ...
0
votes
1answer
57 views

node “Failed commissioning” on MAAS and hang on “[ OK ] Started Update UTMP about System Runlevel Changes.” shown on node console

I use vmware-openstack-autopilot to install MAAS and want to deploy its package. All nodes could not be switched from commissioning to ready state in the Web UI. They switched instead to "Failed ...
0
votes
0answers
239 views

MaaS problem with ESX 6.0 Power Check

i've a problem to power on/off virtual machine configured with vsphere 6.0 the Machine Node give me this error : Failed to query node's BMC - Power state could not be queried: vmware failed with ...
8
votes
3answers
140 views

Is there a way for MaaS to Commission a Raspberry Pi 3B?

I have a small lab (literally) of 3 RBP-3B units with SATA and SD drives attached running Ubuntu 16.04 LTS. I have installed software on them to create a Ceph cluster but its tricky and pretty ...
0
votes
0answers
19 views

Juju Bootstrap failed with timeout - which log will show me error?

I have Ubuntu 14.04 with Maas 1.9 configured with 1 node in ready status. I can deploy that node correctly directly with MaaS itself. However with juju bootstrap everything goes fine until last ...
1
vote
1answer
40 views

MaaS 2.0 - Reserve IP's

A new "feature" of MaaS 2.0 is that it assumes total control of a Subnet. But I desperately need to reserve some IP's on the subnet that are currently in use. How can I achieve this with MaaS 2.0? Or ...
2
votes
0answers
51 views

Apple Mac Pro as part of a MaaS Cluster?

Has anyone tried putting a Apple Mac Pro in a MaaS cluster. Basically we have a internal cluster for development builds, continuous integration, automated testing etc. We need to support Linux, ...
0
votes
1answer
14 views

Reset Unit ID or Machine ID in JUJU

How can we reset unit-id or machine-id? so when it tries to assign id it start form 1, not where it was left before?
0
votes
0answers
21 views

vm not listing in the maas

I got an issue with the maas. My newly created node is not listing in the maas. This node is created using "virt-install" and boot is PXE boot. MAAS Version 1.9.3+bzr4577-0ubuntu1 (trusty1) ...
0
votes
0answers
82 views

MAAS Deploying nodes hangs after SSH Key is shown

Everything was working fine, and then some configuration got changed that now has new nodes failing to finish being deployed. They get to the point where the SSH key is shown, with some Could_init ...
0
votes
0answers
45 views

can't install Openstack on Ubuntu server 16.04

I am trying to install Openstack on Ubuntu server, this command doesn't work on version 16.04 . Does any one face the same problem ? what is the resolution please? command: sudo openstack-install
1
vote
0answers
9 views

Force JUJU to not remove Machine after removing all charms

Why juju remove machine after removing all charms? How can I force juju to not remove machine when I remove all charms from that machine?
1
vote
0answers
66 views

openstack autopilot deployed new machine with juju not showing in horizon dashboard

I added new machine in MAAS and deployed it in juju by using the following command: mrau1@mrau1$ juju ssh landscape-server/0 sudo 'JUJU_HOME=/var/lib/landscape/juju-homes/`sudo ls -rt /var/lib/...
2
votes
0answers
84 views

Juju bootstrap wrong Maas API

Ubuntu 16.04 Maas 2.0.0 (beta3+bzr4941) Juju 2.0beta7 While attempting to bootstrap to an arbitrary MaaS node, Juju tries to access Maas api version 1.0 which does not exist. 2016-05-30 19:16:49 ...
3
votes
0answers
242 views

How to set bootstrap-timeout when deploying landscape-dense-maas from conjure-up on xenial [closed]

I'm currently following Juju 2.0 Bug# 1576003 which will hopefully make this problem obsolete. Until then... JuJu seems to cut-out before landscape deployment completes in a MaaS environment. In ...
0
votes
0answers
23 views

juju bootstrap gives 503 network error

I have the following environment: Ubuntu 16.04 MaaS 2.0 juju 2.0 I am able to deploy 1 node from MaaS gui. Now with juju 2.0: The only thing it allows me to do is first bootstrap, so here goes: I ...
1
vote
1answer
600 views

Openstack Autopilot fails while deploying Landscape

Update: More investigation shows that the LXC containers were not getting IPs during install. But if left for several hours the LXC containers do eventually get an IP from the MAAS. So this morning ...
1
vote
0answers
23 views

Cannot get disk parameters after deployment the node

I deploy the maaS node manually. When the status turned to be deployed, I start the machine again. However it says: "cannot get disk parameters" Could anyone told me what is the possible problems ...
0
votes
0answers
10 views

Redundant for MAAS Cluster and Region

How can I config MAAS Region and CLuster(Rack) for online redundancy and online backup. I need to have zero time recovery process even my MAAS lose its Region or Cluster Managers
1
vote
1answer
23 views

no more WakeOnLan on MaaS ver. 2 as Power Type

Anyone knows why the option WakeOnLan is not more present as Power Type on MaaS ?
1
vote
0answers
22 views

Deploying node in maas error

I deploy the node after they are commissioned, it is failed. The screen prints out a lot of messages, repeatedly says cannot create symlink to/usr/share/ca-certifcates/mozilla/...
0
votes
0answers
32 views

MaaS node failed deployment

I have commissioned four nodes under MaaS controller. Then I click on the deploy button on the MaaS web UI. It seems to be working, then a message shows up that says: /dev/sdb, /dev/sdc ...
4
votes
1answer
61 views

Kdump testing does not work on machines deployed by MAAS and JUJU

I am trying to add kdump on my Openstack platform which is deployed by MAAS and JUJU. I did several ways to do Kernel Crash Dump installation and testing. All the testing use Ubuntu OS 14.03 LTS ...
3
votes
0answers
40 views

How do I make juju request machines and provision them in parallel?

I provision about 40 machines using MAAS and juju. The script I use is below (it has the same problem is I turn --debug off): juju bootstrap -e maas --debug --upload-tools=true --metadata- source="~/...
2
votes
0answers
44 views

MaaS fails commisioning node

After having setup MaaS (DHCP configured), I am able to PXE boot a node but get a lot of warnings like "Temporary failure to resolve proxy" with Xenial after it reaches its login screen. Then it shuts ...
0
votes
1answer
68 views

Step 6 Installing Canonical’s OpenStack Autopilot

I'm at step 6 of the ez mode OpenStack instructions from http://www.ubuntu.com/download/cloud/install-openstack-with-autopilot and I'm unclear as to which box to actually run the "openstack-install" ...
0
votes
2answers
55 views

Error deploying Landscape after MAAS step

I have also posted in github the same question. Hoping I could get some support here as well. All the details can be found below: https://github.com/Ubuntu-Solutions-Engineering/openstack-installer/...
3
votes
3answers
135 views

Juju bootstrap Error “no matching tools available”

System specification: Ubuntu 15.10, maas 1.25 juju bootstrap returns following error: INFO juju.environs.bootstrap tools.go:77 looking for bootstrap tools: version=<nil> ERROR juju.cmd ...
0
votes
0answers
19 views

One more Networks tab missing question. Someone please answer.

I have seen unanswered "Network" tab missing questions. But maybe this one could be answered? Here is what I did briefly: (Tried several ubuntu documentations step by step). I am using split network:...
1
vote
0answers
18 views

juju-gui Access through local network not private network

How can I provide access to juju-gui through public local network not private MAAS network?
0
votes
1answer
51 views

Autopilot (ceph/ceph) how is space allocated?

I have 5 machines deployed, maas server, landscape server, and node01,02,03. Each Node is identical, 8 cores, 32gb ram, 3 HDs for 1gb per machine, (146, 300, 600gb 15k drives). maas and landscape ...
-1
votes
0answers
32 views

Maas nodes are not showing storage

I have successfully Installed Maas, juju and landscape ion a server and 2nd server is also commissioned after that I can access 2nd server via http now I have to add three machines as recommended so ...
0
votes
1answer
20 views

why newly created vm using pxe boot is not listing in the maas

I am using MAAS. MAASRC and MAASCC in different nodes. And I have created new VM using PXE boot. But the newly created VM is not listing in the maas. What should be the issue with this. When I try to ...
0
votes
1answer
103 views

MAAS new Node Network and Storage error

OS: UBUNTU 16.04 MAAS: 2.0.0. Beta 3 I added one node it shows up as new , both network adopter connectet to network(One internal and one exteral), When I am looking at node pages on MAAS GUI, it ...
1
vote
1answer
47 views

maas 2.0 gui does not show node which has been pxe booted

First let me repeat the cliche that I'm pretty new in the field so please excuse me in any ingenuousness. I've already setup a server with ubuntu 16.04 and done pretty much everything it takes to ...
0
votes
0answers
23 views

Is WOL removed from MAAS 16.04?

In the MAAS Web GUI I can't click on the WOL option when adding a machine to the cluster. Is this correct? Has it been removed? Why? and what are the changes that I can add it?
0
votes
3answers
2k views

How to restart MAAS

I can't work out how to restart MAAS, can anyone help? There's nothing in /etc/init.d that I can see. Thanks, Richard
0
votes
0answers
58 views

MAAS 2.0 add subnet

When I try to add a subnet on MAAS 2.0 I have the following configuration: VLAN masstest/untagged space masstest CIDR 10.20.0.3/16 name testadmin Gateway IP 10.20.0.2 DNS 10.20.0....
0
votes
0answers
48 views

Landscape Install no IP addresses

I'm installing landscape after running openstack-install. I'm getting the following errors in the all-machines.log on the node that landscape installs on. The DHCP is managed by MAAS and has roughly ...