Metal as a Service – MAAS – lets you treat physical servers like virtual machines in the cloud. Rather than having to manage each server individually, MAAS turns your bare metal into an elastic cloud-like resource.

learn more… | top users | synonyms

0
votes
0answers
4 views

Bundle: branching and deploying a specific charm revision

Can I branch and deploy a specific revision of a charm using bundle? For example service: myCharm: branch: lp:~myName/path/to/myCharm ...... is it possible to branch revision 14 of ...
0
votes
0answers
5 views

openstack-install juju bootstrap fail

When I run sudo openstack-install with "Landscape OpenStack Autopilot" as my selection, after I enter the admin email, name, MAAS server IP and API, the script fails with "A error has occured: Problem ...
0
votes
1answer
23 views

Is the Openstack Cloud Installer broken?

I am running Ubuntu 16.04 and am up to date. When I follow the instructions here for a single machine installation: Openstack Single Installer Guide Here is the sequence: Add the PPA repo ...
0
votes
0answers
10 views

MAAS NTP Address (Time Server)

UBUNTU 16.04 MAAS 2.0.0 Beta 3 I changed NTP server, on MAAS Setting Web UI "Address of NTP server for nodes". When I am looking in nodes commission log when it itries to commision it tries to get ...
0
votes
1answer
18 views

juju ERROR Unable to connect to environment “maas”

whether i do juju status or destroy-environment or bootstrap i am getting the error ERROR cannot connect to API: unable to connect to ...
0
votes
0answers
12 views

Failed MAAS node Comissioning

UBUNTU 16.04 MAAS 2.0.0 beta 3 Case 1: I see this as error after "Failed Comissioning" cloudinit.util.ProcessExecutionError: Unexpected error while running command.#012Command: ...
1
vote
0answers
16 views

Openstack installer Autopilot failing at juju bootstrap

I have a MAAS node already deployed using juju bootstrap --upgrade tools option and when I run sudo openstack-install and select option Autopilot. It appears it is timing out for entropy.ubuntu.com. ...
0
votes
0answers
16 views

Openstack LXC containers missing DNS

In my newly deployed openstack environment, I noticed that CEPH was failing within the 3 LXC containers. 016-05-03 02:18:38 INFO juju-log Unknown hook update-status - skipping. Reading package ...
0
votes
0answers
28 views

Failed Commisioning

UBUNTU 16.04 MAAS 2.0.0 Beta 3 Node Commission : In MAAS WEB UI on Machine (Node Page) says "Node changed status - From 'Commissioning' to 'Failed commissioning'" When I am looking on Node messages ...
0
votes
1answer
113 views

The maas/stable/ubuntu xenial repository does not have a Release file

When I run sudo apt update on my Ubunutu 16.04 LTS Server with MAAS installed I get the following error message: graeme@MAAS:~$ sudo apt update Hit:1 http://gb.archive.ubuntu.com/ubuntu xenial ...
0
votes
0answers
20 views

After MAAS enlistment of node No power Type set and node doesn't poweroff. (maas-ipmi-autodetect-tool: not found)

I am using MAAS Version 1.9.0+bzr4533-0ubuntu1. I am trying to enlist HP ProLiant BL460c G1 with boot ubuntu16.06 LTS ephemeral image. ubuntu14 LTS ephemeral image simply lands me to initramfs. The ...
3
votes
1answer
61 views

Issue bootstraping juju 2.0 on maas xenial setup

Trying to bootstrap juju on my maas set up, my physical no is aquired it fails after that. Can't figure out what to do rama@Maas:~$ juju bootstrap maas maas/172.17.6.253 --to snoutlike-ute.maas ...
0
votes
0answers
24 views

Howto use maas 2.0 cli to set up dhcp and dns settings

What are the correct steps to configure dhcp/dns settings in case of a maas 2.0 deployment? It seems that https://maas.ubuntu.com/docs2.0/maascli.html#cli-dhcp refers to version 1.x. TIA.
0
votes
0answers
21 views

MAAS Node commissioning I get a lots of“Ignored relative path” and “Error retrieving chunk extents: Operation not supported”

UBUNTU 16.04 MAAS 2.0.0 Beta 3 Nodes get faild comissioning when I looked at node logs: /var/log/maas/rsyslog//.../messages 1) it has a lots of "Ignored relative path" petroleous-arthur ...
0
votes
0answers
8 views

MAAS 1.9.1 No storage information. Commissioning this node will gather the storage information

MAAS 1.9.1 No storage information. Commissioning this node will gather the storage information. Also MAAS picking eth0 for PXE network but i have eth1 configured for PXE.....
0
votes
2answers
30 views

Failed commissioning because of false power on error

OS: UBUNTU 16.4 MAAS: 2.0.0 Beta 3 I Added new node to MAAS After commissioning it gets Failed commissioning and says under node Latest machine events: Failed to power on node - Node could not be ...
0
votes
1answer
29 views

MAAS new Node Network and Storage error

OS: UBUNTU 16.04 MAAS: 2.0.0. Beta 3 I added one node it shows up as new , both network adopter connectet to network(One internal and one exteral), When I am looking at node pages on MAAS GUI, it ...
2
votes
1answer
118 views

Is Autopilot Openstack 16.04 available?

I tried to build an openstack deployment from scratch starting with 7 physical servers and Ubuntu 16.04. I've had no issues using 14.04 on the same setup. After the initial setup in MAAS 2.0 beta3 ...
0
votes
1answer
28 views

MAAS virbr0 interface created

MAAS server had two interfaces eth0 external net and eth1 internal (for pxe boot). Somehow I am seeing a virbr0 under interfaces and an IP assigned to it. Not sure where that interface and its IP came ...
0
votes
1answer
20 views

which file contains network configuration for MAAS?

Ubuntu : 16.04 MAAS: 2.0.0 beta 3 Which file contains network configuration for MAAS?
0
votes
1answer
36 views

How change Gateway of subnet ( private network, Internal) on MAAS

Ubuntu : 16.04 MAAS: 2.0.0 beta 3 I need to change the gateway address of my subnet( private lAN,Internal which is 192.168.120.1) to ip address of my region/rack controller( internal ip ...
0
votes
1answer
21 views

How I can set MAAS to download boot-image for nodes from local storage not internet

OS: ubuntu 16.05 MAAS : 2.0.0 beta 3 There is boot-image setting for nodes in MAAS settion GUI, how can I use local storage for downloading the boot-image for Nodes through PXE booting and ...
0
votes
0answers
48 views

MAAS 2.0 and Ubuntu 16.04 Node Enlist get connection error to Internet behind a NAT

OS: UBUNTU 16.04 MAAS : 2.0.0 beta 3 1 Node as region/rack controller 2 Nodes Nodes are behind proxy I defined NAT on my region/rack controller i defined proxy on MAAS GUI When nodes try to boot ...
0
votes
1answer
37 views

juju bootstrap failing

I have MAAS 1.9.1 and commissioned a node...the node is in ready state..i am behind proxy and can apt get or update ...There two interface on MAAS eth0 is on 170.x.x.x and eth 1 is on 10.x.x.x ... I ...
0
votes
0answers
23 views

Problems with Maas and LVM's across mutiple drives

I'm trying to use ubuntu 14.04 MAAS to provision a system and am having some issues. The end goal I am after is: 1 x 64Gb SSD with a boot partition, a root partition, an lxc partition and a swap ...
1
vote
2answers
115 views

MAAS 1.9.1 PXE boot looking for Xenial image but i have trusty

MAAS 1.9.1 .....I deployed couple of nodes in MAAS and deployment went fine with 14.04 trusty image.....On my third node commissioning at PXE boot it start to look for Xenial image and failing with ...
0
votes
0answers
18 views

MAAS wrong Image location when PXE boot

As per regiond.log It looks like that when i PXE boot ....MAAS trying to go to wrong image location and thus failing......which file can i update for MAAS to get the image from correct ...
1
vote
1answer
22 views

MAAS 1.9.1 GUI Link interface

I have two interfaces on MAAS 1.9.1 eth0 - External Network eth1 - Private/Internal Network ie 10.x.x.x with DHCP/DNS configured I have MAAS GUI configured to access over eth0 ie ...
0
votes
2answers
32 views

Booting under MAAS direction error: File not found

I am PXE boot a node .... PXE IPV4 starts and then i get the error Booting under MAAS direction error: File not found I have downloaded a 14.04 image and Cluster Master is connected, Status Enabled ...
0
votes
2answers
60 views

MAAS unable to to keep Node details under MAAS nodes

Ubuntu 14.04.4 --- MAAS 1.9.1+bzr4543-0ubuntu1 (trusty1) I have a Machine that PXE Boot and getting the console messages below Start PXE over IPV4 Booting under MAAS direction .......... ....Bunch ...
0
votes
1answer
65 views

MAAS “Failed deployment” on node with 16.04 LTS

We have a node with commodity hardware (Dell r620). I can successfully deploy Ubuntu 14.04 LTS and 15.04. When I attempt to deploy 16.04 LTS MAAS eventually returned "Failed deployment". INFO ...
0
votes
1answer
61 views

MAAS 2.0. Importing custom images does not work?

How should I import custom images to MAAS 2.0.0~beta2+bzr4920 in Ubuntu 16.04 LTS Beta2? The command I successfully used in 1.9 is uploading an image without errors: $ maas local boot-resources ...
0
votes
2answers
255 views

Downloading packages from Ubuntu local package mirror during Ubuntu 14.04LTS server installation

During Ubuntu 14.04LTS server installation using MAAS, some packages are downloaded from Ubuntu mirrors. Is there a way of installing Ubuntu using MAAS in an environment without internet connection ...
0
votes
2answers
97 views

Deploy MAAS, Juju, Openstack

I have look in to dozens on online document but none give me the exact steps and recommendation for deploying MAAS, Juju and OpenStack on Ubuntu. There's plenty of documentation available but none ...
0
votes
2answers
33 views

Understand the differences between two network configurations for MAAS

I am trying to understand the differences between two network configurations for MAAS. My understanding is that the both achieve the same tasks where the first network connects to the internet and the ...
-1
votes
1answer
10 views

Ubuntu Autopilot Openstack Dashboard inaccessible

After a successful Autopilot install, I had to recommission nodes in order to reenable ssh. Since then, the Openstack Dashboard is offline. The once reachable IP Address for the dashboard is now not ...
0
votes
1answer
35 views

MAAS 1.9 can't deploy OS

I recently upgraded my MAAS server and found myself with MAAS 1.9.1+bzr4543-0ubuntu1. I saw that the old version of MAAS that I had been running was no longer supported, so no great loss there. ...
0
votes
0answers
53 views

OpenStack Autopilot fails to deploy Landscape with “public/private no address” warnings

After installing MaaS 1.9.1 and Juju 1.25.5 on Ubuntu 14.04.4 and successfully commissioning and deploying nodes and charms I then moved onto Openstack Installer 0.99.28 and chose the "Landscape ...
0
votes
1answer
24 views

Does MAAS Cluster Controller API URL need to setup to Internal Network and not LAN Network

MAAS 1.9 - Ubuntu 14.04.4 Wondering if the MAAS Cluster Controller API URL need to setup to Internal Network and not LAN Network..... My Internal network is 10.x.x.x on eth1 and not accessible from ...
0
votes
1answer
267 views

MAAS interface eth0 (External) and eth1 (internal)

I have two interfaces configured in MAAS under Cluster eth0 - external IP VLAN 10 eth1 - internal (10.x.x.x) VLAN 20 - DHCP-DNS Managed I am going to add a node in MAAS.....I have setup the node ...
0
votes
2answers
46 views

Ubuntu - Auto Pilot Open stack Deployment Guide

I have Ubuntu 14.04.4 Installed and wondering if there is a guide step by step with details and screenshots to deploy the components below MAAS-Landscape-OpenStack The guide available online is not ...
0
votes
0answers
26 views

MAAS 1.9.1 GUI Taskbar missing Network TAB on Ubuntu 14.04.4

I deployed MAAS 1.9.1 on Ubuntu 14.04.4 but all the install guides showing MASS GUI having Network Tab ie Nodes-Cluster-Images-Zones-Network-Settings but i am seeing the GUI Taskbar option below ...
0
votes
1answer
23 views

MaaS Node cant ping external servers

I have setup a MaaS server with eth0 going to the internet and eth1 an internal switch connecting the the MaaS nodes. I and can commission and deploy nodes on Trusty Ubuntu but those nodes can only ...
0
votes
1answer
29 views

Juju bootstrap fails with dns resolution issues

I am building a proof of concept install using old hardware and the AutoPilot install which is using Liberty. I finally managed to get the physical servers to commission in MAAS and commenced the ...
3
votes
0answers
28 views

crm status failing to work after adding remote node

My setup: 1. Ubuntu 14.04.4 LTS 2. Kilo Release (2015.1.3) 3. pacemaker: 1.1.10+git20130802-1ubuntu2.3 4. pacemaker-cli-utils: 1.1.10+git20130802-1ubuntu2.3 5. corosync: 2.3.3-1ubuntu2 6. ...
1
vote
1answer
40 views

MaaS Hyper-v Power Type

I have a Hyper-V 2012 R2 Host that has Ubuntu 14.04 running MaaS 1.9.1 as a Guest VM. This has works well until I need to commission a virtual node as it requires a Power Type to be used to turn on ...
0
votes
1answer
36 views

OpenStack AutoPilot failing at 98%

I'm trying to deploy OpenStack using Landscape's Autopilot. I get no errors till the final steps but after reaching 98% of the install two tasks fail to completed. The two tasks that never reach ...
0
votes
1answer
63 views

Will the first server be added as one of 5 nodes in OpenStack Autopilot?

1. After reading the documentation for setting up OpenStack Autopilot, I am instructed to install Ubuntu server on the first server. But after going to MAAS GUI to add the other nodes, I don't know ...
1
vote
2answers
38 views

juju no route to host

I have set up a system as described below. A server connected to the internet(192.168.16.250) and also to a switch(10.1.1.100). I have nat configured on the switch facing interface and can access the ...
1
vote
0answers
14 views

Juju node is eating up a lot of memory

my Juju node is consuming more than 90% of its RAM. $ free -m total used free shared buffers cached Mem: 3953 3843 109 0 131 ...