Questions related to localhost, loopback. On most computer systems, localhost resolves to the address 127.0.0.1, which is the most-commonly used IPv4 loopback address, and to the IPv6 loopback address ::1.

learn more… | top users | synonyms

7
votes
3answers
6k views

Let Xorg listen on TCP, but only to localhost?

I have some X client program which needs access to an X server. It is only able to access the X server by TCP, not by other methods like unix domain sockets. It will run on the same host as the ...
1
vote
1answer
255 views

ssh connection closes after successful login

I am trying to run ssh on my computer so I can control it with my android phone. When I scan my local network with overlook fing at my phone I get that my computer is running ssh at port 22. So I try ...
4
votes
1answer
3k views

How to access Apache2 virtual host from VirtualBox (or any VM)

I am running Ubuntu 11.04, I have setup my localhost so I access my sites at site1.local site2.local By setting up virtual hosts and adding entries to my hosts file. I want to test them in IE ...
2
votes
4answers
4k views

What would cause 'ping localhost' to fail?

the /etc/hosts file contains a line: 127.0.0.1 localhost so localhost should be a valid hostname, but any attempt to connect to a port on localhost fails, including ping. Connection attempts into ...
1
vote
2answers
507 views

I would like to set 127.0.0.1 in my resolv.conf

I was hoping to set my local host in my resolv.conf to hermes. So in affect if I type in hermes:8080 into the browser, I get the localhost:8080 How is this accomplished? Please and thank you.
4
votes
1answer
1k views

Renaming localhost

By default 127.0.0.1 has the localhost alias. I found several approaches to changing it to a different string, but what is the standard, effective and safe best-practice way of doing it? Can I give ...
3
votes
2answers
789 views

How can I share this local site to not use a sub directory?

I'm working on a site locally that's just sitting in a folder: localhost/tempplace How can I route, with Apache2, that to be like: tempplace:8890 Or just something so it's not a sub ...