The tag has no wiki summary.

learn more… | top users | synonyms

0
votes
0answers
14 views

How to get and install qt header and libraries in specific folder?

Where do I get qt header and libraries from? And then how do I install qt header and libraries in specific folder?
0
votes
0answers
17 views

Package installed from compiled source not found

I'm trying to install libimobiledevice which requires a specific version of libusbmuxd, which requires a specific version of libplist. So I managed to compile libplist from source and install it with ...
0
votes
0answers
13 views

Install Multiarch Libraries Simultaneously

I want to install both the amd64 and the armhf version of the library libcrypto++ on my pc for cross compilation. Is it possible to do that so that both libraries are present on my Pc at the same ...
0
votes
0answers
16 views

Updated libraries, broke SSH and some library

I was trying to update my python and get opencv to work on Ubuntu 12.04, and managed to cause two concerns. I get an email every 30 minutes saying: php5: ...
1
vote
0answers
31 views

Static QT libraries for Ubuntu 14.04

Is there a package which contains all static QT 5 libraries? There are only some static libraries in the qtbase5-dev package (and its dependencies). To be more precise, the static versions of Qt5Test, ...
1
vote
0answers
37 views

Fatal error: tcl.h: No such file or directory #include <tcl.h> [closed]

I am attempting to install xgrafix from PTSG's website. The main error I am have is what the title says. I have installed the tcl/tk dev files and I have located where tcl.h and tk.h are in my ...
0
votes
1answer
13 views

How to tell what libraries a piece of software needs?

I'm using Ubuntu Server 15.04 and mainly running this to get a steam TF2 server going. How can I tell what prerequisites I need to install to ensure this program will work? This is the program wget ...
0
votes
0answers
14 views

Installing GEOS on ubuntu without root rights

I tried installing the GEOS API for Python and got the following error when I entered commands from GEOS dir: ./configure --enable-python make make install Giving the following error SWIG is ...
0
votes
0answers
38 views

No static libraries in some packages

I am using Ubuntu 14.04 and installing tons of prerequisites in order to build some large libraries. I compiled lots of dependencies myself already, but would like to avoid compiling any more due to ...
1
vote
1answer
23 views

How to hide imported Python libraries?

I am a beginning coder in Python. This may sound misplaced, but wait up a second. My program depends on a couple of libraries that I have allowed it to use via import. These libraries are now showing ...
2
votes
2answers
38 views

Ubuntu share library libnetcdf.so.6

I am quite new in linux. Sorry for any silly question. I am trying to run FreeSurfer (5.3.0-HCP). This needs specifically libnetcdf.so.6. I currently have the version 7 installed. It is possible to ...
0
votes
0answers
23 views

installing libtsmux-dev and flutsmux on Ubuntu 14.04

I wanted to install the libtsmux-dev and then flutsmux on this version but it seems this library is removed since executing sudo apt-get install libtsmux-dev gives me this error: E: Unable to locate ...
0
votes
2answers
92 views

PCL Ubuntu Installation

I have been trying to install PCL for linux on Ubuntu 14.10: http://pointclouds.org/downloads/linux.html So far, I have done the first two steps, sudo add-apt-repository ...
0
votes
1answer
44 views

Can't install package [duplicate]

Trying to setup environment for android ROM development, but the libgl1-mesa-glx:i386 package is not installing. Getting error: Reading package lists... Done Building dependency tree Reading ...
0
votes
0answers
52 views

How can I fix E: unable to correct problems, you have held broken packages

I have ran into many issues istalling steam on my Ubuntu Chromebook, so I was trying to install the package libc.so.6. I was running the command sudo apt-get install libc6*, but still I have no luck.
0
votes
1answer
59 views

“error while loading shared libraries” when running executable file

I tried to execute a file and I got an error: ./Tracking: error while loading shared libraries: libboost_system.so.1.49.0: cannot open shared object file: No such file or directory
0
votes
0answers
47 views

Uncomplete install of POCO C++ libraries

I recently started to use POCO C++ libraries to create a simple mail client and I needed to use SecureSMTPClientSession class, but compiler reports Poco/Net/SecureSMTPClientSession.h: No such file ...
1
vote
0answers
24 views

Adding NETSSL_OPENSSL libraire

I recently started to use POCO C++ libraries to create a simple mail client and I needed to use SecureSMTPClientSession class but compiler reports "Poco/Net/SecureSMTPClientSession.h: No such file or ...
3
votes
1answer
30 views

Where should libraries be located for the development process?

With the SDL libraries for example, one would have to point to the headers at the beginning of their code, like so: #include <SDL/SDL.h> And, when compiling with GCC for example the library ...
1
vote
1answer
29 views

Can I install libpoppler-dev on Ubuntu 14.04

It appears as per apt, that libpoppler-dev depends on libpoppler46, which depends on libtiff4. libtiff4 cannot be installed on Ubuntu 14.04 (which already has libtiff5 in my case). Can you suggest a ...
3
votes
2answers
50 views

How to make an application use local shared library instead of the system one

I have qtcreator installed using the qt online installer. It ships which its own version of qt library. The qt library are also installed in the system directories, but those are older. I have ...
0
votes
0answers
17 views

Unable to locate package libcmocka-dev and libcmocka0 [duplicate]

I am trying to install cmocka C unit testing framework. Operating system is Ubuntu 12.04 LTS sudo apt-get install libcmocka-dev libcmocka0 Reading package lists... Done Building dependency tree ...
1
vote
1answer
172 views

The imported target “Qt5::Gui” references the file “/usr/lib/x86_64-linux-gnu/libEGL.so” but this file does not exist. [closed]

So, 15.04 x64, just installed. I installed the nvidia binary in the old way (console, switching off lightdm) because I got an error about DRI2 authentication. Then I wanted to build the nv opengl ...
0
votes
0answers
13 views

How create a deb package with older libs

I was trying to create a deb package but it has some dependencies who I did not find on software center, one of them is libqtmultimedia4. How could I create this package? May I include the lib in the ...
1
vote
1answer
55 views

misunderstanding cmake's part in including library

I have been trying to include this pokerstove library so I could actually include these header files in my simple program so I could calculate some poker hand equities. So far its not going great ...
1
vote
1answer
36 views

Unable to use included library -> pokerstove in ubuntu 14.04

guys! I just included this pokerstove library with help of good instructions and with help of this website and its users I ran all commands in my home directory which is ...
1
vote
1answer
62 views

Getting C++ library to work on ubuntu 14.04

I'm trying to make this pokerstove library to work so it could be included and used in a simple .cpp file opened by simple text editor and compiled in terminal using g++ -o my_prog my_cpp.cpp ...
0
votes
3answers
166 views

Lubuntu 15.04 Missing Libnl1

Been trying to install Libnl1, airodump-ng calls for it. A program I use often. I'e tried the standard "apt-get install libnl1" but it is not found in the updated repositories
1
vote
1answer
526 views

Missing libSM.so.6 library - QT creator installation error

when i trying to ran qt-linux-opensource-5.0.2-x86-offline.run I gets below error. ./qt-linux-opensource-5.0.2-x86-offline.run: error while loading shared libraries: libSM.so.6: cannot open shared ...
0
votes
1answer
61 views

Ubuntu 12.04.5 64bit no /usr/lib64/?

I am currently trying to setup a domU on XEN Hypervisor based on some tutorials. My XEN installed on Ubuntu 12.04.5 Server x64 bit.. (Clean install) I can't find /usr/lib64 only /usr/lib and ...
0
votes
0answers
21 views

gfortran cannot recognise pthread

I am using gfortran for fortran compiling and I was trying to compile a new code with watson sparse linear solver, but when hit compile it appears with these messages: libwsmp64.so: undefined ...
0
votes
0answers
98 views

installation of fflas-ffpack library, blas library not found

I have a problem with installation of the fflas-ffpack library(http://www-ljk.imag.fr/membres/Jean-Guillaume.Dumas/FFLAS/). I've downloaded the installation archive file and extracted it into ...
0
votes
0answers
26 views

Problem with libGL1.so.1

Goodevening/Goodday, askubuntu community, I have a problem with 32bit applications (or at least, applications which require 32bit libraries). After installing a scientific library for C (DISLIN), I ...
1
vote
0answers
194 views

Error installing needed libraries for Steam

So I installed Steam from the steampowered.com download. Now that Steam's installed, when I try to run it I get the following: Steam needs to install these additional packages: ...
1
vote
2answers
110 views

Error while loading shared libraries

I'm using a software called GPUOcelot in order to be able to compile a software that I'm programming that uses CUDA. But my computer doesn't have any NVIDIA card, so that's the reason why I am using ...
2
votes
0answers
81 views

Evince can't open PDF files anymore

I always get this error when I try to open pdf files with evince: error while loading shared libraries: /usr/lib/x86_64-linux-gnu/libpoppler.so.44: invalid ELF header Can someone please help me?
0
votes
1answer
36 views

installing libg2-dev on ubuntu 10.04 lucid

I am trying to install libg2-dev on my ubuntu 10.04. I did it from synaptic package manager and also used sudo apt-get install libg2-dev. When I am trying to configure a source code for a software I ...
0
votes
1answer
94 views

Can't understand difference between liblapack3 and liblapack3gf

I need to install the lapack library in an ubuntu computer for linking to a code I am developing. I have been told to apt-get install liblapack3, but the only one I found is liblapack3gf. My list of ...
5
votes
2answers
185 views

C Using Libraries Without IDE [closed]

This may be a stupid question. How do you use C libraries without an IDE? I want to only use a text editor.
0
votes
0answers
112 views

Error while loading shared libraries: libOSMesa.so.8: cannot open shared object

On Ubuntu 14.04 LTS, I need to install the libOSMesa8, one of the Mesa 3D libraries. In particular, I need the file libOSMesa.so.8 to run the graphic tool Asymptote. Only libosmesa6 is available ...
0
votes
0answers
111 views

Difference between llvm-dev and llvm-3.5-dev

Before install llvm-dev just install llvm-3.5-dev. I run example of llvmlite https://github.com/eliben/pykaleidoscope.git have error: Traceback (most recent call last): File "chapter3and4.py", ...
0
votes
1answer
269 views

Unable to install .deb files [duplicate]

I am recently change from Kubuntu to Xubuntu. I think some files might be deleted. I am trying to install Vlc Player and other .deb packages it throws following error. Please help Error: ...
0
votes
0answers
30 views

How to Program an Indicator into the Unity Panel

I'm working on an open source project and want to edit up one of the notifications for Ubuntu and install it into the Unity Panel (top black bar). How would I go about doing this? What files do I need ...
0
votes
0answers
117 views

Installing LibGlui on Ubuntu 14.04 LTS

I am having trouble installing libglui on my computer running ubuntu 14.04 LTS. I initially tried using a package manager as specified in this askubuntu thread, but had no such luck (the links ...
0
votes
1answer
177 views

sys/cdefs.h:no such file or directory on arm v7 architecture with ubuntu trusty

With amd64 i found in the blogs related to this that try installing lib6-dev-i386 to solve this but i really do not have any idea which package to install for arm v7 cpu on imx6 board so that this ...
0
votes
1answer
58 views

How to compile PythonMagick against custom lib path

I want to compile latest PythonMagick. I am able to compile older one compatible with Ubuntu 14.10 libs, but this version is not sufficient. First step was compile recent imagemagick packages itself ...
3
votes
1answer
8k views

GLIBCXX_3.4.20 not found, how to fix this error?

Whey I try to run the program Layout Editor (available on this site) on Ubuntu 14.04.1 64-bit LTS I get the following output in the terminal: $ layout layout: ...
0
votes
2answers
3k views

error: pcap library not found!

I want to install reaver and the error I am getting is: checking for gcc... gcc checking whether the C compiler works... yes checking for C compiler default output file name... a.out checking for ...
1
vote
1answer
494 views

What is the terminal command to install the whole gtk 3.14 libraries in ubuntu?

I want to develop linux apps for ubuntu using C. Now, for that I need to install the gtk 3.14 libraries and the dependencies. I already tried to install it by downloading the libraries, but was not ...
0
votes
1answer
26 views

How to download a certain version of a package?

I tried sudo apt-get install package-name=1.23, but apparently it is not available for this version of Ubuntu...? I get: E: Version '1.23 for package-name' was not found. Do I need a command line ...