Libav is a complete, cross-platform solution to record, convert and stream audio and video. It includes libavcodec - the leading audio/video codec library.

learn more… | top users | synonyms

6
votes
2answers
2k views

Very slow conversion with avconv (libav) - Trusty Tahr 14.04?

Yesterday I installed the latest Kubuntu release 14.04. So I meet a little problems with the media conversions. The old FFmpeg is finally replaced with avconv which is in the libav-tools library. Till ...
5
votes
2answers
2k views

Why can't I watch video after installing the original ffmpeg fork from Jon Severinson's PPA?

I just installed the Jon Severinsson ffmpeg PPA, and I cant watch any video and get audio only, I get a need extra plugins needed install? and then packaged dependencies could no be resolved . Here ...
3
votes
2answers
6k views

converting multiple files with avconv…libmp3lame0 not found [duplicate]

I have about 20 .webm files that I would like to convert to audio in the terminal. I want to do avconv -i *.webm -acodec libmp3lame0 -aq 4 *.mp3 I tried: for i in *.webm; do avconv -i "${i}" ...
3
votes
1answer
459 views

Is it possible to have both libav and ffmpeg installed and running on ubuntu 14.04?

I want to use Clementine but it needs ffmpeg to be installed if I want to play .ape files from it. On the other way, I still want to have VLC up and running, and I understand that VLC does no longer ...
2
votes
1answer
101 views

Can Not install available update

i can't check to install this available update here is my problem about my ubuntu: i have tried it from terminal with sudo apt-get update, but it still unsolved
2
votes
1answer
425 views

Video Conversion using libav with libopus

i need to convert my video files with VP8 / Opus in Matroska(mkv) container using avconv in terminal Can anyone give example usage of it?
2
votes
2answers
955 views

12.04 upgrade libav from 53 to 54

I am using the latest release of blender 2.66 on 12.04 from the command line. It is looking for libavformat.so.54 but I only seem to have libavformat.so.53 installed, and cant find a way to upgrade ...
2
votes
0answers
1k views

avprobe - doesn't output json document

I'm trying to create a json file with information of a mp4 file with avprobe, but it doesn't print nothing. The command avprobe -v 0 -show_format -of json myvideo.mp4 My avprobe version avprobe ...
1
vote
1answer
4k views

How to install libav from launchpad?

How could I install this package from launchpad on ubuntu 12.04?? https://launchpad.net/ubuntu/+source/libav
1
vote
1answer
913 views

build libav from GIT using --enable-*

I need to get a newer version of libav-tools (containing avconv) to get the AAC-encoder to resample an input 6-channel audio stream into an output 2-channel one. I successfully built the package, ...
1
vote
0answers
200 views

Ubuntu 14.04 OpenCV3 ffmpeg or libav dependencies

I need to install OpenCV on Ubuntu 14.04 to work with Python3 but the only version that is compatible is OpenCV3 which is at 3.0 RC1 http://opencv.org/downloads.html Following installation ...
1
vote
0answers
125 views

Open Cv installation problem

I am following this link for installing OpenCv but on the make step I came across an error: home/aman/opencv/opencv/modules/videoio/src/ffmpeg_codecs.hpp:98:7: error: ‘CODEC_ID_H264’ was not ...
1
vote
0answers
214 views

LibAv: Set a custom Header in RTSP stream

I am trying to play a chunk of video retrieved from an Axis M3004V camera. The camera is continuously recording video in an internal MicroSD card. That video receives a recordingid I can use to query. ...
1
vote
0answers
73 views

How do I install ffmpeg? [duplicate]

I need to install the package ffmpeg because I am trying to install subsonic server on my new Ubuntu Gnome 14.04 When I try: apt-get install ffmpeg I get: Some packages could not be installed. ...
1
vote
0answers
471 views

Specify shared library location for VLC

I built (from source) a newer version of libavcodec.so, libavformat.so, etc. than provided by the Ubuntu repositories. (My newer versions are installed in /usr/local/lib). Using ldd /usr/bin/vlc to ...
1
vote
1answer
814 views

Muxing h264 stream into mp4

I've a H.264 stream (.264). How do I pack (mux) it into a .mp4 file? I know I need to use avconv, but I couldn't get it to work.
0
votes
1answer
137 views

avformat package seems to have outdated headers

I have libavformat56 and libavformat-dev installed on my machine. I'm building some source right now which uses the libavformat.h header. The source (nameply the Pangolin library by Steven Lovegrove) ...
0
votes
1answer
210 views

Self-compiled FFmpeg, checkinstall and APT dependencies

I've compiled FFmpeg and installed it with checkinstall. Now, I'm trying to install OpenCV development files, but it wants to install libavcodec-dev libavcodec54 libavformat54 libavutil-dev ...
0
votes
1answer
282 views

libav : deinsterlace option?

I have compiled from GIT sources the libav 2014-march-10. On usual libav from Ubuntu repositories, I was able to use -deinterlace to... well, deinterlace the video. Now this option appears to be ...
0
votes
1answer
84 views

Uninstall libav packages after re-installing from source

I'm running kubuntu 14.04 and don't plan on upgrading until at least these summer holidays. The libav packages provided are somewhat outdated (two major versions behind) and produce unsatisfying ...
0
votes
1answer
6k views

Installation of libavcodec-extra or libmp3lame fails

I'm trying to install ffmpeg on my dedicated server running on ubuntu 10.04. I want to convert flv-videos to mp3 sound files. As I found out, I have to install libavcodec-extra-52. When I use sudo ...
-1
votes
1answer
211 views

can't play wmv files - Failed to initialize the VAAPI device

I'm trying to run wmv files, and tryed some advices from here, but without any success. I have vlc and ubuntu-restricted-extras. I also did a purge, autoremove and re-installthem. This is what I ...
-1
votes
1answer
519 views

downgrade ubuntu 14.10 to ubuntu 14.04 or 12.04 [duplicate]

Well i installed ubuntu 14.10 with gnome deskotp environment but during installation of opencv. I am having issues with libav as recent ubuntu uses api version 11 and I need api version 9 so i want to ...