1
vote
2answers
209 views

How do I re-run boot loader?

Running sudo apt-get -f install said that The link /vmlinuz.old is a damaged link and: you may need to re-run your boot loader[grub] Here's the full output: user@chrubuntu:~$ sudo apt-get -f ...
1
vote
1answer
131 views

After removing the latest kernel, how can I be notified of kernel updates again?

Yesterday, I updated all packages through the software updater. It installed kernel 3.13.0-35. When I rebooted, I would get a completely unresponsive blank screen, so I went back to the Grub menu ...
0
votes
1answer
642 views

dpkg: error processing package linux-image-generic (--configure): dependency problems - leaving unconfigured

dpkg --configure -a Setting up linux-image-3.13.0-35-generic (3.13.0-35.62) ... Running depmod. update-initramfs: deferring update (hook will be called later) The link /initrd.img is a dangling ...
0
votes
1answer
152 views

“Errors while handling” kernel packages after dist-upgrade [duplicate]

I did an apt-get dist-upgrade, now everytime I do something using apt-get, e.g. installing something, it gives me that there are errors while handling the following packages: ...
0
votes
0answers
103 views

iscsitarget suddenly broken after upgrade of the 12.04 Hardware Stack

After an upgrade to the latest Hardware Stack using Ubuntu 12.04, my iscsi service is not longer operational. The error from the service is such: FATAL: Module iscsi_trgt not found. I have learned ...
1
vote
1answer
669 views

“Your current Hardware Enablement Stack (HWE) is going out of support”

My ubuntu system now says; Your current Hardware Enablement Stack (HWE) is going out of support on 07. aug. 2014. After this date security updates for critical parts (kernel and graphics ...
0
votes
0answers
70 views

Many files in /var/lib/dpkg/info/ corrupted; how to recover

When I run sudo apt-get (anything), I invariably get this error: dpkg: unrecoverable fatal error, aborting: files list file for package 'thunderbird-gnome-support' is missing final newline E: ...
1
vote
1answer
324 views

Error while upgrading kernel

I am trying to upgrade the kernel: (synaptic:22238): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed Väljer tidigare ej valt paket linux-image-3.13.0-30-lowlatency. (Läser ...
0
votes
0answers
836 views

Can't upgrade kernel to 3.13.0-30 on 14.04

I think I broke something with apt on my system. I'm trying to update the kernel to 3.13.0-30, but when I run apt-get I'm getting the following output: Reading package lists... Done Building ...
0
votes
1answer
510 views

sudo apt-get upgrade - Failure [duplicate]

This is a first for me. I've been having trouble upgrading Ubuntu 12.04. How do I fix this? sudo apt-get upgrade: Reading package lists... Done Building dependency tree Reading state ...
3
votes
4answers
822 views

apt-get install was interrupted

I am new to Ubuntu. I got the following lines after an interrupted apt-get install. Running depmod. update-initramfs: deferring update (hook will be called later) Examining /etc/kernel/postinst.d. ...
0
votes
2answers
63 views

How to keep specific old kernel on my next kernel upgrade?

I just updated my Ubuntu 14.04 and got a new kernel. This new kernel is not working properly for me so I booted the previous version. Let's call this good old working version "3.13.0-24.47". Now, I ...
1
vote
1answer
48 views

apt-get autoremove “Before uninstall, this module version was ACTIVE on this kernel”

When running apt-get autoremove (or dry run with -s switch), what does the following message mean? Status: Before uninstall, this module version was ACTIVE on this kernel. And what should I do to ...
2
votes
2answers
770 views

Installed 14.04 on a non-PAE (Pentium-M), but now I can't update (“This kernel does not support a non-PAE CPU.”)

Here is what I'm looking at. This isn't my computer. I repair PC's and I had an end user with this low powered laptop running XP so I decided to let him try out lubuntu. The install went smoothly with ...
1
vote
0answers
111 views

How do I rollback Recent Updates? 50+ crash reports upon login

Am running 13.10 w/Cinnamon, but still have Unity installed. Everything was working fine until I responded to an update manager update notification. I tried rebooting into a prior kernel version, but ...
0
votes
0answers
17 views

how to trigger for some action on package upgrade?

I've got some problems. I have vga passthrough setup on my desktop. And I had to apply some patches to kernel and Nvidia driver. Now I've got custom patched kernel installed and patched nvidia driver. ...
0
votes
1answer
220 views

Creating Virtual Machines using ubuntu-vm-builder

I'm currently trying to install virtual machines on my Ubuntu Server 13.10. I followed the instructions from this guide. I was able to install and check if my machine is is supported how ever when I ...
0
votes
1answer
1k views

Error! Bad return status for module build on kernel: 3.8.0-37-generic (x86_64)

After updating some packages in my machine (using aptitude), I got the following error: Error! Bad return status for module build on kernel: 3.8.0-37-generic (x86_64) Consult ...
1
vote
0answers
352 views

unable to generate .deb file using make deb-pkg?

I am trying to build my linux source tree. I used following steps : sudo make clean sudo make localmodconfig sudo make menuconfig sudo make deb-pkg But after completion I was not able to see any ...
0
votes
1answer
576 views

dpkg opporations fail: Failed to run depmod, error processing linux-image-generic

My Laptop had lost power a couple of times recently, and now, whenever I try to do a package operation I am getting the following error code. I tried searching for a solution on the forums, but these ...
0
votes
0answers
30 views

Letting system updates know that I already have a newer kernel

I am running Elementary OS (basically Ubuntu 12.04). I had to upgrade my kernel to 3.13. I did this using dpkg. However, system updates still shows kernel 3.2 as available. Is this because apt does ...
0
votes
0answers
43 views

Error while installing kernel-headers?

I have a Linux kernel module which I am trying to compile. The module needs the installed kernel headers to install and is looking into /lib/modules/$uname -r/build folder which is not present. I ...
0
votes
0answers
27 views

problem while creating desktop shortcuts from ubuntu-tweek

I followed the below steps to create desktop shortcuts. sudo add-apt-repository ppa:tualatrix/ppa sudo apt-get update sudo apt-get install ubuntu-tweak ubuntu-tweak After installation of ...
1
vote
1answer
106 views

After update to Precise, libc looks hosed and can't update?

Looks like libc is hosed and ldconfig is segfaulting left and right causing issues... Output when I try to run apt-get install --reinstall libc6 to reinstall libc(and hopefully ldconfig...): dpkg: ...
1
vote
1answer
797 views

How to install perf on a custom build kernel?

I want to use profiling tools in linux. I see some information say Oprofile is not support in Ubuntu 12.04 and the alternate is perf. So I try to install perf. I installed linux-tools-common, ...
0
votes
2answers
1k views

Ubuntu roll back to previous kernel: linux-image-3.11.0-11

I had too many kernel updates and the only ones that worked for me were "pushed away". Any suggestions on how can I reinstall kernel version "linux-image-3.11.0-11"?
0
votes
0answers
460 views

How to make linux-{image,header}-3.11.x satisfy linux-generic dependencies?

What is the difference from apt's perspective between Ubuntu 12.04 LTS (Precise) kernel packages: linux-image-3.2.0-57-generic linux-image-3.11.0-14-generic Such that the former satisfies ...
3
votes
2answers
1k views

apt-get does not find suggested package (perf tool)

I am using performance counters (https://perf.wiki.kernel.org/index.php/Main_Page) on Ubuntu 13.10 x86_64. If I type perf I get: perf not found for kernel 3.11.0-031100 You may need to install ...
1
vote
1answer
1k views

Unable to install ZFS (Ubuntu 13.10) [closed]

I'm fairly new to Ubuntu and wanted to setup a server running ZFS/XBMC - The XBMC install went fine, however I ran into trouble getting ZFS working. Configuration : Ubuntu 13.10 (GNU/Linux ...
0
votes
0answers
468 views

I got an error upgrading 13.04 to 13.10 now after DKMS install completed

I had an issue when I upgraded from 13.04 to 13.10 during the upgrade it hung up at the DKMS complete screen, I managed to recover the system with out loosing any of my program however when I try to ...
2
votes
2answers
153 views

puzzled by “no space” complaint from apt

Background: My / partition was at 93%, but I had some unallocated space so I created a new home for /usr . After the move the space usage looks like: >df -k Filesystem 1K-blocks Used ...
3
votes
2answers
894 views

Deleted old version of kernel to free up space - now getting nonstop errors

My /boot partition was full, so I deleted an old version of the kernel to free up space, so I deleted the following files in /boot: abi-3.8.0-25-generic config-3.8.0-25-generic ...
1
vote
2answers
498 views

How do I pin the lowlatency kernels so apt doesn't update with a newer generic kernel?

I'm on Kubuntu 12.04 with lts-raring HWE stack. I'm running kernel 3.8.0.30.18 low latency. A recent update replaced my low latency kernel with a slightly newer (3.8.0.31) generic kernel. I wish to ...
1
vote
0answers
435 views

Can`t update Ubuntu 12.04LTS headless server via terminal

I previously tried to update to 3.2.0.36-linux-generic but this was broken for some reason so every time I restart my server I have to boot 3.2.0.35-linux-generic. When I try sudo apt-get upgrade I ...
1
vote
2answers
3k views

Boot is full can't get apt-get to upgrade [duplicate]

I've followed most instructions an clearing boot found on the interwebs, I'm a bit n00bish on linux inwards I use it mostly for web dev testing, but am pretty good at following command instructions ;) ...
0
votes
1answer
695 views

Can't uninstall old kernel [duplicate]

I can't install a new kernel because by boot partition is full. However I also can't remove an old kernel: sudo apt-get purge -f linux-image-3.2.0-29-generic-pae [.. reading package lists etc, ...
-1
votes
1answer
98 views

Can't install apps or updates…help? [closed]

I have an Ubuntu based distro (ElementaryOS)12.04 and I'm having an issue where I can't update the system nor can install any apps. Basically I can't do anything with it! Before this I simply got an ...
2
votes
2answers
526 views

How to download and use any other kernel than the one which is installed by default

Supposing I am using Ubuntu 12.04(LTS), and it uses the 3.5.0-37 kernel. If i wanted to use the 3.9.6 kernel, how could i use it? I dont want to upgrade to 13.04 Would I have to manually download ...
5
votes
1answer
10k views

what is the right way to downgrade kernel

I decide to downgrade kernel version due to unsolvable problem with wifi. Ubuntu version is 12.10, kernel version is 3.5. In http://packages.ubuntu.com/precise/kernel/ I found the previous kernel ...
0
votes
1answer
54 views

Ubuntu 12.04 LTS null pointer crash

Ok, I think I'm in a Bad Place(TM). I'd gotten too trusting--the Ubuntu kernel updates have been solid for a very long time. I downloaded the latest 3.2.0-51-generic-pae kernel, ran it for a week or ...
2
votes
1answer
364 views

Apt-get dist-upgrade wants to destroy my Ubuntu 12.04 LTS

This morning I have issued a command I use fairly often: apt-get dist-upgrade Usually it finds little to do, some times it will replace the kernel and headers. With my great surprise today it ...
0
votes
1answer
184 views

Cant purge with apt-get, because of dependencies

My /boot/ sadly is full, so I cant use apt-get upgrade anymore, or similar things. If I try to purge one of the kernels, with: apt-get purge linux-image-3.2.0-29-generic I get: Reading package ...
0
votes
2answers
3k views

how to install linux-headers-3.5.0-32-generic [duplicate]

When i try to install some apps i get a message: linux-headers-generic-lts-quantal : Depend: linux-headers-3.5.0-32-generic but it is not installable uname -a Linux ubuntus 3.5.0-27-generic ...
3
votes
1answer
2k views

I cant upgrade anything

I will give a bit of a back story to how I got this issue, The first issue I has was I have a full /boot disk and could not do anything. I moved some of the unused config files to another disk and ...
1
vote
0answers
232 views

dpkg error when installing linux

After running: sudo apt-get -f install or sudo apt-get install linux this error appears: dpkg: error processing linux-generic (--configure): dependency problems - leaving unconfigured dpkg: ...
1
vote
0answers
765 views

Why the installation fails for this package? it says linux-headers not found but it is there

This package is failing to get installed, but the linux-headers are installed. root@sun-Alienware-X51:/var/tmp# uname -a Linux sun-Alienware-X51 3.5.0-28-generic #48~precise1-Ubuntu SMP Wed Apr 24 ...
0
votes
2answers
610 views

12.04-server update failure after full /boot, apt not working, unmet dependencies to non exiting linux-image kernel

Unattended upgrade failed after full /boot partition. Creating disk-space by deleting old kernels with the recommended command sudo apt-get purge linux-image-x.x.x-x-generic does not work and gives ...
2
votes
1answer
1k views

Unmet dependencies when I tried to free up unused kernels

I am running 12.04. I read this http://askubuntu.com/a/90219/18876 as reference. I checked all the one I have. yeukhon@fubini:~$ aptitude search ~ilinux-image i linux-image-3.2.0-29-generic-pae ...
0
votes
1answer
508 views

WiFi not working on MacBook Pro running 12.10

I've seen many other posts like this and found one other where the problem was resolved, but the terminal commands given were for a different pcid than mine. I ran several commands including: sudo ...
2
votes
1answer
626 views

upgrade has a problem

when I use: sudo dpkg --configure -a I get this: Setting up rsyslog (5.8.6-1ubuntu9.1) ... dpkg: error processing rsyslog (--configure): subprocess installed post-installation script returned ...