The Java Runtime Environment.

learn more… | top users | synonyms

296
votes
23answers
474k views

How can I install Sun/Oracle's proprietary Java JDK 6/7/8 or JRE?

I want to install Oracle's JRE and to update to the latest version with the Software Updater when they released. Is there a Ubuntu package that is provided by Canonical or Oracle? Before release Java ...
252
votes
0answers
338k views

How do I install Oracle Java JDK 7? [duplicate]

If I downloaded the latest JDK from Oracle, do I just download the .tar file and extract it to /usr/lib/jvm/?
13
votes
2answers
13k views

Changing JVM in Java

I only recently discovered the different JVM's on the wiki page and thought I'd start tinkering. Its been difficult to find documentation on how to configure Java on Ubuntu though. Lets say I wanted ...
12
votes
6answers
30k views

How do I make java default to a manually installed JRE/JDK?

I have Ubuntu 12.04 amd64 installed on my machine, on the previous versions of Ubuntu it was deadly easy, now there is this command update-java-alternatives with a really bad man page. I just have my ...
9
votes
8answers
26k views

Java JRE will not install due to “tar: Error is not recoverable” error

I have been trying to get Java for the past day now. I followed several tutorials but I keep getting the same error. After I put in tar -xvf jre-7u4-linux-i586.tar.gz it says Cannot open: No such file ...
6
votes
1answer
27k views

“Please ensure you have JAVA_HOME points to JDK rather than JRE” message

I have java installed aaa@ubuntu:~$ whereis java java: /usr/bin/java /usr/bin/X11/java /usr/local/java /usr/share/java aaa@ubuntu:~$ whereis javac javac: /usr/bin/javac /usr/bin/X11/javac and ...
5
votes
2answers
12k views

Cannot get Java to work in Firefox

In Firefox 17 on Ubuntu 12.04, I cannot get the Java verification applet to work (needless to say I cannot get any Java applications on the browser working). I already tried uninstalling and ...
3
votes
2answers
1k views

How do I install a 32-bit Java runtime on an amd64 server with multiarch?

I'm a long time Ubuntu user, but I haven't been following the community for the last several versions. I just did fresh default minimal amd64 install of Oneiric and I need a 32-bit JRE for a ...
2
votes
4answers
3k views

Chrome reports Java plugin outdated

I've just installed the latest version of JRE (7u5) and Chrome still reports that it's outdated. When I go to chrome://plugins/, it shows the following line for Java: Java - Version: 1.7.0_05 ...
2
votes
2answers
1k views

SmartGit crash in ubuntu 13.10

When I try select repository application crash. It's perhaps bug https://bugs.launchpad.net/ubuntu/+source/java-common/+bug/1241101
2
votes
1answer
178 views

Is it safe have more than one version of java?

This question popped up when I tried to download a game for dolphin emu. The site isohunt recommended I use vuze and vuze requires jre. Silly me, as a windows noob, I immediately thought I d have to ...
2
votes
1answer
3k views

Package sun-java6-jre needs to be reinstalled

I installed JRE 1.6u33, and there was a screen that came up asking me to accept the terms of service. I didn't know how, so I closed out of that screen without pressing Ok. Now, I can't install ...
2
votes
1answer
2k views

if I install JDK do I also need to install JRE

if I install JDK 1.7 do I also need to install JRE 1.7 to support Tomcat? I have installed the openJDK package and that seems to include JRE. java -version shows that java 1.7 has been installed
2
votes
1answer
652 views

JREs from different vendors on the same system

In various tutorials, it is said, that you should remove existing JRE/JDK before installing new one (e.g. remove OpenJDK before installing the one from Oracle). Is it really necessary? I remember ...
2
votes
1answer
49 views

yEd shows no windows

I want to use the latest yEd graph editor on my machine with Ubuntu 14.04 running on it as the only OS. I downloaded yEd installer script for 64-bit Linux. Also: $ java -version java version ...
2
votes
1answer
461 views

How to run 32bit eclipse (ODeV) on 64 Bit Ubuntu 13.04

How to run 32bit eclipse (ODeV) on 64 Bit Ubuntu 13.04? Problem is 64 bit version of ODeV preconfigured eclipse does not exists.... so I have to use 32bit one which doesn’t start on U64 bit. ...
2
votes
1answer
189 views

Why doesn't java -version return anything with Oracle's JRE 7?

I've been following these steps and got up to the check version of new JRE installation part but java -version doesn't return anything. I have run sudo update-alternatives --install /usr/bin/java ...
1
vote
1answer
96 views

Turkey.gov.tr libpkcs11wrapper.so Ubuntu Generic thing

While trying to access https://www.turkiye.gov.tr/ using smart identity cards, browser Java Application whether if you have libpkcs11wrapper.so file on your library. General thing is when you search ...
1
vote
2answers
3k views

A fatal error has been detected by the Java Runtime Environment

I wanted to install WindRiver Workbench for VxWorks development on my Linux host. I got the correct license file and everything but my JRE seems to crash, I get the error: Launching installer... # ...
1
vote
1answer
698 views

Adding a library to Java CLASSPATH

I am not sure if my question is more related about Ubuntu or Java, so pardon me! I am trying to compile a java program but I get the following error: package javax.comm does not exist I have ...
1
vote
2answers
2k views

How to install JRE-7 on Xubuntu?

I have followed the other question and did not succeed. mv: cannot move './jre1.7.0_04' to '/usr/lib/jvm/jre1.7.0': No such file or directory Is it installed into the 32bit compatible /lib directory ...
1
vote
1answer
2k views

Installing Oracle Java JRE 7, Terminal Command Not Recognizing Moved File

I'm having a small problem. I've been trying to work Minecraft into working using Wine. Over the past few hours, I've been working with Java over and over (long story, I'll keep it relevant) and have ...
1
vote
1answer
44 views

Where is my Java compiler 1.8, in Eclipse?

1- I installed openjdk8 2- In Eclipse (v3.8.1) -> window -> preferences -> Java -> installed JREs, I added the related standard VM. 3- In Eclipse -> Project -> Properties -> Java build path, I ...
1
vote
1answer
73 views

SIGBUS error with JRE when using eclipse

I encountered a SIGBUS error when starting up eclipse. There was nothing wrong before this, I've just turned on the laptop and the error appears: $ eclipse # # A fatal error has been detected by the ...
1
vote
4answers
720 views

Flash Player Issue In Chromium In Ubuntu 14.04

I needed to download youtube videos and it asked to download plugin from Java website. Adobe Flash Player is required to display some elements on this page. Install plug-in. I downloaded this. ...
1
vote
1answer
527 views

install JRE 1.6 on 1.5 JDK

I have Oracle JDK and JRE 1.5 installed ubuntu LTS. I want to keep JDK 1.5 and install Oracle JRE as 1.6. please let me know the steps or any clear source where I can get this done
1
vote
0answers
22 views

Installing Novell Designer [duplicate]

i try to install Novell Designer 4.0.1 on Ubuntu. But i get the error message: Preparing to install... Extracting the JRE from the installer archive... Unpacking the JRE... Extracting the ...
1
vote
0answers
33 views

Running java applets in the browser [duplicate]

Possible Duplicate: How do I install Java? With my 12.04, if I point my browser (either firefox or chrome) to http://www.java.com/en/download/testjava.jsp it will say that java is not ...
0
votes
3answers
126 views

Packaging jre 7 binary file license questions?

Notice jre and jdk 7 have new license agreement. Am I able to include binary jre without additional license?
0
votes
1answer
197 views

Installation of a second Java SDK

I have Java sdk 1.7 installed correctly. It turns out I need the version of 1.6 also (an application needs it). How do I install the version of 1.6 and how do I make sure that we'll both work ...
0
votes
1answer
655 views

I need the Best/Most Secure Supported JRE for LibreOffice

I want to utilize the Java supported functions of LibreOffice (database/Macros), but I know Java is known to be insecure (notably the latest, cross-platform, zero-day exploit). What is the best ...
0
votes
2answers
2k views

Installing Spark on ubuntu

I am installing Spark IM Client for Ubuntu. The tar.gz doesn't appear to be functional at ALL, (considering the /bin directory is completely empty and lacks important things like unpack200) but I ...
0
votes
1answer
2k views

Removing openjdk-6-jre without the installation of sun-java6-jre

I have alrady installed (manually, from the .bin file) the latest jre (Version 6 Update 30) from oracle and now i want to remove the openjdk-6-jre. However, apt forces me to install old (Version 6 ...
0
votes
2answers
278 views

Eclipse Execute from Home - Eclipse.org Version

Due to a lot of minor errors with the eclipse from the repository( cannot install mylyn or pydev due to unmet dependencies) I manually downloaded from eclipse.org. I have not had this problem before ...
0
votes
1answer
1k views

Remove openjdk-7-jre but apt-get requires to install openjdk-6-jre, etc

I installed openjdk-7-jre and icedtea-7-plugin to use webex in FireFox in Ubuntu 12.04 yesterday. Now I don't have to use JRE so I remove it. But the apt-get says that it will install openjdk-6-jre ...
0
votes
1answer
1k views

Downloading Java JRE

Today, I have been trying to install Java JRE. I have meet some problems. I downloaded the file from Java's website. The file name is jre-7u25-linux-i586.tar.gz. I then extracted the file and have it ...
0
votes
1answer
2k views

JDK/JRE explanation of comands for install

Maybe this is a simple question. I don't find the explanation of the commands for install Java JDK and JRE I downloaded the jdk-7u5-linux-x64.tar.gz and jre-7u5-linux-x64.tar.gz, I extracted these ...
0
votes
1answer
7k views

How to Install JDK 1.7 using a RPM package?

Edit Start I have had eclipse running for a while now. And have been developing a java based server. Edit End Today, eclipse, java project, right click, properties, java build path (jdk 1.6) is ...
0
votes
1answer
1k views

Web start (jnlp) problem with Oracle 7 Java

I have just met a annoying problem with my java. I tried to install jre and jdk on my Ubuntu 12.04 but something must have go wrong. I can run java -version to see java version and javac -version to ...
0
votes
1answer
125 views

Problem while updating :(

I am using Ubuntu 12.04 LTS. And I recently installed Open JDK from the Software Center and also the Iced Tea Plugin. From that time, whenever I install any updates or packages, this error pops up. ...
0
votes
2answers
4k views

How do I remove SUN Java and use OpenJDK instead?

As a programmer I use java for learning to code in Netbeans. I installed Sun java 6 long time ago over openJDK that came with my ubuntu just cause it seemed more responsive... Now that oracle left ...
0
votes
0answers
29 views

Eclipse crash kubuntu 14.10

I have a problem with eclipse (Version: 3.8.1 Build id: debbuild) on Kubuntu 14.10 Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0 # # A fatal ...
0
votes
0answers
179 views

Installing java 8:update-alternatives: error: alternative path /usr/lib/jvm/jdk1.8.0/bin/java doesn't exist

I know this question might seem like a duplicate question, but I think its not. I'm trying to install java 8 on my ubuntu 14.04 LTS. I have tried many method, but nothing worked for me. So I ...
0
votes
1answer
78 views

How to downgrade Java. For example Java 7u72 to 7u67

How can I downgrade java 7 to update 67 as suggested by this Check Point issue? I need this to install Check Point VPN. I have to install Java 7u67. How can I do it? How can I install specific ...
0
votes
0answers
75 views

Java RTE on Ubuntu 14.04.1 64-bit with Google Chrome

I am an Ubuntu 14.04.1 64-bit user who prefers Google Chrome as the default browser. I installed Java on my system and got it work with Mozilla Firefox; however, Google Chrome(Version 39.0.2171.71 ...
0
votes
0answers
21 views

java installation not sucessful on ubuntu 14.04

I tried to install java from terminal but failed to install and got error like dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
0
votes
0answers
172 views

Eclipse Luna(4.4.1) can't find the JRE for jdk1.8u25

I recently installed jdk1.8u25. The java codes are working fine in the terminal but in eclipse it is not working. Can anyone give any solutions for this?
0
votes
0answers
320 views

Help installing Matlab R2014b on Ubuntu 12.04

First of, I've just recently started using Ubuntu and I really don't know my way around it. I have installed it on my chromebook, because I need access to some programs that don't exist as chrome ...
0
votes
1answer
806 views

How to install JRE 7u60 on Ubuntu 14.04 using the tar.gz file? [duplicate]

How do I install JRE without PPAs or anything but the tar.gz file I downloaded from: http://www.java.com/en/download/manual.jsp?locale=en
0
votes
2answers
568 views

Problem in executing a jar file in ubuntu 14.04LTS

I have latest ubuntu 14.04 LTS + java 1.7.0_55 + IcedTea 2.4.7 installed However when i try to execute a jar file i get the notification: "This application requires a newer version of the Java ...