The Java Runtime Environment.

learn more… | top users | synonyms

0
votes
2answers
65 views

Java / Minecraft “Error: Could not find or load main class –Xms1024M”

I am not a Linux pro nor a Java pro, but I am setting up a Minecraft server on Ubuntu 16.04. System has 8GB RAM. I followed all the directions for setting up the server (which is very simple) but ...
2
votes
3answers
56 views

Azureus runs fine on latest java but its dependency check asks for dated version of JRE. How to tell Ubuntu to stop naggin me for “unmet dependency”?

So I force installed Vuze (and its dependency Azureus) via apt-get, and it is working fine on default-jre. Even though the default-jre works as a dependency for Azureus (at least for my use-case ...
0
votes
1answer
35 views

Which JRE should I install for macros in Libre Office for Xenial

I have a clean Ubuntu 16.04 install, and opening Libre Office, it said it requires a JRE installed before I can run or write macros. I want to write VBA macros. Running apt search jre shows many ...
0
votes
1answer
66 views

Installing of jdk and jre 1.8 in Ubuntu 14.04

I tried with all the types possible of installing Java for example: sudo add-apt-repository ppa:webupd8team/java -y sudo apt-get update sudo apt-get install oracle-java8-installer Even I deleted ...
0
votes
2answers
25 views

Executing file with other application through terminal

Is there any way for me to execute a .jar file with JRE through the command line. I'm having an issue with the file and I wanna see if I can get any information as to what the error is. When I try to ...
1
vote
1answer
22 views

Gephi crashes while loading the sample file

I was trying to install gephi for some network analysis. Initially there was problem with the Java Runtime Environment that is installed. I removed the Open JRE and installed the Oracle JRE 8u77. Even ...
0
votes
1answer
40 views

jre and jdk installation

I got following error while installing the open jdk from ubuntu 14.04. how do i solve this ? You might want to run 'apt-get -f install' to correct these: The following packages have unmet ...
0
votes
0answers
17 views

Can't compile scala

$ scalac test.scala error: error while loading CharSequence, class file '/usr/local/java/jdk1.8.0_72/jre/lib/rt.jar(java/lang/CharSequence.class)' is broken (bad constant pool tag 18 at byte 10) one ...
0
votes
1answer
299 views

How to install JRE on ubuntu 15.10?

I have Java version 1.7.0_91 installed in my Ubuntu PC. I installed it using the command sudo apt-get install default-jdk so, I think only JDK is installed but not the JRE. So what can I do to ...
0
votes
0answers
52 views

Symlink not working

I am trying to link java plugin to Opera. I have tried all sorts of methods. These are Opera's instructions for after JRE's installation: So that Java will be discovered, type the following ...
0
votes
0answers
38 views

How to handle Java and software installation

I am not a Java expert and I am trying to understand how java relates to different programs. After some program installations (latest versions) I think that the default java is changed and I ...
0
votes
0answers
45 views

I am trying to install . exe file with wine and getting error “unable to find JRE 1.5.0 or later version in your system”

in the errors.log it says this : "Sat Jan 16 21:08:16 2016 Unable to find JRE 1.5.0 or a later version on your system. Sat Jan 16 21:08:16 2016 Please install the JVM and re-start this installer." i ...
1
vote
0answers
32 views

JRE reinstallation error - Cannot install or upgrade any package

This error occurs everytime I try to install or check for updates. I simply cannot do anything. E:The package jre1.8.0-66 needs to be reinstalled, but I can't find an archive for it.
3
votes
0answers
34 views

Is there anything wrong with java-package?

There is a question about How can I install Sun/Oracle's proprietary Java JDK 6/7/8 or JRE? There are 23 answers at the moment, most of them are either explaining how to do it manually (unpack, move ...
2
votes
1answer
312 views

how can i upgrade only jre from 7 to jre 8 on ubuntu 1404

I currently have the jre 7 and need to upgrade to 8 on ubuntu 1404. I need only JRE upgraded to 8 for demo purpose. Could you please guide me on this? java version "1.7.0_79" OpenJDK Runtime ...
1
vote
2answers
461 views

Java Runtime Environment 1.4.2 Installation

I´ve got HP Proliant dl380 g3 and I can´t use few things from the "iLO(integrated lights-out)" because this tool needs the Java Runtime Environment 1.4.2 to run in my browser HP does not support ...
0
votes
0answers
179 views

trying to install pycharm but need to install JDK first

gives me this error The following packages have unmet dependencies: openjdk-6-jre-headless : Depends: ca-certificates-java but it is not installable Depends: java-common ...
1
vote
1answer
241 views

Error while installing or updating anything

Since I was trying to install Java manually which I couldn't doing I have been having these errors while trying to install or update anything through terminal or update manager. (Reading database ...
0
votes
1answer
663 views

How to backup Exception Site List in Java Control Panel?

I'm backing up my laptop before formatting and re-installing it. I would like to back up the "Exception Site List" in the Java Control Panel so I will not have to re-insert all sites again. The ...
0
votes
1answer
157 views

Installing openJDK along with java oracle

I have java oracle 7 installed. To build some library from the source code I do have to install openJDK 7. I don't know why they require but they do require it. What's the safe way to install ...
4
votes
1answer
2k views

jre not installed on firefox when using Citrix Access Gateway

I'm trying to get to my vpn / citrix access gateway using Firefox 38.0 for Ubuntu Canonical 1.0 Ubuntu 14.04 and when I try to log in I get this error: JRE is not installed on your machine. Install ...
1
vote
0answers
101 views

Run jar from Nautilus - OpenJRE disappeared!

Although I'm frequently using the command line terminal, I find it very irritating when I cannot execute applications from Nautilus. I sometimes write small Swing based Java apps and I've just ...
0
votes
3answers
474 views

How to Verify JAVA_HOME path

I installed java in opt/jdk1.7.75 having following directories--> bin db include jre lib man COPYRIGHT LICENSE README.html relase & other files I set JAVA_HOME path in .bashrc file as follow: ...
1
vote
0answers
193 views

Ubuntu, JavaFX, A fatal error has been detected by the Java Runtime Environment

I have already asked this question here: link to StackOverflow I have installed Ubuntu 14.04.02 x64, oracle JDK 1.8.4 and I try to run JavaFX8 project but I get this message in eclipse(not every time ...
1
vote
1answer
4k views

Installing java 8:update-alternatives: error: alternative path /usr/lib/jvm/jdk1.8.0/bin/java doesn't exist

I know this question might seem like a duplicate question, but I think its not. I'm trying to install java 8 on my ubuntu 14.04 LTS. I have tried many method, but nothing worked for me. So I ...
1
vote
1answer
7k views

Where is my Java compiler 1.8, in Eclipse?

I installed openjdk8 In Eclipse (v3.8.1) -> window -> preferences -> Java -> installed JREs, I added the related standard VM. In Eclipse -> Project -> Properties -> Java build path, I changed the JRE ...
1
vote
1answer
6k views

How to downgrade Java. For example Java 7u72 to 7u67

How can I downgrade java 7 to update 67 as suggested by this Check Point issue? I need this to install Check Point VPN. I have to install Java 7u67. How can I do it? How can I install specific ...
1
vote
1answer
258 views

SIGBUS error with JRE when using eclipse

I encountered a SIGBUS error when starting up eclipse. There was nothing wrong before this, I've just turned on the laptop and the error appears: $ eclipse # # A fatal error has been detected by the ...
2
votes
1answer
154 views

yEd shows no windows

I want to use the latest yEd graph editor on my machine with Ubuntu 14.04 running on it as the only OS. I downloaded yEd installer script for 64-bit Linux. Also: $ java -version java version ...
0
votes
1answer
1k views

How to install JRE 7u60 on Ubuntu 14.04 using the tar.gz file? [duplicate]

How do I install JRE without PPAs or anything but the tar.gz file I downloaded from: http://www.java.com/en/download/manual.jsp?locale=en
0
votes
2answers
1k views

Problem in executing a jar file in ubuntu 14.04LTS

I have latest ubuntu 14.04 LTS + java 1.7.0_55 + IcedTea 2.4.7 installed However when i try to execute a jar file i get the notification: "This application requires a newer version of the Java ...
2
votes
2answers
5k views

A fatal error has been detected by the Java Runtime Environment

I wanted to install WindRiver Workbench for VxWorks development on my Linux host. I got the correct license file and everything but my JRE seems to crash, I get the error: Launching installer... # ...
2
votes
1answer
315 views

Turkey.gov.tr libpkcs11wrapper.so Ubuntu Generic thing

While trying to access https://www.turkiye.gov.tr/ using smart identity cards, browser Java Application whether if you have libpkcs11wrapper.so file on your library. General thing is when you search ...
1
vote
4answers
1k views

Flash Player Issue In Chromium In Ubuntu 14.04

I needed to download youtube videos and it asked to download plugin from Java website. Adobe Flash Player is required to display some elements on this page. Install plug-in. I downloaded this. ...
0
votes
1answer
106 views

Need help installing java jre

I need help installing java NOT THE DEVELOPER VERSION I can only find about the jdk here. Help? Is there easy installers anywhere?
1
vote
1answer
2k views

Remove openjdk-7-jre but apt-get requires to install openjdk-6-jre, etc

I installed openjdk-7-jre and icedtea-7-plugin to use webex in FireFox in Ubuntu 12.04 yesterday. Now I don't have to use JRE so I remove it. But the apt-get says that it will install openjdk-6-jre ...
3
votes
1answer
6k views

if I install JDK do I also need to install JRE

if I install JDK 1.7 do I also need to install JRE 1.7 to support Tomcat? I have installed the openJDK package and that seems to include JRE. java -version shows that java 1.7 has been installed
1
vote
3answers
418 views

Packaging jre 7 binary file license questions?

Notice jre and jdk 7 have new license agreement. Am I able to include binary jre without additional license?
0
votes
2answers
2k views

Installing Matlab on ubuntu 12.04 32 bits

I have been trying to install Matlab2012a, matlab2012b and Matlab2013a for like 4 hours, triedto fix my prospective errors regarding the posts 2012a, Ubuntu-Matlab Documentation and Matlab-central. ...
2
votes
2answers
1k views

SmartGit crash in ubuntu 13.10

When I try select repository application crash. It's perhaps bug https://bugs.launchpad.net/ubuntu/+source/java-common/+bug/1241101
0
votes
2answers
125 views

Do I need JDK & JRE in Ubuntu?

In Windows 7 I had to install jdk & jre to program with eclipse. In the software center I can only find OpenJDK Java 7 Runtime. Do I need both to program in eclipse?
2
votes
1answer
855 views

How to run 32bit eclipse (ODeV) on 64 Bit Ubuntu 13.04

How to run 32bit eclipse (ODeV) on 64 Bit Ubuntu 13.04? Problem is 64 bit version of ODeV preconfigured eclipse does not exists.... so I have to use 32bit one which doesn’t start on U64 bit. ...
1
vote
1answer
2k views

Downloading Java JRE

Today, I have been trying to install Java JRE. I have meet some problems. I downloaded the file from Java's website. The file name is jre-7u25-linux-i586.tar.gz. I then extracted the file and have it ...
1
vote
1answer
715 views

install JRE 1.6 on 1.5 JDK

I have Oracle JDK and JRE 1.5 installed ubuntu LTS. I want to keep JDK 1.5 and install Oracle JRE as 1.6. please let me know the steps or any clear source where I can get this done
0
votes
1answer
733 views

Java not finding libraries in CLASSPATH

I have a JAR file, which has many dependencies (ApacheCommons stuff mostly). When I put all those JAR's in the same directory as my main JAR, everything works fine. But that makes a mess and it also ...
0
votes
1answer
218 views

custom ubuntu iso image with java [duplicate]

I want to build custom Ubuntu image(.iso) file with JRE and my application. I've already built my application on ubuntu. This ubuntu image i'm going to build should only run my application.I want a ...
0
votes
1answer
527 views

can't install jre ( java runtime enviornment ) in ubuntu 10.10? [duplicate]

I know my Ubuntu 10.10 is no more supported. I want to install JaxoDraw and for that I need to install JRE ( Java Runtime Enviornment ). Is there any way to install it manually? Please help.
1
vote
0answers
24 views

Installing Novell Designer [duplicate]

i try to install Novell Designer 4.0.1 on Ubuntu. But i get the error message: Preparing to install... Extracting the JRE from the installer archive... Unpacking the JRE... Extracting the ...
1
vote
2answers
13k views

Installing matlab on Ubuntu 12.04 32bits

I am trying to install Matlab on Ubuntu 12.04, I have a 32bits machine. I downloaded the files and set the file install to exectable, then run : $ ./install -v but then I got the error : Error : ...
0
votes
1answer
1k views

I am trying to install the Oracle java sdk and jre manually on ubuntu 12.10 [duplicate]

I installed the Oracle jdk1.7.0_25 and the Jre1.7.0_25 on Ubuntu 12.10. I used the install method at http://www.noobslab.com/2012/12/install-oracle-java-7-in-ubuntu.html. When I execute "java ...