Java is a programming language originally developed by Sun Microsystems. Questions here should be about the installation, configuration and troubleshooting a JVM (Java Virtual Machine) or a JRE (Java Runtime Environment). Programming questions (unless directly related to Ubuntu) should be asked ...

learn more… | top users | synonyms

1
vote
1answer
2k views

.pigbootup not found

I have a problem trying to get this command to run. I've got all the files in the correct directories, and i'm running the command from within the correct directory. I've downloaded and unpacked Pig,...
1
vote
1answer
598 views

Can't run InstallJava executable file

I can't seem to run a Java executable file, even though I've already installed the latest jdk. See the below screenshot. Am I using the right command, via: ~$ open InstallJava or is ~$ ./InstallJava ...
0
votes
1answer
801 views

Cant mark minecaft as executeable in xubuntu 14.04

I cant mark minecraft as executeable, I try rightclicking minecraft and starting it up with java 7, but i need to mark it as executeable, If i go to "properties" and go to "Permissions" it does not ...
0
votes
2answers
2k views

Eclipse Kepler crashes on Ubuntu 14.04 when using WindowBuilder

I'm using Ubuntu 14.04 and with a lot of problems I have to face daily with this OS, there is another recent one. Problem: Whenever I try to use Eclipse's WindowBuilder to design SWING GUIs, after a ...
0
votes
2answers
1k views

Can't install Openjdk 1.6 in ubuntu

Accidentally I removed Openjdk from Ubuntu. Now it is not possible to install it again.It gives error that: Err http://in.archive.ubuntu.com/ubuntu/ precise-updates/main tzdata all 2014c-0ubuntu0.12....
0
votes
1answer
194 views

My minecraft has a very low FPS rate and freezes every second on 12.04 LTS

I recently installed Minecraft on my Ubuntu 12.04 LTS computer with all the correct Java packages and LWJGL, but when I go to play it, the FPS rate drops to ~3 fps and freezes every second, making ...
0
votes
1answer
2k views

Can't switch compliance level in Eclipse

So after reading another question post I realized my question had changed. It is essentially, why can't I change my compliance level in Eclipse from 1.6 to 1.7 but I'm going to leave the body of my ...
1
vote
2answers
6k views

Gradle finds wrong JAVA_HOME even though it's correctly set ubuntu 13.10

I have just installed gradle from the terminal sudo apt-get install gradle After finishing am trying to run the command gradle -v I get the following error ERROR: JAVA_HOME is set to an ...
0
votes
1answer
2k views

Ubuntu league of legends very slow

First let me introduce myself. i am Raul, the CEO of CobraStudios. I just started using Linux ( Ubuntu ). Now i have an problem fixing everything i want to have on linux. Like Minecraft, League of ...
0
votes
2answers
137 views

Command for checking the default terminal

My Situation Is: I am trying to make a simple IDE for NASM in Java. When I execute a .asm file in my IDE it open the terminal and shows the output. I am using xterm for this purpose. Now the problem ...
2
votes
1answer
6k views

Oracle-xe 11g installation on ubuntu 14.04

I tried to install the oracle-xe 11g rpm package. I tried to follow the oracle pdf provided by the oracle site. I run: rpm -ivh oracle-xe-11.2.0-1.0.x86_64.rpm and I get the following: glibc >=...
0
votes
1answer
197 views

How can I open jnlp files with “lbnetx-java”?

What is libnetx-java package and how can I use it (to open '.jnlp' files)?? Thank you.
4
votes
1answer
1k views

Is there any way of adding an DSN in Ubuntu?

I am using Java-JDBC and Mysql is my database.. I want to have some Standard ODBC DSN like in windows....Is there a way of setting DSN(Data Source Name) in ubuntu for Mysql/ODBC Drivers ??
0
votes
2answers
802 views

Problem in Installing xdman in Ubuntu via terminal

I downloaded xdman in Ubuntu via the terminal using the command, apt-get install xdman However upon downloading when I try to run xdman using the "xdman" command in the terminal I got error ...
1
vote
0answers
212 views

Java still dont recognize horizontal scroll (right click) 14.04

I am totally trackpoint fan, I use it all the time and have disablet my touchpad. Due to my study I work a lot with MATLAB, but MATLAB uses Java, and horizontal scroll does not be recognized by java ...
1
vote
2answers
2k views

How do I work around a “stack size specified is too small” error in Java on POWER8?

I am trying to run Java applications (ElasticSearch and Cassandra) on Ubuntu (14.04) running on Power PC hardware using the OpenJDK. I ran into an error: The stack size specified is too small, ...
1
vote
1answer
1k views

Perrmision denied after /etc/profile while installing Java

I am trying to install Java. I have to reload my system wide PATH from /etc/profile by typing the following command: /etc/profile And then I get the error: bash: /etc/profile: permission denied ...
0
votes
2answers
597 views

NetBeans has broken interface with OpenJDK

Sorry for English. Usually (say, at 4/5 of times), when I start NetBeans, interface is partially broken. For example, menu items are appearing and at once disappearing after click; some parts of ...
3
votes
1answer
11k views

JDK 8 install in ubuntu [duplicate]

I'm tring to install jdk 8 for weeks, but it fails.Following are some outputs, sudo update-alternatives --config java There is only one alternative in link group java (providing /usr/bin/java): /opt/...
0
votes
1answer
1k views

How to update Java version to 7 or 8 using the ppa link ? [duplicate]

I have already tried to: Re-install ca certificates Run: sudo -E apt-add-repository Add repository links to the etc/apt/sources.list manually. None of the above worked. I am trying to run IGV ...
2
votes
0answers
104 views

Weird java memory allocation

My task manager shows that for my java process memory allocated is 16777216.0 TB (yep, TB). It happens when programming swing application with eclipse 3.8. Oh, and my distro is lubuntu 14.04. Nothing ...
1
vote
0answers
546 views

Can Ubuntu for tablets run Java applets?

Can Ubuntu for tablets run JAVA applets in browser? My bank has netbanking build in Java and I need to use it on my android tablet which does not support Java browser applets. Don't have experience ...
0
votes
0answers
10 views

java problem all over again [duplicate]

When I try to run something that requires java, I get this message: "Java(TM) is required to display some elements on this page.". Next to it is offered a link to install plug-in. First it was offered ...
0
votes
1answer
523 views

java plugin stoped working on Chrome [duplicate]

Ubuntu 12.04 here. My java-6-openjdk-amd64 Java plugin was fine until I installed the last week-or-two system updates. Now when I verify java Google Chrome gives me the Install Plugin yellow bar.. I'...
0
votes
1answer
289 views

Installing IcedTeaPlugin for Chrome

I am trying to get the java plugin to work on chrome but have failed so far. I made symbolic links for the two files : IcedTeaPlugin.so and libjavaplugin.so I made the links in the file section /opt/...
2
votes
1answer
2k views

Subversion 1.8.8 doesn't work with Java svn libraries

I'm running an up-to-date 14.04 installation. In a Java project built with Ant, I'm using the <svn> task to grab the current revision information. I've got (as far as I can tell) up-to-date ...
1
vote
2answers
1k views

How are we able to run eclipse.exe in ubuntu?

I was following instructions to manually setup eclipse kepler in Ubuntu 14.04. Next create an executable for Eclipe at ~/bin/eclipse with your favorite text editor by typing vi ~/bin/eclipse or ...
1
vote
2answers
199 views

I can't download Java or WINE due to similiar error

I've been trying to download Java Oracle 8 and WINE and I keep getting the same problem. W: Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release Unable to find expected ...
0
votes
3answers
763 views

Eclipse and java 7 but no javac?

I have a java computer program that I can compile in Eclipse just fine. I want to compile it from the command line and get the message javac not found. I figured that I just didn't have my path setup ...
2
votes
2answers
471 views

OmegaT and Java Version

Installed omegaT from the Software Centre (Ubuntu 12.04). When I try to start it, I just get the error message: Suitable java binary not found. The output of java -version is: java version ...
3
votes
1answer
665 views

Java not working in Google Chrome Lubuntu 14.04 (32-bit)

I have Java 1.7.0_55 installed I have gotten it to work on firefox. My installed chrome version is Version 35.0.1916.114. I have already created the plugins folder in the chrome directory and made a ...
0
votes
3answers
425 views

how to install Jdk 7 on ubuntu 12.04 [duplicate]

I''ve downloaded tar file from oracle server but I don't know how to install it on my ubuntu linux system. Could you please provide step by step details on how to install it? Thanks
1
vote
2answers
4k views

Minecraft won't install

I tried to install minecraft on my computer, but it won't display on-screen. I went to https://www.minecraft.net/download and downloaded the jar file. I put the launcher on the desktop and tried to ...
59
votes
2answers
144k views

How do I get Java plugin working on Google Chrome?

Google has updated its Chrome browser to version 35. This new version uses Aura in place of GTK2 and no longer supports NPAPI plugins like Java (both OpenJDK and Oracle). PPAPI plugins like ...
1
vote
3answers
17k views

Java Plugin issue on chrome browser [duplicate]

I am running Ubuntu 14.04 64 bit. Installed java on this. Version 1.7.0_55. trying to enable java on google chrome but have failed. I symbolic linked libnpjp2.so to /opt/google/chrome/plugins ...
3
votes
2answers
2k views

Java windows open up off-screen (multi monitor setup with Ubuntu 14.04)

I'm on Ubuntu 14.04 (64 Bit) with Java 1.7.0_55 (openjdk-7-jdk:amd64, openjdk-7-jre:amd64). Most GUI Java applications start without any errors or warnings and their Icon shows up in the launcher, but ...
1
vote
0answers
563 views

JavaFx 3D does not run on Ubuntu 14.04

When trying to run the *javaFX 3D demo on my Ubuntu 14.04 (Gallium 0.4 on AMD REDWOOD, Java JDK 8u5), I get the fellowing error message: Executing /home/lehuythangit/NetBeansProjects/...
-1
votes
2answers
6k views

Downgrade Java 1.7 to Java 1.5

I am now on Ubuntu 14.04, and my Java version is java version "1.7.0_55". How can I remove 1.7 and install java 1.5. I tried several tutorials, but they are old and none of them worked for me.
10
votes
3answers
25k views

Tomcat does not recognize JAVA_HOME

I've installed Ubuntu 14.04 Server, extracted JDK1.8u5 and Tomcat7, and added the following to .profile (I also tried adding it to .bashrc with similar [non-] results): export JAVA_HOME=/opt/java/...
1
vote
1answer
1k views

Hash mismatch error while updating and trouble installing some packages

I am using Ubuntu 14.04 and my college provides us software repositories which we can access from inside the campus. I tried installing java and only after that I started getting the hash mismatch ...
0
votes
1answer
277 views

Unable to run javac though java is working [duplicate]

I am getting the error message below when I run javac on ubuntu terminal: The program 'javac' can be found in the following packages: * default-jdk * ecj * gcj-4.6-jdk * gcj-4.7-jdk * openjdk-7-...
1
vote
3answers
2k views

Netbeans installation doesn't work

While trying to install Netbeans 8.0 in my Ubuntu 14.04 I get the following error: Can`t initialize UI Running in headless mode Exception: java.awt.HeadlessException thrown from the ...
1
vote
1answer
1k views

Set All .jar FIles As Executable

I run Java programs alot on my computer. It runs the latest version of OpenJDK, which is OpenJDK 7. When I try to run a .jar file, it gives me an error saying that the .jar file was not marked as ...
29
votes
6answers
125k views

How to set the JDK for Android Studio?

I can't compile a default new project for Android 2.1 because(?) the JDK used by Android Studio is JDK 1.7 but it should be JDK 1.6. To change it I go to File -> Project Structure and try to find the ...
1
vote
1answer
1k views

“Your Java version is out of date.” on Ubuntu 2014.04

With fully updated Ubuntu 2014.04, Firefox tells me: Your Java version is out of date. How to update Java? Typing java -version in a terminal tells me: java version "1.7.0_51" Java(TM) SE ...
2
votes
2answers
5k views

A fatal error has been detected by the Java Runtime Environment

I wanted to install WindRiver Workbench for VxWorks development on my Linux host. I got the correct license file and everything but my JRE seems to crash, I get the error: Launching installer... # ...
1
vote
1answer
310 views

Why does Vim highlight Javadoc comments like this?

I am using vim to edit Java code. I added a Javadoc header above the class definition, but the syntax highlighting is very strange: read the Javadoc comment above Why is the first sentence ...
1
vote
1answer
296 views

ifconfig weirdly returns exit code 1

I am executing the following command to find the MAC Address of eth0 ifconfig eth0 | grep -o -E '([[:xdigit:]]{1,2}:){5}[[:xdigit:]]{1,2}' I have a java wrapper which just calls the script ...
1
vote
1answer
447 views

Aptana crashes on Git Commit in 14.04

Ever since I upgraded my machine to 14.04 - I cannot commit via Aptana's "Team" menu. I was having other, miscellaneous and unrelated problems, so I did a fresh install, and used Oracle Java instead,...
0
votes
1answer
745 views

How to tell javac which libraries to include

So I am trying to run a java file from Terminal. But the file is using the apache.commons.io lib, so a simple javac MyFile.java does not work here. How do you include the libraries in Terminal?