install-from-source refers to one method of installing software packages on Ubuntu without using the Software Center. It is generally not the recommended way of installing software.

learn more… | top users | synonyms

0
votes
1answer
13 views

How to change DPI in Ubuntu GNOME 14.04?

What I would like to do is "Change DPI to 144 in Ubuntu GNOME 14.04". Because it's first time to me to use linux, I installed VMware Player in my laptop, and I installed Ubuntu GNOME 14.04. My laptop ...
1
vote
3answers
198 views

How to install Telegram Desktop in Ubuntu 14.04 LTS

I want to install Telegram Desktop software on my Ubuntu 14.04 LTS. I have downloaded the tsetup.0.6.15.tar.xz file. Now I want to know how to proceed further.
0
votes
3answers
13k views

Is it possible to install Ubuntu through network?

I would like to install Ubuntu for almost 120 users. But it's very difficult in using USB and drives. please suggest ....
0
votes
2answers
3k views

How do I get iperf on a Ubuntu 13.10 Live disc?

I have Ubuntu 13.10 running from a live DVD disc. Unfortunately it does not include the iperf tool, so it will need to be added separately. I already tried the command below. apt-get install iperf ...
-2
votes
1answer
32 views

When installing applications, why do you have to do a make install? Why not just install it? Why compile? [closed]

This issue always stumped me with my years of linux installing stuff. I usually find an app i want to install and I just copy/paste the commands to have it run and install assuming random dependencies ...
20
votes
2answers
58k views

Install Popcorn Time from source files

How can I install Popcorn Time beta ? I see on their website that they only offer a 64-bit installation files, but the sources are open. I can't use the usual ./configure && make. So, what ...
1
vote
3answers
4k views

Flashplayer 11.1 on Ubuntu 12.04

I am new to Ubuntu and I've visited pretty much every webpage that exists on the internet about how to install canonical Flashplayers. Ubuntu 12.04 comes with Adobe Flashplayer 11.2 but that is not ...
2
votes
1answer
90 views

Synaptic and sudo apt-get update broken Ubuntu 14.10?

I just tried to build Riak unsuccessfully. Now something happened that messed everything up. When I try to start synaptic I get this: E: Type '500' is not known on line 1 in source list ...
10
votes
1answer
13k views

No acceptable C compiler found in $PATH

I want to install one package named speech_tools-2.1-release.tar.gz. After I run command ./configure in this package, it show me a message: Configure: error: no acceptable C compiler found in $PATH ...
1
vote
1answer
37 views

Building and using a lib without installing it? (e.g. libcurl)

I'd like to use libcurl (a lib that handles HTTP connections) by linking it statically to a program I am writing. I am new to building programs from their source, so I have no clue on how to do it ...
0
votes
0answers
9 views

Installing Memcached from source

I am trying to install Memcached to my VPS Ubuntu 12Lts but there is no package. I am following this site: https://code.google.com/p/memcached/wiki/NewInstallFromSource. First it says I need to ...
2
votes
0answers
52 views

compile and install calligra-2.8.6 from source

How do I compile and install calligra-2.8.6 from source? I couldn't find any text file or readme in the source folder that would show how to install it. This is not a duplicate of How do I install ...
1
vote
2answers
4k views

How can I install Celtx 2.9.7 properly on Ubuntu 12.04 LTS?

I am new to Ubuntu and Linux and I want to install and use the newest version of the screenwriting software Celtx on Ubuntu 12.04 LTS. After trying ...
0
votes
0answers
81 views

Blender not working on Ubuntu

I am trying to get Blender to start on Ubuntu. When starting the version from the official repositories, it starts, but the opening window does not go away unless I resize the window, and then ...
0
votes
0answers
32 views

Ubuntu install taking too long

I'm installing an upgrade for the first time in two years (I know). I was given various options and chose to keep existing files etc and upgrade to latest version. I am installing from a USB key. I am ...
0
votes
0answers
59 views

HOW TO INSTALL .tar.xz file [duplicate]

I recently downloaded gnome-shell-3.14.2.tar.xz Now I want to install it I tried opening it but it opened in archive manager.May I know how to INSTALL and UNINSTALL it also. THANKS
139
votes
9answers
1.2m views

How do I install a .tar.gz (or .tar.bz2) file?

I have downloaded tar.gz files. But I don't know how to install it. How do I install this kind of file?
0
votes
1answer
30 views

Trying to install from source. minisat

I am trying to install the following plugin of minisat. link But when I go in the directory using terminal and do make install. It gives an error install -d /usr/local/bin install -m 755 ...
2
votes
2answers
18k views

How to install TestDisk from source

I have just come downloading a software called testdisk-6.14-WIP.linux26.tar.bz2. Therefore I'm wondering how to deal with the installation.
0
votes
1answer
60 views

Replace prebuilt package with self-compiled version

I need to update my Point Cloud Library (PCL) that I installed via official instructions with my own version that I just compiled according to this manual. The reason is I need to fix a bug in PCL ...
5
votes
3answers
3k views

How do I install redshift 1.9.1?

I'm new to linux and I don't know how to install redshift 1.9.1, configure the color temperature and make it automatically start. I'm using Ubuntu 14.04 LTS.
2
votes
1answer
6k views

Permission denied while running make install

I am trying to install gtk-server. First I typed the command ./configure and then make, but when I typed command make install it gave me this error: ...
1
vote
4answers
219 views

Where can I get fresh new Wine DLLs?

I was acting careless today and I accidentally deleted one of the .dlls in my Ubuntu Wine installation, ~/.wine/drive_c/windows/system32/ole32.dll to be exact, and need a new fresh copy of only this ...
2
votes
3answers
657 views

How do I install mosml?

I need to get Mosml (Moskow sml) on to my system for university. I never installed anything that wasn't in the software manager or using wine (read: my console skills are low). the package is here: ...
1
vote
1answer
47 views

How to build a source file using make? [closed]

I am trying to build a source using make? This is the first time I am trying to do this as there is no other way to install the program. Contents of directory containing the source are shown here. I ...
0
votes
1answer
34 views

will my files still remain after OS replace install option?

I'd like to try the replace OS option of install....can my files (downloads etc) etc remain intact with this option post installation?
0
votes
0answers
9 views

Installing reaver on ubuntu 14.04 lts [duplicate]

I have such a message what does it mean shpejta@shpejta-DOA150:~/Downloads/reaver-1.4/src$ make install rm -f /usr/local/bin/reaver /usr/local/bin/wash /usr/local/bin/walsh rm: cannot remove ...
1
vote
1answer
18 views

'/usr/' versus '/usr/local/' for source installation

Are there any differences when you compile software and move it to either '/usr/local' or to the '/usr/' directories? Personally, I try to move everything to '/usr/local/' so I don't need to search ...
5
votes
5answers
1k views

Should I use “sudo” before “make install”?

I am installing the latest FFmpeg from this guide: In some places it suggests performing make install without sudo, here is a single example of several: cd ~/ffmpeg_sources wget ...
2
votes
1answer
97 views

uninstall package compiled from source

This question extends this one, where the advice is to use checkinstall in the future. Sound advice, but I wonder if it is possible to just repeat the compile process and then store the list of files ...
0
votes
0answers
53 views

How to upgrade a repository package from source without also upgrading its dependencies?

I tried to upgrade python3-sip from 4.15.5 (latest version in Ubuntu 14.04 repository) to 4.16.2 (latest version from source). However, the version being imported in python3 is still the old version: ...
-1
votes
1answer
110 views

E: Unable to locate package mkinitrd

root@cliu-HP-ZBook-15:/# apt-get install mkinitrd Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package mkinitrd Can ...
2
votes
1answer
897 views

How to Install vaio-control-center from source?

I have a problem about turning off keyboard backlight that I asked here with no useful answers. After searching on internet I find a package for vaio control center and downloaded it from here, I ...
2
votes
1answer
137 views

Installing software from source

I'm trying to understand the rational behind installing from software from source in Ubuntu 12.04. Obviously, I know I can download what I need from repos, but I want to develop a deeper understanding ...
15
votes
1answer
10k views

Installing the latest Node.js / MongoDB?

How can I install Node.js and MongoDB so they are the most current versions? The available versions from package manager are not up to date, and PPA from Chris Lea for Node.js doesn't get updated on ...
1
vote
1answer
61 views

Install from source does not work but apt-get works

I try to install from sources modified version of icewm but I get error so I decide to first install original version to see if it goes and I does not go. I installed icewm using apt-get: sudo ...
2
votes
1answer
26 views

Identify X libs during installation from source without sudo

I am trying to install a program (HTK) from source, but after ./configure (which doesn't give errors), make all complains that /usr/bin/ld: cannot find -lX11. This is a well-known problem which ...
-1
votes
1answer
388 views

How to install gmp 4.3.2 on ubuntu 14.04

I want to install gcc-4.4.3,for which I have to install gmp 4.3.2. When I run: ./configure make I get this error. Can you help me? make all-recursive make[1]: Entering directory ...
14
votes
4answers
707 views

How to manage software that is installed from source?

From time to time, we may have to install something from source due to various reasons. While it is fairly standard how to install software given appropriate dependencies, it is not clear to me how to ...
0
votes
0answers
31 views

Installed a software from source code, how to uninstall it? [duplicate]

Recently I've been doing some reading on FFmpeg, and so I was told that FFmpeg served by the Ubuntu official repository is outdated. I followed the official FFmpeg installation guide, and managed to ...
1
vote
1answer
102 views

Trouble installing specific .tar.bz2

I've used Ubuntu for over a year now and I have never gotten the hang of tarballs. I have a .tar.bz2, I've extracted it but I can't figure out where to go from here. I tried running ./configure but I ...
0
votes
1answer
2k views

config.status: error: cannot find input file: `Makefile.in'

I'm trying to install mod_WSGI on Ubuntu 12.04. Here is the set of commands that I'm following: wget http://modwsgi.googlecode.com/files/mod_wsgi-3.4.tar.gz tar xvfz mod_wsgi-3.4.tar.gz cd ...
1
vote
0answers
22 views

Discrepancy with Swish++ names

I asked this question earlier, but I still have no answer. The problem is: I use ubuntu 12.04, and I need to install Swish++ from the source code. I've downloaded the package from the official page ...
0
votes
1answer
151 views

New to Ubuntu (linux). Would like to install a printer. A bit clueless

I installed Ubuntu 13.10 on my old Dell desktop. It runs fine and I like the Ubunte experience. I found most software using the 'software centre'. But not for my Canon printer. I went to their website ...
0
votes
0answers
62 views

Raknet library how to install

I'm trying to install Raknet library on linux without results what I did: wget http://www.raknet.net/raknet/downloads/RakNet_PC-4.082.zip unzip RakNet_PC-4.082.zip cd RakNet_PC-4.082 cd Source ...
1
vote
2answers
66 views

How to install packages from Launchpad which are not in a PPA?

Launchapad contains a wealth of packages that are not usable (they seem to be in source form or something). For example, by searching for a "ndoc ubuntu" on google, I fell on the page ...
6
votes
2answers
2k views

LESS CSS compilers returning blank

I am not even sure where to start debugging this. Months ago, I could happily compile my CSS from my LESS files. Today, I run either recess --compile test.less or lessc test.less and I just get a ...
1
vote
2answers
1k views

How do I install WhatPulse?

I was expecting a .deb file but instead I got this: http://whatpulse.org/downloads/50/64bit/
0
votes
1answer
66 views

How to install an application from gitweb

I need to get the latest available version of an application called arm which is a terminal monitor for Tor. The download instructions [on the application webpage][2] has a link to an older version ...
1
vote
1answer
100 views

Which version of Banshee in repos with Ubuntu 14.04

I need to know which version of Banshee is the one in repos of Ubuntu 14.04 According to http://packages.ubuntu.com/trusty/sound/banshee It is 2.9.0+really2.6.2-2ubuntu2, so its is 2.9.0 OR 2.6.2?? ...