install-from-source refers to one method of installing software packages on Ubuntu without using the Software Center. It is generally not the recommended way of installing software.

learn more… | top users | synonyms

0
votes
1answer
205 views

Which is exact method to install from source?

I have run (gradually) following command to install gdebi from source: apt-get build-dep gdebi apt-get source gdebi cd gdebi-0.9.5.3 dpkg-buildpackage -uc -us -b Which gives me error (posted last ...
1
vote
1answer
5k views

Error 255 when trying to install openssl-1.0.1g from source

installing man1/cms.1 cms.pod around line 457: Expected text after =item, not a number cms.pod around line 461: Expected text after =item, not a number cms.pod around line 465: Expected text after ...
1
vote
0answers
246 views

Error 255 when installing openSSL from source

I need to build openssl from source because it's needed to build a mysql driver for android for Qt but when I do "make install" I get the following error: cms.pod around line 457: Expected text after ...
0
votes
1answer
172 views

cannot execute executable files x.run

I use Kubuntu 14 on HP Envy. I'm trying to install software (software: MPLAB® X IDE v2.05 and MPLAB® XC32 Compiler v1.31) from .run files this fails. The .run files have executable flags set: ...
2
votes
0answers
216 views

How do I install Foldit.tar.gz (specifically)?

NOTE: THIS IS NOT A DUPLICATE QUESTION. It is specific to Foldit.tar.gz and installing this game is done uniquely. There is an askubuntu page answering the question, "How do I install a .tar.gz (or ...
2
votes
1answer
772 views

How do I Install X13-arima-seats for Rstudio from source?

Hello all and thanks for interest! Im trying to install x13-arima-seats to be used with Rstudio. There are compiled version for RedHat and source available. I have followed these steps from the ...
1
vote
1answer
448 views

What is the good way to remove SDK and other soft?

I have installed AMD-APP-SDK-v2.9 using install script: ./Install-AMD-APP.sh Everything is ok and here is the installation log: 1) Starting Installation of AMD APPSDK v2.9 .... 2) 64-bit Operating ...
0
votes
1answer
182 views

New to Ubuntu (linux). Would like to install a printer. A bit clueless

I installed Ubuntu 13.10 on my old Dell desktop. It runs fine and I like the Ubunte experience. I found most software using the 'software centre'. But not for my Canon printer. I went to their website ...
20
votes
2answers
66k views

Install Popcorn Time from source files

How can I install Popcorn Time beta ? I see on their website that they only offer a 64-bit installation files, but the sources are open. I can't use the usual ./configure && make. So, what ...
0
votes
0answers
23 views

Discrepancy with Swish++ names

I asked this question earlier, but I still have no answer. The problem is: I use ubuntu 12.04, and I need to install Swish++ from the source code. I've downloaded the package from the official page ...
3
votes
1answer
9k views

Permission denied while running make install

I am trying to install gtk-server. First I typed the command ./configure and then make, but when I typed command make install it gave me this error: ...
-2
votes
1answer
228 views

installing antivirus [duplicate]

Why it is not possible to possible on ubuntu to install antivirus or other software just by downloading exe file instead of using command line? Im having all the pains to install free AVG 2014 on ...
1
vote
1answer
1k views

GitLab Omnibus Ubuntu 12.04

I am trying to build GitLab from the Omnibus project in my Ubuntu 12.04 64-bit following this link After issuing sudo apt-get install ruby ruby-bundler I downloaded the source from here and after ...
2
votes
0answers
171 views

Black screen after login when installing Mesa 10 from source

I wanted to update my Mesa version to 10.0, so I compiled it from source, installed it, rebooted and when I logged in, I had a black screen with only my mouse visible. I have reinstalled Ubuntu 13.10 ...
1
vote
1answer
95 views

Error while running make to install drivers

Everytime I want to run make while installing a driver, I get these error messages : make[1]: ***[_module_/home/alaa/Downloads/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012] Error 2 ...
2
votes
4answers
127 views

How can I build and install a Qt project/.pro?

I would like to install sqlite database browser from sourceforge. I downloaded the file and unzipped it with tar -xvf sqlitebrowser_200_b1_src.tar.gz Now it's a directory in my downloads with this ...
0
votes
1answer
2k views

Error compiling a package: “configure: error: no gstreamer-1.0 >= 1.0.0”

I am trying to compile a package, which requires gstreamer-1.0 >= 1.0.3. I think I have an older vesion installed on my system. So I downloaded and compiled gstreamer-1.0.4 and it got installed in ...
1
vote
2answers
4k views

How do I get iperf on a Ubuntu 13.10 Live disc?

I have Ubuntu 13.10 running from a live DVD disc. Unfortunately it does not include the iperf tool, so it will need to be added separately. I already tried the command below. apt-get install iperf ...
1
vote
1answer
184 views

How to install build dependencies for source not available in Ubuntu repositories?

I keep myself busy compiling (makeing) several packages and some of them are not in the repositories (so apt-get build-dep doesn't help), the complete documentation about build dependencies is missing ...
0
votes
1answer
89 views

Installing group of fonts in Ubuntu [duplicate]

How to install group of fonts in a folder in Ubuntu? There are many font folders and I don't where to copy my fonts cause I want to use them in whole Linux environment not in a special program? What ...
0
votes
3answers
5k views

Flashplayer 11.1 on Ubuntu 12.04

I am new to Ubuntu and I've visited pretty much every webpage that exists on the internet about how to install canonical Flashplayers. Ubuntu 12.04 comes with Adobe Flashplayer 11.2 but that is not ...
-1
votes
1answer
988 views

How do I compile lbflow 1.1?

After using "sh ./configure" command, I encountered another error during lbflow package installation (a scientific one). The sequence of operations is here with error: ./configure --disable-gts ...
0
votes
0answers
29 views

How do I install cdemu? [duplicate]

I just installed Ubuntu and made it as flexible as possible I'm stuck while installing cdemu. I successfully installed vhba module as instructed by them now i'm stuck at compiling libmirage. When I ...
0
votes
1answer
101 views

GraphicsMagick not listed in installed packages after install from source

I've installed GraphicsMagick following the instructions on the website, and ran the build verifications it says, and though I'm not sure if those were to verify that install was successful or not, ...
0
votes
1answer
414 views

Building maven from source

I'm trying to build maven from source (on Ubuntu 12.04) following the tutorial: http://maven.apache.org/guides/development/guide-building-m2.html I installed a previous version of maven using sudo ...
2
votes
0answers
168 views

Problem when compiling GCC in Ubuntu

I have run into the well known problem when installing GCC: configure:3605: error: in /usr/local/gcc-4.8.1/i686-pc-linux-gnu/libgcc': configure:3608: error: cannot compute suffix of object files: ...
0
votes
1answer
854 views

problem with the installation of wireshark ubuntu “make” failed

I need to install Wireshark but it seems to have some problems when I type sudo make command. Here is what I get: dell@ubuntu:~/wireshark$ make LANG=C /usr/bin/perl ./make-version.pl . Version ...
1
vote
1answer
114 views

Trouble installing specific .tar.bz2

I've used Ubuntu for over a year now and I have never gotten the hang of tarballs. I have a .tar.bz2, I've extracted it but I can't figure out where to go from here. I tried running ./configure but I ...
0
votes
1answer
147 views

Shell not recognised by configuration scripts

When I try to compile different packages from source (e.g., ipsec-tools, openvpn, etc.) I obtain always the same error from the configuration script: $ ./configure ./configure: This script requires ...
2
votes
1answer
661 views

Python ImportError after reinstallation of nautilus

I have a problem with python on my Ubuntu 12.10. Firstly the problem arose when I was trying to reinstall nautilus because of some troubles with it. I used apt-get --reinstall install nautilus*. The ...
0
votes
3answers
17k views

Is it possible to install Ubuntu through network?

I would like to install Ubuntu for almost 120 users. But it's very difficult in using USB and drives. please suggest ....
1
vote
1answer
1k views

How to install latest version of Cheese from source in Raring?

The source files can be downloaded from here. I want to use the last stable version. How to install Cheese from source? Or Is there any .deb file of version 3.8.3 available somewhere?
5
votes
1answer
400 views

Installation difference between from source and apt-get?

What's the difference between installation from source (./configure && make && make install) and with apt-get? I can think of these: apt-get version usually is more stable and less ...
-1
votes
1answer
1k views

Where are downloaded files stored?

Today I installed 12.10 as my second OS. I made all updates and upgrades. Then I downloaded crunch-3.4tgz and fern-wifi-cracker 1.6 all.deb but I could nowhere find these files to be able to install ...
0
votes
0answers
2k views

Psiphon 3 & Compile a Package

I am a newbie and I use XFCE desktop based on 12.10. Psiphon 3 is open source but I have 2 questions: How can I download the source. When I go to the related site, there's not a file but so many ...
15
votes
1answer
11k views

Installing the latest Node.js / MongoDB?

How can I install Node.js and MongoDB so they are the most current versions? The available versions from package manager are not up to date, and PPA from Chris Lea for Node.js doesn't get updated on ...
1
vote
2answers
2k views

How do I install WhatPulse?

I was expecting a .deb file but instead I got this: http://whatpulse.org/downloads/50/64bit/
2
votes
1answer
154 views

Installing software from source

I'm trying to understand the rational behind installing from software from source in Ubuntu 12.04. Obviously, I know I can download what I need from repos, but I want to develop a deeper understanding ...
0
votes
1answer
2k views

cannot find lcblas ubuntu 12.10

I was trying to use the make file of a program and I hit the following error: /usr/bin/ld: cannot find -lcblas I tried the solution from https://bugs.launchpad.net/ubuntu/+source/atlas/+bug/769180 ...
1
vote
1answer
4k views

How do I fix “/bin/sh: 2: patch: not found” and “make: *** [lib/libcurl.a] Error 127” errors?

curl-loader is a traffic generator. You can generate HTTP, HTTPS, FTP etc. traffic with it. Add to that, you can simulate multiple clients (multiple source IP addresses). Here’s an explanation of ...
1
vote
2answers
115 views

How to compile 'stygmorgan-0.29'?

I am trying to compile stygmorgan-0.29.tar.bz2 and got these messages: stygmorganui.cxx:7:28: fatal error: stygmicon128.xpm: No such file or directory compilation terminated. make[2]: *** ...
1
vote
1answer
2k views

Installing PCRE from source…make install error!

I was trying to install pcre as it was needed by swig which is needed for installing gem5, anyway I am receiving this error after successful ./configure and make (however it's interesting that ...
0
votes
1answer
453 views

How to build libHaru and the examples which are included

I downloaded libHaru from http://libharu.org/. libHaru is a opensource pdf creator. Now in the INSTALL file says I only have to run ./configure && make && make install. When I run this ...
3
votes
1answer
134 views

Does installed from source software get overwritten by automatic updates?

As an example I've installed libcurl v7.30 from source, using their tutorial: ./configure --disable-ipv6 --enable-ares make make install I've had libcurl installed from the official repository ...
1
vote
1answer
3k views

“cannot determine current directory” while building Haskell in 13.04

I'm trying to install the Haskell Platform on Raring. Since there's no apt package, I've downloaded the GHC 7.4.2 binary x86_64 distribution (which is a prerequisite), and I am trying to run ...
1
vote
1answer
2k views

How do I install qBittorrent from the tarball?

Source Tarball. I started with the instructions found in the "INSTALL" file found in the extracted tarball and after I typed ./configure after which I received the error: Configuring qbittorrent ... ...
1
vote
2answers
2k views

How to configure Qjoypad?

I followed the steps on this page but when I run make it gives me this error: /usr/bin/ld: keycode.o: undefined reference to symbol 'XKeycodeToKeysym' /usr/bin/ld: note: 'XKeycodeToKeysym' is defined ...
0
votes
1answer
2k views

How can I install PIKLAB on 12.04?

I'm trying to install PIKLAB IDE for Microchip PIC controllers programming but got stuck at an error message as below: -- Could NOT find Threads (missing: Threads_FOUND) CMake Error at ...
0
votes
1answer
4k views

“make install” errors

I am trying to install vmd on my ubuntu but " make install" is giving these errors. Can someone help? These are the errors. Thanks for the helps. if [ ! -d "/usr/local/lib/vmd" ]; then \ ...
0
votes
1answer
490 views

Getting configure command of php

I am using an ubutnu OS, I have installed LAMP stack using "tasksel", I am not able to find the "Configure Command" while I am going through phpinfo. But , in the same OS I am able to see the ...