install-from-source refers to one method of installing software packages on Ubuntu without using the Software Centre. It is generally not the recommended way of installing software.

learn more… | top users | synonyms

16
votes
2answers
28k views

Install Popcorn Time from source files

How can I install Popcorn Time beta ? I see on their website that they only offer a 64-bit installation files, but the sources are open. I can't use the usual ./configure && make. So, what ...
1
vote
2answers
3k views

How can I install Celtx 2.9.7 properly on Ubuntu 12.04 LTS?

I am new to Ubuntu and Linux and I want to install and use the newest version of the screenwriting software Celtx on Ubuntu 12.04 LTS. After trying ...
14
votes
1answer
9k views

Installing the latest Node.js / MongoDB?

How can I install Node.js and MongoDB so they are the most current versions? The available versions from package manager are not up to date, and PPA from Chris Lea for Node.js doesn't get updated on ...
1
vote
3answers
3k views

Flashplayer 11.1 on Ubuntu 12.04

I am new to Ubuntu and I've visited pretty much every webpage that exists on the internet about how to install canonical Flashplayers. Ubuntu 12.04 comes with Adobe Flashplayer 11.2 but that is not ...
1
vote
1answer
34 views

Install from source does not work but apt-get works

I try to install from sources modified version of icewm but I get error so I decide to first install original version to see if it goes and I does not go. I installed icewm using apt-get: sudo ...
2
votes
1answer
17 views

Identify X libs during installation from source without sudo

I am trying to install a program (HTK) from source, but after ./configure (which doesn't give errors), make all complains that /usr/bin/ld: cannot find -lX11. This is a well-known problem which ...
-1
votes
1answer
44 views

How to install gmp 4.3.2 on ubuntu 14.04

I want to install gcc-4.4.3,for which I have to install gmp 4.3.2. When I run: ./configure make I get this error. Can you help me? make all-recursive make[1]: Entering directory ...
14
votes
4answers
684 views

How to manage software that is installed from source?

From time to time, we may have to install something from source due to various reasons. While it is fairly standard how to install software given appropriate dependencies, it is not clear to me how to ...
0
votes
0answers
31 views

Installed a software from source code, how to uninstall it? [duplicate]

Recently I've been doing some reading on FFmpeg, and so I was told that FFmpeg served by the Ubuntu official repository is outdated. I followed the official FFmpeg installation guide, and managed to ...
1
vote
1answer
82 views

Trouble installing specific .tar.bz2

I've used Ubuntu for over a year now and I have never gotten the hang of tarballs. I have a .tar.bz2, I've extracted it but I can't figure out where to go from here. I tried running ./configure but I ...
0
votes
1answer
456 views

config.status: error: cannot find input file: `Makefile.in'

I'm trying to install mod_WSGI on Ubuntu 12.04. Here is the set of commands that I'm following: wget http://modwsgi.googlecode.com/files/mod_wsgi-3.4.tar.gz tar xvfz mod_wsgi-3.4.tar.gz cd ...
1
vote
0answers
21 views

Discrepancy with Swish++ names

I asked this question earlier, but I still have no answer. The problem is: I use ubuntu 12.04, and I need to install Swish++ from the source code. I've downloaded the package from the official page ...
0
votes
1answer
110 views

New to Ubuntu (linux). Would like to install a printer. A bit clueless

I installed Ubuntu 13.10 on my old Dell desktop. It runs fine and I like the Ubunte experience. I found most software using the 'software centre'. But not for my Canon printer. I went to their website ...
0
votes
0answers
19 views

Raknet library how to install

I'm trying to install Raknet library on linux without results what I did: wget http://www.raknet.net/raknet/downloads/RakNet_PC-4.082.zip unzip RakNet_PC-4.082.zip cd RakNet_PC-4.082 cd Source ...
0
votes
2answers
353 views

How do I install redshift 1.9.1?

I'm new to linux and I don't know how to install redshift 1.9.1, configure the color temperature and make it automatically start. I'm using Ubuntu 14.04 LTS.
1
vote
4answers
46 views

Where can I get fresh new Wine DLLs?

I was acting careless today and I accidentally deleted one of the .dlls in my Ubuntu Wine installation, ~/.wine/drive_c/windows/system32/ole32.dll to be exact, and need a new fresh copy of only this ...
0
votes
2answers
33 views

How to install packages from Launchpad which are not in a PPA?

Launchapad contains a wealth of packages that are not usable (they seem to be in source form or something). For example, by searching for a "ndoc ubuntu" on google, I fell on the page ...
5
votes
2answers
2k views

LESS CSS compilers returning blank

I am not even sure where to start debugging this. Months ago, I could happily compile my CSS from my LESS files. Today, I run either recess --compile test.less or lessc test.less and I just get a ...
1
vote
2answers
1k views

How do I install WhatPulse?

I was expecting a .deb file but instead I got this: http://whatpulse.org/downloads/50/64bit/
0
votes
1answer
37 views

How to install an application from gitweb

I need to get the latest available version of an application called arm which is a terminal monitor for Tor. The download instructions [on the application webpage][2] has a link to an older version ...
1
vote
1answer
82 views

Which version of Banshee in repos with Ubuntu 14.04

I need to know which version of Banshee is the one in repos of Ubuntu 14.04 According to http://packages.ubuntu.com/trusty/sound/banshee It is 2.9.0+really2.6.2-2ubuntu2, so its is 2.9.0 OR 2.6.2?? ...
0
votes
1answer
88 views

Which is exact method to install from source?

I have run (gradually) following command to install gdebi from source: apt-get build-dep gdebi apt-get source gdebi cd gdebi-0.9.5.3 dpkg-buildpackage -uc -us -b Which gives me error (posted last ...
1
vote
0answers
22 views

How to point to Boost built from source

I like to keep my Boost installations full and up to date to the latest release. I just noticed that I sloppily approved libboost-dev-all, and some of my programs that I develop are not able to ...
1
vote
1answer
2k views

Error 255 when trying to install openssl-1.0.1g from source

installing man1/cms.1 cms.pod around line 457: Expected text after =item, not a number cms.pod around line 461: Expected text after =item, not a number cms.pod around line 465: Expected text after ...
0
votes
0answers
182 views

Error 255 when installing openSSL from source

I need to build openssl from source because it's needed to build a mysql driver for android for Qt but when I do "make install" I get the following error: cms.pod around line 457: Expected text after ...
0
votes
1answer
81 views

cannot execute executable files x.run

I use Kubuntu 14 on HP Envy. I'm trying to install software (software: MPLAB® X IDE v2.05 and MPLAB® XC32 Compiler v1.31) from .run files this fails. The .run files have executable flags set: ...
1
vote
0answers
71 views

How do I install Foldit.tar.gz (specifically)?

NOTE: THIS IS NOT A DUPLICATE QUESTION. It is specific to Foldit.tar.gz and installing this game is done uniquely. There is an askubuntu page answering the question, "How do I install a .tar.gz (or ...
0
votes
1answer
3k views

“make install” errors

I am trying to install vmd on my ubuntu but " make install" is giving these errors. Can someone help? These are the errors. Thanks for the helps. if [ ! -d "/usr/local/lib/vmd" ]; then \ ...
2
votes
1answer
162 views

How do I Install X13-arima-seats for Rstudio from source?

Hello all and thanks for interest! Im trying to install x13-arima-seats to be used with Rstudio. There are compiled version for RedHat and source available. I have followed these steps from the ...
1
vote
1answer
41 views

What is the good way to remove SDK and other soft?

I have installed AMD-APP-SDK-v2.9 using install script: ./Install-AMD-APP.sh Everything is ok and here is the installation log: 1) Starting Installation of AMD APPSDK v2.9 .... 2) 64-bit Operating ...
0
votes
1answer
571 views

Error compiling a package: “configure: error: no gstreamer-1.0 >= 1.0.0”

I am trying to compile a package, which requires gstreamer-1.0 >= 1.0.3. I think I have an older vesion installed on my system. So I downloaded and compiled gstreamer-1.0.4 and it got installed in ...
1
vote
1answer
3k views

Permission denied while running make install

I am trying to install gtk-server. First I typed the command ./configure and then make, but when I typed command make install it gave me this error: ...
0
votes
4answers
4k views

Installing driver for Atheros AR8131

I am having the same trouble as others getting my Atheros AR8131 Ethernet card recognised by Ubuntu 12.10 on my new HP Pavillion P7-1449 PC. I found the same question where the answer suggested the ...
1
vote
1answer
592 views

Help with error: ‘struct sockaddr_storage’ has no member named ‘s_addr’ [closed]

I just installed Ubuntu 12.10 on my new machine, and I'm trying to install Ushare from the source from the website. I would just install it through the terminal using 'sudo apt-get install ushare' but ...
1
vote
1answer
648 views

GitLab Omnibus Ubuntu 12.04

I am trying to build GitLab from the Omnibus project in my Ubuntu 12.04 64-bit following this link After issuing sudo apt-get install ruby ruby-bundler I downloaded the source from here and after ...
2
votes
2answers
4k views

wireshark installation

i downloaded wireshark-1.8.0rc2.tar.bz2 and copied it to /opt/wireshark directory and uncompressed it by sudo tar -xjvf wireshark-1.8.0rc2.tar.bz2 then by doing ls in the extracted folder, i found ...
-2
votes
1answer
146 views

installing antivirus [duplicate]

Why it is not possible to possible on ubuntu to install antivirus or other software just by downloading exe file instead of using command line? Im having all the pains to install free AVG 2014 on ...
0
votes
0answers
148 views

The different between install mpich2 from Ubuntu Repository and from mpich source package

I am trying to build parallel computation system with Master Machine and Helper Machine. Based on the literature review I get: Install mpich2 from sudo apt-get install mpich2 Make a shared folder ...
2
votes
3answers
417 views

How do I install mosml?

I need to get Mosml (Moskow sml) on to my system for university. I never installed anything that wasn't in the software manager or using wine (read: my console skills are low). the package is here: ...
0
votes
0answers
29 views

What is the difference among various options of source package download?

I want to download source package of eglibc. I get three options eglibc_2.17-97.dsc, eglibc_2.17.orig.tar.xz, eglibc_2.17-97.debian.tar.xz. Please explain me the differences among these options and ...
2
votes
0answers
156 views

Black screen after login when installing Mesa 10 from source

I wanted to update my Mesa version to 10.0, so I compiled it from source, installed it, rebooted and when I logged in, I had a black screen with only my mouse visible. I have reinstalled Ubuntu 13.10 ...
0
votes
1answer
199 views

Building Ubuntu server from source on very old hardware?

I'd like to build Ubuntu LTS 12.04 from source (kernel+daemons) on very old hardware. The hardware I'm on is i486 cpu on a pc104 single board computer. Most live cd's have trouble getting further than ...
1
vote
1answer
72 views

Error while running make to install drivers

Everytime I want to run make while installing a driver, I get these error messages : make[1]: ***[_module_/home/alaa/Downloads/rtl_92ce_92se_92de_8723ae_linux_mac80211_0006.0514.2012] Error 2 ...
1
vote
1answer
117 views

How to install build dependencies for source not available in Ubuntu repositories?

I keep myself busy compiling (makeing) several packages and some of them are not in the repositories (so apt-get build-dep doesn't help), the complete documentation about build dependencies is missing ...
0
votes
2answers
2k views

How do I get iperf on a Ubuntu 13.10 Live disc?

I have Ubuntu 13.10 running from a live DVD disc. Unfortunately it does not include the iperf tool, so it will need to be added separately. I already tried the command below. apt-get install iperf ...
54
votes
6answers
17k views

How do I build Unity from source?

I'd like to know how I would build Unity from source code in the current development release. Please cover the following topics: Which packages are needed to compile Unity? Where would I get the ...
0
votes
0answers
56 views

How to build latest Gnome apps (music, photos etc) from source?

i've been reading for a while your answers but now the time came to ask mine. I tried several linux distros and i ended up with a customized saucy to run on Gnome 3.10. Though ricotz has compiled ...
2
votes
4answers
101 views

How can I build and install a Qt project/.pro?

I would like to install sqlite database browser from sourceforge. I downloaded the file and unzipped it with tar -xvf sqlitebrowser_200_b1_src.tar.gz Now it's a directory in my downloads with this ...
-1
votes
1answer
710 views

How do I compile lbflow 1.1?

After using "sh ./configure" command, I encountered another error during lbflow package installation (a scientific one). The sequence of operations is here with error: ./configure --disable-gts ...
0
votes
1answer
74 views

Installing group of fonts in Ubuntu [duplicate]

How to install group of fonts in a folder in Ubuntu? There are many font folders and I don't where to copy my fonts cause I want to use them in whole Linux environment not in a special program? What ...