Integrated development environment

learn more… | top users | synonyms

0
votes
3answers
9k views

Can't mount an IDE HDD - “can't read superblock” error message

I'll be brief, I'm trying to mount my HDD, /dev/sdb, which is connected via an enclosure but every time I try do so I get an error message mount: /dev/sdb: can't read superblock I'm new to Ubuntu ...
0
votes
3answers
294 views

Ubuntu 12.04 LTS does not boot with enabled IDE controller

I cannot boot ubuntu 12.04 LTS with the IDE controller enabled. Similar problems (with ASUS mainboards) were described in the threads http://ubuntuforums.org/showthread.php?t=1662883, and ...
2
votes
2answers
488 views

Eclipse IDE just show “General” and “CVS” in wizard

I just installed Eclipse IDE using Ubuntu Software Center and Synaptic, but in both cases it don't shows for example "Java Project" in the wizard (File > New), just shows General and CVS. How can I ...
1
vote
2answers
574 views

uses vim as an ide

I want plugins for vim so that I can use it as a C language IDE. I used to use qtcreator and I really appreciate his auto-completion (really perfect), but after trying for several months vim I really ...
2
votes
1answer
611 views

Ubuntu 12.04 key bindings not working in IntelliJ Idea 12

I've installed the latest version of IntelliJ Idea Community Edition (12.0.1) and I have problems with key bindings there. I am using Ubuntu 12.04 LTS with Unity. None of them, where a letter is ...
1
vote
1answer
271 views

Arduino IDE Crashes When Attempting to Save Sketch

I recently updated Ubuntu (15.04) and ever since the update my Arduino IDE crashes when attempting to save a sketch. Last night I removed and reinstalled the IDE and I am still having the same issue. ...
1
vote
1answer
200 views

How to show Aptana Studio 3 in the “Open with” list?

I've downloaded Aptana Studio 3 from their site and installed it successfully. Now it is showing in the Dash search. Problem is that, when I right click on any file (i.e HTML, CSS, PHP etc.), the ...
1
vote
1answer
626 views

scala ide (eclipse) and sbt project

I am using the last version of the scala ide eclipse http://scala-ide.org/ Scala IDE build of Eclipse SDK Build id: 4.0.0-vfinal-20141216-1226-Typesafe I have a project that I am able to run from ...
1
vote
1answer
1k views

IDE for Symfony (PHP) which is able to manage Vagrant VM's over SSH

I just switched from Windows to Ubuntu on my dev Laptop. Now I'm wondering, what's the best IDE to use on Ubuntu when working with PHP? I know there are a lot of threads here about exactly that thing, ...
1
vote
1answer
456 views

Android IDE for Ubuntu

Are there any other IDEs other then eclipse for Ubuntu which can be used for Android Development
1
vote
1answer
522 views

How to install Ktechlab in ubuntu 13.04?

I'm trying to install the ktechlab in ubuntu 13.04 but the .deb has some dependecies errors and it is not available in the software center.
0
votes
1answer
32 views

How to build an java applet?

The funny thing is, this code was applied with success on other people's computers after they made the byte code and html file. But my java IDE is running on Android and the compiler threw 17 errors, ...
0
votes
1answer
91 views

LPCXpresso 8 on Ubuntu 14.04 64 bit

I'm trying to install LPCXpresso IDE 8 on ubuntu 14.04 64 bit but I receive an error: No protocol specified invalid command name "bind" while executing "::unknown bind Text <Tab>" ...
0
votes
1answer
215 views

PHPStorm not launching

Here is a very strange situation...I installed the PHPStorm and if i use the terminal and type: /opt/phpstorm/bin/phpstorm.sh The IDE open and works normally. I tried to launch the PHPStorm on the ...
0
votes
1answer
65 views

CPP problem / Qt IDE

When trying to install Qt IDE this msg appears : The following packages have unmet dependencies: g++: Depends: cpp (>= 4:4.8.2-1ubuntu6) but 4:4.8.2-1ubuntu6 is to be installed Depends: gcc ...
0
votes
1answer
55 views

Does Hunspell dictionaries work in Pycharm and others Jetbrains products?

I'm using Pycharm to develop projects both in French and English, my whole system is en_US.UTF-8-based so does my Pycharm. After skimming the Pycharm doc on spell-checking I added the hunspell ...
0
votes
1answer
229 views

Anjuta crashes when open *.ui file

I'm using Anjuta IDE version 3.12.0, Ubuntu 14.10 64bit. Whenever I open a *.ui file, Anjuta crashes: if I double click at the *ui file, or right click and choose Open or Open with Glade interface ...
0
votes
1answer
213 views

KVM ide drivers

I've spent about a week installing and destroying a KVM install, and in the last two days have finally managed to get it working and understand the process. What I have is ubuntu 14.04 LTS x64 host ...
0
votes
1answer
65 views

Eclipse window is not fully displayed

Some Eclipse windows is not fully displayed. Example: New project, New Class .... It is lost some of the items. Screenshot:
0
votes
1answer
199 views

Gui application for perl scripts and cshell

I am a very green to Linux. I am now taking a course at my studies basic of Linux. As part of my assessment I need to do some Perl scripts and C shell. But also we have been asked to build a GUI app ...
0
votes
1answer
444 views

BlueJ is not working

I'm new to Ubuntu. I had installed JDK 7 but still BlueJ is not working. I need help as I need BlueJ for my school activities and Java programming.
0
votes
1answer
2k views

PhpStorm problem in Ubuntu 12.04

I have a problem starting PhpStorm 5 on Ubuntu 12.04, it shows the following errors stack: I installed Ubuntu just now, so its a fresh copy, changed only ubuntu 2d when logged in, installed Java from ...
1
vote
0answers
39 views

Web IDE that has a Linux compiler?

Is there a web IDE that has a Linux compiler (virtual Linux compiler) with Python support? I've created a Python application that uses GTK and Linux modules such as os.system and gtk. I need to ...
1
vote
0answers
42 views

Open sublime text editor with predefined lines according to extension

Ok so I'm using ubuntu 14.04 and use sublime text editor 2(currently but I'll be soon updating to 3) for programming in various languages.What I want is that sublime editor should open with specific ...
1
vote
0answers
27 views

Is there such thing as a plymouth IDE?

I have googled and have scoured the internet attempting to find a plymouth script IDE which would allow me to see a sample window which update itself with code changes. Similar to Apple's XCode ...
1
vote
0answers
180 views

Installing brackets

I'm trying to install brackets.i've used the dpkg command.i've checked /opt and there's a new folder called Brackets.What should i do with it in order to run brackets? When i type brackets in ...
1
vote
0answers
66 views

Ubuntu 15.04 Gray Boxes Over scroll Bars, and Multi-line boxes

So, I've had this issue happen a lot, especially when trying to develop using Bluefish IDE, and gray boxes are in my working space, and it makes it an extreme nuisance. When this issue happens in a ...
1
vote
0answers
76 views

Clicking on debug in PyCharm soft reboots ubuntu 14.10

When I click on debug in Pycharm, communiti edition 4.0.3, on my ubuntu 14.10, the screen blanks out, closes all applications & reports an internal error. How do I debug the rootcause of this ? ...
1
vote
0answers
575 views

'Android SDK missing' error when trying to install Titanium

I'm trying to install Titanium on my Ubuntu 13.10. But I can't setup Android SDK. It always show an Error like An Android SDK is missing. Titanium requires Android platform: 2.3.3 or above. I have ...
0
votes
0answers
50 views

errors while installing java mars, help me with this

2016-04-10 00:22:02] An error was detected while performing the engine operation and the changes are being rolled back. See the log for details. [2016-04-10 00:22:02] ERROR: ...
0
votes
0answers
14 views

Got set of errors while upgrading oomph installer for eclipse in ubuntu 15.10

org.eclipse.core.runtime.CoreException: An error occurred while installing the items at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:280) at ...
0
votes
0answers
33 views

disable all netbeans modules?

How do I disable all Netbeans modules? thufir@mordor:~$ thufir@mordor:~$ netbeans --list OpenJDK 64-Bit Server VM warning: ignoring option PermSize=32m; support was removed in 8.0 ^C ...
0
votes
0answers
39 views

Executing .net Code on Ubuntu 14.04

We have a requirement to execute .net code on Ubuntu box 14.04. In this regard, we followed the link to download Visual Studio Code for 32-bit OS and setup on our machine by using the link How To ...
0
votes
0answers
55 views

How to launch MonoDevelop in Ubuntu?

After following those instructions: How to install mono on ubuntu 64-bit v14.04? Then, how to launch MonoDevelop in Ubuntu?
0
votes
0answers
121 views

error : this version information could not be downloaded

I have downloaded the eric ide for python. when ever i try to open the ide the error above said keep popping up on my screen please help
0
votes
0answers
32 views

Why wont my Arduino IDE open?

I have been running Arduino IDE on my Ubuntu 15.04 for about the past 6 months. Since I started using Ubuntu. But about two weeks ago suddenly Arduino IDE won't open as well as another program called ...
0
votes
0answers
141 views

Code editor with SSH/SFTP support and synchronization

I'm looking for a robust code editor that could work with remote server using SSH/SFTP and edit files on-the-fly with ability to compare content before writing it to the remote file system (in order ...
0
votes
0answers
378 views

umake - PHPStorm : /home/username/.cache/dconf/user': Permission denied

I using Ubuntu-Make command line tool to install phpstorm IDE and got a couple of error. username@linux:~$ sudo umake ide phpstorm [sudo] password for username: Choose installation path: ...
0
votes
0answers
24 views

How to change a setting with a custom keybinding in Visual Studio Code

This is a follow up question to this answer. I'd like to create a keyboard shortcut to toggle line wrapping. How can we add a custom keybinding that allows values in settings.json to be changed?
0
votes
0answers
52 views

How do I load directory in geany using Treebrowser plugin?

When I searched on Google for loading directory in Geany IDE, the very first result was the Treebrowser plugin for Geany. I have installed it and activated it from the plugin manager in Geany. Now, ...
0
votes
0answers
134 views

Program exits when building in mingw studio in ubuntu

Is anyone here who uses mingw developer studio in ubuntu? I found this arhive: http://www.iit.upcomillas.es/libroc/mingw-devstudio_linux-2.06.tar.gz I launch the program and everything works well ...