Integrated development environment

learn more… | top users | synonyms

0
votes
0answers
12 views

Ubuntu 15.04 Gray Boxes Over scroll Bars, and Multi-line boxes

So, I've had this issue happen a lot, especially when trying to develop using Bluefish IDE, and gray boxes are in my working space, and it makes it an extreme nuisance. When this issue happens in a ...
2
votes
0answers
27 views

How to wrap text/comments in Visual Studio Code?

Can someone tell me the keyboard shortcut/menu path to wrap text, comments, etc in Microsoft's Visual Studio Code? I couldn't locate it in User Preferences. Here's the screenshot which has a lot of ...
1
vote
1answer
31 views

How to show Aptana Studio 3 in the “Open with” list?

I've downloaded Aptana Studio 3 from their site and installed it successfully. Now it is showing in the Dash search. Problem is that, when I right click on any file (i.e HTML, CSS, PHP etc.), the ...
1
vote
0answers
10 views

Clicking on debug in PyCharm soft reboots ubuntu 14.10

When I click on debug in Pycharm, communiti edition 4.0.3, on my ubuntu 14.10, the screen blanks out, closes all applications & reports an internal error. How do I debug the rootcause of this ? ...
10
votes
1answer
1k views

Error while installing Visual Studio Code on Ubuntu 14.04

I've been trying to install MS Visual Studio Code after it was announced today, on my Ubuntu 14.04 computer. I've read the official docs and setup from Microsoft and I've read an answer to a question ...
21
votes
6answers
7k views

How to install Visual Studio Code on Ubuntu?

I just downloaded VSCode-linux-x64 from the Microsoft website. It's a 62 MB zip file. How can I install it on my Ubuntu system?
1
vote
3answers
68 views

Is there an IDE for Ubuntu that combines Python, Gtk and Glade in one unique program?

I like PyCharm, but it doesn't have a GUI designer. I like the quickly package but I don't want to use Gedit as my editor. I tryed Ubuntu SDK but it's kind of hard to use python on it, and it's not ...
0
votes
0answers
41 views

Anjuta crashes when open *.ui file

I'm using Anjuta IDE version 3.12.0, Ubuntu 14.10 64bit. Whenever I open a *.ui file, Anjuta crashes: if I double click at the *ui file, or right click and choose Open or Open with Glade interface ...
0
votes
0answers
95 views

Monogame 3.0.1 with Monodevelop 5.8 'Core v3.0' and 'Ide v3.0' problem

So, I've managed to install the newest (5.8) Monodevelop version on Ubuntu but unfortunately failed to install Monogame. My problem is when I want to install an add-in from file I downloaded (Monogame ...
0
votes
1answer
91 views

Couldn't find PhpStorm.sh file ( Ubuntu 14.04 ) LTE

Downloaded PhpStorm (PhpStorm-8.0.2.tar.gz) from https://www.jetbrains.com/phpstorm/download/ Instructions: Unpack the PhpStorm-*.tar.gz file using the following command: tar xfz ...
0
votes
2answers
31 views

Is Qt only for cpp coding [closed]

I am a newbie to the coding world and a friend recommend Qt creater for me since I told him I wanted to code in cpp but I want to know if it is possible to use Qt to code in java or anything else and ...
1
vote
1answer
264 views

scala ide (eclipse) and sbt project

I am using the last version of the scala ide eclipse http://scala-ide.org/ Scala IDE build of Eclipse SDK Build id: 4.0.0-vfinal-20141216-1226-Typesafe I have a project that I am able to run from ...
0
votes
1answer
298 views

install jdk-7u71-nb-8_0_2-linux-i586.sh [duplicate]

I have downloaded JDK 7u71 with NetBeans 8.0.2 from http://www.oracle.com/us/technologies/java/jdk-7-netbeans-download-432126.html. I want to know how to install jdk-7u71-nb-8_0_2-linux-i586.sh on ...
1
vote
1answer
159 views

Geany error 127 when programming in C

Error running C program compiled with Geany IDE Error Code: 127 Hey, I am running ubuntu 14.04 LTS and Geany 1.23.1. I also have build-essentials installed and working from Terminal, but when I try ...
1
vote
1answer
434 views

IDE for Symfony (PHP) which is able to manage Vagrant VM's over SSH

I just switched from Windows to Ubuntu on my dev Laptop. Now I'm wondering, what's the best IDE to use on Ubuntu when working with PHP? I know there are a lot of threads here about exactly that thing, ...
1
vote
1answer
1k views

Completely Uninstall Pycharm 3.4 from Ubuntu 14.04

I am using Pycharm 3.4 community edition which does not upgrade to the latest version of the IDE. I want to completely uninstall Pycharm 3.4 and reinstall 4.x.x version. I installed it form .tar.gz ...
0
votes
0answers
16 views

Weird bugs with mplab

I just began to use mplab (IDE provided by Microchips to develop PIC micro-controllers). So I installed it on my computer but I've a lot of weird bugs with the linux version. For example, when I want ...
1
vote
1answer
68 views

Unable to run Java softwares on my ubuntu 14.04 [closed]

I created a simple GUI program using netbeans on my Ubuntu 14.04, it runs from the netbeans IDE but after building it doesn't run without the IDE.
1
vote
1answer
1k views

Problem installing phpstorm 7 in ubuntu 14.04

I have been struggling with installing Phpstorm in Ubuntu 14.04 since I am new to Ubuntu. I have put Phpstorm in my home directory. Here is the code I use after that to activate the software. cd ...
1
vote
2answers
360 views

Install PyCharm IDE from repo (without wget)

Is there a way to install the PyCharm IDE (community version) from a repo (without wget). I think the wget method found in many blogs is too complicated.
0
votes
1answer
66 views

KVM ide drivers

I've spent about a week installing and destroying a KVM install, and in the last two days have finally managed to get it working and understand the process. What I have is ubuntu 14.04 LTS x64 host ...
0
votes
3answers
1k views

How to update PyCharm 3.4 to 4 in Ubuntu 14.04

I have Pycharm 3.4 community edition installed. I want to update my installation to 4.0. Going to Help ⇒ Check for update shows me that I am in latest version which is 3.4.1. Manual download and ...
0
votes
0answers
50 views

error: installing eclipse from software centre. please help

I`m getting this error while installing eclipse from software center. please help.... Error details are as follows: The following packages have unmet dependencies: eclipse-platform: ...
1
vote
1answer
81 views

Graphical Diff viewer that supports LXDE (Lubuntu)

I've installed a fresh copy of Lubuntu on my netbook for the purpose of development "on-the-go". I've installed most of the tools I need except for one handy one: Meld Diff Viewer. Meld required ...
0
votes
0answers
10 views

libraries for c++ development [duplicate]

I am a student and switched form windows to linux just a few months ago. I don't know anything about the paths and libraries in linux. Now I need to work on c++. I need an IDE and compiler that can ...
0
votes
0answers
108 views

Starting with SDL

Hy, i want to start learning/developing with the SDL library. I already found some usefull tutorials like lazyfoo.net. There I noticed there are many ways to use SDL (Console, IDE, ...). So can you ...
0
votes
2answers
2k views

Can't mount an IDE HDD - “can't read superblock” error message

I'll be brief, I'm trying to mount my HDD, /dev/sdb, which is connected via an enclosure but every time I try do so I get an error message mount: /dev/sdb: can't read superblock I'm new to Ubuntu ...
1
vote
1answer
207 views

Eclipse-Can't open in ubuntu 14.04

I downloaded eclipse from here. And tried to open as shown here . But when I double click or try to open the eclipse using command, ./eclipse It shows the following error. How to resolve this? I'm ...
1
vote
1answer
148 views

Make pycharm default for .py files in 14.04

I want to make pycharm ide default for all .py files in ubuntu 14.04. I have extracted the tar.gz file in my home directory but every time i have to run pycharm i have to go over to the bin ...
0
votes
1answer
37 views

Eclipse window is not fully displayed

Some Eclipse windows is not fully displayed. Example: New project, New Class .... It is lost some of the items. Screenshot:
0
votes
0answers
151 views

How to set environment variable in Eric Python IDE

I have no problem running a Python script from the terminal, but in Eric Python IDE, I am getting this error: ImportError libcudart.so.6.0: cannot open shared object file: No such file or directory ...
0
votes
0answers
54 views

Ninja-IDE freezing periodically on Ubuntu 12.04

I'm using Ninja-IDE 2.3 on Ubuntu 12.04 and it used to work like a charm until now. It freezes for a few seconds every 20 or 30 sec and it does not respond to what I type anymore. Maybe it comes from ...
0
votes
1answer
949 views

How do you get C++ to compile from Code::BLocks? (Beginner to Linux)

So I just recently installed Linux after using Windows for my whole life. I also just installed the C++ IDE named code::blocks using the following command in the terminal: sudo apt-get install ...
0
votes
0answers
16 views

How to expand Eclipse editor switcher?

I am running Eclipse Kepler on Ubuntu 12.04. When I have some source files open in the editor, I can hit Ctrl+e to obtain a drop down menu to switch between open files. As you can see, the menu is ...
1
vote
1answer
95 views

Unparseable output from pylint in emacs

I just upgraded from Ubuntu 12.04 to 14.04 (clean upgrade, not in-place). I found that I couldn't call pylint from within emacs (M-x pylint) as I used to, so I installed the package python-mode. Now ...
0
votes
0answers
10 views

In Ubuntu SDK, how do you search for text which include linebreaks?

If you ctrl+f in Ubuntu SDK to browse through your code, and you paste within the search box a multi-line piece of text, it will fail to find any results. Is there a way to get around this ...
0
votes
0answers
213 views

How to make gedit a java ide

Im looking for a lightweight ide. I've heard that gedit can also be used for this purpose. Can anyone tell me how to make it a java ide, I haven't come across anything helpful yet. In Tools > Manage ...
1
vote
1answer
610 views

How to interact with python scripts on geany after running, just like on IDLE

On IDLE after running a script/program made with python by pressing f5, you could still interact with the program even after it finished running. But on Geany, when running it, and when the program ...
5
votes
1answer
2k views

Is there any shortcut key to align code in Geany editor?

Am using Geany editor in ubuntu 13.10, Is there any shortcut key to align code (auto-alignment) in Geany editor? For example : in Eclipse - Ctrl+Shift+F to invoke the Auto Formatter
0
votes
2answers
295 views

Question about Tidy

I just installed Geany IDE When I tried to compile HTML file I got error /bin/sh: 1: tidy: not found Can someone help
1
vote
1answer
2k views

How to change font of code in PyCharm?

PyCharm Community Edition 3.1.3 on Ubuntu Gnome 14.04. Can't find where to change the font of code in PyCharm. File > Settings > Editor > Colors & Fonts > Font > Editor Font is ...
2
votes
2answers
7k views

Pycharm Pro and Ubuntu

I have installed Pycharm on Ubuntu 14.04 using this useful guide. However the installation is the Community one and I'd like to get the Pro version for which I have a licence. Is there any way to ...
0
votes
0answers
117 views
1
vote
2answers
2k views

How to install and use jedi-vim python IDE for vim on ubuntu

How to install jedi-vim python plugin on vim installed on ubuntu and use it's features from remote terminal window. I have gone through documentation as describe but my vim acts in the same normal was ...
2
votes
1answer
40 views

Having trouble installing Ubuntu Phone SDK

I've been trying to install Ubuntu Touch development software, and tried installing the packages by trying these two commands: sudo add-apt-repository ppa:ubuntu-sdk-team/ppa as well as ...
1
vote
1answer
137 views

Android IDE for Ubuntu

Are there any other IDEs other then eclipse for Ubuntu which can be used for Android Development
2
votes
3answers
2k views

IDE/Compiler for C or C++ Programming [duplicate]

Is there any software that supports on C or C++ Programming? Then, if it so, how to run, compile or debug your own code to display its output via terminal(linux/ubuntu) or cmd(windows)
1
vote
0answers
459 views

'Android SDK missing' error when trying to install Titanium

I'm trying to install Titanium on my Ubuntu 13.10. But I can't setup Android SDK. It always show an Error like An Android SDK is missing. Titanium requires Android platform: 2.3.3 or above. I have ...
29
votes
1answer
4k views

phpStorm losing keyboard input

Every now and again phpStorm will lose input from my keyboard. I can still click around, but it will not register any keys. Other windows are fine. It takes a phpStorm restart to bring them back. It ...
1
vote
2answers
359 views

uses vim as an ide

I want plugins for vim so that I can use it as a C language IDE. I used to use qtcreator and I really appreciate his auto-completion (really perfect), but after trying for several months vim I really ...