For questions related with the GStreamer multimedia framework. GStreamer allows a programmer to create a variety of media-handling components, including simple audio playback, audio and video playback, recording, streaming and editing.

learn more… | top users | synonyms

9
votes
3answers
7k views

Ubuntu 14.04, problem when install gstreamer1.0-libav, unmet dependencies

Suddenly my Ubuntu stopped playing video. When I open a video, the player suggests that I install gstreamer1.0-libav. However, it fails to install. I tried installing it manually, here is the error ...
9
votes
5answers
39k views

How do I get HTML5 h.264 Video working on Firefox?

According the the release notes for Firefox 26, h.264 video should now be working in Linux. It does also say the appropriate gstreamer plug-ins need to be installed. Does anyone know what these are? ...
4
votes
1answer
9k views

How to enable VDPAU on GStreamer?

I'm currently experiencing a bit of lag on 720 HD videos. I am hoping VDPAU will help. How do I enable it on either GStreamer-based video players?
3
votes
2answers
8k views

How do you edit the “Preferred Format” settings in Rhythmbox?

In Rhythmbox's Preferences, you can change the "Preferred Format" for Music to MPEG Layer 3 Audio, Ogg Vorbis, FLAC, or MPEG 4 Audio. However, despite there being a Settings button, it does not become ...
20
votes
3answers
26k views

Clementine won't play .wma, with “Your GStreamer installation is missing a plugin” error

Here's a screenshot: It displays messages like: "Clementine stopped." or displays songs that are not playing, and indicator icon is disappearing and reappearing. Does this happens only to me, or is ...
10
votes
4answers
64k views

How can I install gstreamer 1.0 in Ubuntu 12.04?

I'm trying to install GStreamer 1.0 on Ubuntu 12.04, the default GStreamer that comes with Ubuntu 12.04 is gst 0.10. I could see that I could download the GStreamer 1.0 source from ...
4
votes
1answer
2k views

“gstreamer1.0-libav” Package dependencies cannot be resolved [duplicate]

I am in Ubuntu 14.04 amd64, I have met all updates available, but also I am getting these errors in media codecs. First I got this error: gstreamer1.0-libav:i386: Depends: libavcodec-extra-54 ...
2
votes
1answer
1k views

13.04 stopped playing streams in Rhythbox and totem

The stream does not play in Rhythmbox nor totem. It played fine before the upgrade; it looks like a regression from an earlier report about the same. The streams play in mplayer and play fine when ...
2
votes
1answer
181 views

Clarifications about Gstreamer

I'm a bit confused about what Gstreamer does. Does it come installed by default with Ubuntu ? If so which version is the default for 14.04? Does it provide hardware accelerated video playback ...
5
votes
1answer
3k views

Plugins: “ugly” and “bad”

Why are gstreamer plugins labeled as "bad" and "ugly"?
3
votes
3answers
3k views

Why doesn't .mkv files play properly with ubuntu-restricted-extra?

I am running Ubuntu 10.04 with ubuntu-resticted-extra installed. When I play .mkv with the default player, totem it causes the player to stop suddenly without any warning after a random amount of ...
5
votes
2answers
7k views

Video playback not working in Ubuntu 11.10 [closed]

(Ubuntu 11.10, Gnome Classic with Compiz, Nvidia graphics card) This problem occurs with every and all video, whether it's a Youtube video in Firefox, an AVI file in movie player, or any other video. ...
3
votes
1answer
801 views

How do I upgrade to the latest version of Shotwell?

I am running Ubuntu 10.10, and am trying to upgrade Shotwell to the latest version (0.11.1). I've been trying to follow the instructions on the Shotwell installation page for building from source but ...
1
vote
1answer
540 views

Problem with m4a files

Rhythmbox, vlc and totem instantly crash when opening a m4a file. When I run rhythmbox -d and play a m4a file, I receive this message: (rhythmbox:9023): GStreamer-CRITICAL **: ...
1
vote
1answer
558 views

Unable to seek in MP3 encoded files

When I try to play any MP3 encoded song in Rhythmbox, the seek bar is disabled. Upon trying to play the same files in Totem, the same problem appears again. I think that the problem started after ...
1
vote
1answer
1k views

Totem issue with youtube: gstreamer

When trying to play youtube videos in Totem, I get this error: GStreamer encountered a general supporting library error. When starting from the commandline, the actual error is is this: ...