For questions related with the GStreamer multimedia framework. GStreamer allows a programmer to create a variety of media-handling components, including simple audio playback, audio and video playback, recording, streaming and editing.

learn more… | top users | synonyms

0
votes
1answer
232 views

Packages Broken not able to Play Videos [duplicate]

Hi not able to play videos getting and unable to install video players too gstreamer1.0-libav : Depends: libavcodec54 (>= 6:9.1-1) but it is not going to be installed or ...
3
votes
1answer
3k views

“gstreamer1.0-libav” Package dependencies cannot be resolved [duplicate]

I am in Ubuntu 14.04 amd64, I have met all updates available, but also I am getting these errors in media codecs. First I got this error: gstreamer1.0-libav:i386: Depends: libavcodec-extra-54 ...
1
vote
1answer
697 views

How to add audio elements and video elements for gstreamer with qtdemux

I want to stream a youtube video using gstreamer. So I gave the following command in command line : gst-launch-0.10 souphttpsrc location=$(/usr/local/bin/youtube-dl -g -f 18 i4jTHhXuKLA) ! typefind ! ...
1
vote
0answers
381 views

gst-rtsp-server

In ubuntu / debian there is a package which is gst-rtsp-server-0.10 which is the gstreamer rtsp server package however the current version in ubuntu seems to be somewhat buggy / unstable How would I ...
1
vote
0answers
886 views

Ubuntu 14.04, Rhythmbox, missing gstreamer1.0-libav (i386) plugin dependencies

I've recently updated Ubuntu 12.04 to 14.04 (64 bit version). The problem that I've noticed is that Rhythmbox cannot play ALAC (m4a) files. Also, when I run some radio stations, the systems complains ...
0
votes
1answer
1k views

Gstreamer gst-launch-1.0: symbol lookup error: gst-launch-1.0: undefined symbol: _gst_date_time_type

Hi everyone I installed gstreamer on ubuntu and whenever I try to execute some commands in terminal I get : gst-launch-1.0: symbol lookup error: gst-launch-1.0: undefined symbol: _gst_date_time_type ...
3
votes
2answers
12k views

Installing can I install gstreamer 1.4 on ubuntu 14.04?

Hello everyone I need to know is it possible to install gstreamer 1.4 framework on Ubuntu 14.04 I searched google but really didn't found anything about it.
1
vote
1answer
698 views

Problem with m4a files

Rhythmbox, vlc and totem instantly crash when opening a m4a file. When I run rhythmbox -d and play a m4a file, I receive this message: (rhythmbox:9023): GStreamer-CRITICAL **: ...
9
votes
3answers
12k views

Ubuntu 14.04, problem when install gstreamer1.0-libav, unmet dependencies

Suddenly my Ubuntu stopped playing video. When I open a video, the player suggests that I install gstreamer1.0-libav. However, it fails to install. I tried installing it manually, here is the error ...
0
votes
0answers
27 views

Ubuntu bluetooth audio, no sound after pairing [duplicate]

I've rarely used bluetooth on Kubuntu 14.04 and I'm trying to use a set of Bluetooth speakers (Loewe Speaker 2go). I've done the pairing with the wizard, and the device shows as an "Audio Sink", ...
0
votes
2answers
858 views

Wine Corrupted, stream libraries, everything?

I can't remove wine at all, I cannot sudo apt-get remove, purge, or autoremove without error.I've tried removing the /usr/bin/wine files, everything. I am at a complete loss, as every suggestion I've ...
0
votes
1answer
142 views

gstreamer bad plugin of file .dep are not allowing me to install any software

For any install in ubuntu It is giving the same error. How can I remove all these gstreamer package errors? The error is installArchives() failed: dpkg: dependency problems prevent configuration ...
1
vote
1answer
2k views

Wine: using webcam with Cisco Jabber Video client

I'm trying to use Cisco Jabber Video client (https://www.ciscojabbervideo.com/home) with Wine but I'm unable to get the webcam to work. Steps that I have completed this far: Register an account for ...
1
vote
0answers
301 views

How to develop android apps in eclipse with gstreamer?

is there a good and clear tutorial to make install eclipe with andoid and gstreamer developpement in ubuntu 12.04? when I import the tutorial, that an error "gstreamer can not be resolved " with the ...
2
votes
2answers
2k views

QML Qt 5.2 problem with mp4 video

I have qt 5.2(ubuntu sdk) installed on Ubuntu 14.04 When I try to run QML code: MediaPlayer { id: mediaPlayer source: "../path/test.mp4" autoPlay: true } VideoOutput { id: video ...
1
vote
2answers
2k views

Gnome-subtitles shows no video

When I open a subtitle here in Gnome Subtitles there is no video. Just the subs, the audio, and the black screen. It used to work in previous ubuntu instalations I had and in Linux Mint. Just found ...
2
votes
4answers
3k views

Audio applications not playing on 14.04

I recently installed Ubuntu 14.04 from scratch, overwriting 13.10. Ever since then, I haven't been able to play audio in most desktop media applications: Spotify, Rhythmbox, Pithos, Banshee...all of ...
3
votes
1answer
1k views

How to fix a gstreamer error

I upgraded to 14.04 and now gstreamer is not working. What I am trying to accomplish is to hear the audio input on my computer coming from a ham radio. This is the command that I am using: gst-launch ...
2
votes
0answers
407 views

gstreamer pulseaudio echo cancellation

I'm implementing a voip application using gstreamer, i use the example of the rtp in the plugin-good! i want to implement echo cancellation, i couldn't use the speex echo canceller with gstreamer ...
9
votes
1answer
5k views

Plugins: “ugly” and “bad”

Why are gstreamer plugins labeled as "bad" and "ugly"?
1
vote
3answers
7k views

Can't play .TS format from a Samsung TV recording

I recored a movie by Samsung TV and It has a .TS format, and I can't play it. I tried VLC and Smplayer. None of them work. In VLC I get this Error: [0x7fbc40c018b8] ts demux error: libdvbpsi (misc ...
7
votes
3answers
24k views

Ubuntu 14.04 64bit - 'GStreamer ffmpeg video plugin' problem

I can't install gstreamer0.10-ffmpeg on Ubuntu 14.04
8
votes
1answer
7k views

How to play .m4a in Clementine?

Clementine says missing gstreamer plugin when I try to play a .m4a file. Totem and Rhythm Box play it fine. $ wajig listinstalled gstreamer0.10 gstreamer0.10-alsa:amd64 gstreamer0.10-nice:amd64 ...
3
votes
1answer
235 views

Clarifications about Gstreamer

I'm a bit confused about what Gstreamer does. Does it come installed by default with Ubuntu ? If so which version is the default for 14.04? Does it provide hardware accelerated video playback ...
27
votes
3answers
35k views

Clementine won't play .wma, with “Your GStreamer installation is missing a plugin” error

Here's a screenshot: It displays messages like: "Clementine stopped." or displays songs that are not playing, and indicator icon is disappearing and reappearing. Does this happens only to me, or is ...
5
votes
1answer
5k views

Cheese do not start due “GStreamer elements are missing: cluttervideosink”

I recently upgraded to Ubuntu Gnome 14.04, and when I tried to use cheese, it showed the message One or more needed GStreamer elements are missing: cluttervideosink Cheese worked just fine in 13.10 ...
0
votes
2answers
676 views

Is there any light user interface or gtk package for Gstreamer 1.0?

I have just installed package gstreamer 1.0, and I use as executable the file located in ~/usr/bin/gst-play-1.0 . All is fine, I can play local files, and also I can use 'gst-play-1.0' in TV-MAXE to ...
1
vote
1answer
1k views

gstreamer error : MP4 files and thumbnails doesn't work

I think I have done something, but I can't tell what exactly... Now, my Ubuntu doesn't want to decode MPEG-4 and H.264 video-files (files extensions .avi .mp4). vlc still works (of course, it has ...
13
votes
5answers
54k views

How do I get HTML5 h.264 Video working on Firefox?

According the the release notes for Firefox 26, h.264 video should now be working in Linux. It does also say the appropriate gstreamer plug-ins need to be installed. Does anyone know what these are? ...
3
votes
0answers
2k views

missing gstreamer plugin

Whenever i open my webcam with cheese it automatically stops. I think the problem is because of some gstreamer plugins missing. Where can I get this plugin? The following is the output of ...
0
votes
1answer
9k views

How to install gstreamer 1.0 in ubuntu 12.04

The install given elsewhere in the forum is sudo add-apt-repository ppa:gstreamer-developers/ppa sudo apt-get update sudo apt-get install gstreamer1.0* Which isn't currently working ...
1
vote
1answer
1k views

How to enable gstreamer for Firefox 25.0 Ubuntu 13.10

i try to make a Javascript where I need to test the ability of playing "video/mp4". I do that with: var video = document.createElement('video'); video.canPlayType('video/mp4'); But my Firefox ...
1
vote
1answer
294 views

Gstreamer 0.10.21 - how to update faad decoder version from 0.10.22.3 to 0.10.23

How to only update one decoder? I have one hardware which is using echo cancel + noise reduction, when i use decoder faad version 0.10.22.3 it does not work even using WebRTC or PJ echo. I need to ...
0
votes
1answer
245 views

How do I fix the Ubuntu Software Center with gstreamer0.10-plugins-bad?

I can't update files or get new files. I think the problem is gstreamer0.10-plugins-bad. Here's the message I get in Ubuntu Software Center: "New software can't be installed, because there is a ...
0
votes
1answer
3k views

Unresolved Gstreamer dependencies

I am new to Ubuntu, and I am trying to install gstreamer on Ubuntu 12.04.3LTS upgraded from Super OS 11.10 (a repackaging of Ubuntu 11.10 with more apps and plugins ex: vlc and wine) but am getting ...
0
votes
1answer
591 views

How can I reinstall packages accidentally removed when trying to remove another package?

I accidently executed sudo apt-get remove --purge gstreamer0.10, and the packages such as gimp, gnome-, Rhythmbox and etc are removed, so I forced to stop the processing, but I don't remember what ...
3
votes
1answer
341 views

Which media players available in the Ubuntu repositories uses GStreamer, GTK+ and were written in Python?

I'm planning to write a media player for Ubuntu to present in fair in the place I study. And I'd like to use GStreamer and GTK+ with Python, but I could not find a good documentation about the ...
0
votes
1answer
127 views

Upgrade to 13.04 was not successful. Gstreamer not working. What do?

I finally decided to upgrade to 13.04. In the middle of the installation my computer froze completely, and so I decided to force quit. I log back on, and notice that the login says 13.04, but not ...
1
vote
1answer
548 views

How to play h264 encoded videos with Totem?

I can play some mkv videos but some others can't play. Why? I don't want to install ubuntu-restricted-extras cause it brings Adobe Flash that has not been supported again and it is the old version. ...
2
votes
1answer
1k views

13.04 stopped playing streams in Rhythbox and totem

The stream does not play in Rhythmbox nor totem. It played fine before the upgrade; it looks like a regression from an earlier report about the same. The streams play in mplayer and play fine when ...
11
votes
4answers
81k views

How can I install gstreamer 1.0 in Ubuntu 12.04?

I'm trying to install GStreamer 1.0 on Ubuntu 12.04, the default GStreamer that comes with Ubuntu 12.04 is gst 0.10. I could see that I could download the GStreamer 1.0 source from ...
8
votes
1answer
2k views

Building Rhythmbox from source

I'm trying to build rhythmbox from source to have a go at adding an extra feature. I'm running into issues with gstreamer configure: error: Package requirements ( gstreamer-1.0 >= 0.11.92 ...
0
votes
1answer
123 views

On what (main) “engines” are based Ubuntu video players? [closed]

Thinking about using Xine, beside other players like VLC and the mplayer-based ones, I became interested in this and tried to understand this kind of terminology (player, frontend, gui, engine, etc), ...
1
vote
1answer
798 views

Gstreamer videosink configuration error when playing videos with Parole

I can't play videos with Parole. Theres is a gstreamer error (videosink configuration). I've also installed restricted extras and VLC and i still can't play movies. I've no problem playing audio ...
2
votes
0answers
148 views

Music lags/ hiccups when I seek using any Banshee or Rhthmbox

I have been using Linux for years now and this has never been a problem. but on my latest system [Ubuntu 12.10 with Gnome Classic Session] It has been.. hiccuping is the best I can describe it. It ...
1
vote
1answer
457 views

How can I adjust the setting for OggVorbis encoding in Rhythmbox on Ubuntu Precise (12.04)? [duplicate]

Possible Duplicate: How do you edit the “Preferred Format” settings in Rhythmbox? I want to read a CD to my music library. I want to use OggVorbis for compression. I want to set the quality ...
1
vote
1answer
3k views

Install 32-bit gstreamer plugins on 64-bit

I am trying to install the 32-bit gstreamer plugins on my 64-bit system (Ubuntu 12.10 based). I can install the packages gstreamer0.10-plugins-base:i386 and gstreamer0.10-plugins-good:i386. However, ...
1
vote
1answer
1k views

error while trying to play .mp4 file

after agree to download and install extra multimedia plugins, it says package dependency can not be resolved, with below error: The following packages have unmet dependencies: ...
2
votes
1answer
722 views

Can't play midi file, Gstreamer keeps asking for i386 plugin that can't be installed (64bit)

I use Ubuntu 12.04 LTS 64bit. When trying to play midi (.mid) file, it asks for a gstreamer plugin, but the Install button itself is unclickable. Actually, I have gstreamer0.10-plugins-bad ...
3
votes
0answers
597 views

Which are the radio stations are compatible to radiotray?

I had some trouble in searching and adding radio stations to RadioTray. It will be extremely helpful if some one lists radio stations which work on RadioTray. Rock, hard rock, metal, traditional ...