glibc is the GNU C Library, which provides many common and important functions for programs. Almost every program in Ubuntu directly or indirectly depends on this, and will completely fail to run without it. Besides the kernel, glibc is probably the most essential part of the system; even the init ...

learn more… | top users | synonyms

0
votes
0answers
13 views

GTK error - including libc and libpthread

I am trying to install a software that utilizes GTK. When I try to open the software I get the following error: I tried to reinstall the software along with the GTK - but it didn't work. What can be ...
0
votes
0answers
13 views

how to add GLIBC_2.14 and GFORTRAN_1.4 to a remote computer

since I am still beginner in Linux so, I need more explanation for the following; I tried to run -bash-4.1$ ./gtest by the remote computer but it give me the following message. and I need a help to ...
0
votes
0answers
15 views

glibc 2.23 on 16.04 LTS missing sched_getcpu from sched.h

I'm trying to compile some C on Ubuntu that calls sched_getcpu(void) but there seems to be a problem. I'm looking at /usr/include/ and the function is missing from sched.h So Ubuntu's own man pages ...
0
votes
1answer
33 views

Why is apt-get update not picking up recent versions of the package I need?

I'm having trouble installing some software on Travis CI due to missing dependencies to specific versions of libstdc++. /usr/local/EnergyPlus-8-4-0/energyplus: /usr/lib/x86_64-linux-gnu/libstdc++....
8
votes
3answers
1k views

apt: relocation error: version GLIBCXX_3.4.21 not defined in file libstdc++.so.6 with link time reference

Since trying to upgrade to 16.04 xenial, I'm getting $ apt apt: relocation error: /usr/lib/x86_64-linux-gnu/libapt-pkg.so.5.0: symbol ...
0
votes
0answers
28 views

Downloading GLIBC version 2.14

From where do I download an older version of GLIBC ? I am looking for versions 2.14 of GLIBC and version 4.15 of GLIBCXX
0
votes
1answer
45 views

Steam says I am missing 32-bit libraries

When I install Steam I get: You are missing the following 32-bit libraries, and Steam may not run: libc.so.6. How do I run
0
votes
0answers
23 views

Getting Dependencies error anytime while trying to install any package

I am getting the following error while removing or adding any new software, rfc5766-turn-server:i386: Depends: libc6 (>= 2.7) but 2.19-0ubuntu6.7 is installed Depends: ...
2
votes
0answers
621 views

GLIBCXX_3.4.21 not defined in file libstdc++.so.6 with link time reference

When trying to execute any c++ programs, I get this error. The full error message is: ./main: relocation error: ./main: symbol _ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEC1Ev, version ...
0
votes
0answers
55 views

How to rebuild eglibc-2.19 for ubuntu-14.04?

I have the well known TLS issue dlopen: cannot load any more object with static TLS and am trying to recompile eglibc-2.19 on ubuntu-14.04 (x86_64) to increase TLS consumers, i.e. DTV_SURPLUS in ...
0
votes
0answers
182 views

Binary compiled on 15.10 on 14.04 has glibcxx linking problems

I'm trying to run a binary that was compiled on 15.10 on a 14.04 system. (It's this package I want to use: https://github.com/50ButtonsEach/fliclib-linux-dist and they only provide it for 15.10). I ...
0
votes
1answer
39 views

2016 glibc vunerability [duplicate]

We are inheriting some older O.S's at another facility and apparently their support person has moved on. I have some Linux background but it is not with Ubuntu (Redhat). They are older operating ...
1
vote
0answers
93 views

How to restart glibc services without reboot?

On the glibc issue, I realize have a serious issue with restarting ubuntu instances running on my network. It will interrupt lots of stuff for me and so I'm looking for an alternative. These ...
0
votes
0answers
97 views

Would Apache need to be recompiled after patching glibc?

Unfortunately I'm not experienced in this realm, but I'm working on patching our Ubuntu system in light of the new glibc vulnerability. We're using a version of Apache that we compiled ourselves from ...
0
votes
0answers
18 views

libc error Err?=(none)/Reinst-required

i have an error Desired=Unknown/Install/Remove/Purge/Hold | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad) ...
2
votes
2answers
3k views

Upgrading glibc

I just read here that there is security bug in glibc and that it is already fixed. I found out, that the actual insalled version glibc can be shown by 'ldd --version' My systems runs version 2.19. ...
0
votes
0answers
14 views

Vulnerability check for glibc Security Issue: glibc getaddrinfo stack-based buffer overflow [duplicate]

A security problem with getaddrinfo in GNU’s glibc was reported by Google Engineers How can I check if my systems are affected? (using ubuntu 14.04 LTS) How to fix this issue?
4
votes
3answers
4k views

Which Ubuntu releases have fixes for CVE-2015-7547 (“Extremely Severe Bug” with libc getaddrinfo())? [duplicate]

Ars Technica posted an article describing the getaddrinfo() bug and how it is widespread in the Linux world. The vulnerability was introduced in 2008 in GNU C Library, a collection of open ...
0
votes
0answers
131 views

Upgrade 12.04 -> 14.04 : libc6

I just tried to upgrade a 12.04.5 server to 14.04.1 and got the following error message during the upgrade of the libc6-bin package: (Lese Datenbank ... 408104 Dateien und Verzeichnisse sind ...
0
votes
1answer
56 views

glibc-2 is required for this package

I'm pretty new to the Linux world and I'm trying to compile a plugin for DeaDBeeF that's located in this git repo. The instructions say: ===== How to install ===== - git clone https://github.com/...
1
vote
0answers
142 views

eglibc-2.19 nptl build failure on 14.04.3 LTS

vagrant@precise64:~/eglibc-2.19/build$ ../configure --prefix=/tmp/eglibc-2.19 produces: checking build system type... x86_64-unknown-linux-gnu checking host system type... x86_64-unknown-linux-gnu ...
0
votes
0answers
85 views

Broken libc6 package on 14.04.3

I have broken system package libc6 in the Ubuntu Server 14.04.3 which has had libc6_2.19 version and i tried to install 2.15 version. After this attempt most system commands don't work (ls, cp, mv, ...
1
vote
0answers
235 views

Updating glib 2.22 or later on ubuntu 14.04 facing issues.

I'm installing 'libsnarf" which requires glib_ version 2.22 or later Im on ubuntu 14.04 with ldd --version Ubuntu EGLIBC 2.19-0ubuntu6.6) 2.19 when I sudo apt-get install libglib2.0-0 ...
0
votes
0answers
183 views

undefined reference to `__aeabi_read_tp' while compiling glibc2.15 for arm-linux

CC=arm-linux-gnueabi-gcc ../glibc-2.15/configure --host=arm-linux-gnueabi --prefix=/mnt/us/hunter/glibc --without-tls --enable-kernel=2.6.26 --enable-add-ons=nptl,ports CFLAGS="-O2 -U_FORTIFY_SOURCE -...
0
votes
0answers
243 views

error with /lib/libc.so.6: version `GLIBC_2.15' not found?

When I run a program in terminal, it print these: [Failed to open library /mnt/us/hunter/classpath/lib/classpath/libjavanio.so: /lib/libc.so.6: version `GLIBC_2.15' not found (required by /mnt/us/...
2
votes
0answers
155 views

eglibc-2.19 nptl compilation failed on Ubuntu 14.04 LTS

I was trying to build eglibc-2.19 which I downloaded through apt-get source libc6 I followed the INSTALL instructions but got this error when it ran into nptl, gcc sem_init.c -c -std=gnu99 -fgnu89-...
2
votes
3answers
425 views

Installing sqldeveloper – dependency problems: sqldeveloper depends on libc6-amd64 (>= 2.2.5)

dpkg: dependency problems prevent configuration of sqldeveloper: sqldeveloper depends on libc6-amd64 (>= 2.2.5). dpkg: error processing package sqldeveloper (--install):dependency problems - ...
0
votes
1answer
348 views

Buildroot Help Glibc

Iv been trying to use buildroot 2015, but it fails compiling glibc with this error: checking for x86_64-buildroot-linux-gnu-gcc... /home/sam/buildroot/buildroot-2015.05/output/host/usr/bin/x86_64-...
0
votes
1answer
2k views

upgrading glibc to a version at least 2.17 or higher in ubuntu 12.04 LTS?

I need a newer version of glibc in my ubuntu version (precise, 12.04), but I don't seem to be able to go beyond version 2.15 using apt-get. I tried to compile it by myself but I almost destroyed my ...
1
vote
1answer
133 views

relocation error [closed]

In my application I need to use these libraries.But I get this error.I am so new at linux and these issues so I don't understand anything.Do you have any idea about this problem? relocation error: ...
0
votes
1answer
40 views

Given an MD5 hash find the libc it corresponds to

I'd like to find the Ubuntu distribution that contains a libc.so.6 file that hashes to a particular MD5 hash value. Is there a way to go about doing that?
2
votes
1answer
3k views

Ubuntu 12.04.5 LTS won't update libc6 to 2.15-0ubuntu10.10

In light of CVE-2015-0235, I set out to upgrade my Ubuntu Servers today. I have a 12.04.5 LTS server that refuses to update my libc6 package to the version that does not contain the vulnerability (2....
3
votes
1answer
4k views

CVE-2015-0235 How to update eglibc to 2.15-0ubuntu10.10

I followed these instructions and found that my glibc version was 2.15-0ubuntu10.9. How do I update it to 2.15-0ubuntu10.10? It is also mentioned here that services have to be restarted after the ...
3
votes
1answer
5k views

Unable to restart Nautilus (required by Dropbox)

Every time I log in dropbox opens up the screen informing me that Nautilus needs to be restarted. Clicking the restart button does nothing though. If I enter terminal and run nautilus -q it ...
0
votes
2answers
1k views

Ubuntu 14.04 GCC 4.8.2 link dynamically against (older) GLIBC 2.11.1

For the needs of my project I need to use G++ 4.8.2 and GLIBC 2.11.1. Ubuntu 14.04 comes with EGLIBC 2.19. How can I make G++ link dynamically against GLIBC 2.11.1? If there is, how do I go about ...
0
votes
1answer
613 views

Ubuntu 14.04 libc.a file not recognized

When i try to compile a simple .c file with gcc i always get this error: /usr/lib/gcc/x86_64-linux-gnu/4.8/../../../x86_64-linux-gnu/libc.a: file not recognized: File format not recognized i tried ...
1
vote
1answer
377 views

Lost GUI after installed GTK. Gets warning-“System running in low graphics mode”

am using ubuntu 14.4.0 64 bit. yesterday i installed GTK, Glibc and it's dependencies. including, libffi-dev, libcairo2-dev, libtiff-dev, flex, bison, xorg-dev, libatk-bridge2.0 finally ...
0
votes
1answer
487 views

apt-get not looking at /usr/lib for libstdc++.so.6

I have come across the somewhat common "GLIBXX_3.4.15 not found" error. In my case though I'm seeing something really weird. Usually the error appears something like this: /usr/lib/libstdc++.so.6: ...
1
vote
1answer
593 views

Is Ubuntu 14.04 using eglibc or glibc?

I have an ARM chip CM-FX6 using Ubuntu 12.04LTS (armel) using the linux image provided by the vendor Compulab. It is using eglibc. Recently I have to install some sdk for video streaming from ...
0
votes
1answer
212 views

I am unable to download eglibc 2.14 source through svn as www.eglibc.org seems to be down since the last 2 days. Is there an alternate way?

I am trying to build a cross-compiler using crosstool-ng 1.12.2. It bails out while trying to download the eglibc 2.14 packages. Here is the log: DEBUG] ==> Executing: 'svn' 'export' '-r' 'HEAD'...
0
votes
1answer
152 views

glibc reinstallation with new kernel

Recently i removed some old kernel with autoremove function. But later found that i am getting error in configuring linux kerel. Also i googled and got that linux-libc-dev depends on old kernel ...
0
votes
1answer
15k views

apt-get update does not work [duplicate]

I have just installed Ubuntu for the second time (separate downloads) onto my nexus 7. Both the times I could not use apt-get upgrade and thus could not install any applications. Upon the second ...
1
vote
0answers
50 views

Ubuntu kernal panic libc6 screenshot attached

I was installing some packages, 'create repo' I think. I guess this must have messed up my libc6 installation as now I am receiving a kernal panic when I restart my box. Complaining about missing ...
1
vote
1answer
364 views

Nagios remote execution problem libc-so-6-version-glibc-2-14-not-found

i have installed nagios core 4 on ubuntu server 12.04 lts.. everything working fine,, but... i have a problem with remote command to a remote linux (ubuntu server 12.04) pc! when i try to check a ...
0
votes
1answer
721 views

Installing GLIBC from source

I want to install a different version of glibc on my Ubuntu 12.04. The questions are 1) Is it safe to have two versions of GLIBC on a system? 2) Should I remove the current installed GLIBC? How? 3)...
3
votes
2answers
21k views

Can't install glibc-2.19

Several times I tried to install the library glibc-2.19, but it always ended in an error. I followed the installation instructions but it didn't work. I'm trying to install glibc-2.19 on Ubuntu 13.10, ...
1
vote
0answers
735 views

How to install glibc 2.12 or 2.14 on Ubuntu 12.04?

I am making a JNI call to a C++ library and it is compiled in glibc v2.12 or v2.14, but Ubuntu 12.04 has glibc 2.15. Whenever I make a call to the C++ library I get the error glibc 2.14 not found. ...
0
votes
1answer
116 views

How to install older GNU lib C? Is this neccessary?

I am trying to install proprietary ATI Catalyst drivers on my Ubuntu 12.04.1. Every driver on AMD's website says it requires glibc version 2.2 or 2.3. Upon running the ldd --version command, I have ...
0
votes
1answer
20k views

How to get Silverlight and Flash 10+ to work in Chromebook and Ubuntu 12.04 with Firefox [duplicate]

I would like to watch content from many of TV-station's streaming services. First I need Flashplayer 10+ with Firefox and then Silverlight (Mac and Windows are supported I think, Chromebook is not, ...
17
votes
1answer
140k views

libc.so.6: version `GLIBC_2.14' not found

Whenever I try to run a program from the terminal (apt-get for example) I get a: apt-get: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /usr/lib/libstdc++.so.6) Not ...