1
vote
0answers
223 views

What glib do I need?

I am running Ubuntu 12.04 and I am trying to compile the cpabe toolkit, but first I have to compile libbswabe. However, when I try to build libbswabe-0.9 it gives me an error stating that glib.h ...
2
votes
0answers
264 views

I have two versions of glib on my system, and I don't know how to remove the old one

While trying to compile a program (pygobject), running ./configure I am told that I don't have glib. So, I download the tarball and compile and install, no problems. now when I try to ./configure ...
1
vote
1answer
1k views

Glib.h error while trying to compile an application

I've been trying to compile this app from source https://code.launchpad.net/gala and i keep getting this message when i run MAKE: Scanning dependencies of target gala [ 11%] Building C object ...
2
votes
0answers
5k views

How to fix 'error: GLib >= 2.28 is required' when compiling linux-nfc on Ubuntu 10.04?

I try to compiled linux-nfc code, and running its configure file, but I get an error: configure: error: GLib >= 2.28 is required I try to update the glib with apt-get install libglib2.0-0 ...
3
votes
1answer
2k views

compiling from Ubuntu 12.04 using older glibc version

I am an old newbie I am learning now a Operating Systems course where we need to compile a program in 9.10 Ubuntu. this program is not running as expected on further releases of Ubuntu (such as 12.04) ...