The tag has no wiki summary.

learn more… | top users | synonyms

1
vote
0answers
31 views

Why can't I install bcrypt?

I've a problem: when I try to install some Gem with the command "bundle install", I recive this output: Gem::Ext::BuildError: ERROR: Failed to build gem native extension. /usr/bin/ruby2.1 -r ...
0
votes
0answers
25 views

can't install capybara-webkit

When I bundle install I get: Gem::Ext::BuildError: ERROR: Failed to build gem native extension. /usr/bin/ruby2.1 extconf.rb Command 'qmake -spec linux-g++ ' not available Makefile not found ...
1
vote
1answer
162 views

Bundle install fatal error

I am migrating my project over to a new machine and I am having trouble running bundle install on the machine I am trying to use. When I run: bundle install I get this error: Unfortunately, a ...
0
votes
1answer
109 views

gem install eventmachine fails, using rvm

Ubuntu 13.10 64bit, ruby 2.1.1 rvm 1.25.24 gem 2.2.2 from log file: compiling pipe.cpp ...
0
votes
2answers
192 views

Ruby - no such file to load [gems]

This is error: [ERROR] no such file to load -- readline [TIP] Try to run 'gem install readline' or 'gem install --user-install readline'. If you still get an error, Please see README file or ...
2
votes
1answer
468 views

puppet rspec no such file to load — rspec-puppet (LoadError)

I have no prior experience at all of ruby. I am not interested in ruby (and so have no knowledge of rails etc) as such but am using puppet to manage a group of servers. I have written some modules ...
1
vote
1answer
167 views

Gsl ruby gem on Ubuntu Saucy (13.10)

I'm trying to install the gsl gem on Ubuntu Saucy I installed the relevant gsl packages with sudo apt-get install gsl-bin libgsl0-dev But then installing the gem fails In file included from ...
1
vote
2answers
732 views

Unable to Install Guard

I've seen Guard and it's usefulness in web development and would like to install it. Naturally, I expected to be able to use sudo gem install guard to do so (yes, it is a Ruby Gem). However the ...
0
votes
1answer
1k views

why sudo gem install fails but gem install succeeds?

I simply do sudo gem install sqlite3 and have response: sudo: gem: command not found Then I do gem install sqlite3 and it works. Where is the problem with sudo ?
0
votes
1answer
189 views

gssapi requires Ruby version >= 1.9.1. on gem install

I'm trying to install knife-cloudstack plugin using gem install on Ubuntu 12.04 with chef-client configured and got error as said in title. >gem install knife-cloudstack ERROR: Error installing ...
2
votes
1answer
315 views

pdfbeads will only output a single page

Following the instructions from this page I take a djvu document, check it for any sign of corruption by opening it in djvulibre and it checks out fine. Copy it to my testing folder and rename it ...
0
votes
1answer
385 views

error: alternative gem can't be master: it is a slave of ruby

I am struggling to get ruby up and running, and i get this message in many installations update-alternatives: error: alternative gem can't be master: it is a slave of ruby The full message: ...
1
vote
1answer
876 views

can't rake, missing gem but it's available

I'm trying to rake but I keep getting this As you can see, i18n (0.6.4) is installed and alive, so what's going on? what am I missing? I have tried to uninstall and install again, all went well ...
0
votes
2answers
4k views

Determine which version of a gem is installed?

Is there a way via CLI to determine which version number of a gem is installed on my machine? Similar to yolk -l for python? I'm trying to see if I have the latest version of compass / sass / zurb ...
3
votes
1answer
1k views

Installing Jekyll with gem

Im using Ubunto 12.04 I am trying to install Jekyll through gem with sudo gem install jekyll but i get this error at some point of the installation: ERROR: While generating documentation for ...
3
votes
0answers
2k views

Failed to install a ruby gem, eventmachine

I attempts to run a script that prompt Could not find gem 'eventmachine (= 0.12.10) ruby' in the gems available on this machine. Run bundle install to install missing gems. Then I runs ...
1
vote
1answer
7k views

Could not find a valid gem 'rails' (>= 0) in any repository

I am trying to install rails using the following command: sudo gem install rails and get the following error: ERROR: Could not find a valid gem 'rails' (>= 0) in any repository ERROR: ...
0
votes
1answer
41 views

Can I submit a ruby gem I'm working on for ubuntu app showdown?

I've been working on a ruby project, can I submit this for app showdown? Basically its a sinatra app, runs a site on localhost, which plays songs in browser
4
votes
1answer
4k views

Can't install gems from behind proxy

I'm running 12.04 in a VM, and I am behind a corporate proxy. I've got the environment variables set (tried both all lower and all upper case for [http|https|ftp]_proxy, as well as not specifying the ...
3
votes
1answer
3k views

How do I start a ruby/gem program?

I have installed taskjuggler (gem install taskjuggler), but now I have no idea how to start it... $ taskjuggler taskjuggler: command not found $ gem taskjuggler ERROR: While executing gem ... ...
2
votes
2answers
1k views

Can't run a program installed through gem install

I have installed Ruby using RVM. I did a gem install rspec command and it seemed to install rspec correctly. If I do a rspec I get a "The program 'rspec' is not currently installed" and I am ...
1
vote
1answer
677 views

Successfully installed SASS, but the terminal insists it isn't

I wanted to install sass version 3.2.0 alpha. I first ran sudo apt-get install libhaml-ruby1.8, which is what the console recommended It successfully installed, but it installed an older version ...
2
votes
2answers
345 views

Error while installing rails

Following this tutorial here, to install ruby on rails on ubuntu 11.10 with sqlite3 when I run the following command sudo gem install rails I get the following error : ERROR: Could not find a ...
8
votes
3answers
16k views

How do I update to the latest version of SASS?

This is really stupid but I've been Googling for an hour now and can't find the answer. I'm on Ubuntu 10.10, and I'm trying to update to the latest version of SASS so that I can use an @import rule ...