The GNU Compiler Collection is the standard compiler system used on many Unix-like operating systems, including Linux. Originally meant for compiling C programs, it can now also handle C++, Java and several other languages.

learn more… | top users | synonyms

6
votes
0answers
526 views

bfd.h should include libiberty/ansidecl.h in Ubuntu 14.04?

binutils package seems to be changed, as include directory of libiberty.h has moved to /usr/include/libiberty, thus there is possible a wrong include in bfd.h regarding ansidecl.h. Getting those ...
4
votes
0answers
236 views

Compiling and linking of a C program

I am learning about compiler linker and loader and was trying to understand the working of linker and loader on my ubuntu 12.04 machine I wrote 2 simple ".c" files as follows test.c #include<...
4
votes
0answers
549 views

Cross compile for ARM using gcc-multilibs

There are various questions available in AskUbuntu related to Cross compiling. They were not of much help to me. I used to work on gcc-4.5/4.6 for ARM. It was available in Ubuntu repo under the name ...
3
votes
0answers
27 views

compile can't find GL lib

bjorn@bjorn-031:~/samples/SOP$ gcc -lGL /usr/bin/ld: cannot find -lGL I've installed libglu1-mesa-dev and rebooted. I'm using Nvidia drivers. This output look strange to me though: ldconfig -v .....
2
votes
0answers
1k views

Prefix and Path for Cross GCC in Eclipse

I'm pretty new in ubuntu and have a problem with it. I wanna to write a c++ program in eclipse and compile it with cross gcc. At the first i Added "CDT" from "help-->install new software" Now when ...
2
votes
0answers
98 views

Esterel Compiling in Ubuntu 64 bit

The latest version of esterel is available only in 32 bit. Installed it in 64 bit ubuntu. When compiling esterl to C. I haven't get any errors. esterel -simul foo.strl cc -c foo.c While running: ...
2
votes
0answers
288 views

How to compile Saurik's ldid on Ubuntu?

I am trying to install Theos on my Ubuntu and I am stuck on step which is supposed to install ldid: git clone git://git.saurik.com/ldid.git cd ldid git submodule update --init ./make.sh When I ...
2
votes
0answers
216 views

unable to compile program using -m32 and gcc

I have installed multi2sim on my 64-bit Ubuntu machine. Both gcc 4.8 and 4.8.1 is installed in my system. Even after setting and exporting the LD_LIBRARY_PATH AND LD_INCLUDE_PATH, and installing the ...
2
votes
0answers
906 views

GDB not showing C code when gcc -g option is used

I have a file called hello_world.c. I use the command gcc -g -Wall hello_world.c Then gdb ./a.out I set a breakpoint at line 27 And run, it tells me this: warning: no loadable sections found in ...
2
votes
0answers
1k views

Problems installing gcc for cross compiling for ARM

I've been trying to install the gcc-arm-linux-fnueabi package, and I've done it a few times by a few different methods but I always seem to be missing the c++ folder in the includes directory. To ...
2
votes
0answers
2k views

gcc couldn't locate slab.h in ubuntu 12.04?

Please correct me if I'm missing something here. Thanks for your inputs. Header included in code: #include <linux/slab.h> Code snippet from my file that's asking for memory allocation using "...
2
votes
0answers
584 views

Binary package for gcc 4.8.2 on Ubuntu 12.04?

Following this answer, I have installed gcc 4.8.1 on Ubuntu 12.04 a couple of months ago. Unfortunately, I encounter bugs very frequently, varying from failing to compile valid programs to crashing. ...
2
votes
0answers
204 views

Problem when compiling GCC in Ubuntu

I have run into the well known problem when installing GCC: configure:3605: error: in /usr/local/gcc-4.8.1/i686-pc-linux-gnu/libgcc': configure:3608: error: cannot compute suffix of object files: ...
2
votes
0answers
1k views

Changing default GCC Compiler in 12.04

I just downgraded from 13.04, which seems to have some stability problems right now, and moved back to 12.04.LTS. I installed the GCC 4.8 compiler, which is not the default GCC compiler on 12.04. I ...
2
votes
0answers
2k views

gcc does no come up with new upgraded Kernel

After I figuerd out my ubuntu 12.10 amd64 with 3.5.X Kernel does not fill some queuing, and they've fixed that in kernel 3.8.x, I upgraded the kernel of my Ubuntu to v3.10-saucy with installing deb ...
2
votes
0answers
315 views

gcc 4.3 not in repository anymore?

matlab has been so nice not to update its supported compilers. The latest version supported that supports the so-called mex-files is gcc-4.3.4. Now, this version also seems to be deleted from the ...
1
vote
0answers
29 views

Ubuntu 12.04 LTS - Upgrade to a specific version of previously available GCC version

I've added the ppa:ubuntu-toolchain-r/test repo for getting the latest GCC-5 version but I had the unfortunate surprise that the available version for 12.04 LTS changed a few days ago from 5.3 to 5.4. ...
1
vote
0answers
47 views

'make' error - glib.h no such file or directory on Raspberry Pi

I am trying to compile an Example but I am getting following errors/issues. I am not sure where the config file and make file is for this package and I don't want to make changes that wipe out ...
1
vote
0answers
28 views

“evilmake all” not working…please help

I am trying to insatll idlutilis, When I am doing : $ evilmake all i get error: nrutil.h:45:12: warning: ‘iminarg1’ defined but not used [-Wunused-variable] static int iminarg1,iminarg2; ...
1
vote
0answers
814 views

Installing GCC 6.0 in Ubuntu Linux 14.04 LTS

I want the latest version of GCC, namely the GCC 6.0, for running a software. The linux version installed is 14.04 LTS. Every time I am trying to upgrade the GCC version I am ending up installing the ...
1
vote
0answers
46 views

Is libffi.pc broken on Ubuntu?

I'm trying to cross-compile wayland (from freedesktop.org) for a Trusty Tahr armhf environment. To set up the cross-compile I have an arm pkg-config script that properly sets PKG_CONFIG_LIBDIR and ...
1
vote
0answers
51 views

Error while installing R's chron package

I am running R in ubuntu 14.04. Trying to install the package "chron" I get the following message: gcc -std=gnu99 -I/usr/share/R/include -DNDEBUG -fpic -g -O2 -fstack-protector --param=ssp-...
1
vote
0answers
121 views

apt-get upgrade fail for Unmet dependencies after gcc compile

On my headless Ubuntu 14.04.3, I need to use the last release of gcc compiler (version 5.2.0), so I recompiled locally gcc downloading source an doing a checkinstall ( thanks to helpfull answer here: ...
1
vote
0answers
359 views

Can't install gcc-4.9-base:i386 on Ubuntu 14.04

I've been running into some problems while trying to install wine and steam on Ubuntu 14.04, and they all seem to stem from the gcc-4.9-base:i386 package. When I run sudo apt-get install gcc-4.9-base:...
1
vote
0answers
91 views

Problems building libmodbus 3.0.6 ubuntu 14.04

I am finding that libmodbus http://libmodbus.org/ is compiling incorrectly on both my laptop and desktop running Ububtu 14.04 both were upgraded from 11.10 some time ago. I have tried using the live ...
1
vote
0answers
237 views

How to install gcc 2.95.3 on ubuntu 14.04 64 bit?

How to install gcc 2.95.3 on ubuntu 14.04 64 bit. I require to do this to compile kernel 2.6.10. Newer versions of gcc do not compile the linux kernel 2.6.10. Thanks in advance.
1
vote
0answers
65 views

Setup cross-compile env. in eclipse for Kernel API

I'm cross compiling for a beaglebone black (that is running debian) on ubuntu and I want to make Kernel API calls from module.h, kmod.h, or firmware.h and those don't appear to be in the arm-linux-...
1
vote
0answers
132 views

Could not able to compile with /opt/ELDK42/usr/bin/ppc-linux-g++

here is my test.cpp #include<iostream> using namespace std; int main() { cout<<"hello world"; return 0; } $ /opt/ELDK42/usr/bin/ppc-linux-g++ test.cpp ...
1
vote
0answers
38 views

Use package without declaring its version

I have installed g++ from here. When I want to compile a program, I have to use g++-4.9 myle.cpp. How can I set it to use without declaring its version g++ myle.cpp?
1
vote
0answers
663 views

Undefined references to `_gfortran_runtime_error_at'

I use a model is written Fortran90 under Ubuntu 14.04. The gfortran 95 compiler (gfortran 4:4.8.2-1ubuntu6) and the gcc 4:4.8.2-1ubuntu6 is installed by Ubuntu Software Center. The installed gcc has ...
1
vote
0answers
181 views

more than one version of gcc installed

When I enter clang++ -v it outputs Ubuntu clang version 3.5.0-4ubuntu1~xedgers14.04.1 (tags/RELEASE_350/final) (based on LLVM 3.5.0) [...] Found candidate GCC installation: /usr/lib/...
1
vote
0answers
404 views

OsmocomBB - compile error

I tried to install OsmocomBB on my Ubuntu, I've got gnu-arm-toolchain, but when I'm compiling there is an error: configure: error: in `/home/robert/OsmocomBB/osmocom-bb/src/shared/libosmocore/build- ...
1
vote
0answers
2k views

How to install old version of gcc on Ubuntu 14.04

I need to install gcc 3.0 on Ubuntu 14.04. I tried to compile sources but it throws error. Is possible to install gcc 3.0 from repository? How to do that? This does not work for me. apt-get update ...
1
vote
0answers
521 views

Why can I compile against libclang-3.5.so and not against libclang.so?

I am trying to compile a C source file, that needs to be linked against a dynamic library I installed through apt-get (libclang.so). apt-get installed the clang shared libraries in /usr/lib/x86_64-...
1
vote
0answers
18 views

Modify Ubuntu toolchain

In version 11.10 the flag "--as-needed" became default in the Ubuntu toolchain. Due to many problems I have with undefined symbols at runtime I don't want to change all the makefiles anymore. I want ...
1
vote
0answers
277 views

How do I set gcc 4.8 to be the default gcc?

I'm trying to update to gcc 4.8.2. I have Ubuntu 12.04. after this if I type gcc -v it says gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) Next I typed sudo add-apt-repository ppa:ubuntu-...
1
vote
0answers
141 views

How do I set the F77 environment variable to gfortran?

I'm new Ubuntu (and linux) user. In order to do my senior project, I have to install psrchive I use this command to install psrchive ./psrsoft/bin/psrsoft psrchive --no-cfitsio This is part of ...
1
vote
0answers
389 views

Compiled packages and apt-get mess

Due to my work I have to use the last version of gdb (7.7) which is not provide in the ubuntu repositories. For that purpose I download the source code, compiled it and installed it successfully. My ...
1
vote
0answers
2k views

gcc problem -> stdio.h not found

I have to compile one programme. theoretically i need just to change the two path... can you help me? Makefile # Original #CC=arm-1136jf_s_r1_vfp_hard_float-linux-gnueabi-gcc #CFLAGS= -O3 -...
1
vote
0answers
1k views

gcc-4.8 Header files

I am having some trouble using the header files provided by gcc-4.8 since updating to Ubuntu 13.10. When I compile with the Intel compiler icc, it complains about not being able to find the header ...
1
vote
0answers
2k views

gcc without g++?

I run Ubuntu 13.04 (x86_64 if it matters) which I recently installed. Before, when using 12.10, I had both gcc and g++ from the beginning. However, with 13.04 after I downloaded gcc-4.8.1 sources I ...
1
vote
0answers
113 views

Problem with compiling fft using gcc

I have downloaded the source codes of Splash2 from here and i tried to compile fft.c using gcc command on my own machine but i got this error : fft.c:62:28: fatal error: parmacs_config.h: No such ...
1
vote
0answers
428 views

Ramifications of uninstalling GCC 4.7 in leu of GCC 4.6 in Quantal?

I currently have both the gcc-4.6 and gcc-4.7 packages installed in Quantal. I do a lot of software development but haven't had a need for any features that are specific to GCC 4.7. Therefore, in ...
1
vote
0answers
1k views

How do I install GCC 4.7.1 on 12.04?

It so happens that I hit a bug in Ubuntu's GCC 4.7.0, which has been fixed in later versions of GCC; I believe it's already fixed in 4.7.1. I can always download the source, compile and install it, ...
1
vote
0answers
946 views

How do I install/compile CORSIKA & FLUKA for 32-bit Ubuntu 12.04?

I want to use some programs (CORSIKA and FLUKA) which are essentially designed for 32 bit systems. I've installed the 32-bit version of 12.04 on my system (Intel® Core™ i7-2700K CPU @ 3.50GHz × 8). ...
0
votes
0answers
44 views

Error on compile CyanogenMod

I need help. After running make mrproper I can't build CM source in Ubuntu 14.04. It's throwing this error: build/core/tasks/kernel.mk:149: *********************************************************...
0
votes
0answers
12 views

problem during execution multi2sim simulator

I have installed multi2sim-5.0 simulator on ubuntu 14.04 for project work. When I execute "hello world" program, display it, but when use this command m2s --x86-debug-syscalls stdout hello gives error ...
0
votes
0answers
31 views

too many errors while executing dpkg --configure -a

I am not an expert in Ubuntu. I use Ubuntu for my work purposes only. I was trying to upgrade my Ubuntu from 15.04 to 15.10 and while doing lots of dpkg error occurred. Then I restarted the computer ...
0
votes
0answers
18 views

How can I install a subversion of gcc using a .deb file

Actually I have gcc version 4.8.4-2ubuntu1~14.04.3 installed on my PC. Now I need to install gcc version 4.8.2-10ubuntu1 instead. Everytime I try to install the other version, the compilation ...
0
votes
0answers
50 views

Can't install package: dependends on gcc-4.8-base 14.04.01

I'm trying to install all the dependencies to run ASP.Net Core applications on a linux system. I basically have no experience with linux or the linux platform. I found a tutorial explaining the ...