The GNU Compiler Collection is the standard compiler system used on many Unix-like operating systems, including Linux. Originally meant for compiling C programs, it can now also handle C++, Java and several other languages.

learn more… | top users | synonyms

73
votes
2answers
194k views

How to install gcc-4.8

I checked the gcc version on my system. It is currently at 4.6.3. I read that gcc-4.8 is out. I tried the following commands without success: sudo apt-get install gcc (gcc is already the newest ...
6
votes
7answers
23k views

Can I use a C/C++ compiler?

I shifted to Ubuntu 10.10 now I am facing problem to have C/C++ compiler. What are the possible ways so that I can use C/C++ compiler using all the libraries (like graphic, math, conio, stdlib, etc) ...
80
votes
3answers
145k views

Choose gcc and g++ version

So I have installed gcc-4.4 and gcc-4.3 (same for g++). Now as far as I remember there is a tool in Ubuntu which sets the symlinks for you if you just tell it which version you want. However it does ...
34
votes
3answers
87k views

How do I use the latest GCC on Ubuntu 14.04?

I want to compile my program with the latest version of gcc. Ubuntu 14.04 comes with gcc 4.8.2, however there's 4.9.0 available, moreover, I see that it is available as a package: gcc-4.9. I tried to ...
59
votes
7answers
156k views

Getting + installing gcc/g++ 4.9 on Ubuntu?

How do I install the latest version of gcc and g++? I am using a variety of C++11 and C++1y features; which is why I need this.
9
votes
4answers
32k views

Old version of gcc for new Ubuntu

Is there a repository containing packages for old versions of gcc, for the latest Ubuntu. I want to install gcc3 alongside gcc 4, for programs that need gcc3 specifically.
2
votes
3answers
2k views

How to Compile and Run C program

I have installed GCC compiler using Install the build-essential command. after the installation I wrote a simple c prgm. I tried to run with following command: gcc First.c ./a.out but I'm getting ...
6
votes
1answer
3k views

How to use multiple instances of gcc?

I have both gcc 4.7.3 and 4.8.1 installed But on running gcc --version I get gcc (Ubuntu/Linaro 4.7.3-1ubuntu1) 4.7.3 Copyright (C) 2012 Free Software Foundation, Inc. This is free software; see ...
1
vote
1answer
934 views

Problem installing g++ ccompiler on Ubuntu 14.04

I tried to install g++ using packages from another user. offline..but there were errors. After connecting to the net I tried to install using sudo apt-get install g++, but it gave the following ...
47
votes
5answers
85k views

How do I install gcc 4.7?

I wish to install gcc 4.7 so that I can use some c++11 features. I downloaded the source, ran ./configure and was told I needed GMP. Downloaded the code for that, hit ./configure and was told I ...
8
votes
2answers
21k views

How to use GCC 4.7 in place of 4.6?

So I'm working on a project and I wanted to use some C11 features for C. To use those features GCC 4.7 is required, so I went to synaptic and looked up 4.7, and I found the packages gcc-4.7-base so I ...
10
votes
1answer
93k views

configure: error: C compiler cannot create executables

I was trying to install rvm using \curl -L https://get.rvm.io | bash -s stable --ruby --autolibs=enable --auto-dotfiles. It worked fine until I got a configure error: Error running './configure ...
18
votes
4answers
52k views

How to update gcc to the latest version(in this case 4.7) in Ubuntu 10.04?

I have Ubuntu 10.04 32-bit with gcc 4.4.3 currently installed on it. I want to upgrade it to gcc/g++ 4.7 (I am looking for C++ 0x support) How to update using Ubuntu Package Manager: apt-get ...
27
votes
3answers
202k views

Install gcc on Ubuntu 12.04 LTS

When I try to install gcc on Ubuntu 12.04 LTS Server with apt-get install gcc, I get the following error: The following packages have unmet dependencies: gcc : Depends: cpp (>= 4:4.6.1-2ubuntu5) ...
21
votes
1answer
49k views

Cross-Compile for ARM?

How do I set up GCC for cross compiling for the ARM processor? The host would be on x68 ( AMD64 - Ubuntu 12.04 ) and the target would be ARM ( Raspberry Pi as well as Pandaboard - will do separate ...
14
votes
4answers
50k views

GLIBCXX_3.4.20 not found, how to fix this error?

Whey I try to run the program Layout Editor (available on this site) on Ubuntu 14.04.1 64-bit LTS I get the following output in the terminal: $ layout layout: ...
9
votes
3answers
45k views

My program cannot run with “command not found” error

I just switched from Windows to Ubuntu 11.10. I wrote the following code in C with the text editor and saved it as HelloWorld.c in Documents. #include <stdio.h> int main() { printf("Hello ...
4
votes
4answers
7k views

How do I install ALL development libraries?

I want to preinstall all the libraries one could ever need onto a system so someone building something would always have the libraries available. Like in a computer lab where users are not root. I ...
3
votes
3answers
2k views

Bochs Compiling Error AGAIN

I'm trying to compile bochs with this command: ./configure --with-x11 --with-wx --enable-ne2000 --enable-iodebug --enable-disasm --enable-debugger --enable-e1000 --enable-usb --enable-pci it works, ...
2
votes
2answers
10k views

Installing missing package that provides Xm/Xm.h

I'm compiling a software package that requires a header file. The header file is missing from my Ubuntu 11.10 (64-bit) installation. During the compilation using make, gcc and gfortran, I receive ...
1
vote
2answers
4k views

GCC 5.2 on Ubuntu 15.04

Can someone walk me through getting the latest version of gcc on Ubuntu 15.04? I have tried finding testchains but those only go up to 5.1, I believe. Is this something I need wily for?
1
vote
1answer
2k views

C compiler cannot create excecutables

When I am trying to install a openvpn from a tarball , following error occurs checking whether the C compiler works... no configure: error: in `/home/shubhamd/Downloads/openvpn-2.3.2': ...
1
vote
3answers
4k views

Can't install gcc 4.8, dependency issues

I tried downoading 4.8 for 12.04 from https://launchpad.net/~ubuntu-toolchain-r/+archive/test/+packages (I did not find for 13.04 as is mentioned here: How to install gcc-4.8 in Ubuntu 12.04 from the ...
4
votes
1answer
19k views

cannot find -lgcc_s

I am attempting to compile a program with g77 and I keep getting the following error: /usr/bin/ld: cannot find -lgcc_s collect2: ld returned 1 exit status I saw on another forum that this is ...
1
vote
2answers
19k views

Is it possible to downgrade gcc 4.6.1 to 4.4.x?

I've tried the following: sudo apt-get remove gcc sudo apt-get install gcc-4.4 But this does not work, running gcc --version gives a 'No such file or directory' error.
0
votes
2answers
529 views

How to install library that uses g77

I am trying to install "TAUCS" (http://www.tau.ac.il/~stoledo/taucs/) library. However, I am getting following error: /usr/bin/ld: skipping incompatible external/lib/linux/libmetis.a when searching ...
6
votes
2answers
3k views

Need a PPA for the latest GCC

I'm looking for a PPA with the latest and greatest version of GCC. I'm too scared to switch to something totally unstable and knock my production system out of wack, but want the newest version of ...
5
votes
5answers
17k views

How do I install gcc-4.3?

Is there and easy way to install gcc-4.3 on Oneiric ? I really need it because matlab depends on i for the creation of mex-files I tried changing all my resopistories back to Maverick just to install ...
3
votes
2answers
1k views

python 2.7.9 backport to trusty (14.04)

I try to backport Python 2.7.9 from vivid to trusty but when launchpad build this pakage there is an build error. I create my backport : backportpackage -d trusty -u ppa:splanquart/python ...
2
votes
1answer
2k views

Installing gcc from Kubuntu DVD

I am having a hard time with a Kubuntu 12.04 install that does not have an internet connection. In order to build the ethernet driver, I need gcc. I installed from the DVD, and I have gcc-4.7-base ...
1
vote
1answer
2k views

Update GCC compiler in Ubuntu 14.04 to 4.9 [duplicate]

Can I upgrade my GCC compiler now in Ubuntu 14.04? Has the final usable version (4.9) been released?
1
vote
1answer
107 views

What gcc version do I need?

I have installed ns-2.28 on ubuntu 12.04. My kernel version is 3.2.0-29-generic-pae. What gcc version matches my ns-2.28 & 3.2.0-29-generic-pae?
1
vote
1answer
284 views

How to install 64-bit libraries on 32-bit system?

I need to cross-compile for 64-bit architecture on a 32-bit platform (using gcc-multilib and -m64 flag). For this I need to install 64-bit versions of the dependent libraries. How do I do that?
15
votes
2answers
52k views

Building a 32-bit app in 64-bit Ubuntu

After hours of googling, I decide to give up and ask you experts. I am trying to build a 32-bit application (xgap if anyone interested) in my 64 Ubuntu 11.10. I added the CFLAGS=-m32 and the ...
13
votes
4answers
14k views

How to install g++ 5.1 on Ubuntu desktop 15.04 64-bit?

I'd like to experiment with the new GCC 5.1 C++ compiler on Ubuntu. So, I downloaded and installed Linux Ubuntu desktop 15.04 64-bit in a virtual machine. Then, in the terminal, I entered the ...
11
votes
3answers
8k views

Downloaded g++ 4.8 from the PPA but can't set it as default?

I have downloaded g++ 4.8 on Ubuntu 12.10 by doing: sudo add-apt-repository ppa:ubuntu-toolchain-r/test sudo apt-get update sudo apt-get install g++-4.8 but when I do: sudo update-alternatives ...
10
votes
3answers
17k views

How to activate gcc 4.7 version?

I have gcc 4.6.3 installed: gcc --version gcc (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3 I have installed newer version: apt-get install gcc-4.7 But i still get result "gcc 4.6.3" when I type gcc ...
11
votes
1answer
5k views

How to speed up compilation of Ubuntu apps (make, cmake, gcc)

I am compiling some programs here and I have 4 cores. Is there a way to tell make, cmake or gcc to compile using all cores or something to that affect.
5
votes
4answers
6k views

Can't build gcc anymore since upgrade to 11.10

On Monday I've upgraded to from Ubuntu 11.04 (my initial installation) to 11.10 and now I can't build gcc from source anymore. Since I forgot to uninstall the gcc package before the upgrade, Ubuntu ...
6
votes
2answers
14k views

Trouble compiling a 32 bit binary on a 64 bit machine

I'm trying to compile a c program as a 32 bit binary instead of 64 bit. I started by just adding -m32 and got some errors. Googling around a little I came across a note to install ia32-libs. ...
6
votes
5answers
15k views

Linking problems after updating to 11.10

Right now I am having difficulties linking a project I am working on with gcc4.6 in ubuntu 11.10. Before the distribution upgrade everything linked fine and it still compiles/links on the other ...
4
votes
2answers
5k views

Building a static version of Python?

I tried asking this question at StackOverflow, but the dead silence that followed made me wonder if some more Ubuntu-specific expertise might be required. I am trying to build a static version of ...
9
votes
2answers
1k views

Can't compile with GCC on Ubuntu 12.04

I'm trying to compile and run the below C program on my Ubuntu & Windows machines with both GCC & VC9. However, I'm facing below issues: On Ubuntu machine: GCC compiles fine, but when run, ...
3
votes
1answer
16k views

-std=c++11 not recognized on gcc 4.8.1

I just followed an answer to this question to update my gcc version to 4.8. 1 on Ubuntu 12.04, which I thought would support C++11. However it does not seem to. When I try to compile something with ...
3
votes
1answer
6k views

How to compile & install Emerald window manager in Ubuntu 13.04 64bit?

Please give me directions to compile & install Emerald specifically in Raring Ringtail 64bit edition. I've tried to compile it from the source many times, but had no luck.(Compile log : ...
3
votes
3answers
2k views

Are gcc versions tied to kernel versions?

Is there any link between gcc versions and the version of a kernel ? Specifically, would I be able to install a very old version of gcc onto the latest kernel. Alternatively would I be able to build ...
2
votes
1answer
9k views

How to install GCC 4.7 on Lubuntu 11.10?

I installed Lubuntu 11.10 and I installed build-essential with this command: sudo apt-get install build-essential Now I have gcc 4.6 I read on some forum that adding the next PPA I'll be able to ...
1
vote
1answer
263 views

Install gcc/g++ on Ubuntu Phone

My back is so sore and it hurts to sit. However, I need to do my coding assignment. Will it be possible to install gcc/g++ on my Ubuntu Phone and compile my code on it? I tried running sudo apt-get ...
1
vote
1answer
3k views

Using gcc 3.4 on Ubuntu 14.04

By exactly following this post, I was able to install gcc 3.4 on a fresh install of Ubuntu 14.04. But, when I try to compile a program, it fails with the following error: /usr/bin/ld: cannot find ...
1
vote
1answer
7k views

cannot install lxml in virtualenv (python)

I cannot install lxml. In system i have python-lxml package, but i need other... Please help, if you can - my task is install lxml for development in virtual enviroment using virtualenv. I found this ...