The GNU Compiler Collection is the standard compiler system used on many Unix-like operating systems, including Linux. Originally meant for compiling C programs, it can now also handle C++, Java and several other languages.

learn more… | top users | synonyms

2
votes
3answers
312 views

Compiling Mame 0.170 on Ubuntu 15.10

when trying to compile mame 0.170 I get the following error: m1xalis@m1xalis-HP-Compaq-6830s:~$ cd .mame m1xalis@m1xalis-HP-Compaq-6830s:~/.mame$ make GCC 5.2.1 detected Compiling ...
2
votes
0answers
1k views

Prefix and Path for Cross GCC in Eclipse

I'm pretty new in ubuntu and have a problem with it. I wanna to write a c++ program in eclipse and compile it with cross gcc. At the first i Added "CDT" from "help-->install new software" Now when ...
2
votes
3answers
205 views

PPA removed and purged but still showing available upgrades

This is on Ubuntu 14.04 (SERVER, so no GUI) Ok so earlier today I was asked to upgrade GCC to GCC 4.9 (current available is GCC 4.8 for Trusty). So following these directions I installed the PPA ...
2
votes
0answers
85 views

Esterel Compiling in Ubuntu 64 bit

The latest version of esterel is available only in 32 bit. Installed it in 64 bit ubuntu. When compiling esterl to C. I haven't get any errors. esterel -simul foo.strl cc -c foo.c While running: ...
2
votes
1answer
530 views

Help with cross-compiling for ARM

I have recently been trying to cross-compile programs for ARM. However, when I run make, I always get an error within a minute or less that says something like ...
2
votes
0answers
278 views

How to compile Saurik's ldid on Ubuntu?

I am trying to install Theos on my Ubuntu and I am stuck on step which is supposed to install ldid: git clone git://git.saurik.com/ldid.git cd ldid git submodule update --init ./make.sh When I ...
2
votes
1answer
693 views

U-boot build fails - cannot find lgcc / libgcc.a

I am using Ubuntu 12.04 LTS 64 bit and trying to create a Linux Image for the SAMA5D36-EK. In doing so I need the mkimage command. According to website www.at91.com/linux4sam/bin/view/LinuxSAM/U-Boot ...
2
votes
0answers
203 views

unable to compile program using -m32 and gcc

I have installed multi2sim on my 64-bit Ubuntu machine. Both gcc 4.8 and 4.8.1 is installed in my system. Even after setting and exporting the LD_LIBRARY_PATH AND LD_INCLUDE_PATH, and installing the ...
2
votes
1answer
506 views

Compile error when trying to run make

I have the following error when trying to run make command, /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.7/../../../libcppunit.a when searching for -lcppunit /usr/bin/ld: ...
2
votes
1answer
19k views

How to install gcc 4.9 on Ubuntu 14.04? [duplicate]

Now that gcc 4.9 is officially released, is there an easy and convenient way to install it on Ubuntu 14.04 through the package manager (ie. apt-get)? I would also appreciate information on how to ...
2
votes
0answers
888 views

GDB not showing C code when gcc -g option is used

I have a file called hello_world.c. I use the command gcc -g -Wall hello_world.c Then gdb ./a.out I set a breakpoint at line 27 And run, it tells me this: warning: no loadable sections found in ...
2
votes
0answers
1k views

Problems installing gcc for cross compiling for ARM

I've been trying to install the gcc-arm-linux-fnueabi package, and I've done it a few times by a few different methods but I always seem to be missing the c++ folder in the includes directory. To ...
2
votes
0answers
384 views

How to repair broken gcc compilers [duplicate]

I want to install g++. But I got error sanket@sanket-Inspiron-N5110:/opt/objdir$ sudo apt-get install g++ Reading package lists... Done Building dependency tree Reading state information... ...
2
votes
0answers
2k views

gcc couldn't locate slab.h in ubuntu 12.04?

Please correct me if I'm missing something here. Thanks for your inputs. Header included in code: #include <linux/slab.h> Code snippet from my file that's asking for memory allocation using ...
2
votes
0answers
557 views

Binary package for gcc 4.8.2 on Ubuntu 12.04?

Following this answer, I have installed gcc 4.8.1 on Ubuntu 12.04 a couple of months ago. Unfortunately, I encounter bugs very frequently, varying from failing to compile valid programs to crashing. ...
2
votes
0answers
199 views

Problem when compiling GCC in Ubuntu

I have run into the well known problem when installing GCC: configure:3605: error: in /usr/local/gcc-4.8.1/i686-pc-linux-gnu/libgcc': configure:3608: error: cannot compute suffix of object files: ...
2
votes
0answers
1k views

Changing default GCC Compiler in 12.04

I just downgraded from 13.04, which seems to have some stability problems right now, and moved back to 12.04.LTS. I installed the GCC 4.8 compiler, which is not the default GCC compiler on 12.04. I ...
2
votes
0answers
2k views

gcc does no come up with new upgraded Kernel

After I figuerd out my ubuntu 12.10 amd64 with 3.5.X Kernel does not fill some queuing, and they've fixed that in kernel 3.8.x, I upgraded the kernel of my Ubuntu to v3.10-saucy with installing deb ...
2
votes
1answer
127 views

Error installing SHA

I'm trying to install SHA using the following command perl -MCPAN -e 'install Digest::SHA' I also tried using: sudo cpan 'install Digest::SHA' But i'm getting a linker error: ...
2
votes
0answers
131 views

gnudialer Make Problem [closed]

I am trying to build gnudialer. I followed these steps to the T. Now on the last step, making the gnudialer, I get this error: dispo.h:71:1: warning: deprecated conversion from string constant to ...
2
votes
0answers
314 views

gcc 4.3 not in repository anymore?

matlab has been so nice not to update its supported compilers. The latest version supported that supports the so-called mex-files is gcc-4.3.4. Now, this version also seems to be deleted from the ...
2
votes
1answer
1k views

A question about “add-apt-repository”(gcc 4.7 or bumblebee)

I installed Ubuntu 12.04 in my notebook and I use C++. I want to use C++11, so I want to upgrade my gcc to gcc-4.7. I ran these commands: sudo add-apt-repository ppa:ubuntu-toolchain-r/test sudo ...
2
votes
1answer
313 views

Python app crash after sending command “GPIO.setup( 7, GPIO.OUT)”?

Python app crash after sending command "GPIO.setup( 7, GPIO.OUT)" !!! Action step: pi@rp:~$ python3 Python 3.4.3 (default, Mar 26 2015, 23:09:09) [GCC 4.9.2] on linux Type "help", "copyright", ...
1
vote
3answers
400 views

How to install a stand-alone program

If I create the following program in C: #include <stdio.h> int main(){ printf("Hello World"); } And then compile it like so: gcc helloworld.c -o helloworld Is there any easy way to ...
1
vote
2answers
2k views

GCC Fatal Error

everyone Here's my problem; So, I'm new to Ubuntu and programming and I just wanted to start with C. I created the classic "hello.c" file #include <stdio.h> main () { printf("Hello ...
1
vote
1answer
7k views

cannot install lxml in virtualenv (python)

I cannot install lxml. In system i have python-lxml package, but i need other... Please help, if you can - my task is install lxml for development in virtual enviroment using virtualenv. I found this ...
1
vote
3answers
9k views

apt-get: error loading libgcc_s.so.1

I am using Ubuntu 12.04.3 LTS, 64-bit, with gcc 4.6.3 I want to update gcc to 4.7, and do as the link said: How do I install gcc 4.7? But I got error: Fetched 14.0 MB in 18s (767 kB/s) ...
1
vote
2answers
45k views

How to compile a C program that uses math.h? [closed]

I am having problems in math.h header file and when I use square root function as in sqrt(d). But my compiler is not supporting this. Please advise me about this problem. My Ubuntu version is 2012.
1
vote
1answer
191 views

How to deinstall gcc-5-base

I have somehow installed gcc-5-base and now I am unable to deinstall it: sudo apt-get remove gcc-5-base Reading package lists... Done Building dependency tree Reading state information... ...
1
vote
2answers
4k views

GCC 5.2 on Ubuntu 15.04

Can someone walk me through getting the latest version of gcc on Ubuntu 15.04? I have tried finding testchains but those only go up to 5.1, I believe. Is this something I need wily for?
1
vote
2answers
10k views

No such file or directory #include <string> [closed]

I wrote the program kai.c and now am trying to compile it with gcc kai.c -o kai, which returns: kai.c:5:18: fatal error: string: No such file or directory #include <string> ^ ...
1
vote
3answers
366 views

best place to learn ubuntu linux for a windows programmer newbie

I am a programmer, I developed in C/C++/C#.NET, JAVA, HTML and Matlab Most of my work was in C# and .NET framework generally I recently switched to try linux for 2 months as exploration, I want to ...
1
vote
3answers
4k views

Can't install gcc 4.8, dependency issues

I tried downoading 4.8 for 12.04 from https://launchpad.net/~ubuntu-toolchain-r/+archive/test/+packages (I did not find for 13.04 as is mentioned here: How to install gcc-4.8 in Ubuntu 12.04 from the ...
1
vote
1answer
333 views

Exec format error of gcc-compiled Hello World c++

I know there are many similar questions with this error message here. But I cannot find any solution yet. On AWS ubuntu server, I wrote c++ Hello, World program #include <iostream> using ...
1
vote
1answer
9k views

g++ (4.6.1) does not recognize -std=c++11 [closed]

I'm trying to compiling a program (via Make) using g++ 4.6.1 with flag -std=c++11. It's giving me: cc1plus: error: unrecognized command line option ‘-std=c++11’ This is running on Ubuntu 11.04 ...
1
vote
1answer
7k views

Installing proxychains. HELP NEEDED! [duplicate]

OK so i am new to linux. I am trying to install proxychains but im sure it has dependencies that i do not have on my system can somebody look at the following script and tell me the list of packages i ...
1
vote
1answer
8k views

How to install gcc-4.4.6?

My computer has Ubuntu 11.10 32-bit OS. I downloaded gcc4.4.6 core package (tar file), unzipped it and tried the following: ./configure sudo make install which gave me the following error: ...
1
vote
3answers
230 views

Simple way to get all .o files but one

I'm trying to link all *.o files from another folder and would like to in my Makefile do something like; g++ *.o (folder/*.o and not folder/main.o) -o bin Is there someway I can use somekind of ...
1
vote
2answers
70 views

Unable to install build-essential, held broken packages

So I was trying to set up my computer for development. I installed ubuntu 14.04 LTS. I wanted to write a hello-world-program. However I can not compile it. After some searching, I tried sudo apt-get ...
1
vote
2answers
131 views

How to get all packages listed in a PPA at once?

For example, if I do: sudo add-apt-repository ppa:ubuntu-toolchain-r/test sudo apt-get update sudo apt-get install gcc-5 g++-5 I get gcc-5 but not gfortran-5 or cpp-5 or any of the other packages ...
1
vote
1answer
354 views

gcc doesn´t work

I have a problem with GCC I try to compile Wine 1.7.26. When I use the ./configure command I get an error: C compiler cannot create executables See `config.log' for more details This file contains ...
1
vote
1answer
2k views

C compiler cannot create excecutables

When I am trying to install a openvpn from a tarball , following error occurs checking whether the C compiler works... no configure: error: in `/home/shubhamd/Downloads/openvpn-2.3.2': ...
1
vote
1answer
8k views

Terminal commands for installing g++ 4.8?

Could somebody please advise how I could install g++ 4.8 ? I understand its not an official release yet (and that I would need to manually download a file) but I get internal compiler bug issues with ...
1
vote
3answers
1k views

Error while installing tiff-4.0.3

I get the following errors while installing tiff-4.0.3: pranav@pranav-Inspiron-1545:~$ cd dependency/ pranav@pranav-Inspiron-1545:~/dependency$ tar -xvf libtiff4-3.6.0-5.tar.bz2 usr/bin/cygtiff4.dll ...
1
vote
2answers
9k views

How to upgrade g++ to 4.7.1?

Richard Holloway's answer to this thread nicely explains how to upgrade from 4.6.3 to 4.7.0 (on 12.04, in my case) but I would like to upgrade to 4.7.1, which has been available for awhile. However ...
1
vote
2answers
19k views

Is it possible to downgrade gcc 4.6.1 to 4.4.x?

I've tried the following: sudo apt-get remove gcc sudo apt-get install gcc-4.4 But this does not work, running gcc --version gives a 'No such file or directory' error.
1
vote
1answer
1k views

How to downgrade gcc from 4.4.4 to 4.2.1?

The newest Ubuntu (10.10) has gcc version 4.4.4, but I need 4.2.1 for compilation issues. The library that I'm using requires me to use 4.2.1. How can I downgrade the gcc to a specific version?
1
vote
1answer
906 views

How do I run g++-4.5?

I've installed g++-4.5 via apt, and there exists a /usr/bin/g++-4.5. However, when I try and run g++-4.5, I get this error message: /usr/bin/g++-4.5: not found (hardened-c++ could not find target) ...
1
vote
2answers
7k views

Is itoa() available in stdlib.h in Gcc >=4.1?

that's my question. I've Gcc 4.4.1 and that function isn’t present, i had installed the 4.3 and 4.5 versions with the same result :-/ I know that this function is not the C-ANSI standard, but I ...
1
vote
1answer
19 views

G++ ubuntu packaging question

dpkg -s g++ Package: g++ Status: install ok installed Priority: optional Section: devel Installed-Size: 16 Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com> Architecture: ...