-1
votes
1answer
108 views

cannot install lxml in virtualenv (python)

I cannot install lxml. In system i have python-lxml package, but i need other... Please help, if you can - my task is install lxml for development in virtual enviroment using virtualenv. I found this ...
0
votes
2answers
29 views

Downgrade to GCC < v3.0

For specific reasons I have to downgrade my GCC to version 2.x using apt-get (not downloading and compiling the source) Is that possible? If yes, how can I find the repository address and install it ...
2
votes
1answer
6k views

How to install gcc 4.9 on Ubuntu 14.04? [duplicate]

Now that gcc 4.9 is officially released, is there an easy and convenient way to install it on Ubuntu 14.04 through the package manager (ie. apt-get)? I would also appreciate information on how to ...
0
votes
2answers
149 views

How do you fix a gcc compile 127 error? sudo apt-get install g++ doesn't work

*emphasized text*when I try to run a program I get the following error. ubuntu@ubuntu-VirtualBox:~/Desktop$ make g++ -Wall -Wno-switch -I. -g -c -o pass.o pass.cpp make: g++: Command not found ...
2
votes
1answer
30 views

how to create a ppa .dep that depends on non-default GCC?

I want to create a .dep package in my PPA. That project however requires a recent GCC 4.8 or Clang 3.4+. I found out, that you can add custom PPA dependencies, so I added ubuntu-toolchain-r/test to ...
1
vote
0answers
36 views

How do I set the F77 environment variable to gfortran?

I'm new Ubuntu (and linux) user. In order to do my senior project, I have to install psrchive I use this command to install psrchive ./psrsoft/bin/psrsoft psrchive --no-cfitsio This is part of ...
3
votes
2answers
778 views

Why does apt-get want to remove gcc-4.8 and g++-4.8 when I try to upgrade?

I am trying to upgrade gcc-4.8.1 and g++-4.8.1 to 4.8.2. I added the PPA containing g++-4.8.2, ran apt-get update and then when I try: martin@martin-Studio-1537:~$ sudo apt-get upgrade [sudo] ...
1
vote
0answers
255 views

Compiled packages and apt-get mess

Due to my work I have to use the last version of gdb (7.7) which is not provide in the ubuntu repositories. For that purpose I download the source code, compiled it and installed it successfully. My ...
0
votes
1answer
1k views

apt-get: error loading libgcc_s.so.1

I am using Ubuntu 12.04.3 LTS, 64-bit, with gcc 4.6.3 I want to update gcc to 4.7, and do as the link said: How do I install gcc 4.7? But I got error: Fetched 14.0 MB in 18s (767 kB/s) ...
0
votes
0answers
153 views

How to: Install Arm cross compilation for GCC4.8 in Ubuntu 12.04

First off, I'm new to Linux and have installed ubuntu 12.04 as a VM to compile code to an ARM dev. kit. Since only the 12.04 version is supported on the dev. kit I'm unable to install e.g. latest ...
0
votes
1answer
1k views

How to install boost 1.53 or 1.54 from terminal?

I'd like to install boost 1.53 or 1.54 from terminal in Ubuntu 12.04. How do I do this? I used the libboost command and it gave me 1.48, whereas I need a more recent version. Thanks in advance
0
votes
1answer
798 views

“The program 'g++' can be found in the following packages”

I have g++ 4.6, 4.7 and 4.8 installed, but not g++ itself. I am using Ubuntu 12.04. If I do: g++ --version it says: The program 'g++' can be found in the following packages: * g++ * ...
1
vote
1answer
84 views

Different versions of libstdc++6 on 12.04

After upgrading Server 10.04 to 12.04, I was receiving errors related to lgcc_s while trying to compile with g++ and gcc. There are several versions of libgcc_s installed in ...
1
vote
0answers
214 views

Unmet dependencies after trying to install gcc-4.7 on Ubuntu 12.04

I know there are already many questions about unmet dependencies but none of them helped me so far. Even this really detailed answer (How do I resolve unmet dependencies?) didn't solve my problem. ...
0
votes
1answer
101 views

Compilation problem for C++ program

How do I install g++ or pentium builder packages? Do I need to download those? Because when I try to compile the program and with this statement: g++ -Wall -W -Werror main.cpp -o HelloWorldCPP` ...
0
votes
2answers
787 views

How to install gcc/g++ 4.4 and make links

Because I cannot compile some code by gcc/g++ 4.7, I want to install gcc/g++ 4.4. I searched the Internet and found some different way. I don't know what is the best solution. Is it possible to ...
1
vote
0answers
348 views

Ramifications of uninstalling GCC 4.7 in leu of GCC 4.6 in Quantal?

I currently have both the gcc-4.6 and gcc-4.7 packages installed in Quantal. I do a lot of software development but haven't had a need for any features that are specific to GCC 4.7. Therefore, in ...
2
votes
1answer
2k views

error in installation of gcc on ubuntu Ubuntu 12.04

I want to install gcc on a ubuntu machine but got the following errors: t@lab45:~# apt-get install build-essential Reading package lists... Done Building dependency tree Reading state ...
1
vote
1answer
5k views

How to install GCC 4.7 on Lubuntu 11.10?

I installed Lubuntu 11.10 and I installed build-essential with this command: sudo apt-get install build-essential Now I have gcc 4.6 I read on some forum that adding the next PPA I'll be able to ...
0
votes
2answers
342 views

How can I install dpkg-dev without installing gcc 4.6?

I have manually installed gcc/g++ 4.7 on my Ubuntu 12.04 When I run sudo apt-get install dpkg-dev it's trying to download and install g++ 4.6 which would obviously break 4.7. How can I install ...
3
votes
2answers
505 views

Using 12.04, can I compile packages with gcc for 10.04?

My development machine is running Precise, but some of my target servers are still running Lucid. I'm trying to set up my dev machine so that it can compile c/c++ for both Lucid and Precise. I already ...
4
votes
4answers
3k views

How do I install ALL development libraries?

I want to preinstall all the libraries one could ever need onto a system so someone building something would always have the libraries available. Like in a computer lab where users are not root. I ...
12
votes
2answers
110k views

Install gcc on Ubuntu 12.04 LTS

When I try to install gcc on Ubuntu 12.04 LTS Server with apt-get install gcc, I get the following error: The following packages have unmet dependencies: gcc : Depends: cpp (>= 4:4.6.1-2ubuntu5) ...
1
vote
1answer
2k views

How to install a specific gcc version?

I'd like to install an older version of gcc on my Ubuntu Lucid machine. Particularly, I am interested in 2.95.3 or 3.0.2. Is there any repository to download this package with the apt-get command?
1
vote
1answer
9k views

gcc-arm-linux-gnueabi package not found on 10.04 LTS (Lucid)

I am trying to install the gcc-arm-linux-gnueabi package, but this is the error I am getting: $ sudo apt-get install gcc-arm-linux-gnueabi Reading package lists... Done Building dependency tree ...
0
votes
1answer
942 views

I want to save apt-get package

I am using Ubuntu 10.10. Suppose I run this command to install GCC: sudo apt-get install gcc* I want save gcc on my pc forever, so that next time I do not have to run that apt-get command to ...
1
vote
2answers
3k views

How to install gcj? [closed]

It seems I need to install gcc but:
1
vote
1answer
480 views

GCC headers on Ubuntu

I was wondering, if there was a go to place to look for c headers, and how to get them on Ubuntu, often times a quick Google search gets me the apt-get package. I was wondering if it possible look up ...
5
votes
4answers
18k views

Old version of gcc for new Ubuntu

Is there a repository containing packages for old versions of gcc, for the latest Ubuntu. I want to install gcc3 alongside gcc 4, for programs that need gcc3 specifically.