0
votes
1answer
681 views

/usr/bin/ld: cannot find -lgsl on Ubuntu 10.04

I was given a program to install and after running the makefile, I got the error gcc -o SD_Plot SD_Plot.o -lgsl -lgslcblas -lm /usr/bin/ld: cannot find -lgsl I already installed the GNU ...
0
votes
0answers
27 views

How do I install the latest GCC etc on 10.04? [duplicate]

Possible Duplicate: How to update gcc to the latest version(in this case 4.7) in Ubuntu 10.04? So, basically I want to still have GNOME 2 because I need a theme for it (Mac OS X like theme) ...
2
votes
1answer
3k views

How do I get gcc installed without a network connection?

I have a fresh install of Kubuntu 10.04.3 on a new motherboard. The driver(s) in the install do not support the Intel 82579V NIC on the motherboard. I've located and downloaded the NIC driver - but of ...
2
votes
2answers
553 views

Which package should I download to compile C++0x code

OS is Ubuntu 10.04. I need to compile some C++ code with -std=c++0x flag. But compiling doesn't work because I need 4.6.1 version. Now, when I go to Gnu's ftp, I see two different packages: ...
16
votes
3answers
33k views

How to update gcc to the latest version(in this case 4.7) in Ubuntu 10.04?

I have Ubuntu 10.04 32-bit with gcc 4.4.3 currently installed on it. I want to upgrade it to gcc/g++ 4.7 (I am looking for C++ 0x support) How to update using Ubuntu Package Manager: apt-get ...
3
votes
1answer
5k views

How I can update a gcc from v 4.4.3 to 4.6.1?

How i can safe update a gcc compiler v 4.4.3 to 4.6.1 under Ubuntu 10.04? i try: igor@igor-desktop:~$ sudo add-apt-repository ppa:ubuntu-toolchain-r/test [sudo] password for igor: Executing: gpg ...
3
votes
1answer
737 views

Will gcc be upgraded to 4.5.* in one of the 10.04.* releases?

I don't quite understand how the LTS releases work. Will gcc be updated to the newer 4.5 version or will it remain 4.4 and I'll have to wait for 11 before seeing 4.5?