0
votes
1answer
21 views

Problem installing g++ ccompiler on Ubuntu 14.04

I tried to install g++ using packages from another user. offline..but there were errors. After connecting to the net I tried to install using sudo apt-get install g++, but it gave the following ...
0
votes
2answers
37 views

what is exactly object file and how to open it

g++ myCppFile -o myOut I do not know about compiling procedure. But all I want to know is what is the type of myOut? It is not text. It is not like configuration file. So what is it ? And how to ...
0
votes
2answers
58 views

I am not able to compile a simple program using gcc

Wrongly I have install ia32-libs but my host system is 64 bit. Now whenever i try to compile c file i get a message as: unrecognized option '--64' I have uninstall th ia32-libs but I am getting ...
0
votes
2answers
32 views

how to know which version of the compiler used to install a program from source among all versions of the that compiler

I installed a program via source code . To do that I downloaded a gcc and g++ appropriate for that. I use this command in order to install that $ export CC=gcc-?? CXX=g++-?? && ./install ...
2
votes
1answer
7k views

How to install gcc 4.9 on Ubuntu 14.04? [duplicate]

Now that gcc 4.9 is officially released, is there an easy and convenient way to install it on Ubuntu 14.04 through the package manager (ie. apt-get)? I would also appreciate information on how to ...
0
votes
0answers
103 views

I already have the newest version of g++ but I still get a 127 error what do I do?

I have done the following. I just don't know what to try next. I supposedly have the newest version of gcc by following these directions sudo add-apt-repository ppa:ubuntu-toolchain-r/test sudo ...
11
votes
4answers
10k views

Getting + installing gcc/g++ 4.9 on Ubuntu?

How do I install the latest version of gcc and g++? I am using a variety of C++11 and C++1y features; which is why I need this.
0
votes
1answer
239 views

install gcc and g++

I tried all the commands sudo apt-get build-dep build-essential sudo apt-get install gcc sudo apt-get install g++ But all time I am getting this error. The following packages have unmet ...
0
votes
3answers
4k views

Installing gcc 4.8 on 13.10 “The following packages have unmet dependencies” [duplicate]

When i go to install gcc 4.8 using: sudo apt-get update sudo apt-get install gcc-4.8 g++-4.8 I get the error message: Some packages could not be installed. This may mean that you have requested an ...
0
votes
0answers
549 views

How do I compile with GL/glew.h?

Whenever I try to compile a C++ file using: g++ cgaTOH.cpp I keep getting the following error: fatal error: GL/glew.h: No such file or directory Could someone advise on how to get GL/glew.h ...
0
votes
1answer
1k views

How to install boost 1.53 or 1.54 from terminal?

I'd like to install boost 1.53 or 1.54 from terminal in Ubuntu 12.04. How do I do this? I used the libboost command and it gave me 1.48, whereas I need a more recent version. Thanks in advance
8
votes
3answers
3k views

Downloaded g++ 4.8 from the PPA but can't set it as default?

I have downloaded g++ 4.8 on Ubuntu 12.10 by doing: sudo add-apt-repository ppa:ubuntu-toolchain-r/test sudo apt-get update sudo apt-get install g++-4.8 but when I do: sudo update-alternatives ...
0
votes
1answer
3k views

Terminal commands for installing g++ 4.8?

Could somebody please advise how I could install g++ 4.8 ? I understand its not an official release yet (and that I would need to manually download a file) but I get internal compiler bug issues with ...
0
votes
1answer
853 views

“The program 'g++' can be found in the following packages”

I have g++ 4.6, 4.7 and 4.8 installed, but not g++ itself. I am using Ubuntu 12.04. If I do: g++ --version it says: The program 'g++' can be found in the following packages: * g++ * ...
0
votes
0answers
753 views

Get latest G++ (4.7) for C++11?

Netbeans is complaining because I selected C++11 and my G++ version is 4.6 (4.7 supports C++11). However, I have tried: sudo apt-get install build-essential But g++ --version tells me I have ...
-1
votes
1answer
713 views

How do I compile lbflow 1.1?

After using "sh ./configure" command, I encountered another error during lbflow package installation (a scientific one). The sequence of operations is here with error: ./configure --disable-gts ...
1
vote
0answers
860 views

gcc without g++?

I run Ubuntu 13.04 (x86_64 if it matters) which I recently installed. Before, when using 12.10, I had both gcc and g++ from the beginning. However, with 13.04 after I downloaded gcc-4.8.1 sources I ...
1
vote
1answer
884 views

Trying to compile code results in error: make[1]: g++-3: Command not found

I am trying to compile a program on Ubuntu 12.04 (LTS), but the following error keeps resulting: evensteven@pc:~/Desktop/MimoComplexLdpc$ make all cd ./src; make; make[1]: Entering directory ...
0
votes
1answer
102 views

Compilation problem for C++ program

How do I install g++ or pentium builder packages? Do I need to download those? Because when I try to compile the program and with this statement: g++ -Wall -W -Werror main.cpp -o HelloWorldCPP` ...
-2
votes
1answer
297 views

Is Gcc 4.8.1 RELEASE available under raring 13.04 ? ( no snapshot, only release )

I need full c++11 support and I need gcc 4.8.1 release, I'm under Ubuntu 13.04 64 bit, there is a gcc-snapshot package in the repository, but it's outdated and it's an old pre-release version. It's ...
0
votes
2answers
851 views

How to install gcc/g++ 4.4 and make links

Because I cannot compile some code by gcc/g++ 4.7, I want to install gcc/g++ 4.4. I searched the Internet and found some different way. I don't know what is the best solution. Is it possible to ...
1
vote
2answers
2k views

How can i downgrade GCC 4.7.2?

i want to downgrade GCC and G++ 4.7.2 to some older versions, 4.0 perhaps. Any assistance? I'm using Lubuntu ATM.
6
votes
2answers
8k views

Ubuntu 13.04 with gcc/g++/gfortran 4.8 by default?

I plan to download and install Ubuntu 13.04 and I would like to have two compilers on my system. First question: what is the version of gcc/g++/gfortran shipped with ubuntu 13.04 ? (is it 4.7.3 ?). ...
0
votes
2answers
4k views

gcc and g++ are installed but ubuntu says they are not installed

I have installed g++ and gcc from repository on ubuntu 12.04 ad you can see that they are indeed installed mahmood@pc:~$ dpkg -l | grep gcc ii gcc-4.4 4.4.7-1ubuntu2 ...
4
votes
2answers
915 views

How do I compile/run C++ code in the console?

I'm trying to run my C++ code using the console. I used the header file conio.h like I did when I used Turbo C++ IDE in Windows, and I ran the code in console using g++ filename.cpp I have ...
1
vote
1answer
173 views

Restoring gcc and g++ flags

I've recently done something really stupid: I wanted to configure NetCDF libraries using the Intel Fortran compiler and, therefore, I was following instructions for that kind of procedure. ...
1
vote
1answer
244 views

linking cpp object file to c object file and create executable

Suppose i have a c++ file, created an object file and c file created another object file. Now i need to link both into one executable. While i'm trying it is giving errors about c++ not found. Can ...
3
votes
1answer
313 views

Can't find new.h - getting gcc-4.2 on Quantal?

I've been trying to compile the Valve Source SDK (2007) on my machine, but I keep running into the same error: In file included from ../public/tier1/interface.h:50:0, from ...
3
votes
2answers
510 views

Using 12.04, can I compile packages with gcc for 10.04?

My development machine is running Precise, but some of my target servers are still running Lucid. I'm trying to set up my dev machine so that it can compile c/c++ for both Lucid and Precise. I already ...
1
vote
2answers
7k views

How to upgrade g++ to 4.7.1?

Richard Holloway's answer to this thread nicely explains how to upgrade from 4.6.3 to 4.7.0 (on 12.04, in my case) but I would like to upgrade to 4.7.1, which has been available for awhile. However ...
2
votes
1answer
930 views

Why is the GCC 4.7 PPA not upgrading to 4.7.1?

I would like to install from repository (without compilation from source) the latest g++ 4.7.1 on Ubuntu 12.04. I know I can install g++ 4.7.0 according to this tutorial. I have also found the g++ ...
0
votes
1answer
996 views

Installing g++ on 8.04

I am running Ubuntu 8.04 (currently I do not have the option to upgrade due to hardware problems). I need to get g++ onto my installation but as this is no longer supported I am unable to use the ...
2
votes
2answers
559 views

Which package should I download to compile C++0x code

OS is Ubuntu 10.04. I need to compile some C++ code with -std=c++0x flag. But compiling doesn't work because I need 4.6.1 version. Now, when I go to Gnu's ftp, I see two different packages: ...
2
votes
4answers
25k views

Eclipse can't find index libraries of GCC or G++

The instalation of CDT Tools on Eclipse can't find on index libraries of GCC or G++, but the file is running. Ex: include stdio.h (The comment doesn't accept <> and #) The are a yellow line ...
3
votes
1answer
2k views

What package provides -llua for g++?

I've installed all lua5.1 development packages from Synaptic and the g++ linker can not find -llua. I've read on some other question that it is possible that -llua has some other name and that I ...
35
votes
3answers
64k views

Choose gcc and g++ version

So I have installed gcc-4.4 and gcc-4.3 (same for g++). Now as far as I remember there is a tool in Ubuntu which sets the symlinks for you if you just tell it which version you want. However it does ...