G++ is the C++ front-end of the Gnu Compiler Collection (GCC)

learn more… | top users | synonyms

0
votes
1answer
26 views

I want to compile C file

I want to compile c file. I use g++ <filename> -o <output-filename> Error: ch34x.c:13:24: fatal error: linux/init.h: Directory or file doesnt exist. (here is hash I cant type here)include ...
0
votes
0answers
18 views

compiling gcc-g++ 4.6.0 alongside gcc 5.2.1 on ubuntu 15.10 amd64

I'm trying to compile gcc 4.6.0 alongside gcc 5.2.1 on Ubuntu 15.10, with OS 64bit. I followed the instructions here and here. For the source I use gcc-4.6.0.tar.bz2. I installed all prerequisites and ...
1
vote
2answers
63 views

Unable to install build-essential, held broken packages

So I was trying to set up my computer for development. I installed ubuntu 14.04 LTS. I wanted to write a hello-world-program. However I can not compile it. After some searching, I tried sudo apt-get ...
1
vote
1answer
18 views

G++ ubuntu packaging question

dpkg -s g++ Package: g++ Status: install ok installed Priority: optional Section: devel Installed-Size: 16 Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com> Architecture: ...
-1
votes
0answers
9 views

Manually install GNU g++ [duplicate]

My 6 year old computer will not run any of the recent or STL Ubuntu versions. The only stable version on my system is 10.10 Maverick. The problem is that the install archives for maverick are all ...
0
votes
0answers
49 views

How to install g++-4.4.7 RedHat Compiler

I am trying to install the specific g++ compiler version in my terminal on Ubuntu VM. I am using a server to compile my c++ program and I need the same compiler on Ubuntu. Calling g++ --version on the ...
0
votes
1answer
71 views

How to upgrade g++ to the latest version

Newbie here. I just got an error running from the terminal a C++ program I wrote: error: ‘stoi’ is not a member of ‘std’. They told me the compiler is too old. I'm using Ubuntu 14.04. My g++ version ...
0
votes
0answers
57 views

which gcc version

I have ubuntu 14.04 and I want to install a program that asks enter code here me this What is your C++ compiler? [] so I am wonder how to answer and I used this command to know my version gcc -v ...
0
votes
1answer
45 views

Broken dependencies issue is faced immediately after the first install of Ubuntu 14.04.3?

I followed these steps just to get rid of broken dependencies issue but to no avail. A fresh install of ubuntu 14.04.3 LTS Tried to install g++ by sudo apt-get install g++ BOOM... Broken ...
2
votes
1answer
194 views

sudo apt get-install g++ unmet dependencies

Looked through a few questions with similar issues and none of the solutions have worked. The issue is: $ sudo apt-get Install g++ The following packges have unmet dependencies: g++ : Depends:g++-4.8 ...
1
vote
0answers
21 views

Find how does make call g++ when building

I downloaded a program that in order to install it i have to execute the following commands: cmake .. make sudo make install The problem is that i am trying to customize the building flags without ...
0
votes
0answers
35 views

Newest Mplab software that works with Ubuntu and ICD2

I have an old ICD2, used with an old version of MPLAB Integrated Development Environment (IDE) under Windows. Now I need to use this hardware again for a microcontroller but my OS is nowadays Kubuntu ...
3
votes
2answers
157 views

g++ compiled application doesn't work

I wrote a simulation code with C++ and compiled it into an executable using g++. However, the output file doesn't do anything when double clicked. I checked "allow file to be used as executable" as ...
0
votes
1answer
266 views

How to use gcc 4.9 when it's installed in same directory as newer gcc

I've got installed both gcc 5 and gcc 4.9 in same directory (/usr/bin). Using nvcc with --compiler-bindir is impossible since both gccs are in same directory. I need to run command nvcc ...
0
votes
1answer
152 views

Why do I get a “Permission denied” error every time I try to execute a C++ program?

Every time I try to execute a program, no matter what program, I get this message: bash: ./filename.cpp: Permission denied When I compile I have no problems, it works fine. But when I want to ...
0
votes
1answer
88 views

14.04.01 32-bit: Missing g++ 64-bit include files when cross-compiling

So, I've got 32-bit Xubuntu 14.04.1 installed. We have some interface code where we intend to release SOs for the various platforms we support, and Windows DLLs. (Yes I know, binary release bad, but ...
0
votes
0answers
60 views

ubuntu 15.10, jsoncpp, and clang++

On upgrading from 15.04 to 15.10, I stopped being able to compile against libjsoncpp using clang++. (Using g++ works fine.) As far as I can tell, it would suffice to recompile libjsoncpp with ...
1
vote
1answer
170 views

“ g++ not installed ” even after installing it “ sudo apt-get install g++ ”

i recently installed Ubuntu on a VMware and following a tutorial... gcc works for me, but when i try g++, it says " The program 'g++' is currently not installed. You can install it by typing: sudo ...
0
votes
0answers
64 views

how to install git.zip and g++.zip files in ubuntu 14.04(internet not there in my system but ZIP files there)?

Actually in my system INTERNET is not there,but in another system i have downloaded git and g++ ZIP files, but how to install that zip files tell me?
0
votes
1answer
303 views

C++ header files for HDF5 are missing

I am trying to compile a C++ program using g++ which uses the H5Cpp.h header file. g++ is producing a fatal error saying: fatal error: H5Cpp.h: No such file or directory I have already installed ...
0
votes
1answer
47 views

Can't use g++ compiler

I tried to do this: $ g++ The program 'g++' is currently not installed. You can install it by typing: sudo apt-get install g++ $ sudo apt-get install g++ [sudo] password for user: Reading package ...
0
votes
0answers
50 views

cannot start freefilesycn after update to version 7.6

I updated my FreeFileSync-installation recently to version 7.6. After doing this I'm not able to start FFS anymore with this error ./FreeFileSync: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version ...
0
votes
0answers
164 views

G++ Compiling error when making from source?

I am trying to install bitcoin server using this guide https://www.sky-ip.org/configure-bitcoin-node-debian-ubuntu.html However when I make, I see the error g++: internal compiler error: Killed ...
2
votes
1answer
159 views

After updating to 15.10, my scopes projects fail to build for the unity-scope-tool. “error: g++ version must be 4.9!”

I recently upgraded to Ubuntu 15.10. I have been making scopes, and many of my scopes projects stopped building after the upgrade. My work process consists of running the scopes first in the ...
0
votes
0answers
13 views

G++ does not install 4.8 [duplicate]

I am using 12.04 and trying to compile a file using -std=c++11 in g++. I need to update to 4.8, but every time I try to it says 4.8 is the most current version, but g++--version tells me I have g++ ...
2
votes
1answer
245 views

Can't install g++ Ubuntu 14.04.3

I tried "sudo apt-get install g++" I got a long string of qtdeclarative5-qtfeedback-plugin is already the newest version. gnome-power-manager is already the newest version. Ending in: 0 ...
0
votes
1answer
258 views

Install gcc/g++ on Ubuntu Phone

My back is so sore and it hurts to sit. However, I need to do my coding assignment. Will it be possible to install gcc/g++ on my Ubuntu Phone and compile my code on it? I tried running sudo apt-get ...
0
votes
0answers
29 views

iulib - header not found when compiling test cc files

I installed iulib (https://github.com/tmbdev/iulib) by following the instructions in the install file and downloaded the ubuntu-packages, then when I tried to compile and run a cpp file namely: ...
5
votes
1answer
3k views

Install g++ ubuntu 14.04 Depends: g++-4.8 (>= 4.8.2-5~) but it is not going to be installed

I just typed: sudo apt-get install g++ and got: The following packages have unmet dependencies: g++ : Depends: g++-4.8 (>= 4.8.2-5~) but it is not going to be installed E: Unable to correct ...
0
votes
0answers
30 views

Building OpenGL program: Cannnot find -lGL - but bumblebee, nvidia drivers and libgl1-mesa-dev are installed?

I am trying to compile an open gl program on xubuntu 15.04. I have installed bumblebee, the nvidia driver 304 and the libgl1-mesa-dev library. Inside /usr/lib I have the file libGL.so.1. What's ...
0
votes
0answers
17 views

get URI's of g++ dependencies [duplicate]

I have g++ installed on my computer, I have another computer that doesn't have any connection to the internet. and I need to install g++ on that computer. my question is- how can I get a list of ...
0
votes
1answer
75 views

g++4.9 -fvtable-verify link error: cannot find vtv_start.o

I am running g++ 4.9.2.0ubuntu1~14.04 (installed from the toolchain ppa: ppa:ubuntu-toolchain-r/test), and I want to use the Virtual Table Verification (VTV) feature (-fvtable-verify in C++ dialect ...
0
votes
0answers
16 views

Using aliases with command line arguments [duplicate]

I'm using the g++ compiler to compile my c++ code. I've already created an alias g++='g++ -std=c++11 -o' and it works fine. However I want to be able to create an alias such as grun or gr++ that ...
1
vote
1answer
573 views

Ubuntu14.04 can not install g++

My computer environment: Ubuntu 14.04, 64 bit OS; gcc version: gcc version 4.8.4 (Ubuntu 4.8.4-2ubuntu1~14.04) I tried to install g++ by executing: sudo apt-get install g++ Then I got this output ...
0
votes
0answers
55 views

Unable to install g++ package

I get the following error, when I'm trying to install the g++ package. The following packages have unmet dependencies: g++ : Depends: g++-4.8 (>= 4.8.2-5~) but it is not going to be installed E: ...
0
votes
1answer
331 views

Problem in installing g++

I want to install g++ on my laptop(ubutu 14.04 LTS), however it shows the following errors- maddman@MADDY-PC:~/Desktop$ sudo apt-get install g++ Reading package lists... Done Building ...
-2
votes
1answer
51 views

Not able to find out g++

I have installed g++ in Ubuntu 12.04 from Ubuntu software center to write, c and c++ and to complie, but I am not able to find out where is the software gone after installation, please help me how to ...
0
votes
0answers
75 views

g++ and vim on Ubuntu phone

Can i install g++ and vim on my ubuntu phone? I have tried running sudo apt-get install vim g++ from the terminal app, but neither were in the repositories.
2
votes
1answer
94 views

Why is g++ installed at usr/bin and not in usr/local/bin

I'm trying to understand the file structure of Linux systems.(At least basic parts). Now, according to this answer, /usr/local - directory is for read-only files installed by the local administrator ...
0
votes
0answers
46 views

Error in installation of MeTA (meta requires a compiler with at least C++0x support)

I followed procedure from https://meta-toolkit.org/setup-guide.html Steps==> sudo apt-get update sudo apt-get install software-properties-common add the ppa for cmake sudo add-apt-repository ...
1
vote
0answers
630 views

Problem installing g++

I typed sudo apt-get install g++ then got the output: g++ depends on g++-4.8 (>=4.8.2-5~) but it will not be installed Then I continued sudo apt-get install g++-4.8 then got g++-4.8 ...
0
votes
0answers
36 views

Using migw32 to compile for windows

I have been writing a program that requires C++ 11, so I had been using the -std=c++11 to compile with g++. That worked, until I wanted to use mingw32, I ran into the same problems (such as stod and ...
0
votes
0answers
131 views

open3: exec of /usr/bin/gcc -v failed at /usr/local/bin/gcc

short version: I have been trying to downgrade my gcc and g++ and now it says open3: exec of /usr/bin/gcc -v failed at /usr/local/bin/gcc" even with a simple version check. Or it says - not found ...
0
votes
1answer
170 views

Error: ‘is_same’ is not a member of ‘std’ when build c++ project in ubuntu?

I have a small project and i get an error ‘is_same’ is not a member of ‘std’ when building. this is some code: template <class T> T* UcmExportFactory::Unwrap (T* ptr) { Utils::IUcmWrapper* ...
1
vote
1answer
1k views

Process terminated with status 127 while compiling in code blocks

I installed codeblock in ubuntu and try with a helloworld c++ program with the following code: #include <iostream> using namespace std; int main() { cout << "Hello world!" << ...
0
votes
2answers
988 views

shall i need to install g++ to compile c++ files in Ubuntu 14.04.1

I am using Ubuntu 14.04.1 I want to know, Do I need to install g++ from the Ubuntu Software Center to compile the c++ files? Is GCC(GNU Compiler Collection) able to accomplish this instead? if the ...
1
vote
1answer
967 views

Use g++-4.8 with Qt

I am trying to compile a Qt project that uses the "override" keyword, and thus needs GCC 4.8. I have installed GCC 4.8 on my Ubuntu 12.04 machine already, and it lives in /usr/bin as gcc-4.8 and ...
0
votes
1answer
29 views

Runing a program appears to not work [closed]

I do not know what the problem is or what happened but when I want to run a program compiled with g++ not working. I starts like this: gabi@gabi-work:~/Desktop/comp$ ./a.out and receive this: ...
0
votes
1answer
457 views

Compile error, g++ and c++11 [closed]

Im trying to compile this code via g++, #include <iostream> #include <set> using namespace std; std::set<int> s; int main(){ for(int i=0;i<10;i++) s.insert(i); for(auto ...
0
votes
0answers
134 views

Make Error while building LDV for ubuntu 14.04

I am trying to build LDV project by following this.While running make console-tools , i am getting the following error. In file included from ../../aspectator/gcc/lto-streamer.h:27:0, ...