G++ is the C++ front-end of the Gnu Compiler Collection (GCC)

learn more… | top users | synonyms

1
vote
2answers
33 views

How do locate and use programs that are available on the computer by default?

I wanted to locate g++ on ubuntu. However when I type it in the dash's search, it says that nothing matches my search. Where exactly can I access such programs on ubuntu ?
0
votes
2answers
947 views

Ubuntu 14.04 GCC 4.8.2 link dynamically against (older) GLIBC 2.11.1

For the needs of my project I need to use G++ 4.8.2 and GLIBC 2.11.1. Ubuntu 14.04 comes with EGLIBC 2.19. How can I make G++ link dynamically against GLIBC 2.11.1? If there is, how do I go about ...
0
votes
2answers
3k views

How to install gcc/g++ 4.4 and make links

Because I cannot compile some code by gcc/g++ 4.7, I want to install gcc/g++ 4.4. I searched the Internet and found some different way. I don't know what is the best solution. Is it possible to ...
2
votes
1answer
194 views

sudo apt get-install g++ unmet dependencies

Looked through a few questions with similar issues and none of the solutions have worked. The issue is: $ sudo apt-get Install g++ The following packges have unmet dependencies: g++ : Depends:g++-4.8 ...
2
votes
1answer
245 views

Can't install g++ Ubuntu 14.04.3

I tried "sudo apt-get install g++" I got a long string of qtdeclarative5-qtfeedback-plugin is already the newest version. gnome-power-manager is already the newest version. Ending in: 0 ...
2
votes
1answer
946 views

When will GCC support C++11 regex_token_iterator?

When will GCC support for C++11 regex_token_iterator? Some of regex seems to be implemented, but the token iterator is not supported yet in my 32-bit Ubuntu/Linaro (version 4.7.2-4precise1) ...
1
vote
1answer
172 views

“ g++ not installed ” even after installing it “ sudo apt-get install g++ ”

i recently installed Ubuntu on a VMware and following a tutorial... gcc works for me, but when i try g++, it says " The program 'g++' is currently not installed. You can install it by typing: sudo ...
1
vote
1answer
2k views

Trying to compile code results in error: make[1]: g++-3: Command not found

I am trying to compile a program on Ubuntu 12.04 (LTS), but the following error keeps resulting: evensteven@pc:~/Desktop/MimoComplexLdpc$ make all cd ./src; make; make[1]: Entering directory ...
1
vote
1answer
2k views

Eclipse and the g++ - how is it work

I am using ubuntu 12.04. I have eclipse juno. I wrote test.cpp : #include <iostream> using namespace std; int main() { cout << "!!!Hello World!!!" << endl; // prints !!!Hello ...
1
vote
1answer
4k views

How to compile a c++11 program using future in Ubuntu 12.04?

I'm trying to compile a c++ program in Ubuntu 12.04. I'm using g++ 4.7 (installed from a ppa). I'm using std::future, but I have an error. The code: $ cat main.cpp #include <iostream> ...
1
vote
1answer
788 views

Problem Compiling with link -lstdc++

I'm new using Linux (Ubuntu 12.04 LTS, 64-bit). I am trying to learn how to create binary files for a program called Tecplot. I've been trying to compile the example file simtest.f90, using this: $ ...
0
votes
1answer
304 views

C++ header files for HDF5 are missing

I am trying to compile a C++ program using g++ which uses the H5Cpp.h header file. g++ is producing a fatal error saying: fatal error: H5Cpp.h: No such file or directory I have already installed ...
0
votes
1answer
170 views

Error: ‘is_same’ is not a member of ‘std’ when build c++ project in ubuntu?

I have a small project and i get an error ‘is_same’ is not a member of ‘std’ when building. this is some code: template <class T> T* UcmExportFactory::Unwrap (T* ptr) { Utils::IUcmWrapper* ...
0
votes
1answer
890 views

Ubuntu 10.04 update GCC 4.8.1 to GCC 4.8.2

I installed GCC on Ubuntu 10.04 using the following commands: sudo apt-get update sudo apt-get install gcc-4.8 sudo apt-get install g++-4.8 sudo update-alternatives --install /usr/bin/gcc gcc ...
0
votes
1answer
43 views

Cannot install g++ 4.8 on OpenVZ

I have everything set, but doing apt-get install g++4.8 gives me the following java (!?!?!?) related error. Setting up ca-certificates-java (20110426ubuntu0.10.04.2) ... Error occurred during ...
0
votes
1answer
779 views

install gcc and g++

I tried all the commands sudo apt-get build-dep build-essential sudo apt-get install gcc sudo apt-get install g++ But all time I am getting this error. The following packages have unmet ...
0
votes
1answer
2k views

“fatal error: GL/glfw.h: No such file or directory #include <GL/glfw.h>” - How to solve it?

I'm trying to install GLFW to develop a OpenGL 3.0+ program and I've followed a few tutorials on how to install GLFW and I keep getting this error. I know I have installed it correctly with cmake, ...
0
votes
1answer
357 views

ld error while linking to SDL2

i'm struggling in the attept to compile c++ with SDL2. I've done as always: checkout the code (both from mercurial and libsdl.org) ./configure, make, sudo make install But it keeps to say: ...
0
votes
1answer
2k views

Compiling c++ script with external libraries, not working

I can't seem to get this working. I have a c++ script that i haven't written myself, that i need to compile with g++. The start of the script looks like this: #include "x.hh" #include "y.hh" ...
0
votes
1answer
2k views

GLIBCXX 3.4.14 on Ubuntu 10.04

Is there a way of getting GLIBCXX 3.4.14 on Ubuntu 10.04? I am trying to use the Z3 solver from Microsoft in my research but it requires at least GLIBCXX 3.4.14 which is not available in my setup. ...
-1
votes
1answer
110 views

libc6 for g++ is installed but it says: NO!

It is one week that i have a problem in installing g++ in my Ubuntu 14.04.1 server. It wants about 5 dependencies, but the last one is libc6, and when I try to install it, this massage will appear: ...
2
votes
0answers
72 views

Error in statically linking libSDL

I am trying to statically link libsdl on a test I wrote. What I did is: g++ test.cpp -Wl,-Bstatic $(sdl-config --static-libs) -Wl,-Bdynamic which gave me the error: ...
1
vote
0answers
21 views

Find how does make call g++ when building

I downloaded a program that in order to install it i have to execute the following commands: cmake .. make sudo make install The problem is that i am trying to customize the building flags without ...
1
vote
0answers
630 views

Problem installing g++

I typed sudo apt-get install g++ then got the output: g++ depends on g++-4.8 (>=4.8.2-5~) but it will not be installed Then I continued sudo apt-get install g++-4.8 then got g++-4.8 ...
1
vote
0answers
37 views

Use package without declaring its version

I have installed g++ from here. When I want to compile a program, I have to use g++-4.9 myle.cpp. How can I set it to use without declaring its version g++ myle.cpp?
1
vote
0answers
829 views

Unable to compile C++ Code

Whenever I try to compile a C++ file with IOStream , I get this error.. I've tried reinstalling GCC G++ (both 4.6 and 4.9) AND cpp.. It hasnt helped (or maybe I didnt do it the right way). How do I ...
1
vote
0answers
2k views

gcc without g++?

I run Ubuntu 13.04 (x86_64 if it matters) which I recently installed. Before, when using 12.10, I had both gcc and g++ from the beginning. However, with 13.04 after I downloaded gcc-4.8.1 sources I ...
0
votes
0answers
18 views

compiling gcc-g++ 4.6.0 alongside gcc 5.2.1 on ubuntu 15.10 amd64

I'm trying to compile gcc 4.6.0 alongside gcc 5.2.1 on Ubuntu 15.10, with OS 64bit. I followed the instructions here and here. For the source I use gcc-4.6.0.tar.bz2. I installed all prerequisites and ...
0
votes
0answers
49 views

How to install g++-4.4.7 RedHat Compiler

I am trying to install the specific g++ compiler version in my terminal on Ubuntu VM. I am using a server to compile my c++ program and I need the same compiler on Ubuntu. Calling g++ --version on the ...
0
votes
0answers
57 views

which gcc version

I have ubuntu 14.04 and I want to install a program that asks enter code here me this What is your C++ compiler? [] so I am wonder how to answer and I used this command to know my version gcc -v ...
0
votes
0answers
35 views

Newest Mplab software that works with Ubuntu and ICD2

I have an old ICD2, used with an old version of MPLAB Integrated Development Environment (IDE) under Windows. Now I need to use this hardware again for a microcontroller but my OS is nowadays Kubuntu ...
0
votes
0answers
61 views

ubuntu 15.10, jsoncpp, and clang++

On upgrading from 15.04 to 15.10, I stopped being able to compile against libjsoncpp using clang++. (Using g++ works fine.) As far as I can tell, it would suffice to recompile libjsoncpp with ...
0
votes
0answers
64 views

how to install git.zip and g++.zip files in ubuntu 14.04(internet not there in my system but ZIP files there)?

Actually in my system INTERNET is not there,but in another system i have downloaded git and g++ ZIP files, but how to install that zip files tell me?
0
votes
0answers
50 views

cannot start freefilesycn after update to version 7.6

I updated my FreeFileSync-installation recently to version 7.6. After doing this I'm not able to start FFS anymore with this error ./FreeFileSync: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version ...
0
votes
0answers
164 views

G++ Compiling error when making from source?

I am trying to install bitcoin server using this guide https://www.sky-ip.org/configure-bitcoin-node-debian-ubuntu.html However when I make, I see the error g++: internal compiler error: Killed ...
0
votes
0answers
29 views

iulib - header not found when compiling test cc files

I installed iulib (https://github.com/tmbdev/iulib) by following the instructions in the install file and downloaded the ubuntu-packages, then when I tried to compile and run a cpp file namely: ...
0
votes
0answers
30 views

Building OpenGL program: Cannnot find -lGL - but bumblebee, nvidia drivers and libgl1-mesa-dev are installed?

I am trying to compile an open gl program on xubuntu 15.04. I have installed bumblebee, the nvidia driver 304 and the libgl1-mesa-dev library. Inside /usr/lib I have the file libGL.so.1. What's ...
0
votes
0answers
55 views

Unable to install g++ package

I get the following error, when I'm trying to install the g++ package. The following packages have unmet dependencies: g++ : Depends: g++-4.8 (>= 4.8.2-5~) but it is not going to be installed E: ...
0
votes
0answers
75 views

g++ and vim on Ubuntu phone

Can i install g++ and vim on my ubuntu phone? I have tried running sudo apt-get install vim g++ from the terminal app, but neither were in the repositories.
0
votes
0answers
46 views

Error in installation of MeTA (meta requires a compiler with at least C++0x support)

I followed procedure from https://meta-toolkit.org/setup-guide.html Steps==> sudo apt-get update sudo apt-get install software-properties-common add the ppa for cmake sudo add-apt-repository ...
0
votes
0answers
36 views

Using migw32 to compile for windows

I have been writing a program that requires C++ 11, so I had been using the -std=c++11 to compile with g++. That worked, until I wanted to use mingw32, I ran into the same problems (such as stod and ...
0
votes
0answers
131 views

open3: exec of /usr/bin/gcc -v failed at /usr/local/bin/gcc

short version: I have been trying to downgrade my gcc and g++ and now it says open3: exec of /usr/bin/gcc -v failed at /usr/local/bin/gcc" even with a simple version check. Or it says - not found ...
0
votes
0answers
134 views

Make Error while building LDV for ubuntu 14.04

I am trying to build LDV project by following this.While running make console-tools , i am getting the following error. In file included from ../../aspectator/gcc/lto-streamer.h:27:0, ...
0
votes
0answers
26 views

Using GNU compiler and JRE in Wine applications

There is a .exe application that I want to run and it needs JRE, to making sense, it is an IDE based on Eclipse but it is not Eclipse itself. Also in this IDE for compiling, it uses g++ as compiler. ...